import libwnck3-40.0-2.el9
This commit is contained in:
commit
cad707d86e
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/libwnck-40.0.tar.xz
|
1
.libwnck3.metadata
Normal file
1
.libwnck3.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
ff5ad434cbd424047965b5e301dc2d46a4d62ca4 SOURCES/libwnck-40.0.tar.xz
|
@ -0,0 +1,98 @@
|
|||||||
|
From 89a5825eb20bfa91b91055e5a3dfe6445e6b9bd2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: raveit65 <mate@raveit.de>
|
||||||
|
Date: Fri, 11 Jun 2021 21:26:40 +0200
|
||||||
|
Subject: [PATCH] Revert "pager: do not change workspace size from
|
||||||
|
size_allocate"
|
||||||
|
|
||||||
|
This reverts commit 3456b747b6381f17d48629dd8fdd4d511e739b10.
|
||||||
|
---
|
||||||
|
libwnck/pager.c | 59 +++++++++++++++++++++++++++++++++++++++++++++++++
|
||||||
|
1 file changed, 59 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/libwnck/pager.c b/libwnck/pager.c
|
||||||
|
index c769d62..a563a4d 100644
|
||||||
|
--- a/libwnck/pager.c
|
||||||
|
+++ b/libwnck/pager.c
|
||||||
|
@@ -122,6 +122,8 @@ static void wnck_pager_get_preferred_height_for_width (GtkWidget *widget,
|
||||||
|
int width,
|
||||||
|
int *minimum_height,
|
||||||
|
int *natural_height);
|
||||||
|
+static void wnck_pager_size_allocate (GtkWidget *widget,
|
||||||
|
+ GtkAllocation *allocation);
|
||||||
|
static gboolean wnck_pager_draw (GtkWidget *widget,
|
||||||
|
cairo_t *cr);
|
||||||
|
static gboolean wnck_pager_button_press (GtkWidget *widget,
|
||||||
|
@@ -247,6 +249,7 @@ wnck_pager_class_init (WnckPagerClass *klass)
|
||||||
|
widget_class->get_preferred_width_for_height = wnck_pager_get_preferred_width_for_height;
|
||||||
|
widget_class->get_preferred_height = wnck_pager_get_preferred_height;
|
||||||
|
widget_class->get_preferred_height_for_width = wnck_pager_get_preferred_height_for_width;
|
||||||
|
+ widget_class->size_allocate = wnck_pager_size_allocate;
|
||||||
|
widget_class->draw = wnck_pager_draw;
|
||||||
|
widget_class->button_press_event = wnck_pager_button_press;
|
||||||
|
widget_class->button_release_event = wnck_pager_button_release;
|
||||||
|
@@ -684,6 +687,62 @@ wnck_pager_get_preferred_height_for_width (GtkWidget *widget,
|
||||||
|
*natural_height = *minimum_height = MAX (height, 0);
|
||||||
|
}
|
||||||
|
|
||||||
|
+static gboolean
|
||||||
|
+_wnck_pager_queue_resize (gpointer data)
|
||||||
|
+{
|
||||||
|
+ gtk_widget_queue_resize (GTK_WIDGET (data));
|
||||||
|
+ return FALSE;
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+static void
|
||||||
|
+wnck_pager_size_allocate (GtkWidget *widget,
|
||||||
|
+ GtkAllocation *allocation)
|
||||||
|
+{
|
||||||
|
+ WnckPager *pager;
|
||||||
|
+ int workspace_size;
|
||||||
|
+ GtkBorder padding;
|
||||||
|
+ int width;
|
||||||
|
+ int height;
|
||||||
|
+
|
||||||
|
+ pager = WNCK_PAGER (widget);
|
||||||
|
+
|
||||||
|
+ width = allocation->width;
|
||||||
|
+ height = allocation->height;
|
||||||
|
+
|
||||||
|
+ _wnck_pager_get_padding (pager, &padding);
|
||||||
|
+ width -= padding.left + padding.right;
|
||||||
|
+ height -= padding.top + padding.bottom;
|
||||||
|
+
|
||||||
|
+ g_assert (pager->priv->n_rows > 0);
|
||||||
|
+
|
||||||
|
+ if (pager->priv->orientation == GTK_ORIENTATION_VERTICAL)
|
||||||
|
+ {
|
||||||
|
+ if (pager->priv->show_all_workspaces)
|
||||||
|
+ workspace_size = (width - (pager->priv->n_rows - 1)) / pager->priv->n_rows;
|
||||||
|
+ else
|
||||||
|
+ workspace_size = width;
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ {
|
||||||
|
+ if (pager->priv->show_all_workspaces)
|
||||||
|
+ workspace_size = (height - (pager->priv->n_rows - 1))/ pager->priv->n_rows;
|
||||||
|
+ else
|
||||||
|
+ workspace_size = height;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ workspace_size = MAX (workspace_size, 1);
|
||||||
|
+
|
||||||
|
+ if (workspace_size != pager->priv->workspace_size)
|
||||||
|
+ {
|
||||||
|
+ pager->priv->workspace_size = workspace_size;
|
||||||
|
+ g_idle_add (_wnck_pager_queue_resize, pager);
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ GTK_WIDGET_CLASS (wnck_pager_parent_class)->size_allocate (widget,
|
||||||
|
+ allocation);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
static void
|
||||||
|
get_workspace_rect (WnckPager *pager,
|
||||||
|
int space,
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
228
SPECS/libwnck3.spec
Normal file
228
SPECS/libwnck3.spec
Normal file
@ -0,0 +1,228 @@
|
|||||||
|
%global source_name libwnck
|
||||||
|
|
||||||
|
Summary: Window Navigator Construction Kit
|
||||||
|
Name: libwnck3
|
||||||
|
Version: 40.0
|
||||||
|
Release: 2%{?dist}
|
||||||
|
URL: http://download.gnome.org/sources/%{source_name}/
|
||||||
|
Source0: http://download.gnome.org/sources/%{source_name}/40/%{source_name}-%{version}.tar.xz
|
||||||
|
License: LGPLv2+
|
||||||
|
|
||||||
|
Patch1: libwnck_0001-Revert-pager-do-not-change-workspace-size-from-size_.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: meson
|
||||||
|
BuildRequires: gettext
|
||||||
|
BuildRequires: glib2-devel
|
||||||
|
BuildRequires: gobject-introspection-devel
|
||||||
|
BuildRequires: gtk3-devel
|
||||||
|
BuildRequires: gtk-doc
|
||||||
|
BuildRequires: libXres-devel
|
||||||
|
BuildRequires: pango-devel
|
||||||
|
BuildRequires: startup-notification-devel
|
||||||
|
|
||||||
|
Requires: startup-notification
|
||||||
|
|
||||||
|
%description
|
||||||
|
libwnck (pronounced "libwink") is used to implement pagers, tasklists,
|
||||||
|
and other such things. It allows applications to monitor information
|
||||||
|
about open windows, workspaces, their names/icons, and so forth.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Libraries and headers for libwnck
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{source_name}-%{version} -p1
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%meson -Dgtk_doc=true
|
||||||
|
%meson_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%meson_install
|
||||||
|
|
||||||
|
%find_lang %{source_name}-3.0 --with-gnome --all-name
|
||||||
|
|
||||||
|
|
||||||
|
%ldconfig_scriptlets
|
||||||
|
|
||||||
|
|
||||||
|
%files -f %{source_name}-3.0.lang
|
||||||
|
%license COPYING
|
||||||
|
%doc AUTHORS README NEWS
|
||||||
|
%{_libdir}/%{source_name}-3.so.0*
|
||||||
|
%{_bindir}/wnck-urgency-monitor
|
||||||
|
%{_libdir}/girepository-1.0/Wnck-3.0.typelib
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_bindir}/wnckprop
|
||||||
|
%{_libdir}/%{source_name}-3.so
|
||||||
|
%{_libdir}/pkgconfig/*
|
||||||
|
%{_includedir}/%{source_name}-3.0/
|
||||||
|
%{_datadir}/gir-1.0/Wnck-3.0.gir
|
||||||
|
%doc %{_datadir}/gtk-doc
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 24 2021 Wolfgang Ulbrich <fedora@raveit.de> - 40.0-2
|
||||||
|
- revert https://gitlab.gnome.org/GNOME/libwnck/-/commit/3456b74
|
||||||
|
- fixes rhbz #1971048
|
||||||
|
- and https://github.com/mate-desktop/mate-panel/issues/1230
|
||||||
|
|
||||||
|
* Tue Aug 24 2021 Kalev Lember <klember@redhat.com> - 40.0-1
|
||||||
|
- Update to 40.0
|
||||||
|
- Tighten soname globs
|
||||||
|
|
||||||
|
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 3.36.0-5
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 3.36.0-4
|
||||||
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.36.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.36.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Mar 28 2020 Wolfgang Ulbrich <fedora@raveit.de> - 3.36.0-1
|
||||||
|
- update to 3.36.0
|
||||||
|
|
||||||
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.32.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.32.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 01 2019 Phil Wyett <philwyett@kathenas.org> - 3.32.0-1
|
||||||
|
- Update to 3.32.0
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Kalev Lember <klember@redhat.com> - 3.31.4-1
|
||||||
|
- Update to 3.31.4
|
||||||
|
- Switch to the meson build system
|
||||||
|
|
||||||
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.24.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.24.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.24.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 31 2017 Kalev Lember <klember@redhat.com> - 3.24.1-1
|
||||||
|
- Update to 3.24.1
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.24.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 22 2017 Wolfgang Ulbrich <fedora@raveit.de> - 3.24.0-2
|
||||||
|
- fix locale dir
|
||||||
|
- https://git.gnome.org/browse/libwnck/commit/?id=4feb967
|
||||||
|
|
||||||
|
* Sun Jul 02 2017 Wolfgang Ulbrich <fedora@raveit.de> - 3.24.0-1
|
||||||
|
- Update to 3.24.0
|
||||||
|
- modernize spec file
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.20.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 29 2016 Wolfgang Ulbrich <chat-to-me@raveit.de> - 3.20.1-1
|
||||||
|
- Update to 3.20.1
|
||||||
|
|
||||||
|
* Wed Jun 22 2016 Richard Hughes <rhughes@redhat.com> - 3.20.0-1
|
||||||
|
- Update to 3.20.0
|
||||||
|
|
||||||
|
* Tue Feb 16 2016 Richard Hughes <rhughes@redhat.com> - 3.14.1-1
|
||||||
|
- Update to 3.14.1
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.14.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.14.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
|
||||||
|
- Update to 3.14.0
|
||||||
|
|
||||||
|
* Wed Sep 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.4.9-1
|
||||||
|
- Update to 3.4.9
|
||||||
|
- Tighten -devel subpackage deps
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 3.4.7-3
|
||||||
|
- Rebuilt for gobject-introspection 1.41.4
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 22 2013 Kalev Lember <kalevlember@gmail.com> - 3.4.7-1
|
||||||
|
- Update to 3.4.7
|
||||||
|
|
||||||
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Feb 19 2013 Richard Hughes <rhughes@redhat.com> - 3.4.5-1
|
||||||
|
- Update to 3.4.5
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Nov 12 2012 Kalev Lember <kalevlember@gmail.com> - 3.4.4-1
|
||||||
|
- Update to 3.4.4
|
||||||
|
|
||||||
|
* Sat Sep 22 2012 Kalev Lember <kalevlember@gmail.com> - 3.4.3-1
|
||||||
|
- Update to 3.4.3
|
||||||
|
|
||||||
|
* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri May 18 2012 Richard Hughes <hughsient@gmail.com> - 3.4.2-1
|
||||||
|
- Update to 3.4.2
|
||||||
|
|
||||||
|
* Tue Mar 27 2012 Kalev Lember <kalevlember@gmail.com> - 3.4.0-1
|
||||||
|
- Update to 3.4.0
|
||||||
|
|
||||||
|
* Tue Feb 7 2012 Matthias Clasen <mclasen@redhat.com> - 3.3.5-1
|
||||||
|
- Update to 3.3.5
|
||||||
|
|
||||||
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2
|
||||||
|
- Rebuilt for glibc bug#747377
|
||||||
|
|
||||||
|
* Mon Oct 17 2011 Matthias Clasen <mclasen@redhat.com> - 3.2.1-1
|
||||||
|
- Update to 3.2.1
|
||||||
|
|
||||||
|
* Tue Sep 27 2011 Ray <rstrode@redhat.com> - 3.2.0-1
|
||||||
|
- Update to 3.2.0
|
||||||
|
|
||||||
|
* Mon Sep 19 2011 Matthias Clasen <mclasen@redhat.com> 3.1.92-1
|
||||||
|
- Update to 3.1.92
|
||||||
|
|
||||||
|
* Wed Aug 31 2011 Matthias Clasen <mclasen@redhat.com> 3.1.90-1
|
||||||
|
- Update to 3.1.90
|
||||||
|
|
||||||
|
* Wed Jul 6 2011 Matthias Clasen <mclasen@redhat.com> 3.0.2-1
|
||||||
|
- Update to 3.0.2
|
||||||
|
|
||||||
|
* Thu Feb 10 2011 Matthias Clasen <mclasen@redhat.com> 2.91.6-3
|
||||||
|
- Rebuild against newer gtk3
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.91.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 02 2011 Ray Strode <rstrode@redhat.com> 2.91.6-1
|
||||||
|
- Initial import.
|
Loading…
Reference in New Issue
Block a user