fix locale dir
This commit is contained in:
parent
c3ce4c2ff6
commit
b3f8b2f332
@ -3,12 +3,15 @@
|
|||||||
Summary: Window Navigator Construction Kit
|
Summary: Window Navigator Construction Kit
|
||||||
Name: libwnck3
|
Name: libwnck3
|
||||||
Version: 3.24.0
|
Version: 3.24.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
URL: http://download.gnome.org/sources/%{source_name}/
|
URL: http://download.gnome.org/sources/%{source_name}/
|
||||||
Source0: http://download.gnome.org/sources/%{source_name}/3.20/%{source_name}-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/%{source_name}/3.24/%{source_name}-%{version}.tar.xz
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
|
|
||||||
|
# https://git.gnome.org/browse/libwnck/commit/?id=4feb967
|
||||||
|
Patch1: libwnck3_fix-locale-dir.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel
|
BuildRequires: glib2-devel
|
||||||
BuildRequires: gtk3-devel
|
BuildRequires: gtk3-devel
|
||||||
BuildRequires: pango-devel
|
BuildRequires: pango-devel
|
||||||
@ -40,6 +43,10 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{source_name}-%{version}
|
%setup -q -n %{source_name}-%{version}
|
||||||
|
|
||||||
|
%patch1 -p1 -b .fix-locale-dir
|
||||||
|
|
||||||
|
autoreconf -fi
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
@ -76,7 +83,12 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
|||||||
%{_datadir}/gir-1.0/Wnck-3.0.gir
|
%{_datadir}/gir-1.0/Wnck-3.0.gir
|
||||||
%doc %{_datadir}/gtk-doc
|
%doc %{_datadir}/gtk-doc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jul 22 2017 Wolfgang Ulbrich <fedora@raveit.de> - 3.24.0-2
|
||||||
|
- fix locale dir
|
||||||
|
- https://git.gnome.org/browse/libwnck/commit/?id=4feb967
|
||||||
|
|
||||||
* Sun Jul 02 2017 Wolfgang Ulbrich <fedora@raveit.de> - 3.24.0-1
|
* Sun Jul 02 2017 Wolfgang Ulbrich <fedora@raveit.de> - 3.24.0-1
|
||||||
- Update to 3.24.0
|
- Update to 3.24.0
|
||||||
- modernize spec file
|
- modernize spec file
|
||||||
|
46
libwnck3_fix-locale-dir.patch
Normal file
46
libwnck3_fix-locale-dir.patch
Normal file
@ -0,0 +1,46 @@
|
|||||||
|
From aab7f7ace8838803f984599f0cba400d15059be3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Alberts=20Muktup=C4=81vels?= <alberts.muktupavels@gmail.com>
|
||||||
|
Date: Sat, 22 Jul 2017 14:07:04 +0300
|
||||||
|
Subject: fix locale dir
|
||||||
|
|
||||||
|
Commit 4feb96726f014270a6ae4f9ed29342ad53462d7f ported libwnck to
|
||||||
|
upstream gettext, but was still using $DATADIRNAME that was no
|
||||||
|
longer substituded with correct directory.
|
||||||
|
---
|
||||||
|
configure.ac | 5 -----
|
||||||
|
libwnck/Makefile.am | 2 +-
|
||||||
|
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 5935844..87e252a 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -75,11 +75,6 @@ GETTEXT_PACKAGE=libwnck-3.0
|
||||||
|
AC_SUBST(GETTEXT_PACKAGE)
|
||||||
|
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Package name])
|
||||||
|
|
||||||
|
-# AM_GLIB_GNU_GETTEXT above substs $DATADIRNAME
|
||||||
|
-# this is the directory where the *.{mo,gmo} files are installed
|
||||||
|
-wncklocaledir='${prefix}/${DATADIRNAME}/locale'
|
||||||
|
-AC_SUBST(wncklocaledir)
|
||||||
|
-
|
||||||
|
AC_PATH_PROG([GLIB_COMPILE_RESOURCES], [glib-compile-resources])
|
||||||
|
AC_PATH_PROG(PKG_CONFIG, pkg-config)
|
||||||
|
|
||||||
|
diff --git a/libwnck/Makefile.am b/libwnck/Makefile.am
|
||||||
|
index 5c025cc..6b6c7f8 100644
|
||||||
|
--- a/libwnck/Makefile.am
|
||||||
|
+++ b/libwnck/Makefile.am
|
||||||
|
@@ -25,7 +25,7 @@ AM_CPPFLAGS = \
|
||||||
|
-I$(top_srcdir) \
|
||||||
|
-I$(top_builddir) \
|
||||||
|
-DWNCK_I_KNOW_THIS_IS_UNSTABLE \
|
||||||
|
- -DWNCK_LOCALEDIR=\"$(wncklocaledir)\" \
|
||||||
|
+ -DWNCK_LOCALEDIR=\"$(localedir)\" \
|
||||||
|
$(DISABLE_DEPRECATED_CFLAGS)
|
||||||
|
|
||||||
|
AM_CFLAGS = $(WARN_CFLAGS)
|
||||||
|
--
|
||||||
|
cgit v0.12
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user