This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/libwebp.git#749e681bfe70e9be6a652eadd3375a80c99e5dd0
27 lines
980 B
Diff
27 lines
980 B
Diff
diff -rupN --no-dereference libwebp-1.2.0/CMakeLists.txt libwebp-1.2.0-new/CMakeLists.txt
|
|
--- libwebp-1.2.0/CMakeLists.txt 2021-01-21 04:43:45.000000000 +0100
|
|
+++ libwebp-1.2.0-new/CMakeLists.txt 2021-02-01 11:37:20.760764115 +0100
|
|
@@ -506,8 +506,8 @@ endif()
|
|
|
|
if(WEBP_BUILD_VWEBP)
|
|
# vwebp
|
|
- find_package(GLUT)
|
|
- if(GLUT_FOUND)
|
|
+ find_package(FreeGLUT)
|
|
+ if(FreeGLUT_FOUND)
|
|
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
|
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
|
add_executable(vwebp ${VWEBP_SRCS})
|
|
diff -rupN --no-dereference libwebp-1.2.0/examples/vwebp.c libwebp-1.2.0-new/examples/vwebp.c
|
|
--- libwebp-1.2.0/examples/vwebp.c 2021-01-21 04:43:45.000000000 +0100
|
|
+++ libwebp-1.2.0-new/examples/vwebp.c 2021-02-01 11:37:20.760764115 +0100
|
|
@@ -27,7 +27,7 @@
|
|
#if defined(HAVE_GLUT_GLUT_H)
|
|
#include <GLUT/glut.h>
|
|
#else
|
|
-#include <GL/glut.h>
|
|
+#include <GL/freeglut.h>
|
|
#ifdef FREEGLUT
|
|
#include <GL/freeglut.h>
|
|
#endif
|