Update to 1.1.0
This commit is contained in:
parent
0f707cf412
commit
fa32124542
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
||||
/libwebp-1.0.0.tar.gz
|
||||
/libwebp-1.0.2.tar.gz
|
||||
/libwebp-1.0.3.tar.gz
|
||||
/libwebp-1.1.0.tar.gz
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- a/CMakeLists.txt~ 2019-07-04 14:32:37.000000000 -0500
|
||||
+++ a/CMakeLists.txt 2019-09-20 15:18:10.590042650 -0500
|
||||
@@ -458,20 +458,20 @@
|
||||
diff -rupN --no-dereference libwebp-1.1.0/CMakeLists.txt libwebp-1.1.0-new/CMakeLists.txt
|
||||
--- libwebp-1.1.0/CMakeLists.txt 2019-12-21 14:37:43.000000000 +0100
|
||||
+++ libwebp-1.1.0-new/CMakeLists.txt 2020-01-07 08:40:04.574415507 +0100
|
||||
@@ -459,8 +459,8 @@ endif()
|
||||
|
||||
if(WEBP_BUILD_VWEBP)
|
||||
# vwebp
|
||||
@ -11,22 +12,9 @@
|
||||
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
|
||||
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
|
||||
add_executable(vwebp ${VWEBP_SRCS})
|
||||
target_link_libraries(vwebp
|
||||
${OPENGL_LIBRARIES}
|
||||
exampleutil
|
||||
- GLUT::GLUT
|
||||
+ -lglut
|
||||
imageioutil
|
||||
webp
|
||||
webpdemux)
|
||||
target_include_directories(vwebp
|
||||
- PRIVATE GLUT::GLUT
|
||||
+ PRIVATE -lglut
|
||||
${CMAKE_CURRENT_BINARY_DIR}/src
|
||||
${OPENGL_INCLUDE_DIR})
|
||||
install(TARGETS vwebp RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
|
||||
--- a/examples/vwebp.c~ 2019-07-04 14:32:37.000000000 -0500
|
||||
+++ a/examples/vwebp.c 2019-09-20 15:38:32.276641491 -0500
|
||||
diff -rupN --no-dereference libwebp-1.1.0/examples/vwebp.c libwebp-1.1.0-new/examples/vwebp.c
|
||||
--- libwebp-1.1.0/examples/vwebp.c 2019-12-21 14:37:43.000000000 +0100
|
||||
+++ libwebp-1.1.0-new/examples/vwebp.c 2020-01-07 08:40:04.575415463 +0100
|
||||
@@ -27,7 +27,7 @@
|
||||
#if defined(HAVE_GLUT_GLUT_H)
|
||||
#include <GLUT/glut.h>
|
||||
|
@ -1,8 +1,8 @@
|
||||
%global _hardened_build 1
|
||||
|
||||
Name: libwebp
|
||||
Version: 1.0.3
|
||||
Release: 3%{?dist}
|
||||
Version: 1.1.0
|
||||
Release: 1%{?dist}
|
||||
URL: http://webmproject.org/
|
||||
Summary: Library and tools for the WebP graphics format
|
||||
# Additional IPR is licensed as well. See PATENTS file for details
|
||||
@ -143,6 +143,9 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 07 2020 Sandro Mani <manisandro@gmail.com> - 1.1.0-1
|
||||
- Update to 1.1.0
|
||||
|
||||
* Tue Sep 17 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.0.3-3
|
||||
- Rebuilt for new freeglut
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libwebp-1.0.3.tar.gz) = 3ccdc62e5906f8de791053560e932b39df3cfdd7793617bd4562b7d95e2f6feac1535bc035e1b02591cab14b117ab15e51af6f9e4e3af1df0869c63945ec86b9
|
||||
SHA512 (libwebp-1.1.0.tar.gz) = c8440059a985587d4876a5e7fc2d07523bc7f582a04ee5dab0ef07df32b9635b907224de2cc15246c831dd5d9215569770196626badccc3171fe2832d7cb4549
|
||||
|
Loading…
Reference in New Issue
Block a user