Auto sync2gitlab import of libwebp-1.0.0-5.el8.src.rpm
This commit is contained in:
parent
0803ef4731
commit
efcb68475f
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/libwebp-1.0.0.tar.gz
|
282
libwebp.spec
Normal file
282
libwebp.spec
Normal file
@ -0,0 +1,282 @@
|
||||
%global _hardened_build 1
|
||||
|
||||
Name: libwebp
|
||||
Version: 1.0.0
|
||||
Release: 5%{?dist}
|
||||
URL: http://webmproject.org/
|
||||
Summary: Library and tools for the WebP graphics format
|
||||
# Additional IPR is licensed as well. See PATENTS file for details
|
||||
License: BSD
|
||||
Source0: http://downloads.webmproject.org/releases/webp/%{name}-%{version}.tar.gz
|
||||
Source1: libwebp_jni_example.java
|
||||
Patch0: rhbz-1956829.patch
|
||||
Patch1: rhbz-1956843.patch
|
||||
Patch2: rhbz-1956919.patch
|
||||
Patch3: rhbz-1956853.patch
|
||||
Patch4: rhbz-1956856.patch
|
||||
Patch5: rhbz-1956917.patch
|
||||
Patch6: rhbz-1956868.patch
|
||||
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: giflib-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: java-devel
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: swig
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: freeglut-devel
|
||||
|
||||
%description
|
||||
WebP is an image format that does lossy compression of digital
|
||||
photographic images. WebP consists of a codec based on VP8, and a
|
||||
container based on RIFF. Webmasters, web developers and browser
|
||||
developers can use WebP to compress, archive and distribute digital
|
||||
images more efficiently.
|
||||
|
||||
|
||||
%package tools
|
||||
Summary: The WebP command line tools
|
||||
|
||||
%description tools
|
||||
WebP is an image format that does lossy compression of digital
|
||||
photographic images. WebP consists of a codec based on VP8, and a
|
||||
container based on RIFF. Webmasters, web developers and browser
|
||||
developers can use WebP to compress, archive and distribute digital
|
||||
images more efficiently.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for libwebp, a library for the WebP format
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
WebP is an image format that does lossy compression of digital
|
||||
photographic images. WebP consists of a codec based on VP8, and a
|
||||
container based on RIFF. Webmasters, web developers and browser
|
||||
developers can use WebP to compress, archive and distribute digital
|
||||
images more efficiently.
|
||||
|
||||
|
||||
%package java
|
||||
Summary: Java bindings for libwebp, a library for the WebP format
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: java-headless
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description java
|
||||
Java bindings for libwebp.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
|
||||
%build
|
||||
autoreconf -vif
|
||||
%ifarch aarch64
|
||||
export CFLAGS="%{optflags} -frename-registers"
|
||||
%endif
|
||||
# Neon disabled due to resulting CFLAGS conflict resulting in
|
||||
# inlining failed in call to always_inline '[...]': target specific option mismatch
|
||||
%configure --disable-static --enable-libwebpmux \
|
||||
--enable-libwebpdemux --enable-libwebpdecoder \
|
||||
--disable-neon
|
||||
%make_build V=1
|
||||
|
||||
# swig generated Java bindings
|
||||
cp %{SOURCE1} .
|
||||
cd swig
|
||||
rm -rf libwebp.jar libwebp_java_wrap.c
|
||||
mkdir -p java/com/google/webp
|
||||
swig -ignoremissing -I../src -java \
|
||||
-package com.google.webp \
|
||||
-outdir java/com/google/webp \
|
||||
-o libwebp_java_wrap.c libwebp.swig
|
||||
|
||||
gcc %{__global_ldflags} %{optflags} -shared \
|
||||
-I/usr/lib/jvm/java/include \
|
||||
-I/usr/lib/jvm/java/include/linux \
|
||||
-I../src \
|
||||
-L../src/.libs -lwebp libwebp_java_wrap.c \
|
||||
-o libwebp_jni.so
|
||||
|
||||
cd java
|
||||
javac com/google/webp/libwebp.java
|
||||
jar cvf ../libwebp.jar com/google/webp/*.class
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
|
||||
|
||||
# swig generated Java bindings
|
||||
mkdir -p %{buildroot}/%{_libdir}/%{name}-java
|
||||
cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
|
||||
%files tools
|
||||
%{_bindir}/cwebp
|
||||
%{_bindir}/dwebp
|
||||
%{_bindir}/gif2webp
|
||||
%{_bindir}/img2webp
|
||||
%{_bindir}/webpinfo
|
||||
%{_bindir}/webpmux
|
||||
%{_bindir}/vwebp
|
||||
%{_mandir}/man*/*
|
||||
|
||||
%files -n %{name}
|
||||
%doc README PATENTS NEWS AUTHORS
|
||||
%license COPYING
|
||||
%{_libdir}/%{name}.so.7*
|
||||
%{_libdir}/%{name}decoder.so.3*
|
||||
%{_libdir}/%{name}demux.so.2*
|
||||
%{_libdir}/%{name}mux.so.3*
|
||||
|
||||
%files devel
|
||||
%{_libdir}/%{name}*.so
|
||||
%{_includedir}/*
|
||||
%{_libdir}/pkgconfig/*
|
||||
|
||||
%files java
|
||||
%doc libwebp_jni_example.java
|
||||
%{_libdir}/%{name}-java/
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 27 2021 Martin Stransky <stransky@redhat.com> - 1.0.0-5
|
||||
- Added fixes for rhbz#1956853, rhbz#1956856, rhbz#1956868, rhbz#1956917
|
||||
|
||||
* Mon May 17 2021 Martin Stransky <stransky@redhat.com> - 1.0.0-3
|
||||
- Added fixes for rhbz#1956829, rhbz#1956843, rhbz#1956919
|
||||
|
||||
* Thu Apr 26 2018 Sandro Mani <manisandro@gmail.com> - 1.0.0-1
|
||||
- Update to 1.0.0
|
||||
|
||||
* Tue Feb 27 2018 Sandro Mani <manisandro@gmail.com> - 0.6.1-8
|
||||
- Fix LDFLAGS not passed when building libwebp_jni.so (#1548718)
|
||||
|
||||
* Mon Feb 26 2018 Sandro Mani <manisandro@gmail.com> - 0.6.1-7
|
||||
- More big-endian fixes
|
||||
|
||||
* Fri Feb 16 2018 Sandro Mani <manisandro@gmail.com> - 0.6.1-6
|
||||
- Backport another big-endian fix
|
||||
|
||||
* Fri Feb 16 2018 Sandro Mani <manisandro@gmail.com> - 0.6.1-5
|
||||
- Backport upstream big-endian fix
|
||||
|
||||
* Tue Feb 13 2018 Sandro Mani <manisandro@gmail.com> - 0.6.1-4
|
||||
- Rebuild (giflib)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.1-2
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Thu Nov 30 2017 Sandro Mani <manisandro@gmail.com> - 0.6.1-1
|
||||
- Update to 0.6.1
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 0.6.0-1
|
||||
- Update to 0.6.0
|
||||
|
||||
* Thu Dec 22 2016 Sandro Mani <manisandro@gmail.com> - 0.5.2-1
|
||||
- Update to 0.5.2
|
||||
|
||||
* Sat Oct 29 2016 Sandro Mani <manisandro@gmail.com> - 0.5.1-2
|
||||
- Backport e2affacc35f1df6cc3b1a9fa0ceff5ce2d0cce83 (CVE-2016-9085, rhbz#1389338)
|
||||
|
||||
* Fri Aug 12 2016 Sandro Mani <manisandro@gmail.com> - 0.5.1-1
|
||||
- upstream release 0.5.1
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Dec 28 2015 Sandro Mani <manisandro@gmail.com> - 0.5.0-1
|
||||
- upstream release 0.5.0
|
||||
|
||||
* Fri Oct 30 2015 Sandro Mani <manisandro@gmail.com> - 0.4.4-1
|
||||
- upstream release 0.4.4
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Mar 27 2015 Sandro Mani <manisandro@gmail.com> - 0.4.3-2
|
||||
- Add BuildRequires: freeglut-devel to build vwebp
|
||||
|
||||
* Thu Mar 12 2015 Sandro Mani <manisandro@gmail.com> - 0.4.3-1
|
||||
- upstream release 0.4.3
|
||||
|
||||
* Fri Oct 17 2014 Sandro Mani <manisandro@gmail.com> - 0.4.2-1
|
||||
- upstream release 0.4.2
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Wed Aug 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.4.1-2
|
||||
- Use frename-registers cflag to fix FTBFS on aarch64
|
||||
|
||||
* Tue Aug 05 2014 Sandro Mani <manisandro@gmail.com> - 0.4.1-1
|
||||
- upstream release 0.4.1
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue Apr 08 2014 Jaromir Capik <jcapik@redhat.com> - 0.4.0-3
|
||||
- Fixing endian checks (#962091)
|
||||
- Fixing FTPBS caused by rpath presence
|
||||
|
||||
* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 0.4.0-2
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 0.4.0-1
|
||||
- upstream release 0.4.0
|
||||
|
||||
* Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 0.3.1-2
|
||||
- enable webpdemux
|
||||
|
||||
* Sun Aug 04 2013 Sandro Mani <manisandro@gmail.com> - 0.3.1-1
|
||||
- upstream release 0.3.1
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon May 13 2013 Rahul Sundaram <sundaram@fedoraproject.org> - 0.3.0-1
|
||||
- upstream release 0.3.0
|
||||
- enable gif2webp
|
||||
- add build requires on giflib-devel and libtiff-devel
|
||||
- use make_install and hardened macros
|
||||
- list binaries explicitly
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 0.2.1-2
|
||||
- rebuild due to "jpeg8-ABI" feature drop
|
||||
|
||||
* Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
|
||||
- new upstream release 0.2.1
|
||||
|
||||
* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
|
||||
- rebuild against new libjpeg
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
|
||||
- Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
|
||||
|
||||
* Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
|
||||
- Initial spec. Based on openSUSE one
|
27
libwebp_jni_example.java
Normal file
27
libwebp_jni_example.java
Normal file
@ -0,0 +1,27 @@
|
||||
import com.google.webp.libwebp;
|
||||
|
||||
import java.lang.reflect.Method;
|
||||
|
||||
public class libwebp_jni_example {
|
||||
static {
|
||||
try {
|
||||
System.load("/usr/lib64/libwebp-java/libwebp_jni.so");
|
||||
} catch (UnsatisfiedLinkError e) {
|
||||
System.load("/usr/lib/libwebp-java/libwebp_jni.so");
|
||||
}
|
||||
}
|
||||
|
||||
/**
|
||||
* usage: java -cp libwebp.jar:. libwebp_jni_example
|
||||
*/
|
||||
public static void main(String argv[]) {
|
||||
final int version = libwebp.WebPGetDecoderVersion();
|
||||
System.out.println("libwebp version: " + Integer.toHexString(version));
|
||||
|
||||
System.out.println("libwebp methods:");
|
||||
final Method[] libwebpMethods = libwebp.class.getDeclaredMethods();
|
||||
for (int i = 0; i < libwebpMethods.length; i++) {
|
||||
System.out.println(libwebpMethods[i]);
|
||||
}
|
||||
}
|
||||
}
|
15
rhbz-1956829.patch
Normal file
15
rhbz-1956829.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/src/dec/buffer_dec.c b/src/dec/buffer_dec.c
|
||||
index 75eb3c4..3cd94eb 100644
|
||||
--- a/src/dec/buffer_dec.c
|
||||
+++ b/src/dec/buffer_dec.c
|
||||
@@ -74,7 +74,8 @@
|
||||
} else { // RGB checks
|
||||
const WebPRGBABuffer* const buf = &buffer->u.RGBA;
|
||||
const int stride = abs(buf->stride);
|
||||
- const uint64_t size = MIN_BUFFER_SIZE(width, height, stride);
|
||||
+ const uint64_t size =
|
||||
+ MIN_BUFFER_SIZE(width * kModeBpp[mode], height, stride);
|
||||
ok &= (size <= buf->size);
|
||||
ok &= (stride >= width * kModeBpp[mode]);
|
||||
ok &= (buf->rgba != NULL);
|
||||
|
19
rhbz-1956843.patch
Normal file
19
rhbz-1956843.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff --git a/src/dec/idec_dec.c b/src/dec/idec_dec.c
|
||||
index a371ed7..258d15b 100644
|
||||
--- a/src/dec/idec_dec.c
|
||||
+++ b/src/dec/idec_dec.c
|
||||
|
||||
@@ -283,10 +283,8 @@
|
||||
|
||||
static VP8StatusCode IDecError(WebPIDecoder* const idec, VP8StatusCode error) {
|
||||
if (idec->state_ == STATE_VP8_DATA) {
|
||||
- VP8Io* const io = &idec->io_;
|
||||
- if (io->teardown != NULL) {
|
||||
- io->teardown(io);
|
||||
- }
|
||||
+ // Synchronize the thread, clean-up and check for errors.
|
||||
+ VP8ExitCritical((VP8Decoder*)idec->dec_, &idec->io_);
|
||||
}
|
||||
idec->state_ = STATE_ERROR;
|
||||
return error;
|
||||
|
42
rhbz-1956853.patch
Normal file
42
rhbz-1956853.patch
Normal file
@ -0,0 +1,42 @@
|
||||
diff --git a/src/mux/muxread.c b/src/mux/muxread.c
|
||||
index 0b55286..eb5070b 100644
|
||||
--- a/src/mux/muxread.c
|
||||
+++ b/src/mux/muxread.c
|
||||
|
||||
@@ -187,7 +187,7 @@
|
||||
size = bitstream->size;
|
||||
|
||||
if (data == NULL) return NULL;
|
||||
- if (size < RIFF_HEADER_SIZE) return NULL;
|
||||
+ if (size < RIFF_HEADER_SIZE + CHUNK_HEADER_SIZE) return NULL;
|
||||
if (GetLE32(data + 0) != MKFOURCC('R', 'I', 'F', 'F') ||
|
||||
GetLE32(data + CHUNK_HEADER_SIZE) != MKFOURCC('W', 'E', 'B', 'P')) {
|
||||
return NULL;
|
||||
@@ -196,8 +196,6 @@
|
||||
mux = WebPMuxNew();
|
||||
if (mux == NULL) return NULL;
|
||||
|
||||
- if (size < RIFF_HEADER_SIZE + TAG_SIZE) goto Err;
|
||||
-
|
||||
tag = GetLE32(data + RIFF_HEADER_SIZE);
|
||||
if (tag != kChunks[IDX_VP8].tag &&
|
||||
tag != kChunks[IDX_VP8L].tag &&
|
||||
@@ -206,12 +204,11 @@
|
||||
}
|
||||
|
||||
riff_size = SizeWithPadding(GetLE32(data + TAG_SIZE));
|
||||
- if (riff_size > MAX_CHUNK_PAYLOAD || riff_size > size) {
|
||||
- goto Err;
|
||||
- } else {
|
||||
- if (riff_size < size) { // Redundant data after last chunk.
|
||||
- size = riff_size; // To make sure we don't read any data beyond mux_size.
|
||||
- }
|
||||
+ if (riff_size < CHUNK_HEADER_SIZE) goto Err;
|
||||
+ if (riff_size > MAX_CHUNK_PAYLOAD || riff_size > size) goto Err;
|
||||
+ // There's no point in reading past the end of the RIFF chunk.
|
||||
+ if (size > riff_size + CHUNK_HEADER_SIZE) {
|
||||
+ size = riff_size + CHUNK_HEADER_SIZE;
|
||||
}
|
||||
|
||||
end = data + size;
|
||||
|
61
rhbz-1956856.patch
Normal file
61
rhbz-1956856.patch
Normal file
@ -0,0 +1,61 @@
|
||||
diff --git a/src/mux/muxi.h b/src/mux/muxi.h
|
||||
index 6b57eea..14fd6e2 100644
|
||||
--- a/src/mux/muxi.h
|
||||
+++ b/src/mux/muxi.h
|
||||
|
||||
@@ -14,6 +14,7 @@
|
||||
#ifndef WEBP_MUX_MUXI_H_
|
||||
#define WEBP_MUX_MUXI_H_
|
||||
|
||||
+#include <assert.h>
|
||||
#include <stdlib.h>
|
||||
#include "src/dec/vp8i_dec.h"
|
||||
#include "src/dec/vp8li_dec.h"
|
||||
@@ -143,13 +144,13 @@
|
||||
|
||||
// Returns size of the chunk including chunk header and padding byte (if any).
|
||||
static WEBP_INLINE size_t SizeWithPadding(size_t chunk_size) {
|
||||
+ assert(chunk_size <= MAX_CHUNK_PAYLOAD);
|
||||
return CHUNK_HEADER_SIZE + ((chunk_size + 1) & ~1U);
|
||||
}
|
||||
|
||||
// Size of a chunk including header and padding.
|
||||
static WEBP_INLINE size_t ChunkDiskSize(const WebPChunk* chunk) {
|
||||
const size_t data_size = chunk->data_.size;
|
||||
- assert(data_size < MAX_CHUNK_PAYLOAD);
|
||||
return SizeWithPadding(data_size);
|
||||
}
|
||||
|
||||
|
||||
diff --git a/src/mux/muxread.c b/src/mux/muxread.c
|
||||
index eb5070b..ef50dae 100644
|
||||
--- a/src/mux/muxread.c
|
||||
+++ b/src/mux/muxread.c
|
||||
|
||||
@@ -59,6 +59,7 @@
|
||||
// Sanity checks.
|
||||
if (data_size < CHUNK_HEADER_SIZE) return WEBP_MUX_NOT_ENOUGH_DATA;
|
||||
chunk_size = GetLE32(data + TAG_SIZE);
|
||||
+ if (chunk_size > MAX_CHUNK_PAYLOAD) return WEBP_MUX_BAD_DATA;
|
||||
|
||||
{
|
||||
const size_t chunk_disk_size = SizeWithPadding(chunk_size);
|
||||
@@ -203,9 +204,14 @@
|
||||
goto Err; // First chunk should be VP8, VP8L or VP8X.
|
||||
}
|
||||
|
||||
- riff_size = SizeWithPadding(GetLE32(data + TAG_SIZE));
|
||||
+ riff_size = GetLE32(data + TAG_SIZE);
|
||||
+ if (riff_size > MAX_CHUNK_PAYLOAD) goto Err;
|
||||
+
|
||||
+ // Note this padding is historical and differs from demux.c which does not
|
||||
+ // pad the file size.
|
||||
+ riff_size = SizeWithPadding(riff_size);
|
||||
if (riff_size < CHUNK_HEADER_SIZE) goto Err;
|
||||
- if (riff_size > MAX_CHUNK_PAYLOAD || riff_size > size) goto Err;
|
||||
+ if (riff_size > size) goto Err;
|
||||
// There's no point in reading past the end of the RIFF chunk.
|
||||
if (size > riff_size + CHUNK_HEADER_SIZE) {
|
||||
size = riff_size + CHUNK_HEADER_SIZE;
|
||||
|
||||
|
213
rhbz-1956868.patch
Normal file
213
rhbz-1956868.patch
Normal file
@ -0,0 +1,213 @@
|
||||
diff -up libwebp-1.0.0/src/dec/vp8l_dec.c.old libwebp-1.0.0/src/dec/vp8l_dec.c
|
||||
--- libwebp-1.0.0/src/dec/vp8l_dec.c.old 2018-04-21 05:04:55.000000000 +0200
|
||||
+++ libwebp-1.0.0/src/dec/vp8l_dec.c 2018-11-09 00:29:51.000000000 +0100
|
||||
@@ -362,12 +362,19 @@ static int ReadHuffmanCodes(VP8LDecoder*
|
||||
VP8LMetadata* const hdr = &dec->hdr_;
|
||||
uint32_t* huffman_image = NULL;
|
||||
HTreeGroup* htree_groups = NULL;
|
||||
+ // When reading htrees, some might be unused, as the format allows it.
|
||||
+ // We will still read them but put them in this htree_group_bogus.
|
||||
+ HTreeGroup htree_group_bogus;
|
||||
HuffmanCode* huffman_tables = NULL;
|
||||
+ HuffmanCode* huffman_tables_bogus = NULL;
|
||||
HuffmanCode* next = NULL;
|
||||
int num_htree_groups = 1;
|
||||
+ int num_htree_groups_max = 1;
|
||||
int max_alphabet_size = 0;
|
||||
int* code_lengths = NULL;
|
||||
const int table_size = kTableSize[color_cache_bits];
|
||||
+ int* mapping = NULL;
|
||||
+ int ok = 0;
|
||||
|
||||
if (allow_recursion && VP8LReadBits(br, 1)) {
|
||||
// use meta Huffman codes.
|
||||
@@ -384,10 +391,42 @@ static int ReadHuffmanCodes(VP8LDecoder*
|
||||
// The huffman data is stored in red and green bytes.
|
||||
const int group = (huffman_image[i] >> 8) & 0xffff;
|
||||
huffman_image[i] = group;
|
||||
- if (group >= num_htree_groups) {
|
||||
- num_htree_groups = group + 1;
|
||||
+ if (group >= num_htree_groups_max) {
|
||||
+ num_htree_groups_max = group + 1;
|
||||
}
|
||||
}
|
||||
+ // Check the validity of num_htree_groups_max. If it seems too big, use a
|
||||
+ // smaller value for later. This will prevent big memory allocations to end
|
||||
+ // up with a bad bitstream anyway.
|
||||
+ // The value of 1000 is totally arbitrary. We know that num_htree_groups_max
|
||||
+ // is smaller than (1 << 16) and should be smaller than the number of pixels
|
||||
+ // (though the format allows it to be bigger).
|
||||
+ if (num_htree_groups_max > 1000 || num_htree_groups_max > xsize * ysize) {
|
||||
+ // Create a mapping from the used indices to the minimal set of used
|
||||
+ // values [0, num_htree_groups)
|
||||
+ mapping = (int*)WebPSafeMalloc(num_htree_groups_max, sizeof(*mapping));
|
||||
+ if (mapping == NULL) {
|
||||
+ dec->status_ = VP8_STATUS_OUT_OF_MEMORY;
|
||||
+ goto Error;
|
||||
+ }
|
||||
+ // -1 means a value is unmapped, and therefore unused in the Huffman
|
||||
+ // image.
|
||||
+ memset(mapping, 0xff, num_htree_groups_max * sizeof(*mapping));
|
||||
+ for (num_htree_groups = 0, i = 0; i < huffman_pixs; ++i) {
|
||||
+ // Get the current mapping for the group and remap the Huffman image.
|
||||
+ int* const mapped_group = &mapping[huffman_image[i]];
|
||||
+ if (*mapped_group == -1) *mapped_group = num_htree_groups++;
|
||||
+ huffman_image[i] = *mapped_group;
|
||||
+ }
|
||||
+ huffman_tables_bogus = (HuffmanCode*)WebPSafeMalloc(
|
||||
+ table_size, sizeof(*huffman_tables_bogus));
|
||||
+ if (huffman_tables_bogus == NULL) {
|
||||
+ dec->status_ = VP8_STATUS_OUT_OF_MEMORY;
|
||||
+ goto Error;
|
||||
+ }
|
||||
+ } else {
|
||||
+ num_htree_groups = num_htree_groups_max;
|
||||
+ }
|
||||
}
|
||||
|
||||
if (br->eos_) goto Error;
|
||||
@@ -403,11 +442,11 @@ static int ReadHuffmanCodes(VP8LDecoder*
|
||||
}
|
||||
}
|
||||
|
||||
+ code_lengths = (int*)WebPSafeCalloc((uint64_t)max_alphabet_size,
|
||||
+ sizeof(*code_lengths));
|
||||
huffman_tables = (HuffmanCode*)WebPSafeMalloc(num_htree_groups * table_size,
|
||||
sizeof(*huffman_tables));
|
||||
htree_groups = VP8LHtreeGroupsNew(num_htree_groups);
|
||||
- code_lengths = (int*)WebPSafeCalloc((uint64_t)max_alphabet_size,
|
||||
- sizeof(*code_lengths));
|
||||
|
||||
if (htree_groups == NULL || code_lengths == NULL || huffman_tables == NULL) {
|
||||
dec->status_ = VP8_STATUS_OUT_OF_MEMORY;
|
||||
@@ -415,28 +454,35 @@ static int ReadHuffmanCodes(VP8LDecoder*
|
||||
}
|
||||
|
||||
next = huffman_tables;
|
||||
- for (i = 0; i < num_htree_groups; ++i) {
|
||||
- HTreeGroup* const htree_group = &htree_groups[i];
|
||||
+ for (i = 0; i < num_htree_groups_max; ++i) {
|
||||
+ // If the index "i" is unused in the Huffman image, read the coefficients
|
||||
+ // but store them to a bogus htree_group.
|
||||
+ const int is_bogus = (mapping != NULL && mapping[i] == -1);
|
||||
+ HTreeGroup* const htree_group =
|
||||
+ is_bogus ? &htree_group_bogus :
|
||||
+ &htree_groups[(mapping == NULL) ? i : mapping[i]];
|
||||
HuffmanCode** const htrees = htree_group->htrees;
|
||||
+ HuffmanCode* huffman_tables_i = is_bogus ? huffman_tables_bogus : next;
|
||||
int size;
|
||||
int total_size = 0;
|
||||
int is_trivial_literal = 1;
|
||||
int max_bits = 0;
|
||||
for (j = 0; j < HUFFMAN_CODES_PER_META_CODE; ++j) {
|
||||
int alphabet_size = kAlphabetSize[j];
|
||||
- htrees[j] = next;
|
||||
+ htrees[j] = huffman_tables_i;
|
||||
if (j == 0 && color_cache_bits > 0) {
|
||||
alphabet_size += 1 << color_cache_bits;
|
||||
}
|
||||
- size = ReadHuffmanCode(alphabet_size, dec, code_lengths, next);
|
||||
+ size =
|
||||
+ ReadHuffmanCode(alphabet_size, dec, code_lengths, huffman_tables_i);
|
||||
if (size == 0) {
|
||||
goto Error;
|
||||
}
|
||||
if (is_trivial_literal && kLiteralMap[j] == 1) {
|
||||
- is_trivial_literal = (next->bits == 0);
|
||||
+ is_trivial_literal = (huffman_tables_i->bits == 0);
|
||||
}
|
||||
- total_size += next->bits;
|
||||
- next += size;
|
||||
+ total_size += huffman_tables_i->bits;
|
||||
+ huffman_tables_i += size;
|
||||
if (j <= ALPHA) {
|
||||
int local_max_bits = code_lengths[0];
|
||||
int k;
|
||||
@@ -448,38 +494,41 @@ static int ReadHuffmanCodes(VP8LDecoder*
|
||||
max_bits += local_max_bits;
|
||||
}
|
||||
}
|
||||
+ if (!is_bogus) next = huffman_tables_i;
|
||||
htree_group->is_trivial_literal = is_trivial_literal;
|
||||
htree_group->is_trivial_code = 0;
|
||||
if (is_trivial_literal) {
|
||||
const int red = htrees[RED][0].value;
|
||||
const int blue = htrees[BLUE][0].value;
|
||||
const int alpha = htrees[ALPHA][0].value;
|
||||
- htree_group->literal_arb =
|
||||
- ((uint32_t)alpha << 24) | (red << 16) | blue;
|
||||
+ htree_group->literal_arb = ((uint32_t)alpha << 24) | (red << 16) | blue;
|
||||
if (total_size == 0 && htrees[GREEN][0].value < NUM_LITERAL_CODES) {
|
||||
htree_group->is_trivial_code = 1;
|
||||
htree_group->literal_arb |= htrees[GREEN][0].value << 8;
|
||||
}
|
||||
}
|
||||
- htree_group->use_packed_table = !htree_group->is_trivial_code &&
|
||||
- (max_bits < HUFFMAN_PACKED_BITS);
|
||||
+ htree_group->use_packed_table =
|
||||
+ !htree_group->is_trivial_code && (max_bits < HUFFMAN_PACKED_BITS);
|
||||
if (htree_group->use_packed_table) BuildPackedTable(htree_group);
|
||||
}
|
||||
- WebPSafeFree(code_lengths);
|
||||
+ ok = 1;
|
||||
|
||||
- // All OK. Finalize pointers and return.
|
||||
+ // All OK. Finalize pointers.
|
||||
hdr->huffman_image_ = huffman_image;
|
||||
hdr->num_htree_groups_ = num_htree_groups;
|
||||
hdr->htree_groups_ = htree_groups;
|
||||
hdr->huffman_tables_ = huffman_tables;
|
||||
- return 1;
|
||||
|
||||
Error:
|
||||
WebPSafeFree(code_lengths);
|
||||
- WebPSafeFree(huffman_image);
|
||||
- WebPSafeFree(huffman_tables);
|
||||
- VP8LHtreeGroupsFree(htree_groups);
|
||||
- return 0;
|
||||
+ WebPSafeFree(huffman_tables_bogus);
|
||||
+ WebPSafeFree(mapping);
|
||||
+ if (!ok) {
|
||||
+ WebPSafeFree(huffman_image);
|
||||
+ WebPSafeFree(huffman_tables);
|
||||
+ VP8LHtreeGroupsFree(htree_groups);
|
||||
+ }
|
||||
+ return ok;
|
||||
}
|
||||
|
||||
//------------------------------------------------------------------------------
|
||||
@@ -884,7 +933,11 @@ static WEBP_INLINE void CopyBlock8b(uint
|
||||
#endif
|
||||
break;
|
||||
case 2:
|
||||
+#if !defined(WORDS_BIGENDIAN)
|
||||
memcpy(&pattern, src, sizeof(uint16_t));
|
||||
+#else
|
||||
+ pattern = ((uint32_t)src[0] << 8) | src[1];
|
||||
+#endif
|
||||
#if defined(__arm__) || defined(_M_ARM)
|
||||
pattern |= pattern << 16;
|
||||
#elif defined(WEBP_USE_MIPS_DSP_R2)
|
||||
@@ -1523,7 +1576,6 @@ int VP8LDecodeAlphaHeader(ALPHDecoder* c
|
||||
if (dec == NULL) return 0;
|
||||
|
||||
assert(alph_dec != NULL);
|
||||
- alph_dec->vp8l_dec_ = dec;
|
||||
|
||||
dec->width_ = alph_dec->width_;
|
||||
dec->height_ = alph_dec->height_;
|
||||
@@ -1555,11 +1607,12 @@ int VP8LDecodeAlphaHeader(ALPHDecoder* c
|
||||
|
||||
if (!ok) goto Err;
|
||||
|
||||
+ // Only set here, once we are sure it is valid (to avoid thread races).
|
||||
+ alph_dec->vp8l_dec_ = dec;
|
||||
return 1;
|
||||
|
||||
Err:
|
||||
- VP8LDelete(alph_dec->vp8l_dec_);
|
||||
- alph_dec->vp8l_dec_ = NULL;
|
||||
+ VP8LDelete(dec);
|
||||
return 0;
|
||||
}
|
||||
|
14
rhbz-1956917.patch
Normal file
14
rhbz-1956917.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff --git a/src/mux/muxread.c b/src/mux/muxread.c
|
||||
index fbe9f05..ea07dbf 100644
|
||||
--- a/src/mux/muxread.c
|
||||
+++ b/src/mux/muxread.c
|
||||
|
||||
@@ -264,6 +264,7 @@
|
||||
chunk_list = MuxGetChunkListFromId(mux, id); // List to add this chunk.
|
||||
if (ChunkSetNth(&chunk, chunk_list, 0) != WEBP_MUX_OK) goto Err;
|
||||
if (id == WEBP_CHUNK_VP8X) { // grab global specs
|
||||
+ if (data_size < CHUNK_HEADER_SIZE + VP8X_CHUNK_SIZE) goto Err;
|
||||
mux->canvas_width_ = GetLE24(data + 12) + 1;
|
||||
mux->canvas_height_ = GetLE24(data + 15) + 1;
|
||||
}
|
||||
|
36
rhbz-1956919.patch
Normal file
36
rhbz-1956919.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff --git a/src/utils/quant_levels_dec_utils.c b/src/utils/quant_levels_dec_utils.c
|
||||
index 3818a78..f65b6cd 100644
|
||||
--- a/src/utils/quant_levels_dec_utils.c
|
||||
+++ b/src/utils/quant_levels_dec_utils.c
|
||||
|
||||
@@ -261,9 +261,15 @@
|
||||
|
||||
int WebPDequantizeLevels(uint8_t* const data, int width, int height, int stride,
|
||||
int strength) {
|
||||
- const int radius = 4 * strength / 100;
|
||||
+ int radius = 4 * strength / 100;
|
||||
+
|
||||
if (strength < 0 || strength > 100) return 0;
|
||||
if (data == NULL || width <= 0 || height <= 0) return 0; // bad params
|
||||
+
|
||||
+ // limit the filter size to not exceed the image dimensions
|
||||
+ if (2 * radius + 1 > width) radius = (width - 1) >> 1;
|
||||
+ if (2 * radius + 1 > height) radius = (height - 1) >> 1;
|
||||
+
|
||||
if (radius > 0) {
|
||||
SmoothParams p;
|
||||
memset(&p, 0, sizeof(p));
|
||||
diff --git a/src/mux/muxread.c b/src/mux/muxread.c
|
||||
index ef50dae..fbe9f05 100644
|
||||
--- a/src/mux/muxread.c
|
||||
+++ b/src/mux/muxread.c
|
||||
|
||||
@@ -138,6 +138,7 @@
|
||||
wpi->is_partial_ = 1; // Waiting for a VP8 chunk.
|
||||
break;
|
||||
case WEBP_CHUNK_IMAGE:
|
||||
+ if (wpi->img_ != NULL) goto Fail; // Only 1 image chunk allowed.
|
||||
if (ChunkSetNth(&subchunk, &wpi->img_, 1) != WEBP_MUX_OK) goto Fail;
|
||||
if (!MuxImageFinalize(wpi)) goto Fail;
|
||||
wpi->is_partial_ = 0; // wpi is completely filled.
|
||||
|
Loading…
Reference in New Issue
Block a user