Update to 1.3.1

This commit is contained in:
Sandro Mani 2023-06-30 14:06:26 +02:00
parent 75ab568b76
commit 6ef6953f51
7 changed files with 35 additions and 44 deletions

1
.gitignore vendored
View File

@ -22,3 +22,4 @@
/libwebp-1.2.3.tar.gz
/libwebp-1.2.4.tar.gz
/libwebp-1.3.0.tar.gz
/libwebp-1.3.1.tar.gz

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.623139692 +0100
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.627139720 +0100
@@ -716,7 +716,7 @@ install(
diff -rupN --no-dereference libwebp-1.3.1/CMakeLists.txt libwebp-1.3.1-new/CMakeLists.txt
--- libwebp-1.3.1/CMakeLists.txt 2023-06-30 13:58:57.280934048 +0200
+++ libwebp-1.3.1-new/CMakeLists.txt 2023-06-30 13:58:57.284933988 +0200
@@ -738,7 +738,7 @@ install(
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
@ -10,18 +10,3 @@ diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMake
install(EXPORT ${PROJECT_NAME}Targets NAMESPACE ${PROJECT_NAME}::
DESTINATION ${ConfigPackageLocation})
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt.rej libwebp-1.3.0-new/CMakeLists.txt.rej
--- libwebp-1.3.0/CMakeLists.txt.rej 1970-01-01 01:00:00.000000000 +0100
+++ libwebp-1.3.0-new/CMakeLists.txt.rej 2023-01-13 13:06:13.627139720 +0100
@@ -0,0 +1,11 @@
+--- CMakeLists.txt 2022-08-07 11:33:19.069010628 +0200
++++ CMakeLists.txt 2022-08-07 11:33:19.073010628 +0200
+@@ -726,7 +726,7 @@ install(TARGETS ${INSTALLED_LIBRARIES}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+-set(ConfigPackageLocation ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake/)
++set(ConfigPackageLocation ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}/)
+ install(EXPORT ${PROJECT_NAME}Targets
+ NAMESPACE ${PROJECT_NAME}::
+ DESTINATION ${ConfigPackageLocation})

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
--- libwebp-1.3.0/CMakeLists.txt 2022-12-20 01:23:35.000000000 +0100
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.548139166 +0100
@@ -552,8 +552,8 @@ endif()
diff -rupN --no-dereference libwebp-1.3.1/CMakeLists.txt libwebp-1.3.1-new/CMakeLists.txt
--- libwebp-1.3.1/CMakeLists.txt 2023-06-23 20:52:38.000000000 +0200
+++ libwebp-1.3.1-new/CMakeLists.txt 2023-06-30 13:58:57.206935155 +0200
@@ -564,8 +564,8 @@ endif()
if(WEBP_BUILD_VWEBP)
# vwebp
@ -12,7 +12,7 @@ diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMake
include_directories(${WEBP_DEP_IMG_INCLUDE_DIRS})
parse_makefile_am(${CMAKE_CURRENT_SOURCE_DIR}/examples "VWEBP_SRCS" "vwebp")
add_executable(vwebp ${VWEBP_SRCS})
@@ -561,7 +561,7 @@ if(WEBP_BUILD_VWEBP)
@@ -573,7 +573,7 @@ if(WEBP_BUILD_VWEBP)
vwebp
${OPENGL_LIBRARIES}
exampleutil
@ -21,9 +21,9 @@ diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMake
imageioutil
webp
webpdemux)
diff -rupN --no-dereference libwebp-1.3.0/examples/vwebp.c libwebp-1.3.0-new/examples/vwebp.c
--- libwebp-1.3.0/examples/vwebp.c 2022-12-20 01:23:35.000000000 +0100
+++ libwebp-1.3.0-new/examples/vwebp.c 2023-01-13 13:06:13.548139166 +0100
diff -rupN --no-dereference libwebp-1.3.1/examples/vwebp.c libwebp-1.3.1-new/examples/vwebp.c
--- libwebp-1.3.1/examples/vwebp.c 2023-06-23 20:52:38.000000000 +0200
+++ libwebp-1.3.1-new/examples/vwebp.c 2023-06-30 13:58:57.207935140 +0200
@@ -27,7 +27,7 @@
#if defined(HAVE_GLUT_GLUT_H)
#include <GLUT/glut.h>

View File

@ -1,7 +1,7 @@
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.583139412 +0100
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.588139447 +0100
@@ -275,6 +275,9 @@ macro(set_version FILE TARGET_NAME NAME_
diff -rupN --no-dereference libwebp-1.3.1/CMakeLists.txt libwebp-1.3.1-new/CMakeLists.txt
--- libwebp-1.3.1/CMakeLists.txt 2023-06-30 13:58:57.241934631 +0200
+++ libwebp-1.3.1-new/CMakeLists.txt 2023-06-30 13:58:57.246934557 +0200
@@ -286,6 +286,9 @@ macro(set_version FILE TARGET_NAME NAME_
MACHO_CURRENT_VERSION
${LIBWEBP_MACHO_COMPATIBILITY_VERSION}.${LT_REVISION})
endif()

View File

@ -1,18 +1,20 @@
diff -rupN --no-dereference libwebp-1.3.0/CMakeLists.txt libwebp-1.3.0-new/CMakeLists.txt
--- libwebp-1.3.0/CMakeLists.txt 2023-01-13 13:06:13.664139980 +0100
+++ libwebp-1.3.0-new/CMakeLists.txt 2023-01-13 13:06:13.669140015 +0100
@@ -101,11 +101,11 @@ endif()
diff -rupN --no-dereference libwebp-1.3.1/CMakeLists.txt libwebp-1.3.1-new/CMakeLists.txt
--- libwebp-1.3.1/CMakeLists.txt 2023-06-30 13:58:57.318933479 +0200
+++ libwebp-1.3.1-new/CMakeLists.txt 2023-06-30 13:58:57.323933405 +0200
@@ -112,11 +112,11 @@ endif()
include(cmake/deps.cmake)
include(GNUInstallDirs)
-if(BUILD_SHARED_LIBS AND NOT CMAKE_INSTALL_RPATH)
+#if(BUILD_SHARED_LIBS AND NOT CMAKE_INSTALL_RPATH)
# Set the rpath to match autoconf/libtool behavior. Note this must be set
# before target creation.
-if(BUILD_SHARED_LIBS AND NOT DEFINED CMAKE_INSTALL_RPATH)
- # Set the rpath to match autoconf/libtool behavior. Note this must be set
- # before target creation.
- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
-endif()
+ # set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
+#endif()
+# if(BUILD_SHARED_LIBS AND NOT DEFINED CMAKE_INSTALL_RPATH)
+# # Set the rpath to match autoconf/libtool behavior. Note this must be set
+# # before target creation.
+# set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
+# endif()
# ##############################################################################
# Options.

View File

@ -13,8 +13,8 @@
%endif
Name: libwebp
Version: 1.3.0
Release: 2%{?dist}
Version: 1.3.1
Release: 1%{?dist}
URL: http://webmproject.org/
Summary: Library and tools for the WebP graphics format
# Additional IPR is licensed as well. See PATENTS file for details
@ -285,6 +285,9 @@ cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
%changelog
* Fri Jun 30 2023 Sandro Mani <manisandro@gmail.com> - 1.3.1-1
- Update to 1.3.1
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (libwebp-1.3.0.tar.gz) = 5af6999654e9ba3189574158c194396e3ad7b7d5061abf2711a7c93558a5898cd99adccd1c051e9a7910beb915fba8e703d33e7b6f06753b6f68c009c0e0d2bc
SHA512 (libwebp-1.3.1.tar.gz) = f2c5e4fbbb5adf63d4a36bad88de23881c296da6f3ec73baded5e80fd55abef6cbeb90c271fd40766a76e170e5499c2983670d91e01064027ede22965d2b1d90