fix bugzilla 599147, albeit, a bit hackishly
This commit is contained in:
parent
07479af4d8
commit
cc8d55575d
@ -0,0 +1,36 @@
|
||||
From 646460472bed9064f4f49f7b9fe5043f22329d97 Mon Sep 17 00:00:00 2001
|
||||
From: Timothy B. Terriberry <tterribe@xiph.org>
|
||||
Date: Wed, 19 May 2010 20:55:29 -0400
|
||||
Subject: [PATCH] Test commit for a version of the SPLITMV bounds patch that doesn't break the
|
||||
current encoder.
|
||||
|
||||
---
|
||||
vp8/decoder/decodemv.c | 12 ++++++++++++
|
||||
1 files changed, 12 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/vp8/decoder/decodemv.c b/vp8/decoder/decodemv.c
|
||||
index 6035f3e..b42da20 100644
|
||||
--- a/vp8/decoder/decodemv.c
|
||||
+++ b/vp8/decoder/decodemv.c
|
||||
@@ -268,6 +268,18 @@ void vp8_decode_mode_mvs(VP8D_COMP *pbi)
|
||||
break;
|
||||
}
|
||||
|
||||
+ /* Clip the MV for this partition so that it does
|
||||
+ not extend to far out of image. */
|
||||
+ if (mv->col < (xd->mb_to_left_edge - LEFT_TOP_MARGIN))
|
||||
+ mv->col = xd->mb_to_left_edge - LEFT_TOP_MARGIN;
|
||||
+ else if (mv->col > xd->mb_to_right_edge + RIGHT_BOTTOM_MARGIN + 7)
|
||||
+ mv->col = xd->mb_to_right_edge + RIGHT_BOTTOM_MARGIN + 7;
|
||||
+
|
||||
+ if (mv->row < (xd->mb_to_top_edge - LEFT_TOP_MARGIN))
|
||||
+ mv->row = xd->mb_to_top_edge - LEFT_TOP_MARGIN;
|
||||
+ else if (mv->row > xd->mb_to_bottom_edge + RIGHT_BOTTOM_MARGIN + 7)
|
||||
+ mv->row = xd->mb_to_bottom_edge + RIGHT_BOTTOM_MARGIN + 7;
|
||||
+
|
||||
/* Fill (uniform) modes, mvs of jth subset.
|
||||
Must do it here because ensuing subsets can
|
||||
refer back to us via "left" or "above". */
|
||||
--
|
||||
1.6.4.4
|
||||
|
10
libvpx.spec
10
libvpx.spec
@ -1,7 +1,7 @@
|
||||
Name: libvpx
|
||||
Summary: VP8 Video Codec SDK
|
||||
Version: 0.9.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
Source0: http://webm.googlecode.com/files/%{name}-%{version}.tar.bz2
|
||||
@ -9,6 +9,9 @@ Source1: libvpx.pc
|
||||
# Thanks to debian.
|
||||
Source2: libvpx.ver
|
||||
Patch0: libvpx-0.9.0-no-explicit-dep-on-static-lib.patch
|
||||
# Hackish fix for bz 599147
|
||||
# See: https://groups.google.com/a/webmproject.org/group/codec-devel/browse_frm/thread/ff90bd82d0369b96/79d4c40ea78db91b?tvc=1&q=timothy#79d4c40ea78db91b
|
||||
Patch1: 0001-Test-commit-for-a-version-of-the-SPLITMV-bounds-patc.patch
|
||||
URL: http://www.webmproject.org/tools/vp8-sdk/
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: yasm
|
||||
@ -41,6 +44,7 @@ and decoder.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .no-static-lib
|
||||
%patch1 -p1 -b .bz599147
|
||||
|
||||
%build
|
||||
%ifarch %{ix86}
|
||||
@ -143,6 +147,10 @@ rm -rf %{buildroot}
|
||||
%{_bindir}/*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 2 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-6
|
||||
- add hackish fix for bz 599147
|
||||
(upstream will hopefully fix properly in future release)
|
||||
|
||||
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-5
|
||||
- fix noexecstack flag
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user