libvpx 0.9.7
This commit is contained in:
parent
6b03ae8248
commit
79299466f6
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
libvpx-0.9.1.tar.bz2
|
libvpx-0.9.1.tar.bz2
|
||||||
/libvpx-v0.9.5.tar.bz2
|
/libvpx-v0.9.5.tar.bz2
|
||||||
/libvpx-v0.9.6.tar.bz2
|
/libvpx-v0.9.6.tar.bz2
|
||||||
|
/libvpx-v0.9.7.tar.bz2
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From 646460472bed9064f4f49f7b9fe5043f22329d97 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Timothy B. Terriberry <tterribe@xiph.org>
|
|
||||||
Date: Wed, 19 May 2010 20:55:29 -0400
|
|
||||||
Subject: [PATCH] Test commit for a version of the SPLITMV bounds patch that doesn't break the
|
|
||||||
current encoder.
|
|
||||||
|
|
||||||
---
|
|
||||||
vp8/decoder/decodemv.c | 12 ++++++++++++
|
|
||||||
1 files changed, 12 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/vp8/decoder/decodemv.c b/vp8/decoder/decodemv.c
|
|
||||||
index 6035f3e..b42da20 100644
|
|
||||||
--- a/vp8/decoder/decodemv.c
|
|
||||||
+++ b/vp8/decoder/decodemv.c
|
|
||||||
@@ -268,6 +268,18 @@ void vp8_decode_mode_mvs(VP8D_COMP *pbi)
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /* Clip the MV for this partition so that it does
|
|
||||||
+ not extend to far out of image. */
|
|
||||||
+ if (mv->col < (xd->mb_to_left_edge - LEFT_TOP_MARGIN))
|
|
||||||
+ mv->col = xd->mb_to_left_edge - LEFT_TOP_MARGIN;
|
|
||||||
+ else if (mv->col > xd->mb_to_right_edge + RIGHT_BOTTOM_MARGIN + 7)
|
|
||||||
+ mv->col = xd->mb_to_right_edge + RIGHT_BOTTOM_MARGIN + 7;
|
|
||||||
+
|
|
||||||
+ if (mv->row < (xd->mb_to_top_edge - LEFT_TOP_MARGIN))
|
|
||||||
+ mv->row = xd->mb_to_top_edge - LEFT_TOP_MARGIN;
|
|
||||||
+ else if (mv->row > xd->mb_to_bottom_edge + RIGHT_BOTTOM_MARGIN + 7)
|
|
||||||
+ mv->row = xd->mb_to_bottom_edge + RIGHT_BOTTOM_MARGIN + 7;
|
|
||||||
+
|
|
||||||
/* Fill (uniform) modes, mvs of jth subset.
|
|
||||||
Must do it here because ensuing subsets can
|
|
||||||
refer back to us via "left" or "above". */
|
|
||||||
--
|
|
||||||
1.6.4.4
|
|
||||||
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -up libvpx-0.9.0/examples.mk.BAD libvpx-0.9.0/examples.mk
|
|
||||||
--- libvpx-0.9.0/examples.mk.BAD 2010-05-19 17:58:42.611058552 -0400
|
|
||||||
+++ libvpx-0.9.0/examples.mk 2010-05-19 17:59:11.934181029 -0400
|
|
||||||
@@ -129,7 +129,6 @@ BINS-$(NOT_MSVS) += $(addprefi
|
|
||||||
# Instantiate linker template for all examples.
|
|
||||||
CODEC_LIB=$(if $(CONFIG_DEBUG_LIBS),vpx_g,vpx)
|
|
||||||
$(foreach bin,$(BINS-yes),\
|
|
||||||
- $(if $(BUILD_OBJS),$(eval $(bin): $(LIB_PATH)/lib$(CODEC_LIB).a))\
|
|
||||||
$(if $(BUILD_OBJS),$(eval $(call linker_template,$(bin),\
|
|
||||||
$(call objs,$($(notdir $(bin)).SRCS)) \
|
|
||||||
-l$(CODEC_LIB) $(addprefix -l,$(CODEC_EXTRA_LIBS))\
|
|
@ -1,73 +0,0 @@
|
|||||||
From 9fb80f7170ec48e23c3c7b477149eeb37081c699 Mon Sep 17 00:00:00 2001
|
|
||||||
From: John Koleszar <jkoleszar@google.com>
|
|
||||||
Date: Thu, 4 Nov 2010 16:59:26 -0400
|
|
||||||
Subject: [PATCH] fix integer promotion bug in partition size check
|
|
||||||
|
|
||||||
The check '(user_data_end - partition < partition_size)' must be
|
|
||||||
evaluated as a signed comparison, but because partition_size was
|
|
||||||
unsigned, the LHS was promoted to unsigned, causing an incorrect
|
|
||||||
result on 32-bit. Instead, check the upper and lower bounds of
|
|
||||||
the segment separately.
|
|
||||||
|
|
||||||
Change-Id: I6266aba7fd7de084268712a3d2a81424ead7aa06
|
|
||||||
---
|
|
||||||
vp8/decoder/decodframe.c | 6 ++++--
|
|
||||||
vp8/vp8_dx_iface.c | 10 ++++++++--
|
|
||||||
2 files changed, 12 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/vp8/decoder/decodframe.c b/vp8/decoder/decodframe.c
|
|
||||||
index 2d81d61..f5e49a1 100644
|
|
||||||
--- a/vp8/decoder/decodframe.c
|
|
||||||
+++ b/vp8/decoder/decodframe.c
|
|
||||||
@@ -462,7 +462,8 @@ static void setup_token_decoder(VP8D_COMP *pbi,
|
|
||||||
partition_size = user_data_end - partition;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (user_data_end - partition < partition_size)
|
|
||||||
+ if (partition + partition_size > user_data_end
|
|
||||||
+ || partition + partition_size < partition)
|
|
||||||
vpx_internal_error(&pc->error, VPX_CODEC_CORRUPT_FRAME,
|
|
||||||
"Truncated packet or corrupt partition "
|
|
||||||
"%d length", i + 1);
|
|
||||||
@@ -580,7 +581,8 @@ int vp8_decode_frame(VP8D_COMP *pbi)
|
|
||||||
(data[0] | (data[1] << 8) | (data[2] << 16)) >> 5;
|
|
||||||
data += 3;
|
|
||||||
|
|
||||||
- if (data_end - data < first_partition_length_in_bytes)
|
|
||||||
+ if (data + first_partition_length_in_bytes > data_end
|
|
||||||
+ || data + first_partition_length_in_bytes < data)
|
|
||||||
vpx_internal_error(&pc->error, VPX_CODEC_CORRUPT_FRAME,
|
|
||||||
"Truncated packet or corrupt partition 0 length");
|
|
||||||
vp8_setup_version(pc);
|
|
||||||
diff --git a/vp8/vp8_dx_iface.c b/vp8/vp8_dx_iface.c
|
|
||||||
index e7e5356..f0adf5b 100644
|
|
||||||
--- a/vp8/vp8_dx_iface.c
|
|
||||||
+++ b/vp8/vp8_dx_iface.c
|
|
||||||
@@ -253,8 +253,11 @@ static vpx_codec_err_t vp8_peek_si(const uint8_t *data,
|
|
||||||
unsigned int data_sz,
|
|
||||||
vpx_codec_stream_info_t *si)
|
|
||||||
{
|
|
||||||
-
|
|
||||||
vpx_codec_err_t res = VPX_CODEC_OK;
|
|
||||||
+
|
|
||||||
+ if(data + data_sz <= data)
|
|
||||||
+ res = VPX_CODEC_INVALID_PARAM;
|
|
||||||
+ else
|
|
||||||
{
|
|
||||||
/* Parse uncompresssed part of key frame header.
|
|
||||||
* 3 bytes:- including version, frame type and an offset
|
|
||||||
@@ -331,7 +334,10 @@ static vpx_codec_err_t vp8_decode(vpx_codec_alg_priv_t *ctx,
|
|
||||||
|
|
||||||
ctx->img_avail = 0;
|
|
||||||
|
|
||||||
- /* Determine the stream parameters */
|
|
||||||
+ /* Determine the stream parameters. Note that we rely on peek_si to
|
|
||||||
+ * validate that we have a buffer that does not wrap around the top
|
|
||||||
+ * of the heap.
|
|
||||||
+ */
|
|
||||||
if (!ctx->si.h)
|
|
||||||
res = ctx->base.iface->dec.peek_si(data, data_sz, &ctx->si);
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.3.1
|
|
||||||
|
|
12
libvpx.spec
12
libvpx.spec
@ -1,14 +1,15 @@
|
|||||||
Name: libvpx
|
Name: libvpx
|
||||||
Summary: VP8 Video Codec SDK
|
Summary: VP8 Video Codec SDK
|
||||||
Version: 0.9.6
|
Version: 0.9.7
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source0: http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
|
Source0: http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
|
||||||
|
# Probably this should be dropped now that upstream ships a vpx.pc;
|
||||||
|
# not for F16 though
|
||||||
Source1: libvpx.pc
|
Source1: libvpx.pc
|
||||||
# Thanks to debian.
|
# Thanks to debian.
|
||||||
Source2: libvpx.ver
|
Source2: libvpx.ver
|
||||||
Patch0: libvpx-0.9.0-no-explicit-dep-on-static-lib.patch
|
|
||||||
URL: http://www.webmproject.org/tools/vp8-sdk/
|
URL: http://www.webmproject.org/tools/vp8-sdk/
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
BuildRequires: yasm
|
BuildRequires: yasm
|
||||||
@ -40,7 +41,6 @@ and decoder.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-v%{version}
|
%setup -q -n %{name}-v%{version}
|
||||||
%patch0 -p1 -b .no-static-lib
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%ifarch %{ix86}
|
%ifarch %{ix86}
|
||||||
@ -150,6 +150,7 @@ rm -rf %{buildroot}
|
|||||||
%doc docs/html/
|
%doc docs/html/
|
||||||
%{_includedir}/vpx/
|
%{_includedir}/vpx/
|
||||||
%{_libdir}/pkgconfig/libvpx.pc
|
%{_libdir}/pkgconfig/libvpx.pc
|
||||||
|
%{_libdir}/pkgconfig/vpx.pc
|
||||||
%{_libdir}/libvpx.so
|
%{_libdir}/libvpx.so
|
||||||
|
|
||||||
%files utils
|
%files utils
|
||||||
@ -157,6 +158,9 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 09 2011 Adam Jackson <ajax@redhat.com> 0.9.7-1
|
||||||
|
- libvpx 0.9.7
|
||||||
|
|
||||||
* Mon Mar 21 2011 Dan Horák <dan[at]danny.cz> - 0.9.6-2
|
* Mon Mar 21 2011 Dan Horák <dan[at]danny.cz> - 0.9.6-2
|
||||||
- add 2 symbols to the shared library for generic targets
|
- add 2 symbols to the shared library for generic targets
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user