RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libvpx#5e9ca6bc1773df5e76267c609662a234fb55d3f8
This commit is contained in:
parent
4f34ac8485
commit
78e7838a93
18
.gitignore
vendored
18
.gitignore
vendored
@ -0,0 +1,18 @@
|
||||
libvpx-0.9.1.tar.bz2
|
||||
/libvpx-v0.9.5.tar.bz2
|
||||
/libvpx-v0.9.6.tar.bz2
|
||||
/libvpx-v0.9.7.tar.bz2
|
||||
/libvpx-v0.9.7-p1.tar.bz2
|
||||
/libvpx-v1.0.0.tar.bz2
|
||||
/libvpx-v1.1.0.tar.bz2
|
||||
/libvpx-v1.2.0.tar.bz2
|
||||
/libvpx-v1.3.0.tar.bz2
|
||||
/v1.4.0.tar.gz
|
||||
/libvpx-1.5.0.tar.bz2
|
||||
/libvpx-1.6.0.tar.bz2
|
||||
/v1.6.1.tar.gz
|
||||
/v1.7.0.tar.gz
|
||||
/v1.8.0.tar.gz
|
||||
/v1.8.1.tar.gz
|
||||
/v1.8.2.tar.gz
|
||||
/v1.9.0.tar.gz
|
@ -0,0 +1,54 @@
|
||||
From 5a40c8fde11bf82cccb5bd2f57c46ab5e6262cbf Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Jiang <jianj@google.com>
|
||||
Date: Wed, 27 Sep 2017 11:08:37 -0700
|
||||
Subject: [PATCH] Fix image width alignment. Enable ImageSizeSetting test.
|
||||
|
||||
BUG=b/64710201
|
||||
|
||||
Change-Id: I5465f6c6481d3c9a5e00fcab024cf4ae562b6b01
|
||||
|
||||
diff --git a/vpx/src/vpx_image.c b/vpx/src/vpx_image.c
|
||||
index dba439c10..ebd3d7f74 100644
|
||||
--- a/vpx/src/vpx_image.c
|
||||
+++ b/vpx/src/vpx_image.c
|
||||
@@ -88,11 +88,10 @@ static vpx_image_t *img_alloc_helper(vpx_image_t *img, vpx_img_fmt_t fmt,
|
||||
default: ycs = 0; break;
|
||||
}
|
||||
|
||||
- /* Calculate storage sizes given the chroma subsampling */
|
||||
- align = (1 << xcs) - 1;
|
||||
- w = (d_w + align) & ~align;
|
||||
- align = (1 << ycs) - 1;
|
||||
- h = (d_h + align) & ~align;
|
||||
+ /* Calculate storage sizes. If the buffer was allocated externally, the width
|
||||
+ * and height shouldn't be adjusted. */
|
||||
+ w = d_w;
|
||||
+ h = d_h;
|
||||
s = (fmt & VPX_IMG_FMT_PLANAR) ? w : bps * w / 8;
|
||||
s = (s + stride_align - 1) & ~(stride_align - 1);
|
||||
stride_in_bytes = (fmt & VPX_IMG_FMT_HIGHBITDEPTH) ? s * 2 : s;
|
||||
@@ -111,9 +110,18 @@ static vpx_image_t *img_alloc_helper(vpx_image_t *img, vpx_img_fmt_t fmt,
|
||||
img->img_data = img_data;
|
||||
|
||||
if (!img_data) {
|
||||
- const uint64_t alloc_size = (fmt & VPX_IMG_FMT_PLANAR)
|
||||
- ? (uint64_t)h * s * bps / 8
|
||||
- : (uint64_t)h * s;
|
||||
+ uint64_t alloc_size;
|
||||
+ /* Calculate storage sizes given the chroma subsampling */
|
||||
+ align = xcs ? (1 << xcs) - 1 : 1;
|
||||
+ w = (d_w + align - 1) & ~(align - 1);
|
||||
+ align = ycs ? (1 << ycs) - 1 : 1;
|
||||
+ h = (d_h + align - 1) & ~(align - 1);
|
||||
+
|
||||
+ s = (fmt & VPX_IMG_FMT_PLANAR) ? w : bps * w / 8;
|
||||
+ s = (s + stride_align - 1) & ~(stride_align - 1);
|
||||
+ stride_in_bytes = (fmt & VPX_IMG_FMT_HIGHBITDEPTH) ? s * 2 : s;
|
||||
+ alloc_size = (fmt & VPX_IMG_FMT_PLANAR) ? (uint64_t)h * s * bps / 8
|
||||
+ : (uint64_t)h * s;
|
||||
|
||||
if (alloc_size != (size_t)alloc_size) goto fail;
|
||||
|
||||
--
|
||||
2.14.3
|
||||
|
32
Bug-fix-in-ssse3-quantize-function.patch
Normal file
32
Bug-fix-in-ssse3-quantize-function.patch
Normal file
@ -0,0 +1,32 @@
|
||||
commit 0d43bd77e5f429467fbd280a7b8f7fbc0bfe1809
|
||||
Author: Yunqing Wang <yunqingwang@google.com>
|
||||
Date: Fri Feb 7 14:27:07 2014 -0800
|
||||
|
||||
Bug fix in ssse3 quantize function
|
||||
|
||||
A bug was reported in Issue 702: "SIGILL (Illegal instruction) when
|
||||
transcoding with vp9 - using FFmpeg". It was reproduced and fixed.
|
||||
|
||||
Change-Id: Ie32c149a89af02856084aeaf289e848a905c7700
|
||||
|
||||
diff --git a/vp9/encoder/x86/vp9_quantize_ssse3.asm b/vp9/encoder/x86/vp9_quantize_ssse3.asm
|
||||
index db30660..48ccef8 100644
|
||||
--- a/vp9/encoder/x86/vp9_quantize_ssse3.asm
|
||||
+++ b/vp9/encoder/x86/vp9_quantize_ssse3.asm
|
||||
@@ -188,7 +188,8 @@ cglobal quantize_%1, 0, %2, 15, coeff, ncoeff, skip, zbin, round, quant, \
|
||||
pmaxsw m8, m7
|
||||
pshuflw m7, m8, 0x1
|
||||
pmaxsw m8, m7
|
||||
- pextrw [r2], m8, 0
|
||||
+ pextrw r6, m8, 0
|
||||
+ mov [r2], r6
|
||||
RET
|
||||
|
||||
; skip-block, i.e. just write all zeroes
|
||||
@@ -214,5 +215,5 @@ cglobal quantize_%1, 0, %2, 15, coeff, ncoeff, skip, zbin, round, quant, \
|
||||
%endmacro
|
||||
|
||||
INIT_XMM ssse3
|
||||
-QUANTIZE_FN b, 6
|
||||
+QUANTIZE_FN b, 7
|
||||
QUANTIZE_FN b_32x32, 7
|
12
libvpx-1.7.0-leave-fortify-source-on.patch
Normal file
12
libvpx-1.7.0-leave-fortify-source-on.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up libvpx-1.7.0/build/make/configure.sh.leave-fs-on libvpx-1.7.0/build/make/configure.sh
|
||||
--- libvpx-1.7.0/build/make/configure.sh.leave-fs-on 2018-01-26 15:02:18.767645332 -0500
|
||||
+++ libvpx-1.7.0/build/make/configure.sh 2018-01-26 15:02:28.594420775 -0500
|
||||
@@ -1440,7 +1440,7 @@ EOF
|
||||
|
||||
# Work around longjmp interception on glibc >= 2.11, to improve binary
|
||||
# compatibility. See http://code.google.com/p/webm/issues/detail?id=166
|
||||
- enabled linux && check_add_cflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
|
||||
+ # enabled linux && check_add_cflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=0
|
||||
|
||||
# Check for strip utility variant
|
||||
${STRIP} -V 2>/dev/null | grep GNU >/dev/null && enable_feature gnu_strip
|
21
libvpx-v1.0.0-pcfix.patch
Normal file
21
libvpx-v1.0.0-pcfix.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up libvpx-v1.0.0/libs.mk.pcfix libvpx-v1.0.0/libs.mk
|
||||
--- libvpx-v1.0.0/libs.mk.pcfix 2012-01-27 13:36:39.000000000 -0500
|
||||
+++ libvpx-v1.0.0/libs.mk 2012-05-29 10:48:27.348425023 -0400
|
||||
@@ -232,7 +232,7 @@ vpx.pc: config.mk libs.mk
|
||||
$(qexec)echo '# pkg-config file from libvpx $(VERSION_STRING)' > $@
|
||||
$(qexec)echo 'prefix=$(PREFIX)' >> $@
|
||||
$(qexec)echo 'exec_prefix=$${prefix}' >> $@
|
||||
- $(qexec)echo 'libdir=$${prefix}/lib' >> $@
|
||||
+ $(qexec)echo 'libdir=$${prefix}/$(LIBSUBDIR)' >> $@
|
||||
$(qexec)echo 'includedir=$${prefix}/include' >> $@
|
||||
$(qexec)echo '' >> $@
|
||||
$(qexec)echo 'Name: vpx' >> $@
|
||||
@@ -240,7 +240,7 @@ vpx.pc: config.mk libs.mk
|
||||
$(qexec)echo 'Version: $(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_PATCH)' >> $@
|
||||
$(qexec)echo 'Requires:' >> $@
|
||||
$(qexec)echo 'Conflicts:' >> $@
|
||||
- $(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
|
||||
+ $(qexec)echo 'Libs: -L$${libdir} -lvpx -lm' >> $@
|
||||
$(qexec)echo 'Cflags: -I$${includedir}' >> $@
|
||||
INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
|
||||
INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc
|
12
libvpx-v1.1.0-pcfix.patch
Normal file
12
libvpx-v1.1.0-pcfix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up libvpx-v1.1.0/libs.mk.pcfix libvpx-v1.1.0/libs.mk
|
||||
--- libvpx-v1.1.0/libs.mk.pcfix 2012-05-29 17:07:15.786028887 -0400
|
||||
+++ libvpx-v1.1.0/libs.mk 2012-05-29 17:07:19.362006037 -0400
|
||||
@@ -241,7 +241,7 @@ vpx.pc: config.mk libs.mk
|
||||
$(qexec)echo 'Version: $(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_PATCH)' >> $@
|
||||
$(qexec)echo 'Requires:' >> $@
|
||||
$(qexec)echo 'Conflicts:' >> $@
|
||||
- $(qexec)echo 'Libs: -L$${libdir} -lvpx' >> $@
|
||||
+ $(qexec)echo 'Libs: -L$${libdir} -lvpx -lm' >> $@
|
||||
$(qexec)echo 'Cflags: -I$${includedir}' >> $@
|
||||
INSTALL-LIBS-yes += $(LIBSUBDIR)/pkgconfig/vpx.pc
|
||||
INSTALL_MAPS += $(LIBSUBDIR)/pkgconfig/%.pc %.pc
|
14
libvpx.pc
Normal file
14
libvpx.pc
Normal file
@ -0,0 +1,14 @@
|
||||
prefix=@PREFIX@
|
||||
exec_prefix=@PREFIX@
|
||||
libdir=@LIBDIR@
|
||||
includedir=@INCLUDEDIR@
|
||||
|
||||
Name: libvpx
|
||||
Description: VP8 Video Codec SDK library
|
||||
Version: 1.0.0
|
||||
URL: http://www.webmproject.org/tools/vp8-sdk/
|
||||
Requires:
|
||||
Conflicts:
|
||||
Libs: -L${libdir} -lvpx
|
||||
Libs.private:
|
||||
Cflags: -I${includedir}/vpx/
|
469
libvpx.spec
Normal file
469
libvpx.spec
Normal file
@ -0,0 +1,469 @@
|
||||
%global somajor 6
|
||||
%global sominor 0
|
||||
%global sotiny 0
|
||||
%global soversion %{somajor}.%{sominor}.%{sotiny}
|
||||
|
||||
Name: libvpx
|
||||
Summary: VP8/VP9 Video Codec SDK
|
||||
Version: 1.9.0
|
||||
Release: 2%{?dist}
|
||||
License: BSD
|
||||
#Source0: http://downloads.webmproject.org/releases/webm/%{name}-%{version}.tar.bz2
|
||||
Source0: https://github.com/webmproject/libvpx/archive/v%{version}.tar.gz
|
||||
Source1: vpx_config.h
|
||||
# Thanks to debian.
|
||||
Source2: libvpx.ver
|
||||
URL: http://www.webmproject.org/code/
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: yasm
|
||||
%endif
|
||||
BuildRequires: doxygen, php-cli, perl(Getopt::Long)
|
||||
# Do not disable FORTIFY_SOURCE=2
|
||||
Patch0: libvpx-1.7.0-leave-fortify-source-on.patch
|
||||
|
||||
%description
|
||||
libvpx provides the VP8/VP9 SDK, which allows you to integrate your applications
|
||||
with the VP8 and VP9 video codecs, high quality, royalty free, open source codecs
|
||||
deployed on millions of computers and devices worldwide.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for libvpx
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Development libraries and headers for developing software against
|
||||
libvpx.
|
||||
|
||||
%package utils
|
||||
Summary: VP8 utilities and tools
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description utils
|
||||
A selection of utilities and tools for VP8, including a sample encoder
|
||||
and decoder.
|
||||
|
||||
%prep
|
||||
%setup -q -n libvpx-%{version}
|
||||
%patch0 -p1 -b .leave-fs-on
|
||||
|
||||
%build
|
||||
|
||||
%ifarch %{ix86}
|
||||
%global vpxtarget x86-linux-gcc
|
||||
%else
|
||||
%ifarch x86_64
|
||||
%global vpxtarget x86_64-linux-gcc
|
||||
%else
|
||||
%ifarch armv7hl
|
||||
%global vpxtarget armv7-linux-gcc
|
||||
%else
|
||||
%ifarch aarch64
|
||||
%global vpxtarget arm64-linux-gcc
|
||||
%else
|
||||
%global vpxtarget generic-gnu
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
|
||||
# History: The configure script used to reject the shared flag on the generic target.
|
||||
# This meant that we needed to fall back to manual shared lib creation.
|
||||
# However, the modern configure script permits the shared flag and assumes ELF.
|
||||
# Additionally, the libvpx.ver would need to be updated to work properly.
|
||||
# As a result, we disable this universally, but keep it around in case we ever need to support
|
||||
# something "special".
|
||||
%if "%{vpxtarget}" == "generic-gnu"
|
||||
%global generic_target 0
|
||||
%else
|
||||
%global generic_target 0
|
||||
%endif
|
||||
|
||||
%set_build_flags
|
||||
|
||||
%ifarch armv7hl
|
||||
CROSS=armv7hl-redhat-linux-gnueabi- CHOST=armv7hl-redhat-linux-gnueabi-hardfloat ./configure \
|
||||
%else
|
||||
./configure --target=%{vpxtarget} \
|
||||
%endif
|
||||
%ifarch %{arm}
|
||||
--disable-neon --disable-neon_asm \
|
||||
%endif
|
||||
--enable-pic --disable-install-srcs \
|
||||
--enable-vp9-decoder --enable-vp9-encoder \
|
||||
--enable-experimental \
|
||||
--enable-vp9-highbitdepth \
|
||||
%if ! %{generic_target}
|
||||
--enable-shared \
|
||||
%endif
|
||||
--enable-install-srcs \
|
||||
--prefix=%{_prefix} --libdir=%{_libdir} --size-limit=16384x16384
|
||||
|
||||
%ifarch armv7hl
|
||||
#hackety hack hack
|
||||
sed -i "s|AR=armv7hl-redhat-linux-gnueabi-ar|AR=ar|g" libs-%{vpxtarget}.mk
|
||||
sed -i "s|AR=armv7hl-redhat-linux-gnueabi-ar|AR=ar|g" examples-%{vpxtarget}.mk
|
||||
sed -i "s|AR=armv7hl-redhat-linux-gnueabi-ar|AR=ar|g" docs-%{vpxtarget}.mk
|
||||
|
||||
sed -i "s|AS=armv7hl-redhat-linux-gnueabi-as|AS=as|g" libs-%{vpxtarget}.mk
|
||||
sed -i "s|AS=armv7hl-redhat-linux-gnueabi-as|AS=as|g" examples-%{vpxtarget}.mk
|
||||
sed -i "s|AS=armv7hl-redhat-linux-gnueabi-as|AS=as|g" docs-%{vpxtarget}.mk
|
||||
|
||||
sed -i "s|NM=armv7hl-redhat-linux-gnueabi-nm|NM=nm|g" libs-%{vpxtarget}.mk
|
||||
sed -i "s|NM=armv7hl-redhat-linux-gnueabi-nm|NM=nm|g" examples-%{vpxtarget}.mk
|
||||
sed -i "s|NM=armv7hl-redhat-linux-gnueabi-nm|NM=nm|g" docs-%{vpxtarget}.mk
|
||||
%endif
|
||||
|
||||
%make_build verbose=true
|
||||
|
||||
# Manual shared library creation
|
||||
# We should never need to do this anymore, and if we do, we need to fix the version-script.
|
||||
%if %{generic_target}
|
||||
mkdir tmp
|
||||
cd tmp
|
||||
ar x ../libvpx_g.a
|
||||
cd ..
|
||||
gcc -fPIC -shared -pthread -lm -Wl,--no-undefined -Wl,-soname,libvpx.so.%{somajor} -Wl,--version-script,%{SOURCE2} -Wl,-z,noexecstack -o libvpx.so.%{soversion} tmp/*.o
|
||||
rm -rf tmp
|
||||
%endif
|
||||
|
||||
# Temporarily dance the static libs out of the way
|
||||
# mv libvpx.a libNOTvpx.a
|
||||
# mv libvpx_g.a libNOTvpx_g.a
|
||||
|
||||
# We need to do this so the examples can link against it.
|
||||
# ln -sf libvpx.so.%{soversion} libvpx.so
|
||||
|
||||
# %make_build verbose=true target=examples CONFIG_SHARED=1
|
||||
# %make_build verbose=true target=docs
|
||||
|
||||
# Put them back so the install doesn't fail
|
||||
# mv libNOTvpx.a libvpx.a
|
||||
# mv libNOTvpx_g.a libvpx_g.a
|
||||
|
||||
%install
|
||||
%ifarch armv7hl
|
||||
export CROSS=armv7hl-redhat-linux-gnueabi-
|
||||
export CHOST=armv7hl-redhat-linux-gnueabi-hardfloat
|
||||
%endif
|
||||
make DIST_DIR=%{buildroot}%{_prefix} dist
|
||||
|
||||
# Simpler to label the dir as %%doc.
|
||||
if [ -d %{buildroot}%{_prefix}/docs ]; then
|
||||
mv %{buildroot}%{_prefix}/docs doc/
|
||||
fi
|
||||
|
||||
# Again, we should never need to do this anymore.
|
||||
%if %{generic_target}
|
||||
install -p libvpx.so.%{soversion} %{buildroot}%{_libdir}
|
||||
pushd %{buildroot}%{_libdir}
|
||||
ln -sf libvpx.so.%{soversion} libvpx.so
|
||||
ln -sf libvpx.so.%{soversion} libvpx.so.%{somajor}
|
||||
ln -sf libvpx.so.%{soversion} libvpx.so.%{somajor}.%{sominor}
|
||||
popd
|
||||
%endif
|
||||
|
||||
pushd %{buildroot}
|
||||
# Stuff we don't need.
|
||||
rm -rf .%{_prefix}/build/ .%{_prefix}/md5sums.txt .%{_libdir}*/*.a .%{_prefix}/CHANGELOG .%{_prefix}/README
|
||||
# No, bad google. No treat.
|
||||
mv .%{_bindir}/examples/* .%{_bindir}
|
||||
rm -rf .%{_bindir}/examples
|
||||
|
||||
# Rename a few examples
|
||||
mv .%{_bindir}/postproc .%{_bindir}/vp8_postproc
|
||||
mv .%{_bindir}/simple_decoder .%{_bindir}/vp8_simple_decoder
|
||||
mv .%{_bindir}/simple_encoder .%{_bindir}/vp8_simple_encoder
|
||||
mv .%{_bindir}/twopass_encoder .%{_bindir}/vp8_twopass_encoder
|
||||
# Fix the binary permissions
|
||||
chmod 755 .%{_bindir}/*
|
||||
popd
|
||||
|
||||
# Get the vpx_config.h file
|
||||
%ifarch %{arm}
|
||||
cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-arm.h
|
||||
%else
|
||||
# Does ppc64le need its own?
|
||||
%ifarch ppc64 ppc64le
|
||||
cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-ppc64.h
|
||||
%else
|
||||
%ifarch s390 s390x
|
||||
cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-s390.h
|
||||
%else
|
||||
%ifarch %{ix86}
|
||||
cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-x86.h
|
||||
%else
|
||||
cp -a vpx_config.h %{buildroot}%{_includedir}/vpx/vpx_config-%{_arch}.h
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
%endif
|
||||
cp %{SOURCE1} %{buildroot}%{_includedir}/vpx/vpx_config.h
|
||||
# for timestamp sync
|
||||
touch -r AUTHORS %{buildroot}%{_includedir}/vpx/vpx_config.h
|
||||
|
||||
mv %{buildroot}%{_prefix}/src/vpx_dsp %{buildroot}%{_includedir}/
|
||||
mv %{buildroot}%{_prefix}/src/vpx_mem %{buildroot}%{_includedir}/
|
||||
mv %{buildroot}%{_prefix}/src/vpx_ports %{buildroot}%{_includedir}/
|
||||
mv %{buildroot}%{_prefix}/src/vpx_scale %{buildroot}%{_includedir}/
|
||||
|
||||
rm -rf %{buildroot}%{_prefix}/src
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%license LICENSE
|
||||
%doc AUTHORS CHANGELOG README
|
||||
%{_libdir}/libvpx.so.%{somajor}*
|
||||
|
||||
%files devel
|
||||
# These are SDK docs, not really useful to an end-user.
|
||||
%doc docs/html/
|
||||
%{_includedir}/vpx/
|
||||
%{_includedir}/vpx_dsp/
|
||||
%{_includedir}/vpx_mem/
|
||||
%{_includedir}/vpx_ports/
|
||||
%{_includedir}/vpx_scale/
|
||||
%{_libdir}/pkgconfig/vpx.pc
|
||||
%{_libdir}/libvpx.so
|
||||
|
||||
%files utils
|
||||
%{_bindir}/*
|
||||
|
||||
%changelog
|
||||
* Sat Oct 10 2020 Jeff Law <law@redhat.com> - 1.9.0-2
|
||||
- Re-enable LTO
|
||||
|
||||
* Thu Aug 13 2020 Tom Callaway <spot@fedoraproject.org> - 1.9.0-1
|
||||
- update to 1.9.0
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-6
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Tom Stellard <tstellar@redhat.com> - 1.8.2-4
|
||||
- Use make macros
|
||||
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
|
||||
|
||||
* Wed Jul 01 2020 Jeff Law <law@redhat.com> - 1.8.2-3
|
||||
- Disable LTO
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Dec 20 2019 Tom Callaway <spot@fedoraproject.org> - 1.8.2-1
|
||||
- update to 1.8.2
|
||||
|
||||
* Wed Jul 31 2019 Tom Callaway <spot@fedoraproject.org> - 1.8.1-1
|
||||
- update to 1.8.1
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Feb 05 2019 Pete Walter <pwalter@fedoraproject.org> - 1.8.0-4
|
||||
- Avoid setting optflags twice
|
||||
|
||||
* Tue Feb 05 2019 Pete Walter <pwalter@fedoraproject.org> - 1.8.0-3
|
||||
- Tighten soname glob to avoid accidental soname bumps
|
||||
|
||||
* Tue Feb 05 2019 Björn Esser <besser82@fedoraproject.org> - 1.8.0-2
|
||||
- rebuilt (libvpx)
|
||||
|
||||
* Tue Feb 05 2019 Pete Walter <pwalter@fedoraproject.org> - 1.8.0-1
|
||||
- Update to 1.8.0
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Sep 18 2018 Owen Taylor <otaylor@redhat.com> - 1.7.0-8
|
||||
- Avoid hardcoding prefix=/usr
|
||||
|
||||
* Fri Jul 20 2018 Wim Taymans <wtaymans@redhat.com> - 1.7.0-7
|
||||
- Add compilers as buildrequires
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Feb 12 2018 Tom Callaway <spot@fedoraproject.org> - 1.7.0-5
|
||||
- properly set build flags in rawhide (bz1543819)
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 3 2018 Tom Callaway <spot@fedoraproject.org> - 1.7.0-3
|
||||
- package more files (for firefox)
|
||||
- setup vpx_config.h for multilib
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.7.0-2
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Fri Jan 26 2018 Tom Callaway <spot@fedoraproject.org> - 1.7.0-1
|
||||
- update to 1.7.0 (ABI change)
|
||||
|
||||
* Wed Jan 17 2018 Wim Taymans <wtaymans@wredhat.com> - 1.6.1-5
|
||||
- fix for CVE-2017-13194
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Jan 16 2017 Tom Callaway <spot@fedoraproject.org> - 1.6.1-1
|
||||
- update to 1.6.1
|
||||
|
||||
* Thu Jan 12 2017 Tom Callaway <spot@fedoraproject.org> - 1.6.0-2
|
||||
- enable vp9-highbitdepth (thanks to mike@cchtml.com)
|
||||
|
||||
* Fri Jul 22 2016 Tom Callaway <spot@fedoraproject.org> - 1.6.0-1
|
||||
- update to 1.6.0
|
||||
|
||||
* Wed Mar 16 2016 Tom Callaway <spot@fedoraproject.org> - 1.5.0-4
|
||||
- disable generic_target conditional universally (bz1311125)
|
||||
|
||||
* Tue Mar 8 2016 Tom Callaway <spot@fedoraproject.org> - 1.5.0-3
|
||||
- enable-experimental and enable-spatial-svc
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Dec 1 2015 Tom Callaway <spot@fedoraproject.org> - 1.5.0-1
|
||||
- update to 1.5.0
|
||||
|
||||
* Mon Sep 21 2015 Tom Callaway <spot@fedoraproject.org> - 1.4.0-6
|
||||
- remove exit 0
|
||||
|
||||
* Tue Sep 15 2015 Tom Callaway <spot@fedoraproject.org> - 1.4.0-5
|
||||
- set --size-limit=16384x16384 to avoid CVE-2015-1258
|
||||
|
||||
* Mon Jul 27 2015 Kalev Lember <klember@redhat.com> - 1.4.0-4
|
||||
- Package review fixes (#1225648)
|
||||
- Update URL
|
||||
- Use license macro
|
||||
- Escape a commented out macro
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.4.0-2
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Mon Apr 6 2015 Tom Callaway <spot@fedoraproject.org> - 1.4.0-1
|
||||
- update to 1.4.0
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Thu Mar 20 2014 Wim Taymans <wtaymans@redhat.com> - 1.3.0-4
|
||||
- fix Illegal Instruction abort
|
||||
|
||||
* Thu Feb 13 2014 Dan Horák <dan[at]danny.cz> - 1.3.0-3
|
||||
- update library symbol list for 1.3.0 from Debian
|
||||
|
||||
* Tue Feb 11 2014 Tom Callaway <spot@fedoraproject.org> - 1.3.0-2
|
||||
- armv7hl specific target
|
||||
|
||||
* Tue Feb 11 2014 Tom Callaway <spot@fedoraproject.org> - 1.3.0-1
|
||||
- update to 1.3.0
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 28 2013 Tom Callaway <spot@fedoraproject.org> - 1.2.0-1
|
||||
- update to 1.2.0
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue May 29 2012 Tom Callaway <spot@fedoraproject.org> - 1.1.0-1
|
||||
- update to 1.1.0
|
||||
|
||||
* Tue May 29 2012 Tom Callaway <spot@fedoraproject.org> - 1.0.0-3
|
||||
- fix vpx.pc file to include -lm (bz825754)
|
||||
|
||||
* Fri May 11 2012 Tom Callaway <spot@fedoraproject.org> - 1.0.0-2
|
||||
- use included vpx.pc file (drop local libvpx.pc)
|
||||
- apply upstream fix to vpx.pc file (bz 814177)
|
||||
|
||||
* Mon Jan 30 2012 Tom Callaway <spot@fedoraproject.org> - 1.0.0-1
|
||||
- update to 1.0.0
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.7.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Oct 10 2011 Dan Horák <dan[at]danny.cz> - 0.9.7.1-3
|
||||
- use macro instead of hard-coded version
|
||||
|
||||
* Mon Sep 12 2011 Dan Horák <dan[at]danny.cz> - 0.9.7.1-2
|
||||
- fix build on generic targets
|
||||
|
||||
* Tue Aug 16 2011 Adam Jackson <ajax@redhat.com> 0.9.7.1-1
|
||||
- libvpx 0.9.7-p1
|
||||
|
||||
* Tue Aug 09 2011 Adam Jackson <ajax@redhat.com> 0.9.7-1
|
||||
- libvpx 0.9.7
|
||||
|
||||
* Mon Mar 21 2011 Dan Horák <dan[at]danny.cz> - 0.9.6-2
|
||||
- add 2 symbols to the shared library for generic targets
|
||||
|
||||
* Thu Mar 10 2011 Tom Callaway <spot@fedoraproject.org> - 0.9.6-1
|
||||
- update to 0.9.6
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Nov 17 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.5-2
|
||||
- apply patch from upstream git (Change I6266aba7), should resolve CVE-2010-4203
|
||||
|
||||
* Mon Nov 1 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.5-1
|
||||
- update to 0.9.5
|
||||
|
||||
* Wed Sep 1 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-3
|
||||
- only package html docs to avoid multilib conflict (bz 613185)
|
||||
|
||||
* Thu Jun 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-2
|
||||
- build shared library the old way for generic arches
|
||||
|
||||
* Thu Jun 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-1
|
||||
- update to 0.9.1
|
||||
|
||||
* Fri Jun 11 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-7
|
||||
- update to git revision 8389f1967c5f8b3819cca80705b1b4ba04132b93
|
||||
- upstream fix for bz 599147
|
||||
- proper shared library support
|
||||
|
||||
* Wed Jun 2 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-6
|
||||
- add hackish fix for bz 599147
|
||||
(upstream will hopefully fix properly in future release)
|
||||
|
||||
* Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-5
|
||||
- fix noexecstack flag
|
||||
|
||||
* Thu May 20 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-4
|
||||
- BuildRequires: yasm (we're optimized again)
|
||||
|
||||
* Thu May 20 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-3
|
||||
- add pkg-config file
|
||||
- move headers into include/vpx/
|
||||
- enable optimization
|
||||
|
||||
* Thu May 20 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-2
|
||||
- fix permissions on binaries
|
||||
- rename generic binaries to v8_*
|
||||
- link shared library to -lm, -lpthread to resolve missing weak symbols
|
||||
|
||||
* Wed May 19 2010 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.0-1
|
||||
- Initial package for Fedora
|
79
libvpx.ver
Normal file
79
libvpx.ver
Normal file
@ -0,0 +1,79 @@
|
||||
{ global:
|
||||
vpx_codec_build_config;
|
||||
vpx_codec_control_;
|
||||
vpx_codec_dec_init_ver;
|
||||
vpx_codec_decode;
|
||||
vpx_codec_destroy;
|
||||
vpx_codec_enc_config_default;
|
||||
vpx_codec_enc_config_set;
|
||||
vpx_codec_enc_init_ver;
|
||||
vpx_codec_encode;
|
||||
vpx_codec_error;
|
||||
vpx_codec_error_detail;
|
||||
vpx_codec_err_to_string;
|
||||
vpx_codec_get_caps;
|
||||
vpx_codec_get_cx_data;
|
||||
vpx_codec_get_frame;
|
||||
vpx_codec_get_global_headers;
|
||||
vpx_codec_get_mem_map;
|
||||
vpx_codec_get_preview_frame;
|
||||
vpx_codec_get_stream_info;
|
||||
vpx_codec_iface_name;
|
||||
vpx_codec_peek_stream_info;
|
||||
vpx_codec_register_put_frame_cb;
|
||||
vpx_codec_register_put_slice_cb;
|
||||
vpx_codec_set_cx_data_buf;
|
||||
vpx_codec_set_frame_buffer_functions;
|
||||
vpx_codec_set_mem_map;
|
||||
vpx_codec_version;
|
||||
vpx_codec_version_extra_str;
|
||||
vpx_codec_version_str;
|
||||
vpx_codec_vp8_algo;
|
||||
vpx_codec_vp8_cx;
|
||||
vpx_codec_vp8_cx_algo;
|
||||
vpx_codec_vp8_dx;
|
||||
vpx_codec_vp8_dx_algo;
|
||||
vpx_codec_vp9_cx;
|
||||
vpx_codec_vp9_cx_algo;
|
||||
vpx_codec_vp9_dx;
|
||||
vpx_codec_vp9_dx_algo;
|
||||
vpx_dec_control;
|
||||
vpx_dec_decode;
|
||||
vpx_dec_destroy;
|
||||
vpx_dec_error;
|
||||
vpx_dec_error_detail;
|
||||
vpx_dec_err_to_string;
|
||||
vpx_dec_get_caps;
|
||||
vpx_dec_get_frame;
|
||||
vpx_dec_get_mem_map;
|
||||
vpx_dec_get_stream_info;
|
||||
vpx_dec_iface_name;
|
||||
vpx_dec_init_ver;
|
||||
vpx_dec_peek_stream_info;
|
||||
vpx_dec_register_put_frame_cb;
|
||||
vpx_dec_register_put_slice_cb;
|
||||
vpx_dec_set_mem_map;
|
||||
vpx_dec_xma_init_ver;
|
||||
vpx_enc_vp8_algo;
|
||||
vpx_img_alloc;
|
||||
vpx_img_flip;
|
||||
vpx_img_free;
|
||||
vpx_img_set_rect;
|
||||
vpx_img_wrap;
|
||||
vpx_svc_dump_statistics;
|
||||
vpx_svc_encode;
|
||||
vpx_svc_get_buffer;
|
||||
vpx_svc_get_encode_frame_count;
|
||||
vpx_svc_get_frame_size;
|
||||
vpx_svc_get_layer_resolution;
|
||||
vpx_svc_get_message;
|
||||
vpx_svc_get_rc_stats_buffer;
|
||||
vpx_svc_get_rc_stats_buffer_size;
|
||||
vpx_svc_init;
|
||||
vpx_svc_is_keyframe;
|
||||
vpx_svc_release;
|
||||
vpx_svc_set_keyframe;
|
||||
vpx_svc_set_options;
|
||||
vpx_svc_set_quantizers;
|
||||
vpx_svc_set_scale_factors;
|
||||
local: *; };
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (v1.9.0.tar.gz) = 8d544552b35000ea5712aec220b78bb5f7dc210704b2f609365214cb95a4f5a0e343b362723d829cb4a9ac203b10d5443700ba84b28fd6b2fefbabb40663e298
|
18
vpx_config.h
Normal file
18
vpx_config.h
Normal file
@ -0,0 +1,18 @@
|
||||
/* Provide a real file - not a symlink - as it would cause multiarch conflicts
|
||||
(when multiple different arch releases are installed simultaneously. */
|
||||
|
||||
#if defined __x86_64__
|
||||
# include "vpx_config-x86_64.h"
|
||||
#elif defined __aarch64__
|
||||
# include "vpx_config-aarch64.h"
|
||||
#elif defined __arm__
|
||||
# include "vpx_config-arm.h"
|
||||
#elif defined __i386__
|
||||
# include "vpx_config-x86.h"
|
||||
#elif defined __powerpc64__
|
||||
# include "vpx_config-ppc64.h"
|
||||
#elif defined __s390__
|
||||
# include "vpx_config-s390.h"
|
||||
#else
|
||||
# error "Unsupported arch"
|
||||
#endif
|
Loading…
Reference in New Issue
Block a user