use upstream vpx.pc file, drop local libvpx.pc file, apply upstream fix for vpx.pc file
This commit is contained in:
parent
a17e80ebac
commit
3ff9f4462f
12
libvpx-v1.0.0-pcfix.patch
Normal file
12
libvpx-v1.0.0-pcfix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up libvpx-v1.0.0/libs.mk.pcfix libvpx-v1.0.0/libs.mk
|
||||
--- libvpx-v1.0.0/libs.mk.pcfix 2012-05-11 15:54:50.452637490 -0400
|
||||
+++ libvpx-v1.0.0/libs.mk 2012-05-11 15:55:06.694515039 -0400
|
||||
@@ -232,7 +232,7 @@ vpx.pc: config.mk libs.mk
|
||||
$(qexec)echo '# pkg-config file from libvpx $(VERSION_STRING)' > $@
|
||||
$(qexec)echo 'prefix=$(PREFIX)' >> $@
|
||||
$(qexec)echo 'exec_prefix=$${prefix}' >> $@
|
||||
- $(qexec)echo 'libdir=$${prefix}/lib' >> $@
|
||||
+ $(qexec)echo 'libdir=$${prefix}/$(LIBSUBDIR)' >> $@
|
||||
$(qexec)echo 'includedir=$${prefix}/include' >> $@
|
||||
$(qexec)echo '' >> $@
|
||||
$(qexec)echo 'Name: vpx' >> $@
|
20
libvpx.spec
20
libvpx.spec
@ -2,15 +2,13 @@ Name: libvpx
|
||||
Summary: VP8 Video Codec SDK
|
||||
Version: 1.0.0
|
||||
%global soversion %{version}
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Libraries
|
||||
Source0: http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
|
||||
# Probably this should be dropped now that upstream ships a vpx.pc;
|
||||
# not for F16 though
|
||||
Source1: libvpx.pc
|
||||
# Thanks to debian.
|
||||
Source2: libvpx.ver
|
||||
Patch0: libvpx-v1.0.0-pcfix.patch
|
||||
URL: http://www.webmproject.org/tools/vp8-sdk/
|
||||
%ifarch %{ix86} x86_64
|
||||
BuildRequires: yasm
|
||||
@ -42,6 +40,7 @@ and decoder.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-v%{version}
|
||||
%patch0 -p1 -b .pcfix
|
||||
|
||||
%build
|
||||
%ifarch %{ix86}
|
||||
@ -102,14 +101,6 @@ mv libNOTvpx_g.a libvpx_g.a
|
||||
%install
|
||||
make DIST_DIR=%{buildroot}%{_prefix} dist
|
||||
|
||||
# Install the pkg-config file
|
||||
mkdir -p %{buildroot}%{_libdir}/pkgconfig/
|
||||
install -m0644 %{SOURCE1} %{buildroot}%{_libdir}/pkgconfig/
|
||||
# Fill in the variables
|
||||
sed -i "s|@PREFIX@|%{_prefix}|g" %{buildroot}%{_libdir}/pkgconfig/libvpx.pc
|
||||
sed -i "s|@LIBDIR@|%{_libdir}|g" %{buildroot}%{_libdir}/pkgconfig/libvpx.pc
|
||||
sed -i "s|@INCLUDEDIR@|%{_includedir}|g" %{buildroot}%{_libdir}/pkgconfig/libvpx.pc
|
||||
|
||||
# Simpler to label the dir as %doc.
|
||||
mv %{buildroot}/usr/docs doc/
|
||||
|
||||
@ -145,7 +136,6 @@ popd
|
||||
# These are SDK docs, not really useful to an end-user.
|
||||
%doc docs/html/
|
||||
%{_includedir}/vpx/
|
||||
%{_libdir}/pkgconfig/libvpx.pc
|
||||
%{_libdir}/pkgconfig/vpx.pc
|
||||
%{_libdir}/libvpx.so
|
||||
|
||||
@ -153,6 +143,10 @@ popd
|
||||
%{_bindir}/*
|
||||
|
||||
%changelog
|
||||
* Fri May 11 2012 Tom Callaway <spot@fedoraproject.org> - 1.0.0-2
|
||||
- use included vpx.pc file (drop local libvpx.pc)
|
||||
- apply upstream fix to vpx.pc file (bz 814177)
|
||||
|
||||
* Mon Jan 30 2012 Tom Callaway <spot@fedoraproject.org> - 1.0.0-1
|
||||
- update to 1.0.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user