import libvma-9.4.0-1.el8
This commit is contained in:
parent
052f7b2369
commit
be3944e365
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/libvma-9.3.1.tar.gz
|
||||
SOURCES/libvma-9.4.0.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
0c43ee34e73cf00ff0f2776974542c830228a9ef SOURCES/libvma-9.3.1.tar.gz
|
||||
fa114e38bffba3499ff324b550f9c640eaefb879 SOURCES/libvma-9.4.0.tar.gz
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 061e5640686f670398856b8640161762ce56d5e5 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Ivanov <igori@nvidia.com>
|
||||
Date: Thu, 17 Jun 2021 16:07:31 +0300
|
||||
Subject: [PATCH] Fix fc35 issues
|
||||
|
||||
- glibc:
|
||||
The function pthread_yield has been deprecated; programs should use
|
||||
the equivalent standard function sched_yield instead.
|
||||
- systemd:
|
||||
Fix systemd detection
|
||||
|
||||
Signed-off-by: Igor Ivanov <igori@nvidia.com>
|
||||
---
|
||||
Makefile.am | 10 ++--------
|
||||
src/vma/iomux/epfd_info.cpp | 2 +-
|
||||
2 files changed, 3 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index ee543c8f..c8dea6ee 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -19,21 +19,15 @@ mydocdir = $(if $(docdir),$(docdir),${datadir}/doc/$(distdir))
|
||||
mydoc_DATA = README CHANGES
|
||||
|
||||
install-exec-hook:
|
||||
- if type systemctl >/dev/null 2>&1; then \
|
||||
+ if systemctl >/dev/null 2>&1; then \
|
||||
mkdir -p $(DESTDIR)$(prefix)/lib/systemd/system/; \
|
||||
cp $(top_builddir)/contrib/scripts/vma.service $(DESTDIR)$(prefix)/lib/systemd/system/vma.service; \
|
||||
chmod 644 $(DESTDIR)$(prefix)/lib/systemd/system/vma.service; \
|
||||
- else \
|
||||
- mkdir -p $(DESTDIR)/$(sysconfdir)/init.d; \
|
||||
- cp $(top_builddir)/contrib/scripts/vma.init $(DESTDIR)$(sysconfdir)/init.d/vma; \
|
||||
- chmod 755 $(DESTDIR)$(sysconfdir)/init.d/vma; \
|
||||
fi
|
||||
|
||||
uninstall-hook:
|
||||
- if type systemctl >/dev/null 2>&1; then \
|
||||
+ if systemctl >/dev/null 2>&1; then \
|
||||
rm -rf $(DESTDIR)$(prefix)/lib/systemd/system/vma.service; \
|
||||
- else \
|
||||
- rm -rf $(DESTDIR)$(sysconfdir)/init.d/vma; \
|
||||
fi
|
||||
|
||||
install-all: install
|
||||
diff --git a/src/vma/iomux/epfd_info.cpp b/src/vma/iomux/epfd_info.cpp
|
||||
index c7670c7b..d7c6c4fc 100644
|
||||
--- a/src/vma/iomux/epfd_info.cpp
|
||||
+++ b/src/vma/iomux/epfd_info.cpp
|
||||
@@ -624,7 +624,7 @@ int epfd_info::ring_poll_and_process_element(uint64_t *p_poll_sn, void* pv_fd_re
|
||||
|
||||
m_ring_map_lock.unlock();
|
||||
|
||||
- if (m_sysvar_thread_mode == THREAD_MODE_PLENTY && ret_total == 0 && errno == EAGAIN) pthread_yield();
|
||||
+ if (m_sysvar_thread_mode == THREAD_MODE_PLENTY && ret_total == 0 && errno == EAGAIN) sched_yield();
|
||||
|
||||
if (ret_total) {
|
||||
__log_func("ret_total=%d", ret_total);
|
||||
--
|
||||
2.18.1
|
||||
|
@ -1,14 +1,13 @@
|
||||
%{!?configure_options: %global configure_options %{nil}}
|
||||
|
||||
Name: libvma
|
||||
Version: 9.3.1
|
||||
Version: 9.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: A library for boosting TCP and UDP traffic (over RDMA hardware)
|
||||
|
||||
License: GPLv2 or BSD
|
||||
Url: https://github.com/Mellanox/libvma
|
||||
Source0: https://github.com/Mellanox/libvma/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-Fix-fc35-issues.patch
|
||||
|
||||
# libvma currently supports only the following architectures
|
||||
ExclusiveArch: x86_64 ppc64le ppc64 aarch64
|
||||
@ -68,6 +67,7 @@ fi
|
||||
|
||||
find $RPM_BUILD_ROOT%{_libdir} -name '*.la' -delete
|
||||
install -D -m 644 contrib/scripts/vma.service $RPM_BUILD_ROOT/%{_prefix}/lib/systemd/system/vma.service
|
||||
rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/init.d/vma
|
||||
|
||||
%post
|
||||
%systemd_post vma.service
|
||||
@ -99,6 +99,10 @@ install -D -m 644 contrib/scripts/vma.service $RPM_BUILD_ROOT/%{_prefix}/lib/sys
|
||||
%{_mandir}/man8/vma_stats.*
|
||||
|
||||
%changelog
|
||||
* Tue Nov 30 2021 Honggang Li <honli@redhat.com> - 9.4.0-1
|
||||
- Bump version to 9.4.0
|
||||
- Resolves: rhbz#1982205
|
||||
|
||||
* Tue Jul 06 2021 Honggang Li <honli@redhat.com> - 9.3.1-1
|
||||
- Bump version to 9.3.1
|
||||
- Resolves: rhbz#1915316
|
||||
|
Loading…
Reference in New Issue
Block a user