Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/libvma.git#4636fdd1a5332594a75ab93ff4589ef86cf47ffa
This commit is contained in:
DistroBaker 2021-02-03 19:03:25 +00:00
parent 0898b45505
commit 42a210d39f
2 changed files with 44 additions and 7 deletions

View File

@ -1,4 +1,4 @@
From 3178430b32c71c0348eb33521d8323122714a58b Mon Sep 17 00:00:00 2001
From d64a8e295ad39032790501955e3bdb7d86e8b05f Mon Sep 17 00:00:00 2001
From: Igor Ivanov <igor.ivanov.va@gmail.com>
Date: Wed, 16 Dec 2020 13:46:17 +0200
Subject: [PATCH] Fix issues for gcc-11
@ -6,14 +6,16 @@ Subject: [PATCH] Fix issues for gcc-11
1. The register storage class specifier is deprecated in C++11
2. Disable -Wno-free-nonheap-object diagnostic that looks as
incorrect for gcc-11
3. [-Werror=stringop-overread] in std::string()
Signed-off-by: Igor Ivanov <igor.ivanov.va@gmail.com>
---
configure.ac | 8 ++++++--
src/utils/asm-x86.h | 2 +-
src/vma/sock/cleanable_obj.h | 9 ++++++++-
src/vma/util/utils.cpp | 4 ++--
4 files changed, 17 insertions(+), 6 deletions(-)
configure.ac | 8 ++++++--
src/utils/asm-x86.h | 2 +-
src/vma/dev/net_device_val.cpp | 6 +++---
src/vma/sock/cleanable_obj.h | 9 ++++++++-
src/vma/util/utils.cpp | 4 ++--
5 files changed, 20 insertions(+), 9 deletions(-)
diff --git a/configure.ac b/configure.ac
index 1540324a..811eb421 100644
@ -47,6 +49,37 @@ index 5dfb6f42..4e8f03ca 100644
// ReaD Time Stamp Counter (RDTCS)
__asm__ __volatile__("rdtsc" : "=a" (lower_32), "=d" (upper_32));
diff --git a/src/vma/dev/net_device_val.cpp b/src/vma/dev/net_device_val.cpp
index 0e48a9e4..989e4539 100644
--- a/src/vma/dev/net_device_val.cpp
+++ b/src/vma/dev/net_device_val.cpp
@@ -962,7 +962,7 @@ void net_device_val::update_netvsc_slaves(int if_index, int if_flags)
std::string net_device_val::to_str()
{
- return std::string("Net Device: " + m_name);
+ return std::string("Net Device: ") + m_name;
}
ring* net_device_val::reserve_ring(resource_allocation_key *key)
@@ -1414,7 +1414,7 @@ void net_device_val_eth::create_br_address(const char* ifname)
}
std::string net_device_val_eth::to_str()
{
- return std::string("ETH: " + net_device_val::to_str());
+ return std::string("ETH: ") + net_device_val::to_str();
}
net_device_val_ib::~net_device_val_ib()
@@ -1512,7 +1512,7 @@ void net_device_val_ib::create_br_address(const char* ifname)
std::string net_device_val_ib::to_str()
{
- return std::string("IB: " + net_device_val::to_str());
+ return std::string("IB: ") + net_device_val::to_str();
}
diff --git a/src/vma/sock/cleanable_obj.h b/src/vma/sock/cleanable_obj.h
index 34801712..ea38f24b 100644
--- a/src/vma/sock/cleanable_obj.h

View File

@ -2,7 +2,7 @@
Name: libvma
Version: 9.2.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: A library for boosting TCP and UDP traffic (over RDMA hardware)
License: GPLv2 or BSD
@ -25,6 +25,7 @@ BuildRequires: rdma-core-devel
BuildRequires: systemd-rpm-macros
BuildRequires: pkgconfig(libnl-3.0)
BuildRequires: pkgconfig(libnl-route-3.0)
BuildRequires: make
%description
libvma is a LD_PRELOAD-able library that boosts performance of TCP and
@ -102,6 +103,9 @@ install -D -m 644 contrib/scripts/vma.service $RPM_BUILD_ROOT/%{_prefix}/lib/sys
%{_mandir}/man8/vma_stats.*
%changelog
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 9.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Dec 16 2020 Igor Ivanov <igor.ivanov.va@gmail.com> 9.2.2-1
- Bump version to 9.2.2
- Fix issues for gcc-11