libvirt/SOURCES/libvirt-Revert-RHEL-network...

85 lines
3.0 KiB
Diff

From 195908ad66fc52643d94eca0f45e5740f25e3e78 Mon Sep 17 00:00:00 2001
Message-Id: <195908ad66fc52643d94eca0f45e5740f25e3e78@dist-git>
From: Laine Stump <laine@laine.org>
Date: Fri, 1 Feb 2019 20:29:26 -0500
Subject: [PATCH] Revert "RHEL: network: regain guest network connectivity
after firewalld switch to nftables"
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This reverts commit 54e270d7fb68b41002654374d395e4f260a24add.
This patch appeared in libvirt-4.5.0-11.el8 (RHEL git commit id
2fb53957). It was a downstream-only temporary fix to the networking
issues resulting from firewalld's switch to using nftables. Now that
there is a permanent fix upstream we can revert this patch and use the
upstream patches instead.
https://bugzilla.redhat.com/1650320
Signed-off-by: Laine Stump <laine@laine.org>
Reviewed-by: Ján Tomko <jtomko@redhat.com>
---
libvirt.spec.in | 14 --------------
src/network/Makefile.inc.am | 10 +---------
src/network/libvirt.zone | 15 ---------------
3 files changed, 1 insertion(+), 38 deletions(-)
delete mode 100644 src/network/libvirt.zone
diff --git a/src/network/Makefile.inc.am b/src/network/Makefile.inc.am
index 20d899e699..508c8c0422 100644
--- a/src/network/Makefile.inc.am
+++ b/src/network/Makefile.inc.am
@@ -87,11 +87,6 @@ install-data-network:
( cd $(DESTDIR)$(confdir)/qemu/networks/autostart && \
rm -f default.xml && \
$(LN_S) ../default.xml default.xml )
-if HAVE_FIREWALLD
- $(MKDIR_P) "$(DESTDIR)$(prefix)/lib/firewalld/zones"
- $(INSTALL_DATA) $(srcdir)/network/libvirt.zone \
- $(DESTDIR)$(prefix)/lib/firewalld/zones/libvirt.xml
-endif HAVE_FIREWALLD
uninstall-data-network:
rm -f $(DESTDIR)$(confdir)/qemu/networks/autostart/default.xml
@@ -100,13 +95,10 @@ uninstall-data-network:
rmdir "$(DESTDIR)$(confdir)/qemu/networks" || :
rmdir "$(DESTDIR)$(localstatedir)/lib/libvirt/network" ||:
rmdir "$(DESTDIR)$(localstatedir)/run/libvirt/network" ||:
-if HAVE_FIREWALLD
- rm -f $(DESTDIR)$(prefix)/lib/firewalld/zones/libvirt.xml
-endif HAVE_FIREWALLD
endif WITH_NETWORK
-EXTRA_DIST += network/default.xml network/libvirt.zone
+EXTRA_DIST += network/default.xml
.PHONY: \
install-data-network \
diff --git a/src/network/libvirt.zone b/src/network/libvirt.zone
deleted file mode 100644
index 355a70b4da..0000000000
--- a/src/network/libvirt.zone
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<zone target="ACCEPT">
- <short>libvirt</short>
- <description>All network connections are accepted. This also permits packets to/from interfaces in the zone to be forwarded. This zone is intended to be used only by libvirt virtual networks.</description>
- <interface name="virbr0"/>
- <interface name="virbr1"/>
- <interface name="virbr2"/>
- <interface name="virbr3"/>
- <interface name="virbr4"/>
- <interface name="virbr5"/>
- <interface name="virbr6"/>
- <interface name="virbr7"/>
- <interface name="virbr8"/>
- <interface name="virbr9"/>
-</zone>
--
2.20.1