libvirt/libvirt-sync_qemu_models_i386-Generate-missing-v1-variants.patch
Jiri Denemark 0028645d09 libvirt-10.10.0-2.el9
- util: Fix typo in virNetDevOpenvswitchInterfaceSetQos (RHEL-69938)
- qemu: tpm: do not update profile name for transient domains (RHEL-71072)
- qemu: Enable I/O APIC if needed (RHEL-65844)
- cpu_map: Sort data files in meson.build (RHEL-70052)
- sync_qemu_models_i386: Update meson.build (RHEL-70052)
- sync_qemu_models_i386: Generate missing -v1 variants (RHEL-70052)
- cpu_map: Add 486-v1 CPU model (RHEL-70052)
- cpu_map: Add pentium-v1 CPU model (RHEL-70052)
- cpu_map: Add pentium2-v1 CPU model (RHEL-70052)
- cpu_map: Add pentium3-v1 CPU model (RHEL-70052)
- cpu_map: Add coreduo-v1 CPU model (RHEL-70052)
- cpu_map: Add n270-v1 CPU model (RHEL-70052)
- cpu_map: Add core2duo-v1 CPU model (RHEL-70052)
- cpu_map: Add qemu32-v1 CPU model (RHEL-70052)
- cpu_map: Add kvm32-v1 CPU model (RHEL-70052)
- cpu_map: Add qemu64-v1 CPU model (RHEL-70052)
- cpu_map: Add kvm64-v1 CPU model (RHEL-70052)
- cpu_map: Add Conroe-v1 CPU model (RHEL-70052)
- cpu_map: Add Penryn-v1 CPU model (RHEL-70052)
- cpu_map: Add KnightsMill-v1 CPU model (RHEL-70052)
- cpu_map: Add athlon-v1 CPU model (RHEL-70052)
- cpu_map: Add phenom-v1 CPU model (RHEL-70052)
- cpu_map: Add Opteron_G1-v1 CPU model (RHEL-70052)
- cpu_map: Add Opteron_G2-v1 CPU model (RHEL-70052)
- cpu_map: Add Opteron_G3-v1 CPU model (RHEL-70052)
- cpu_map: Add Opteron_G4-v1 CPU model (RHEL-70052)
- cpu_map: Add Opteron_G5-v1 CPU model (RHEL-70052)
- cpu_map: Add EPYC-Genoa-v1 CPU model (RHEL-70052)

Resolves: RHEL-65844, RHEL-69938, RHEL-70052, RHEL-71072
2024-12-17 12:00:47 +01:00

38 lines
1.3 KiB
Diff

From 0f6f879e8070aca4f61305c7b9099ba8039d6f6d Mon Sep 17 00:00:00 2001
Message-ID: <0f6f879e8070aca4f61305c7b9099ba8039d6f6d.1734433245.git.jdenemar@redhat.com>
From: Jiri Denemark <jdenemar@redhat.com>
Date: Thu, 28 Nov 2024 13:40:16 +0100
Subject: [PATCH] sync_qemu_models_i386: Generate missing -v1 variants
QEMU supports -v1 variant of any CPU model even though the list of
versions is not defined (i.e., even if { .version = 1 } item is
missing).
Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
Reviewed-by: Michal Privoznik <mprivozn@redhat.com>
(cherry picked from commit 8bc6ebb495f82ce8edb206eb4d5133e206fd8f2e)
https://issues.redhat.com/browse/RHEL-70052
Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
---
src/cpu_map/sync_qemu_models_i386.py | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/cpu_map/sync_qemu_models_i386.py b/src/cpu_map/sync_qemu_models_i386.py
index 11fe1f7435..3e14136e07 100755
--- a/src/cpu_map/sync_qemu_models_i386.py
+++ b/src/cpu_map/sync_qemu_models_i386.py
@@ -484,6 +484,9 @@ def expand_model(outdir, model):
print(result['name'])
yield result
+ if len(versions) == 0:
+ versions.append({".version": "1"})
+
name = result["name"]
for version in versions:
result = copy.deepcopy(result)
--
2.47.1