eabdullin
2daa9ba65a
- qemu: domain: Check arch in qemuDomainMakeCPUMigratable - conf: cpu: Introduce virCPUDefListFeatures - qemu: domain: Drop added features from migratable CPU - Add vmx-* features to Broadwell* - Add vmx-* features to Cascadelake* - Add vmx-* features to Conroe - Add vmx-* features to Cooperlake - Add vmx-* features to core2duo - Add vmx-* features to Haswell* - Add vmx-* features to Icelake* - Add vmx-* features to IvyBridge* - Add vmx-* features to kvm* - Add vmx-* features to Nehalem* - Add vmx-* features to Penryn - Add vmx-* features to SandyBridge* - Add vmx-* features to SapphireRapids - Add vmx-* features to Skylake* - Add vmx-* features to Snowridge - Add vmx-* features to Westmere* - qemu: virtiofs: do not crash if cgroups are missing - qemu: virtiofs: set correct label when creating the socket - qemu: virtiofs: error out if getting the group or user name fails
32 lines
1.2 KiB
Diff
32 lines
1.2 KiB
Diff
From 4c5b2e1e0d0d0cbbf8c6ed28ce77d055d5974f7f Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
|
Date: Wed, 6 Mar 2024 17:26:40 +0100
|
|
Subject: [PATCH] qemu: virtiofs: set correct label when creating the socket
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Use svirt_t instead of virtd_t, since virtd_t is not available in the
|
|
session mode and qemu with svirt_t won't be able to talk to unconfined_t
|
|
socket.
|
|
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
Reviewed-by: Michal Privoznik <mprivozn@redhat.com>
|
|
---
|
|
src/qemu/qemu_virtiofs.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/qemu/qemu_virtiofs.c b/src/qemu/qemu_virtiofs.c
|
|
index 15dea3bb57f..d80cddd3ba9 100644
|
|
--- a/src/qemu/qemu_virtiofs.c
|
|
+++ b/src/qemu/qemu_virtiofs.c
|
|
@@ -102,7 +102,7 @@ qemuVirtioFSOpenChardev(virQEMUDriver *driver,
|
|
chrdev->data.nix.listen = true;
|
|
chrdev->data.nix.path = g_strdup(socket_path);
|
|
|
|
- if (qemuSecuritySetDaemonSocketLabel(driver->securityManager, vm->def) < 0)
|
|
+ if (qemuSecuritySetSocketLabel(driver->securityManager, vm->def) < 0)
|
|
goto cleanup;
|
|
fd = qemuOpenChrChardevUNIXSocket(chrdev);
|
|
if (fd < 0) {
|