38c4b724fe
* Make PCI multifunction support more manual - Bug 742836 * Builds on F15 should still use cgconfig - Bug 738725
57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From 5d219e1bd98b562eed28e1df424a2590bb92b366 Mon Sep 17 00:00:00 2001
|
|
From: Eric Blake <eblake@redhat.com>
|
|
Date: Mon, 26 Sep 2011 14:28:47 -0600
|
|
Subject: [PATCH 1/2] spec: F15 still uses cgconfig, RHEL lacks hyperv
|
|
|
|
Commit ecd8725c dropped attempts to probe the cgconfig service on
|
|
new enough Fedora where systemd took over that aspect of the system,
|
|
but mistakenly used F14 instead of F15 as the cutoff point.
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=741358
|
|
|
|
Also, RHEL does not include HyperV support yet.
|
|
|
|
* libvirt.spec.in (with_cgconfig): Check cgconfig service in F15.
|
|
(%{?rhel}): Provide default for with_hyperv.
|
|
---
|
|
libvirt.spec.in | 8 +++++---
|
|
1 files changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/libvirt.spec.in b/libvirt.spec.in
|
|
index c0ea898..b87e3f6 100644
|
|
--- a/libvirt.spec.in
|
|
+++ b/libvirt.spec.in
|
|
@@ -97,7 +97,8 @@
|
|
%endif
|
|
|
|
# RHEL doesn't ship OpenVZ, VBox, UML, PowerHypervisor,
|
|
-# VMWare, libxenserver (xenapi), or libxenlight (Xen 4.1 and newer)
|
|
+# VMWare, libxenserver (xenapi), libxenlight (Xen 4.1 and newer),
|
|
+# or HyperV.
|
|
%if 0%{?rhel}
|
|
%define with_openvz 0
|
|
%define with_vbox 0
|
|
@@ -106,6 +107,7 @@
|
|
%define with_vmware 0
|
|
%define with_xenapi 0
|
|
%define with_libxl 0
|
|
+%define with_hyperv 0
|
|
%endif
|
|
|
|
# RHEL-5 has restricted QEMU to x86_64 only and is too old for LXC
|
|
@@ -894,9 +896,9 @@ done
|
|
%endif
|
|
|
|
%if %{with_cgconfig}
|
|
-# Starting with Fedora 15, systemd automounts all cgroups, and cgconfig is
|
|
+# Starting with Fedora 16, systemd automounts all cgroups, and cgconfig is
|
|
# no longer a necessary service.
|
|
-%if 0%{?fedora} <= 14 || 0%{?rhel} <= 6
|
|
+%if 0%{?fedora} <= 15 || 0%{?rhel} <= 6
|
|
if [ "$1" -eq "1" ]; then
|
|
/sbin/chkconfig cgconfig on
|
|
fi
|
|
--
|
|
1.7.4.4
|
|
|