libvirt/libvirt-util-Fix-typo-in-virNetDevOpenvswitchInterfaceSetQos.patch
Jiri Denemark 733f87f1f7 libvirt-10.10.0-2.el10
- util: Fix typo in virNetDevOpenvswitchInterfaceSetQos (RHEL-69840)
- qemu: tpm: do not update profile name for transient domains (RHEL-69774)
- qemu: Enable I/O APIC if needed (RHEL-71414)
- cpu_map: Sort data files in meson.build (RHEL-70129)
- sync_qemu_models_i386: Update meson.build (RHEL-70129)
- sync_qemu_models_i386: Generate missing -v1 variants (RHEL-70129)
- cpu_map: Add 486-v1 CPU model (RHEL-70129)
- cpu_map: Add pentium-v1 CPU model (RHEL-70129)
- cpu_map: Add pentium2-v1 CPU model (RHEL-70129)
- cpu_map: Add pentium3-v1 CPU model (RHEL-70129)
- cpu_map: Add coreduo-v1 CPU model (RHEL-70129)
- cpu_map: Add n270-v1 CPU model (RHEL-70129)
- cpu_map: Add core2duo-v1 CPU model (RHEL-70129)
- cpu_map: Add qemu32-v1 CPU model (RHEL-70129)
- cpu_map: Add kvm32-v1 CPU model (RHEL-70129)
- cpu_map: Add qemu64-v1 CPU model (RHEL-70129)
- cpu_map: Add kvm64-v1 CPU model (RHEL-70129)
- cpu_map: Add Conroe-v1 CPU model (RHEL-70129)
- cpu_map: Add Penryn-v1 CPU model (RHEL-70129)
- cpu_map: Add KnightsMill-v1 CPU model (RHEL-70129)
- cpu_map: Add athlon-v1 CPU model (RHEL-70129)
- cpu_map: Add phenom-v1 CPU model (RHEL-70129)
- cpu_map: Add Opteron_G1-v1 CPU model (RHEL-70129)
- cpu_map: Add Opteron_G2-v1 CPU model (RHEL-70129)
- cpu_map: Add Opteron_G3-v1 CPU model (RHEL-70129)
- cpu_map: Add Opteron_G4-v1 CPU model (RHEL-70129)
- cpu_map: Add Opteron_G5-v1 CPU model (RHEL-70129)
- cpu_map: Add EPYC-Genoa-v1 CPU model (RHEL-70129)

Resolves: RHEL-69774, RHEL-69840, RHEL-70129, RHEL-71414
2024-12-17 10:59:14 +01:00

39 lines
1.4 KiB
Diff

From 1953c2ecd3a3e8858a79ad2634e7bea8e708588d Mon Sep 17 00:00:00 2001
Message-ID: <1953c2ecd3a3e8858a79ad2634e7bea8e708588d.1734429553.git.jdenemar@redhat.com>
From: Jiri Denemark <jdenemar@redhat.com>
Date: Wed, 4 Dec 2024 11:53:47 +0100
Subject: [PATCH] util: Fix typo in virNetDevOpenvswitchInterfaceSetQos
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The typo is causing virtqemud to crash when starting a domain with ovs
bridge interface and QOS.
https://issues.redhat.com/browse/RHEL-69840
Fixes: a3b8753db975d8b92b122ccc7daee986974f8b18
Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
Reviewed-by: Ján Tomko <jtomko@redhat.com>
(cherry picked from commit dba710374d92688f797bf64642cc0d640c301239)
Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
---
src/util/virnetdevopenvswitch.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/util/virnetdevopenvswitch.c b/src/util/virnetdevopenvswitch.c
index a1bd9f3d5b..0f5d23b794 100644
--- a/src/util/virnetdevopenvswitch.c
+++ b/src/util/virnetdevopenvswitch.c
@@ -958,7 +958,7 @@ virNetDevOpenvswitchInterfaceSetQos(const char *ifname,
}
if (rx) {
- if (rx->peak && tx->peak != rx->average) {
+ if (rx->peak && rx->peak != rx->average) {
VIR_WARN("Setting different 'peak' value than 'average' for QoS for OVS interface %s might have unexpected results",
ifname);
}
--
2.47.1