64 lines
2.7 KiB
Diff
64 lines
2.7 KiB
Diff
From 0c35c1c0495a953268719ad83cf2f368ab53018b Mon Sep 17 00:00:00 2001
|
|
Message-Id: <0c35c1c0495a953268719ad83cf2f368ab53018b@dist-git>
|
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
|
Date: Fri, 20 Jan 2023 12:56:48 +0100
|
|
Subject: [PATCH] conf: clarify some external TPM error messages
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Two of the messages referred to 'backend type' when dealing
|
|
with the source type and one mentioned the 'client' attribute
|
|
from an earlier iteration of the patches, even though the attribute
|
|
was later changed to 'connect'.
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=2063723
|
|
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
Reviewed-by: Martin Kletzander <mkletzan@redhat.com>
|
|
(cherry picked from commit 1c7476c8797b7f0d6e8d607f6a42c5bf43441677)
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
---
|
|
src/conf/domain_conf.c | 4 ++--
|
|
src/conf/domain_validate.c | 2 +-
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/conf/domain_conf.c b/src/conf/domain_conf.c
|
|
index 45965fa0fa..733399e6da 100644
|
|
--- a/src/conf/domain_conf.c
|
|
+++ b/src/conf/domain_conf.c
|
|
@@ -10545,7 +10545,7 @@ virDomainTPMDefParseXML(virDomainXMLOption *xmlopt,
|
|
case VIR_DOMAIN_TPM_TYPE_EXTERNAL:
|
|
if (!(type = virXPathString("string(./backend/source/@type)", ctxt))) {
|
|
virReportError(VIR_ERR_XML_ERROR, "%s",
|
|
- _("missing external TPM backend type"));
|
|
+ _("missing external TPM backend source type"));
|
|
goto error;
|
|
}
|
|
|
|
@@ -10555,7 +10555,7 @@ virDomainTPMDefParseXML(virDomainXMLOption *xmlopt,
|
|
def->data.external.source->type = virDomainChrTypeFromString(type);
|
|
if (def->data.external.source->type < 0) {
|
|
virReportError(VIR_ERR_CONFIG_UNSUPPORTED,
|
|
- _("unknown backend type '%s' for external TPM"),
|
|
+ _("unknown backend source type '%s' for external TPM"),
|
|
type);
|
|
goto error;
|
|
}
|
|
diff --git a/src/conf/domain_validate.c b/src/conf/domain_validate.c
|
|
index 39d924d4ed..1c13929281 100644
|
|
--- a/src/conf/domain_validate.c
|
|
+++ b/src/conf/domain_validate.c
|
|
@@ -2757,7 +2757,7 @@ virDomainTPMDevValidate(const virDomainTPMDef *tpm)
|
|
}
|
|
if (tpm->data.external.source->data.nix.listen) {
|
|
virReportError(VIR_ERR_XML_ERROR, "%s",
|
|
- _("only 'client' mode is supported for external TPM device"));
|
|
+ _("only 'connect' mode is supported for external TPM device"));
|
|
return -1;
|
|
}
|
|
if (tpm->data.external.source->data.nix.path == NULL) {
|
|
--
|
|
2.39.1
|
|
|