Sync patches from git

This commit is contained in:
Mark McLoughlin 2009-08-17 08:08:46 +00:00
parent e1b7b518ac
commit da05e02884
6 changed files with 164 additions and 87 deletions

View File

@ -1,6 +1,21 @@
--- src/qemu_conf.c.orig 2009-05-29 19:24:59.000000000 +0200 From f9355301cf4dda452308b616e8c00e59be5aec0a Mon Sep 17 00:00:00 2001
+++ src/qemu_conf.c 2009-05-29 19:19:39.000000000 +0200 From: Daniel P. Berrange <berrange@redhat.com>
@@ -792,6 +792,20 @@ int qemudBuildCommandLine(virConnectPtr Date: Mon, 17 Aug 2009 08:32:08 +0100
Subject: [PATCH] Disable sound cards when running sVirt
Temporary hack till PulseAudio autostart problems are sorted out when
SELinux enforcing (bz 486112)
Fedora-patch: libvirt-0.6.4-svirt-sound.patch
---
src/qemu_conf.c | 17 ++++++++++++++++-
1 files changed, 16 insertions(+), 1 deletions(-)
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
index 6b0b404..53186e0 100644
--- a/src/qemu_conf.c
+++ b/src/qemu_conf.c
@@ -1384,6 +1384,20 @@ int qemudBuildCommandLine(virConnectPtr conn,
char uuid[VIR_UUID_STRING_BUFLEN]; char uuid[VIR_UUID_STRING_BUFLEN];
char domid[50]; char domid[50];
const char *cpu = NULL; const char *cpu = NULL;
@ -10,7 +25,7 @@
+ driver->securityDriver->name && + driver->securityDriver->name &&
+ STREQ(driver->securityDriver->name, "selinux") && + STREQ(driver->securityDriver->name, "selinux") &&
+ getuid() == 0) { + getuid() == 0) {
+ static int soundWarned = 0; + static int soundWarned = 0;
+ skipSound = 1; + skipSound = 1;
+ if (def->nsounds && + if (def->nsounds &&
+ !soundWarned) { + !soundWarned) {
@ -21,7 +36,7 @@
uname_normalize(&ut); uname_normalize(&ut);
@@ -1429,7 +1443,8 @@ int qemudBuildCommandLine(virConnectPtr @@ -2015,7 +2029,8 @@ int qemudBuildCommandLine(virConnectPtr conn,
} }
/* Add sound hardware */ /* Add sound hardware */
@ -31,3 +46,6 @@
int size = 100; int size = 100;
char *modstr; char *modstr;
if (VIR_ALLOC_N(modstr, size+1) < 0) if (VIR_ALLOC_N(modstr, size+1) < 0)
--
1.6.2.5

View File

@ -1,4 +1,6 @@
From 541cfdf5465ac3bba2c0c0901950547bc6638e47 Mon Sep 17 00:00:00 2001
From: Mark McLoughlin <markmc@redhat.com> From: Mark McLoughlin <markmc@redhat.com>
Date: Thu, 6 Aug 2009 15:14:19 +0100
Subject: [PATCH] chown kernel/initrd before spawning qemu Subject: [PATCH] chown kernel/initrd before spawning qemu
If we're running qemu unprivileged, we need to chown any supplied kernel If we're running qemu unprivileged, we need to chown any supplied kernel
@ -8,6 +10,10 @@ or initrd before spawning it.
qemuDomainSetFileOwnership(), pass it a path string instead of a disk qemuDomainSetFileOwnership(), pass it a path string instead of a disk
definition and use it for chowning the kernel/initrd in definition and use it for chowning the kernel/initrd in
qemuDomainSetAllDeviceOwnership() qemuDomainSetAllDeviceOwnership()
(cherry picked from commit c42b39784534930791d1feb3de859d85a7848168)
Fedora-patch: libvirt-0.7.0-chown-kernel-initrd-before-spawning-qemu.patch
--- ---
src/qemu_driver.c | 20 ++++++++++++-------- src/qemu_driver.c | 20 ++++++++++++--------
1 files changed, 12 insertions(+), 8 deletions(-) 1 files changed, 12 insertions(+), 8 deletions(-)

View File

@ -1,4 +1,6 @@
From ddf0a7cb04debe60825d11186e68cc6de6fd1dd2 Mon Sep 17 00:00:00 2001
From: Mark McLoughlin <markmc@redhat.com> From: Mark McLoughlin <markmc@redhat.com>
Date: Mon, 10 Aug 2009 11:16:37 +0100
Subject: [PATCH] Handle kernels with no ipv6 support Subject: [PATCH] Handle kernels with no ipv6 support
If the ipv6 kernel module is not loaded, then we get this when starting If the ipv6 kernel module is not loaded, then we get this when starting
@ -13,6 +15,10 @@ way.
* src/network_driver.c: make networkDisableIPV6() not fail if the kernel * src/network_driver.c: make networkDisableIPV6() not fail if the kernel
has no ipv6 support has no ipv6 support
(cherry picked from commit f5a8f969dd92ec2744e1eec5d35288d5fbcded22)
Fedora-patch: libvirt-0.7.0-handle-kernels-with-no-ipv6-support.patch
--- ---
src/network_driver.c | 6 ++++++ src/network_driver.c | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-) 1 files changed, 6 insertions(+), 0 deletions(-)

View File

@ -1,16 +1,24 @@
commit 19bac57b26c2d46ac8a7601158f210f34acdceac From 663bf081dc6737c7fcc68a7ca1169aca60fbf8e5 Mon Sep 17 00:00:00 2001
Author: Daniel P. Berrange <berrange@redhat.com> From: Daniel P. Berrange <berrange@redhat.com>
Date: Thu Aug 13 11:56:31 2009 +0100 Date: Thu, 13 Aug 2009 11:56:31 +0100
Subject: [PATCH] Make LXC / UML drivers robust against NUMA topology brokenness
Make LXC / UML drivers robust against NUMA topology brokenness Some kernel versions expose broken NUMA topology for some machines.
This causes the LXC/UML drivers to fail to start. QEMU driver was
Some kernel versions expose broken NUMA topology for some machines. already fixed for this problem
This causes the LXC/UML drivers to fail to start. QEMU driver was
already fixed for this problem * src/lxc_conf.c: Log and ignore failure to populate NUMA info
* src/uml_conf.c: Log and ignore failure to populate NUMA info
* src/lxc_conf.c: Log and ignore failure to populate NUMA info * src/capabilities.c: Reset nnumaCell to 0 after freeing
* src/uml_conf.c: Log and ignore failure to populate NUMA info
* src/capabilities.c: Reset nnumaCell to 0 after freeing (cherry picked from commit 19bac57b26c2d46ac8a7601158f210f34acdceac)
Fedora-patch: libvirt-0.7.0-numa-ignore-fail.patch
---
src/capabilities.c | 1 +
src/lxc_conf.c | 12 ++++++++++--
src/uml_conf.c | 11 +++++++++--
3 files changed, 20 insertions(+), 4 deletions(-)
diff --git a/src/capabilities.c b/src/capabilities.c diff --git a/src/capabilities.c b/src/capabilities.c
index c6766b6..193a9fe 100644 index c6766b6..193a9fe 100644
@ -83,3 +91,6 @@ index 48e05a8..4f756d4 100644
if ((guest = virCapabilitiesAddGuest(caps, if ((guest = virCapabilitiesAddGuest(caps,
"uml", "uml",
--
1.6.2.5

View File

@ -1,6 +1,28 @@
diff -rupN libvirt-0.7.0/configure.in libvirt-0.7.0.new/configure.in From d54fc5008d465d192101a0cb78fd02c437dff736 Mon Sep 17 00:00:00 2001
--- libvirt-0.7.0/configure.in 2009-08-05 08:53:49.000000000 -0400 From: Daniel P. Berrange <berrange@redhat.com>
+++ libvirt-0.7.0.new/configure.in 2009-08-13 08:37:22.393897620 -0400 Date: Mon, 17 Aug 2009 08:32:08 +0100
Subject: [PATCH] Policykit rewrite (bug #499970)
Fedora-patch: libvirt-0.7.0-policy-kit-rewrite.patch
---
configure.in | 73 ++++++++++++++++++++++++++++--------------
qemud/Makefile.am | 11 +++++-
qemud/libvirtd.policy | 42 ------------------------
qemud/libvirtd.policy-0 | 42 ++++++++++++++++++++++++
qemud/libvirtd.policy-1 | 42 ++++++++++++++++++++++++
qemud/qemud.c | 4 +-
qemud/qemud.h | 4 +-
qemud/remote.c | 81 ++++++++++++++++++++++++++++++++++++++++++++--
src/remote_internal.c | 7 ++++
9 files changed, 230 insertions(+), 76 deletions(-)
delete mode 100644 qemud/libvirtd.policy
create mode 100644 qemud/libvirtd.policy-0
create mode 100644 qemud/libvirtd.policy-1
diff --git a/configure.in b/configure.in
index 45fa9ed..d28c44a 100644
--- a/configure.in
+++ b/configure.in
@@ -641,40 +641,61 @@ AC_SUBST([SASL_LIBS]) @@ -641,40 +641,61 @@ AC_SUBST([SASL_LIBS])
dnl PolicyKit library dnl PolicyKit library
POLKIT_CFLAGS= POLKIT_CFLAGS=
@ -99,9 +121,48 @@ diff -rupN libvirt-0.7.0/configure.in libvirt-0.7.0.new/configure.in
else else
AC_MSG_NOTICE([ polkit: no]) AC_MSG_NOTICE([ polkit: no])
fi fi
diff -rupN libvirt-0.7.0/qemud/libvirtd.policy libvirt-0.7.0.new/qemud/libvirtd.policy diff --git a/qemud/Makefile.am b/qemud/Makefile.am
--- libvirt-0.7.0/qemud/libvirtd.policy 2009-07-22 09:37:32.000000000 -0400 index 959ff88..3d143da 100644
+++ libvirt-0.7.0.new/qemud/libvirtd.policy 1969-12-31 19:00:00.000000000 -0500 --- a/qemud/Makefile.am
+++ b/qemud/Makefile.am
@@ -21,7 +21,8 @@ EXTRA_DIST = \
remote_protocol.x \
libvirtd.conf \
libvirtd.init.in \
- libvirtd.policy \
+ libvirtd.policy-0 \
+ libvirtd.policy-1 \
libvirtd.sasl \
libvirtd.sysconf \
libvirtd.aug \
@@ -147,7 +148,13 @@ endif
libvirtd_LDADD += ../src/libvirt.la
if HAVE_POLKIT
+if HAVE_POLKIT0
policydir = $(datadir)/PolicyKit/policy
+policyfile = libvirtd.policy-0
+else
+policydir = $(datadir)/polkit-1/actions
+policyfile = libvirtd.policy-1
+endif
endif
if HAVE_AVAHI
@@ -197,7 +204,7 @@ endif
if HAVE_POLKIT
install-data-polkit:: install-init
mkdir -p $(DESTDIR)$(policydir)
- $(INSTALL_DATA) $(srcdir)/libvirtd.policy $(DESTDIR)$(policydir)/org.libvirt.unix.policy
+ $(INSTALL_DATA) $(srcdir)/$(policyfile) $(DESTDIR)$(policydir)/org.libvirt.unix.policy
uninstall-data-polkit:: install-init
rm -f $(DESTDIR)$(policydir)/org.libvirt.unix.policy
else
diff --git a/qemud/libvirtd.policy b/qemud/libvirtd.policy
deleted file mode 100644
index b6da946..0000000
--- a/qemud/libvirtd.policy
+++ /dev/null
@@ -1,42 +0,0 @@ @@ -1,42 +0,0 @@
-<!DOCTYPE policyconfig PUBLIC -<!DOCTYPE policyconfig PUBLIC
- "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN" - "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
@ -145,9 +206,11 @@ diff -rupN libvirt-0.7.0/qemud/libvirtd.policy libvirt-0.7.0.new/qemud/libvirtd.
- </defaults> - </defaults>
- </action> - </action>
-</policyconfig> -</policyconfig>
diff -rupN libvirt-0.7.0/qemud/libvirtd.policy-0 libvirt-0.7.0.new/qemud/libvirtd.policy-0 diff --git a/qemud/libvirtd.policy-0 b/qemud/libvirtd.policy-0
--- libvirt-0.7.0/qemud/libvirtd.policy-0 1969-12-31 19:00:00.000000000 -0500 new file mode 100644
+++ libvirt-0.7.0.new/qemud/libvirtd.policy-0 2009-08-13 08:37:22.408883879 -0400 index 0000000..b6da946
--- /dev/null
+++ b/qemud/libvirtd.policy-0
@@ -0,0 +1,42 @@ @@ -0,0 +1,42 @@
+<!DOCTYPE policyconfig PUBLIC +<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN" + "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
@ -191,9 +254,11 @@ diff -rupN libvirt-0.7.0/qemud/libvirtd.policy-0 libvirt-0.7.0.new/qemud/libvirt
+ </defaults> + </defaults>
+ </action> + </action>
+</policyconfig> +</policyconfig>
diff -rupN libvirt-0.7.0/qemud/libvirtd.policy-1 libvirt-0.7.0.new/qemud/libvirtd.policy-1 diff --git a/qemud/libvirtd.policy-1 b/qemud/libvirtd.policy-1
--- libvirt-0.7.0/qemud/libvirtd.policy-1 1969-12-31 19:00:00.000000000 -0500 new file mode 100644
+++ libvirt-0.7.0.new/qemud/libvirtd.policy-1 2009-08-13 08:37:22.412905763 -0400 index 0000000..6fa3a5e
--- /dev/null
+++ b/qemud/libvirtd.policy-1
@@ -0,0 +1,42 @@ @@ -0,0 +1,42 @@
+<!DOCTYPE policyconfig PUBLIC +<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN" + "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
@ -237,46 +302,11 @@ diff -rupN libvirt-0.7.0/qemud/libvirtd.policy-1 libvirt-0.7.0.new/qemud/libvirt
+ </defaults> + </defaults>
+ </action> + </action>
+</policyconfig> +</policyconfig>
diff -rupN libvirt-0.7.0/qemud/Makefile.am libvirt-0.7.0.new/qemud/Makefile.am diff --git a/qemud/qemud.c b/qemud/qemud.c
--- libvirt-0.7.0/qemud/Makefile.am 2009-07-22 09:37:32.000000000 -0400 index 3e551ca..50b0cdd 100644
+++ libvirt-0.7.0.new/qemud/Makefile.am 2009-08-13 08:37:22.398915449 -0400 --- a/qemud/qemud.c
@@ -21,7 +21,8 @@ EXTRA_DIST = \ +++ b/qemud/qemud.c
remote_protocol.x \ @@ -895,7 +895,7 @@ static struct qemud_server *qemudNetworkInit(struct qemud_server *server) {
libvirtd.conf \
libvirtd.init.in \
- libvirtd.policy \
+ libvirtd.policy-0 \
+ libvirtd.policy-1 \
libvirtd.sasl \
libvirtd.sysconf \
libvirtd.aug \
@@ -147,7 +148,13 @@ endif
libvirtd_LDADD += ../src/libvirt.la
if HAVE_POLKIT
+if HAVE_POLKIT0
policydir = $(datadir)/PolicyKit/policy
+policyfile = libvirtd.policy-0
+else
+policydir = $(datadir)/polkit-1/actions
+policyfile = libvirtd.policy-1
+endif
endif
if HAVE_AVAHI
@@ -197,7 +204,7 @@ endif
if HAVE_POLKIT
install-data-polkit:: install-init
mkdir -p $(DESTDIR)$(policydir)
- $(INSTALL_DATA) $(srcdir)/libvirtd.policy $(DESTDIR)$(policydir)/org.libvirt.unix.policy
+ $(INSTALL_DATA) $(srcdir)/$(policyfile) $(DESTDIR)$(policydir)/org.libvirt.unix.policy
uninstall-data-polkit:: install-init
rm -f $(DESTDIR)$(policydir)/org.libvirt.unix.policy
else
diff -rupN libvirt-0.7.0/qemud/qemud.c libvirt-0.7.0.new/qemud/qemud.c
--- libvirt-0.7.0/qemud/qemud.c 2009-07-22 09:37:32.000000000 -0400
+++ libvirt-0.7.0.new/qemud/qemud.c 2009-08-13 08:37:22.419878018 -0400
@@ -895,7 +895,7 @@ static struct qemud_server *qemudNetwork
} }
#endif #endif
@ -285,7 +315,7 @@ diff -rupN libvirt-0.7.0/qemud/qemud.c libvirt-0.7.0.new/qemud/qemud.c
if (auth_unix_rw == REMOTE_AUTH_POLKIT || if (auth_unix_rw == REMOTE_AUTH_POLKIT ||
auth_unix_ro == REMOTE_AUTH_POLKIT) { auth_unix_ro == REMOTE_AUTH_POLKIT) {
DBusError derr; DBusError derr;
@@ -982,7 +982,7 @@ static struct qemud_server *qemudNetwork @@ -982,7 +982,7 @@ static struct qemud_server *qemudNetworkInit(struct qemud_server *server) {
sock = sock->next; sock = sock->next;
} }
@ -294,9 +324,10 @@ diff -rupN libvirt-0.7.0/qemud/qemud.c libvirt-0.7.0.new/qemud/qemud.c
if (server->sysbus) if (server->sysbus)
dbus_connection_unref(server->sysbus); dbus_connection_unref(server->sysbus);
#endif #endif
diff -rupN libvirt-0.7.0/qemud/qemud.h libvirt-0.7.0.new/qemud/qemud.h diff --git a/qemud/qemud.h b/qemud/qemud.h
--- libvirt-0.7.0/qemud/qemud.h 2009-07-23 12:33:02.000000000 -0400 index 254db44..e8ce209 100644
+++ libvirt-0.7.0.new/qemud/qemud.h 2009-08-13 08:37:22.425909852 -0400 --- a/qemud/qemud.h
+++ b/qemud/qemud.h
@@ -34,7 +34,7 @@ @@ -34,7 +34,7 @@
#include <sasl/sasl.h> #include <sasl/sasl.h>
#endif #endif
@ -315,9 +346,10 @@ diff -rupN libvirt-0.7.0/qemud/qemud.h libvirt-0.7.0.new/qemud/qemud.h
DBusConnection *sysbus; DBusConnection *sysbus;
#endif #endif
}; };
diff -rupN libvirt-0.7.0/qemud/remote.c libvirt-0.7.0.new/qemud/remote.c diff --git a/qemud/remote.c b/qemud/remote.c
--- libvirt-0.7.0/qemud/remote.c 2009-07-23 12:33:02.000000000 -0400 index d32d513..490a807 100644
+++ libvirt-0.7.0.new/qemud/remote.c 2009-08-13 08:37:22.431865087 -0400 --- a/qemud/remote.c
+++ b/qemud/remote.c
@@ -43,7 +43,7 @@ @@ -43,7 +43,7 @@
#include <fnmatch.h> #include <fnmatch.h>
#include "virterror_internal.h" #include "virterror_internal.h"
@ -327,7 +359,7 @@ diff -rupN libvirt-0.7.0/qemud/remote.c libvirt-0.7.0.new/qemud/remote.c
#include <polkit/polkit.h> #include <polkit/polkit.h>
#include <polkit-dbus/polkit-dbus.h> #include <polkit-dbus/polkit-dbus.h>
#endif #endif
@@ -3106,7 +3106,80 @@ remoteDispatchAuthSaslStep (struct qemud @@ -3106,7 +3106,80 @@ remoteDispatchAuthSaslStep (struct qemud_server *server ATTRIBUTE_UNUSED,
#endif /* HAVE_SASL */ #endif /* HAVE_SASL */
@ -418,7 +450,7 @@ diff -rupN libvirt-0.7.0/qemud/remote.c libvirt-0.7.0.new/qemud/remote.c
static int static int
remoteDispatchAuthPolkit (struct qemud_server *server ATTRIBUTE_UNUSED, remoteDispatchAuthPolkit (struct qemud_server *server ATTRIBUTE_UNUSED,
@@ -3231,7 +3304,7 @@ remoteDispatchAuthPolkit (struct qemud_s @@ -3231,7 +3304,7 @@ remoteDispatchAuthPolkit (struct qemud_server *server ATTRIBUTE_UNUSED,
remoteDispatchAuthError(rerr); remoteDispatchAuthError(rerr);
return -1; return -1;
} }
@ -427,10 +459,11 @@ diff -rupN libvirt-0.7.0/qemud/remote.c libvirt-0.7.0.new/qemud/remote.c
/*************************************************************** /***************************************************************
diff -rupN libvirt-0.7.0/src/remote_internal.c libvirt-0.7.0.new/src/remote_internal.c diff --git a/src/remote_internal.c b/src/remote_internal.c
--- libvirt-0.7.0/src/remote_internal.c 2009-07-29 10:42:15.000000000 -0400 index a58b768..e98c99b 100644
+++ libvirt-0.7.0.new/src/remote_internal.c 2009-08-13 10:55:57.607899170 -0400 --- a/src/remote_internal.c
@@ -6201,6 +6201,7 @@ remoteAuthPolkit (virConnectPtr conn, st +++ b/src/remote_internal.c
@@ -6201,6 +6201,7 @@ remoteAuthPolkit (virConnectPtr conn, struct private_data *priv, int in_open,
virConnectAuthPtr auth) virConnectAuthPtr auth)
{ {
remote_auth_polkit_ret ret; remote_auth_polkit_ret ret;
@ -438,7 +471,7 @@ diff -rupN libvirt-0.7.0/src/remote_internal.c libvirt-0.7.0.new/src/remote_inte
int i, allowcb = 0; int i, allowcb = 0;
virConnectCredential cred = { virConnectCredential cred = {
VIR_CRED_EXTERNAL, VIR_CRED_EXTERNAL,
@@ -6210,8 +6211,10 @@ remoteAuthPolkit (virConnectPtr conn, st @@ -6210,8 +6211,10 @@ remoteAuthPolkit (virConnectPtr conn, struct private_data *priv, int in_open,
NULL, NULL,
0, 0,
}; };
@ -449,7 +482,7 @@ diff -rupN libvirt-0.7.0/src/remote_internal.c libvirt-0.7.0.new/src/remote_inte
if (auth && auth->cb) { if (auth && auth->cb) {
/* Check if the necessary credential type for PolicyKit is supported */ /* Check if the necessary credential type for PolicyKit is supported */
for (i = 0 ; i < auth->ncredtype ; i++) { for (i = 0 ; i < auth->ncredtype ; i++) {
@@ -6220,6 +6223,7 @@ remoteAuthPolkit (virConnectPtr conn, st @@ -6220,6 +6223,7 @@ remoteAuthPolkit (virConnectPtr conn, struct private_data *priv, int in_open,
} }
if (allowcb) { if (allowcb) {
@ -457,7 +490,7 @@ diff -rupN libvirt-0.7.0/src/remote_internal.c libvirt-0.7.0.new/src/remote_inte
/* Run the authentication callback */ /* Run the authentication callback */
if ((*(auth->cb))(&cred, 1, auth->cbdata) < 0) { if ((*(auth->cb))(&cred, 1, auth->cbdata) < 0) {
virRaiseError (in_open ? NULL : conn, NULL, NULL, VIR_FROM_REMOTE, virRaiseError (in_open ? NULL : conn, NULL, NULL, VIR_FROM_REMOTE,
@@ -6233,6 +6237,9 @@ remoteAuthPolkit (virConnectPtr conn, st @@ -6233,6 +6237,9 @@ remoteAuthPolkit (virConnectPtr conn, struct private_data *priv, int in_open,
} else { } else {
DEBUG0("No auth callback provided"); DEBUG0("No auth callback provided");
} }
@ -467,3 +500,6 @@ diff -rupN libvirt-0.7.0/src/remote_internal.c libvirt-0.7.0.new/src/remote_inte
memset (&ret, 0, sizeof ret); memset (&ret, 0, sizeof ret);
if (call (conn, priv, in_open, REMOTE_PROC_AUTH_POLKIT, if (call (conn, priv, in_open, REMOTE_PROC_AUTH_POLKIT,
--
1.6.2.5

View File

@ -78,7 +78,7 @@
Summary: Library providing a simple API virtualization Summary: Library providing a simple API virtualization
Name: libvirt Name: libvirt
Version: 0.7.0 Version: 0.7.0
Release: 4%{?dist}%{?extra_release} Release: 5%{?dist}%{?extra_release}
License: LGPLv2+ License: LGPLv2+
Group: Development/Libraries Group: Development/Libraries
Source: libvirt-%{version}.tar.gz Source: libvirt-%{version}.tar.gz
@ -282,7 +282,7 @@ of recent versions of Linux (and other OSes).
%patch03 -p1 %patch03 -p1
%patch04 -p1 %patch04 -p1
%patch200 -p0 %patch200 -p1
%build %build
%if ! %{with_xen} %if ! %{with_xen}