Avoid a segfault if missing an emulator, Daniel
This commit is contained in:
parent
1b864048bd
commit
c0c1a7bb79
13
libvirt-0.4.5-no-emulator-segfault.patch
Normal file
13
libvirt-0.4.5-no-emulator-segfault.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
|
||||||
|
index d742c32..23ef050 100644
|
||||||
|
--- a/src/qemu_conf.c
|
||||||
|
+++ b/src/qemu_conf.c
|
||||||
|
@@ -790,7 +790,7 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
||||||
|
if (!emulator)
|
||||||
|
return -1;
|
||||||
|
|
||||||
|
- ADD_ARG_LIT(vm->def->emulator);
|
||||||
|
+ ADD_ARG_LIT(emulator);
|
||||||
|
ADD_ARG_LIT("-S");
|
||||||
|
ADD_ARG_LIT("-M");
|
||||||
|
ADD_ARG_LIT(vm->def->os.machine);
|
12
libvirt.spec
12
libvirt.spec
@ -30,10 +30,11 @@
|
|||||||
Summary: Library providing a simple API virtualization
|
Summary: Library providing a simple API virtualization
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.4.5
|
Version: 0.4.5
|
||||||
Release: 1%{?dist}%{?extra_release}
|
Release: 2%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: libvirt-%{version}.tar.gz
|
Source: libvirt-%{version}.tar.gz
|
||||||
|
Patch0: libvirt-0.4.5-no-emulator-segfault.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://libvirt.org/
|
URL: http://libvirt.org/
|
||||||
BuildRequires: python python-devel
|
BuildRequires: python python-devel
|
||||||
@ -147,6 +148,7 @@ of recent versions of Linux (and other OSes).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -302,9 +304,15 @@ fi
|
|||||||
%doc docs/examples/python
|
%doc docs/examples/python
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 9 2008 Daniel Veillard <veillard@redhat.com> - 0.4.5-2.fc10
|
||||||
|
- fix a crash if a QEmu/KVM domain is defined without an emulator path
|
||||||
|
|
||||||
* Mon Sep 8 2008 Daniel Veillard <veillard@redhat.com> - 0.4.5-1.fc10
|
* Mon Sep 8 2008 Daniel Veillard <veillard@redhat.com> - 0.4.5-1.fc10
|
||||||
- upstream release 0.4.5
|
- upstream release 0.4.5
|
||||||
- update
|
- a lot of bug fixes
|
||||||
|
- major updates to QEmu/KVM and Linux containers drivers
|
||||||
|
- support for OpenVZ if installed
|
||||||
|
|
||||||
* Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-3.fc10
|
* Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-3.fc10
|
||||||
- fix license tag
|
- fix license tag
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user