Update to 7.6.0 release
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
This commit is contained in:
parent
7744acbb6b
commit
ac122f4525
@ -1,39 +0,0 @@
|
||||
From 9cccc94408d59ddd8f3b999bb62e133d443987f5 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Krempa <pkrempa@redhat.com>
|
||||
Date: Tue, 27 Jul 2021 19:12:09 +0200
|
||||
Subject: [PATCH] qemu: block: Use 'discard': 'unmap' for the copy-on-read
|
||||
block filter
|
||||
|
||||
---
|
||||
src/qemu/qemu_block.c | 1 +
|
||||
tests/qemuxml2argvdata/disk-copy_on_read.x86_64-latest.args | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/qemu/qemu_block.c b/src/qemu/qemu_block.c
|
||||
index 1610f72d07..4691dff4f7 100644
|
||||
--- a/src/qemu/qemu_block.c
|
||||
+++ b/src/qemu/qemu_block.c
|
||||
@@ -2157,6 +2157,7 @@ qemuBlockStorageGetCopyOnReadProps(virDomainDiskDef *disk)
|
||||
"s:driver", "copy-on-read",
|
||||
"s:node-name", priv->nodeCopyOnRead,
|
||||
"s:file", disk->src->nodeformat,
|
||||
+ "s:discard", "unmap",
|
||||
NULL));
|
||||
|
||||
return ret;
|
||||
diff --git a/tests/qemuxml2argvdata/disk-copy_on_read.x86_64-latest.args b/tests/qemuxml2argvdata/disk-copy_on_read.x86_64-latest.args
|
||||
index 93d3a06c88..690d4f3ea1 100644
|
||||
--- a/tests/qemuxml2argvdata/disk-copy_on_read.x86_64-latest.args
|
||||
+++ b/tests/qemuxml2argvdata/disk-copy_on_read.x86_64-latest.args
|
||||
@@ -30,7 +30,7 @@ XDG_CONFIG_HOME=/tmp/lib/domain--1-test/.config \
|
||||
-device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 \
|
||||
-blockdev '{"driver":"file","filename":"/var/lib/libvirt/images/f14.img","node-name":"libvirt-2-storage","auto-read-only":true,"discard":"unmap"}' \
|
||||
-blockdev '{"node-name":"libvirt-2-format","read-only":false,"driver":"qcow2","file":"libvirt-2-storage"}' \
|
||||
--blockdev '{"driver":"copy-on-read","node-name":"libvirt-CoR-vda","file":"libvirt-2-format"}' \
|
||||
+-blockdev '{"driver":"copy-on-read","node-name":"libvirt-CoR-vda","file":"libvirt-2-format","discard":"unmap"}' \
|
||||
-device virtio-blk-pci,bus=pci.0,addr=0x4,drive=libvirt-CoR-vda,id=virtio-disk0,bootindex=2 \
|
||||
-blockdev '{"driver":"file","filename":"/var/lib/libvirt/Fedora-14-x86_64-Live-KDE.iso","node-name":"libvirt-1-storage","auto-read-only":true,"discard":"unmap"}' \
|
||||
-blockdev '{"node-name":"libvirt-1-format","read-only":true,"driver":"raw","file":"libvirt-1-storage"}' \
|
||||
--
|
||||
2.32.0
|
||||
|
11
libvirt.spec
11
libvirt.spec
@ -200,8 +200,8 @@
|
||||
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 7.5.0
|
||||
Release: 3%{?dist}
|
||||
Version: 7.6.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://libvirt.org/
|
||||
|
||||
@ -210,10 +210,6 @@ URL: https://libvirt.org/
|
||||
%endif
|
||||
Source: https://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||
|
||||
# Not upstream, but already reviewed and acked for 7.6
|
||||
# https://listman.redhat.com/archives/libvir-list/2021-July/msg00823.html
|
||||
Patch1: 0001-qemu-block-Use-discard-unmap-for-the-copy-on-read-bl.patch
|
||||
|
||||
Requires: libvirt-daemon = %{version}-%{release}
|
||||
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
||||
Requires: libvirt-daemon-config-nwfilter = %{version}-%{release}
|
||||
@ -1906,6 +1902,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 2 2021 Daniel P. Berrangé <berrange@redhat.com> - 7.6.0-1
|
||||
- Update to 7.6.0 release
|
||||
|
||||
* Wed Jul 28 2021 Richard W.M. Jones <rjones@redhat.com> - 7.5.0-3
|
||||
- Add fix for discard + copy-on-read affecting virt-v2v (RHBZ#1986509)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-7.5.0.tar.xz) = cf89800c8970b8b1373ee32cc49ea88b87e76b50fd134df5da354be83e0ef490e514f16425c1c16eb3989fbadd3ba7d9976972fbbae6cb40db3d2ae94863219d
|
||||
SHA512 (libvirt-7.6.0.tar.xz) = bad6cc02af071ca909bbbe3c07165e91cad863c9a759b26d9cff6aed6ea5643bc723d2f3c61ad41436dffd4fd50389333d74b131e37eaa54a5071a3ae26df627
|
||||
|
Loading…
Reference in New Issue
Block a user