libvirt-7.1.0-1
Update to version 7.1.0
This commit is contained in:
parent
bbfa59c8da
commit
a11202d9e2
@ -1,60 +0,0 @@
|
|||||||
From b776d049b8c89b033004ad9502270d4b255a1958 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Laine Stump <laine@redhat.com>
|
|
||||||
Date: Thu, 21 Jan 2021 16:01:06 -0500
|
|
||||||
Subject: [PATCH 1/2] build: support explicitly disabling netcf
|
|
||||||
|
|
||||||
placing "-Dnetcf=disabled" on the meson commandline was ignored,
|
|
||||||
meaning that even with that option the build would get WITH_NETCF if
|
|
||||||
the netcf-devel package was found - the only way to disable it was to
|
|
||||||
uninstall netcf-devel.
|
|
||||||
|
|
||||||
This patch adds the small bit of logic to check the netcf meson
|
|
||||||
commandline option (in addition to whether netcf-devel is installed)
|
|
||||||
before defining WITH_NETCF.
|
|
||||||
|
|
||||||
Signed-off-by: Laine Stump <laine@redhat.com>
|
|
||||||
Reviewed-by: Neal Gompa <ngompa13@gmail.com>
|
|
||||||
Reviewed-by: Michal Privoznik <mprivozn@redhat.com>
|
|
||||||
(cherry picked from commit 06169a115d46d8870a96d293c2faf6ea87e71020)
|
|
||||||
---
|
|
||||||
meson.build | 10 ++++++----
|
|
||||||
1 file changed, 6 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index b5164f68ed..e9d6d9f82e 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -1155,8 +1155,10 @@ libm_dep = cc.find_library('m', required : false)
|
|
||||||
|
|
||||||
netcf_version = '0.1.8'
|
|
||||||
netcf_dep = dependency('netcf', version: '>=' + netcf_version, required: get_option('netcf'))
|
|
||||||
-if netcf_dep.found()
|
|
||||||
- conf.set('WITH_NETCF', 1)
|
|
||||||
+if not get_option('netcf').disabled()
|
|
||||||
+ if netcf_dep.found()
|
|
||||||
+ conf.set('WITH_NETCF', 1)
|
|
||||||
+ endif
|
|
||||||
endif
|
|
||||||
|
|
||||||
have_gnu_gettext_tools = false
|
|
||||||
@@ -1550,7 +1552,7 @@ elif get_option('driver_hyperv').enabled()
|
|
||||||
error('openwsman is required for the Hyper-V driver')
|
|
||||||
endif
|
|
||||||
|
|
||||||
-if not get_option('driver_interface').disabled() and conf.has('WITH_LIBVIRTD') and (udev_dep.found() or netcf_dep.found())
|
|
||||||
+if not get_option('driver_interface').disabled() and conf.has('WITH_LIBVIRTD') and (udev_dep.found() or conf.has('WITH_NETCF'))
|
|
||||||
conf.set('WITH_INTERFACE', 1)
|
|
||||||
elif get_option('driver_interface').enabled()
|
|
||||||
error('Requested the Interface driver without netcf or udev and libvirtd support')
|
|
||||||
@@ -2362,7 +2364,7 @@ libs_summary = {
|
|
||||||
'libssh': libssh_dep.found(),
|
|
||||||
'libssh2': libssh2_dep.found(),
|
|
||||||
'libutil': libutil_dep.found(),
|
|
||||||
- 'netcf': netcf_dep.found(),
|
|
||||||
+ 'netcf': conf.has('WITH_NETCF'),
|
|
||||||
'NLS': have_gnu_gettext_tools,
|
|
||||||
'numactl': numactl_dep.found(),
|
|
||||||
'openwsman': openwsman_dep.found(),
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
23
libvirt.spec
23
libvirt.spec
@ -17,7 +17,7 @@
|
|||||||
%define _vpath_builddir %{_target_platform}
|
%define _vpath_builddir %{_target_platform}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define arches_qemu_kvm %{ix86} x86_64 %{power64} %{arm} aarch64 s390x riscv64
|
%define arches_qemu_kvm %{ix86} x86_64 %{power64} %{arm} aarch64 s390x
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
%define arches_qemu_kvm x86_64 %{power64} aarch64 s390x
|
%define arches_qemu_kvm x86_64 %{power64} aarch64 s390x
|
||||||
%endif
|
%endif
|
||||||
@ -218,8 +218,8 @@
|
|||||||
|
|
||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 7.0.0
|
Version: 7.1.0
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://libvirt.org/
|
URL: https://libvirt.org/
|
||||||
|
|
||||||
@ -228,8 +228,6 @@ URL: https://libvirt.org/
|
|||||||
%endif
|
%endif
|
||||||
Source: https://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
Source: https://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0001: 0001-build-support-explicitly-disabling-netcf.patch
|
|
||||||
|
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
||||||
Requires: libvirt-daemon-config-nwfilter = %{version}-%{release}
|
Requires: libvirt-daemon-config-nwfilter = %{version}-%{release}
|
||||||
@ -260,7 +258,6 @@ Requires: libvirt-libs = %{version}-%{release}
|
|||||||
|
|
||||||
# All build-time requirements. Run-time requirements are
|
# All build-time requirements. Run-time requirements are
|
||||||
# listed against each sub-RPM
|
# listed against each sub-RPM
|
||||||
BuildRequires: gettext-devel
|
|
||||||
%if 0%{?rhel} == 7
|
%if 0%{?rhel} == 7
|
||||||
BuildRequires: python36-docutils
|
BuildRequires: python36-docutils
|
||||||
%else
|
%else
|
||||||
@ -1596,6 +1593,7 @@ exit 0
|
|||||||
%{_mandir}/man8/libvirtd.8*
|
%{_mandir}/man8/libvirtd.8*
|
||||||
%{_mandir}/man8/virtlogd.8*
|
%{_mandir}/man8/virtlogd.8*
|
||||||
%{_mandir}/man8/virtlockd.8*
|
%{_mandir}/man8/virtlockd.8*
|
||||||
|
%{_mandir}/man8/virtproxyd.8*
|
||||||
%{_mandir}/man7/virkey*.7*
|
%{_mandir}/man7/virkey*.7*
|
||||||
|
|
||||||
%files daemon-config-network
|
%files daemon-config-network
|
||||||
@ -1620,6 +1618,7 @@ exit 0
|
|||||||
%{_unitdir}/virtinterfaced-admin.socket
|
%{_unitdir}/virtinterfaced-admin.socket
|
||||||
%attr(0755, root, root) %{_sbindir}/virtinterfaced
|
%attr(0755, root, root) %{_sbindir}/virtinterfaced
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_interface.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_interface.so
|
||||||
|
%{_mandir}/man8/virtinterfaced.8*
|
||||||
|
|
||||||
%files daemon-driver-network
|
%files daemon-driver-network
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/virtnetworkd
|
%config(noreplace) %{_sysconfdir}/sysconfig/virtnetworkd
|
||||||
@ -1639,6 +1638,7 @@ exit 0
|
|||||||
%dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/dnsmasq/
|
%dir %attr(0755, root, root) %{_localstatedir}/lib/libvirt/dnsmasq/
|
||||||
%attr(0755, root, root) %{_libexecdir}/libvirt_leaseshelper
|
%attr(0755, root, root) %{_libexecdir}/libvirt_leaseshelper
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_network.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_network.so
|
||||||
|
%{_mandir}/man8/virtnetworkd.8*
|
||||||
|
|
||||||
%if %{with_firewalld_zone}
|
%if %{with_firewalld_zone}
|
||||||
%{_prefix}/lib/firewalld/zones/libvirt.xml
|
%{_prefix}/lib/firewalld/zones/libvirt.xml
|
||||||
@ -1655,6 +1655,7 @@ exit 0
|
|||||||
%{_unitdir}/virtnodedevd-admin.socket
|
%{_unitdir}/virtnodedevd-admin.socket
|
||||||
%attr(0755, root, root) %{_sbindir}/virtnodedevd
|
%attr(0755, root, root) %{_sbindir}/virtnodedevd
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_nodedev.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_nodedev.so
|
||||||
|
%{_mandir}/man8/virtnodedevd.8*
|
||||||
|
|
||||||
%files daemon-driver-nwfilter
|
%files daemon-driver-nwfilter
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/virtnwfilterd
|
%config(noreplace) %{_sysconfdir}/sysconfig/virtnwfilterd
|
||||||
@ -1669,6 +1670,7 @@ exit 0
|
|||||||
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/nwfilter/
|
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/nwfilter/
|
||||||
%ghost %dir %{_rundir}/libvirt/network/
|
%ghost %dir %{_rundir}/libvirt/network/
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_nwfilter.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_nwfilter.so
|
||||||
|
%{_mandir}/man8/virtnwfilterd.8*
|
||||||
|
|
||||||
%files daemon-driver-secret
|
%files daemon-driver-secret
|
||||||
%config(noreplace) %{_sysconfdir}/sysconfig/virtsecretd
|
%config(noreplace) %{_sysconfdir}/sysconfig/virtsecretd
|
||||||
@ -1681,6 +1683,7 @@ exit 0
|
|||||||
%{_unitdir}/virtsecretd-admin.socket
|
%{_unitdir}/virtsecretd-admin.socket
|
||||||
%attr(0755, root, root) %{_sbindir}/virtsecretd
|
%attr(0755, root, root) %{_sbindir}/virtsecretd
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_secret.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_secret.so
|
||||||
|
%{_mandir}/man8/virtsecretd.8*
|
||||||
|
|
||||||
%files daemon-driver-storage
|
%files daemon-driver-storage
|
||||||
|
|
||||||
@ -1698,6 +1701,7 @@ exit 0
|
|||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_storage.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_storage.so
|
||||||
%{_libdir}/%{name}/storage-backend/libvirt_storage_backend_fs.so
|
%{_libdir}/%{name}/storage-backend/libvirt_storage_backend_fs.so
|
||||||
%{_libdir}/%{name}/storage-file/libvirt_storage_file_fs.so
|
%{_libdir}/%{name}/storage-file/libvirt_storage_file_fs.so
|
||||||
|
%{_mandir}/man8/virtstoraged.8*
|
||||||
|
|
||||||
%files daemon-driver-storage-disk
|
%files daemon-driver-storage-disk
|
||||||
%{_libdir}/%{name}/storage-backend/libvirt_storage_backend_disk.so
|
%{_libdir}/%{name}/storage-backend/libvirt_storage_backend_disk.so
|
||||||
@ -1766,6 +1770,7 @@ exit 0
|
|||||||
%dir %attr(0730, tss, tss) %{_localstatedir}/log/swtpm/libvirt/qemu/
|
%dir %attr(0730, tss, tss) %{_localstatedir}/log/swtpm/libvirt/qemu/
|
||||||
%{_bindir}/virt-qemu-run
|
%{_bindir}/virt-qemu-run
|
||||||
%{_mandir}/man1/virt-qemu-run.1*
|
%{_mandir}/man1/virt-qemu-run.1*
|
||||||
|
%{_mandir}/man8/virtqemud.8*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_lxc}
|
%if %{with_lxc}
|
||||||
@ -1788,6 +1793,7 @@ exit 0
|
|||||||
%{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
|
%{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
|
||||||
%attr(0755, root, root) %{_libexecdir}/libvirt_lxc
|
%attr(0755, root, root) %{_libexecdir}/libvirt_lxc
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_lxc.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_lxc.so
|
||||||
|
%{_mandir}/man8/virtlxcd.8*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_libxl}
|
%if %{with_libxl}
|
||||||
@ -1810,6 +1816,7 @@ exit 0
|
|||||||
%ghost %dir %{_rundir}/libvirt/libxl/
|
%ghost %dir %{_rundir}/libvirt/libxl/
|
||||||
%dir %attr(0700, root, root) %{_localstatedir}/lib/libvirt/libxl/
|
%dir %attr(0700, root, root) %{_localstatedir}/lib/libvirt/libxl/
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_libxl.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_libxl.so
|
||||||
|
%{_mandir}/man8/virtxend.8*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_vbox}
|
%if %{with_vbox}
|
||||||
@ -1824,6 +1831,7 @@ exit 0
|
|||||||
%{_unitdir}/virtvboxd-admin.socket
|
%{_unitdir}/virtvboxd-admin.socket
|
||||||
%attr(0755, root, root) %{_sbindir}/virtvboxd
|
%attr(0755, root, root) %{_sbindir}/virtvboxd
|
||||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_vbox.so
|
%{_libdir}/%{name}/connection-driver/libvirt_driver_vbox.so
|
||||||
|
%{_mandir}/man8/virtvboxd.8*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_qemu_tcg}
|
%if %{with_qemu_tcg}
|
||||||
@ -1966,6 +1974,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 01 2021 Cole Robinson <crobinso@redhat.com> - 7.1.0-1
|
||||||
|
- Update to version 7.1.0
|
||||||
|
|
||||||
* Wed Feb 03 2021 Cole Robinson <aintdiscole@gmail.com> - 7.0.0-4
|
* Wed Feb 03 2021 Cole Robinson <aintdiscole@gmail.com> - 7.0.0-4
|
||||||
- Increase meson test timeout to fix builds on s390x copr
|
- Increase meson test timeout to fix builds on s390x copr
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libvirt-7.0.0.tar.xz) = dd6db5ec4971cf4c6059795fd81d5a3a889b10740e34c3c92271eda1c683c99df2c8f923398065d8a7c4f987a20eb1da617d5297ba8ea5a31f154412af50c343
|
SHA512 (libvirt-7.1.0.tar.xz) = 475b212e920bf8587db4a551126d9eb417d4e18a72550f94feb1aec94821fbac8c84d67ffd59cfe4f8289b6b10ae5f6b579ee170c0d72cb0493ec7ec52183cd6
|
||||||
|
Loading…
Reference in New Issue
Block a user