Disable virnettlscontexttest which apparently fails because of a broken gnutls3.
Note since this patch touches Makefile.am, I have enabled autoreconf (enable_autotools).
This commit is contained in:
parent
b856ae03bf
commit
97d7c80e2e
25
0001-Disable-virnettlscontexttest.patch
Normal file
25
0001-Disable-virnettlscontexttest.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 1047121c46e34749a92bf7e7f5193d4fcbe65e52 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||||
|
Date: Thu, 28 Feb 2013 12:52:12 +0000
|
||||||
|
Subject: [PATCH] Disable virnettlscontexttest.
|
||||||
|
|
||||||
|
---
|
||||||
|
tests/Makefile.am | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||||
|
index d3a7868..1226a41 100644
|
||||||
|
--- a/tests/Makefile.am
|
||||||
|
+++ b/tests/Makefile.am
|
||||||
|
@@ -106,7 +106,7 @@ test_programs = virshtest sockettest \
|
||||||
|
$(NULL)
|
||||||
|
|
||||||
|
if WITH_GNUTLS
|
||||||
|
-test_programs += virnettlscontexttest
|
||||||
|
+#test_programs += virnettlscontexttest
|
||||||
|
endif
|
||||||
|
|
||||||
|
if WITH_SECDRIVER_SELINUX
|
||||||
|
--
|
||||||
|
1.8.1.2
|
||||||
|
|
12
libvirt.spec
12
libvirt.spec
@ -11,7 +11,7 @@
|
|||||||
# Default to skipping autoreconf. Distros can change just this one line
|
# Default to skipping autoreconf. Distros can change just this one line
|
||||||
# (or provide a command-line override) if they backport any patches that
|
# (or provide a command-line override) if they backport any patches that
|
||||||
# touch configure.ac or Makefile.am.
|
# touch configure.ac or Makefile.am.
|
||||||
%{!?enable_autotools:%define enable_autotools 0}
|
%{!?enable_autotools:%define enable_autotools 1}
|
||||||
|
|
||||||
# A client only build will create a libvirt.so only containing
|
# A client only build will create a libvirt.so only containing
|
||||||
# the generic RPC driver, and test driver and no libvirtd
|
# the generic RPC driver, and test driver and no libvirtd
|
||||||
@ -341,7 +341,7 @@
|
|||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 1.0.2
|
Version: 1.0.2
|
||||||
Release: 3%{?dist}%{?extra_release}
|
Release: 4%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -354,6 +354,8 @@ Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
|||||||
Patch1: 0001-complete-virterror-virerror-name-change.patch
|
Patch1: 0001-complete-virterror-virerror-name-change.patch
|
||||||
Patch2: 0001-Fix-missing-error-constants-in-libvirt-python-module.patch
|
Patch2: 0001-Fix-missing-error-constants-in-libvirt-python-module.patch
|
||||||
Patch3: 0001-qemu-check-backing-chains-even-when-cgroup-is-omitte.patch
|
Patch3: 0001-qemu-check-backing-chains-even-when-cgroup-is-omitte.patch
|
||||||
|
# See https://www.redhat.com/archives/libvir-list/2013-February/thread.html#01673
|
||||||
|
Patch4: 0001-Disable-virnettlscontexttest.patch
|
||||||
|
|
||||||
%if %{with_libvirtd}
|
%if %{with_libvirtd}
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
@ -1084,6 +1086,7 @@ of recent versions of Linux (and other OSes).
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -2000,9 +2003,12 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Feb 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-3
|
* Thu Feb 28 2013 Richard W.M. Jones <rjones@redhat.com> - 1.0.2-4
|
||||||
- Backport "qemu: check backing chains even when cgroup is omitted"
|
- Backport "qemu: check backing chains even when cgroup is omitted"
|
||||||
(RHBZ#896685).
|
(RHBZ#896685).
|
||||||
|
- Disable virnettlscontexttest which apparently fails because of
|
||||||
|
a broken gnutls3. Note since this patch touches Makefile.am, I
|
||||||
|
have enabled autoreconf (enable_autotools).
|
||||||
|
|
||||||
* Tue Feb 5 2013 Daniel P. Berrange <berrange@redhat.com> - 1.0.2-2
|
* Tue Feb 5 2013 Daniel P. Berrange <berrange@redhat.com> - 1.0.2-2
|
||||||
- Fix missing python binding constants
|
- Fix missing python binding constants
|
||||||
|
Loading…
Reference in New Issue
Block a user