import libvirt-8.5.0-7.4.el9_1

This commit is contained in:
CentOS Sources 2023-02-28 09:49:42 +00:00 committed by Stepan Oksanichenko
parent 445a9cd1f1
commit 96c82c5239
2 changed files with 70 additions and 1 deletions

View File

@ -0,0 +1,65 @@
From d9b1f47fc3139bccd08838064f4b233b7cff5f29 Mon Sep 17 00:00:00 2001
Message-Id: <d9b1f47fc3139bccd08838064f4b233b7cff5f29@dist-git>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Thu, 8 Dec 2022 08:39:24 +0100
Subject: [PATCH] tools: Fix install_mode for some scripts
Scripts from the following list were installed with group write
bit set: virt-xml-validate, virt-pki-validate,
virt-sanlock-cleanup, libvirt-guests.sh. This is very unusual and
in contrast with the way other scripts/binaries are installed.
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=2151202
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Reviewed-by: Peter Krempa <pkrempa@redhat.com>
Reviewed-by: Jiri Denemark <jdenemar@redhat.com>
(cherry picked from commit e771e32f15ff2b263ca70306d93080541a96792b)
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=2158208
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
---
tools/meson.build | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/tools/meson.build b/tools/meson.build
index bb28a904dc..8a3dd63271 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -249,7 +249,7 @@ configure_file(
configuration: tools_conf,
install: true,
install_dir: bindir,
- install_mode: 'rwxrwxr-x',
+ install_mode: 'rwxr-xr-x',
)
configure_file(
@@ -258,7 +258,7 @@ configure_file(
configuration: tools_conf,
install: true,
install_dir: bindir,
- install_mode: 'rwxrwxr-x',
+ install_mode: 'rwxr-xr-x',
)
executable(
@@ -295,7 +295,7 @@ if conf.has('WITH_SANLOCK')
configuration: tools_conf,
install: true,
install_dir: sbindir,
- install_mode: 'rwxrwxr-x',
+ install_mode: 'rwxr-xr-x',
)
endif
@@ -306,7 +306,7 @@ if conf.has('WITH_LIBVIRTD')
configuration: tools_conf,
install: true,
install_dir: libexecdir,
- install_mode: 'rwxrwxr-x',
+ install_mode: 'rwxr-xr-x',
)
if init_script == 'systemd'
--
2.39.1

View File

@ -231,7 +231,7 @@
Summary: Library providing a simple virtualization API
Name: libvirt
Version: 8.5.0
Release: 7.3%{?dist}%{?extra_release}
Release: 7.4%{?dist}%{?extra_release}
License: LGPLv2+
URL: https://libvirt.org/
@ -285,6 +285,7 @@ Patch42: libvirt-util-json-Split-out-array-strinlist-conversion-from-virJSONValu
Patch43: libvirt-qemuAgentGetDisks-Don-t-use-virJSONValueObjectGetStringArray-for-optional-data.patch
Patch44: libvirt-util-Extend-virProcessGetStatInfo-for-sysTime-and-userTime.patch
Patch45: libvirt-qemu-Implement-qemuDomainGetStatsCpu-fallback-for-qemu-session.patch
Patch46: libvirt-tools-Fix-install_mode-for-some-scripts.patch
Requires: libvirt-daemon = %{version}-%{release}
@ -2191,6 +2192,9 @@ exit 0
%changelog
* Tue Jan 31 2023 Jiri Denemark <jdenemar@redhat.com> - 8.5.0-7.4.el9_1
- tools: Fix install_mode for some scripts (rhbz#2158208)
* Thu Jan 5 2023 Jiri Denemark <jdenemar@redhat.com> - 8.5.0-7.3.el9_1
- util: json: Split out array->strinlist conversion from virJSONValueObjectGetStringArray (rhbz#2154410)
- qemuAgentGetDisks: Don't use virJSONValueObjectGetStringArray for optional data (rhbz#2154410)