libvirt assigns same address to two PCI devices (bz #1325085)
Fix build with -Werror
This commit is contained in:
parent
0debbff964
commit
8fa41135ca
165
0001-qemu-support-virt-2.6-machine-type-on-arm.patch
Normal file
165
0001-qemu-support-virt-2.6-machine-type-on-arm.patch
Normal file
@ -0,0 +1,165 @@
|
|||||||
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
||||||
|
Date: Fri, 8 Apr 2016 10:46:41 +0200
|
||||||
|
Subject: [PATCH] qemu: support virt-2.6 machine type on arm
|
||||||
|
|
||||||
|
Some places already check for "virt-" prefix as well as plain "virt".
|
||||||
|
virQEMUCapsHasPCIMultiBus did not, resulting in multiple PCI devices
|
||||||
|
having assigned the same unnumbered "pci" alias.
|
||||||
|
|
||||||
|
Add a test for the "virt-2.6" machine type which also omits the
|
||||||
|
<model type='virtio'/> in <interface>, to check if
|
||||||
|
qemuDomainDefaultNetModel works too.
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1325085
|
||||||
|
(cherry picked from commit f06ca25d235433f9139cbfb3d5d9eae7409156b9)
|
||||||
|
---
|
||||||
|
src/qemu/qemu_capabilities.c | 3 +-
|
||||||
|
src/qemu/qemu_domain.c | 3 +-
|
||||||
|
...l2argv-aarch64-virt-2.6-virtio-pci-default.args | 37 +++++++++++++++++
|
||||||
|
...ml2argv-aarch64-virt-2.6-virtio-pci-default.xml | 47 ++++++++++++++++++++++
|
||||||
|
tests/qemuxml2argvtest.c | 6 +++
|
||||||
|
5 files changed, 94 insertions(+), 2 deletions(-)
|
||||||
|
create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.args
|
||||||
|
create mode 100644 tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.xml
|
||||||
|
|
||||||
|
diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
|
||||||
|
index 2823843..57e2056 100644
|
||||||
|
--- a/src/qemu/qemu_capabilities.c
|
||||||
|
+++ b/src/qemu/qemu_capabilities.c
|
||||||
|
@@ -2172,7 +2172,8 @@ bool virQEMUCapsHasPCIMultiBus(virQEMUCapsPtr qemuCaps,
|
||||||
|
/* If 'virt' supports PCI, it supports multibus.
|
||||||
|
* No extra conditions here for simplicity.
|
||||||
|
*/
|
||||||
|
- if (STREQ(def->os.machine, "virt"))
|
||||||
|
+ if (STREQ(def->os.machine, "virt") ||
|
||||||
|
+ STRPREFIX(def->os.machine, "virt-"))
|
||||||
|
return true;
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/src/qemu/qemu_domain.c b/src/qemu/qemu_domain.c
|
||||||
|
index f38b0f3..d9d5041 100644
|
||||||
|
--- a/src/qemu/qemu_domain.c
|
||||||
|
+++ b/src/qemu/qemu_domain.c
|
||||||
|
@@ -1479,7 +1479,8 @@ qemuDomainDefaultNetModel(const virDomainDef *def,
|
||||||
|
if (STREQ(def->os.machine, "versatilepb"))
|
||||||
|
return "smc91c111";
|
||||||
|
|
||||||
|
- if (STREQ(def->os.machine, "virt"))
|
||||||
|
+ if (STREQ(def->os.machine, "virt") ||
|
||||||
|
+ STRPREFIX(def->os.machine, "virt-"))
|
||||||
|
return "virtio";
|
||||||
|
|
||||||
|
/* Incomplete. vexpress (and a few others) use this, but not all
|
||||||
|
diff --git a/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.args b/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.args
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..93c181d
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.args
|
||||||
|
@@ -0,0 +1,37 @@
|
||||||
|
+LC_ALL=C \
|
||||||
|
+PATH=/bin \
|
||||||
|
+HOME=/home/test \
|
||||||
|
+USER=test \
|
||||||
|
+LOGNAME=test \
|
||||||
|
+QEMU_AUDIO_DRV=none \
|
||||||
|
+/usr/bin/qemu-system-aarch64 \
|
||||||
|
+-name aarch64test \
|
||||||
|
+-S \
|
||||||
|
+-M virt-2.6 \
|
||||||
|
+-cpu cortex-a53 \
|
||||||
|
+-m 1024 \
|
||||||
|
+-smp 1 \
|
||||||
|
+-uuid 496d7ea8-9739-544b-4ebd-ef08be936e8b \
|
||||||
|
+-nographic \
|
||||||
|
+-nodefconfig \
|
||||||
|
+-nodefaults \
|
||||||
|
+-monitor unix:/tmp/lib/domain--1-aarch64test/monitor.sock,server,nowait \
|
||||||
|
+-boot c \
|
||||||
|
+-kernel /aarch64.kernel \
|
||||||
|
+-initrd /aarch64.initrd \
|
||||||
|
+-append 'earlyprintk console=ttyAMA0,115200n8 rw root=/dev/vda rootwait' \
|
||||||
|
+-dtb /aarch64.dtb \
|
||||||
|
+-device i82801b11-bridge,id=pci.1,bus=pcie.0,addr=0x1 \
|
||||||
|
+-device pci-bridge,chassis_nr=2,id=pci.2,bus=pci.1,addr=0x1 \
|
||||||
|
+-device virtio-serial-device,id=virtio-serial0 \
|
||||||
|
+-usb \
|
||||||
|
+-drive file=/aarch64.raw,format=raw,if=none,id=drive-virtio-disk0 \
|
||||||
|
+-device virtio-blk-device,drive=drive-virtio-disk0,id=virtio-disk0 \
|
||||||
|
+-device virtio-net-device,vlan=0,id=net0,mac=52:54:00:09:a4:37 \
|
||||||
|
+-net user,vlan=0,name=hostnet0 \
|
||||||
|
+-serial pty \
|
||||||
|
+-chardev pty,id=charconsole1 \
|
||||||
|
+-device virtconsole,chardev=charconsole1,id=console1 \
|
||||||
|
+-device virtio-balloon-device,id=balloon0 \
|
||||||
|
+-object rng-random,id=objrng0,filename=/dev/random \
|
||||||
|
+-device virtio-rng-device,rng=objrng0,id=rng0
|
||||||
|
diff --git a/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.xml b/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.xml
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..e745101
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/tests/qemuxml2argvdata/qemuxml2argv-aarch64-virt-2.6-virtio-pci-default.xml
|
||||||
|
@@ -0,0 +1,47 @@
|
||||||
|
+<domain type="qemu">
|
||||||
|
+ <name>aarch64test</name>
|
||||||
|
+ <uuid>496d7ea8-9739-544b-4ebd-ef08be936e8b</uuid>
|
||||||
|
+ <memory>1048576</memory>
|
||||||
|
+ <currentMemory>1048576</currentMemory>
|
||||||
|
+ <vcpu placement='static'>1</vcpu>
|
||||||
|
+ <os>
|
||||||
|
+ <type arch="aarch64" machine="virt-2.6">hvm</type>
|
||||||
|
+ <kernel>/aarch64.kernel</kernel>
|
||||||
|
+ <initrd>/aarch64.initrd</initrd>
|
||||||
|
+ <dtb>/aarch64.dtb</dtb>
|
||||||
|
+ <cmdline>earlyprintk console=ttyAMA0,115200n8 rw root=/dev/vda rootwait</cmdline>
|
||||||
|
+ </os>
|
||||||
|
+ <features>
|
||||||
|
+ <acpi/>
|
||||||
|
+ <apic/>
|
||||||
|
+ <pae/>
|
||||||
|
+ </features>
|
||||||
|
+ <cpu match='exact'>
|
||||||
|
+ <model>cortex-a53</model>
|
||||||
|
+ </cpu>
|
||||||
|
+ <clock offset="utc"/>
|
||||||
|
+ <on_poweroff>destroy</on_poweroff>
|
||||||
|
+ <on_reboot>restart</on_reboot>
|
||||||
|
+ <on_crash>restart</on_crash>
|
||||||
|
+ <devices>
|
||||||
|
+ <emulator>/usr/bin/qemu-system-aarch64</emulator>
|
||||||
|
+ <disk type='file' device='disk'>
|
||||||
|
+ <source file='/aarch64.raw'/>
|
||||||
|
+ <target dev='vda' bus='virtio'/>
|
||||||
|
+ </disk>
|
||||||
|
+ <interface type='user'>
|
||||||
|
+ <mac address='52:54:00:09:a4:37'/>
|
||||||
|
+ </interface>
|
||||||
|
+ <console type='pty'/>
|
||||||
|
+ <console type='pty'>
|
||||||
|
+ <target type='virtio' port='0'/>
|
||||||
|
+ </console>
|
||||||
|
+ <memballoon model='virtio'/>
|
||||||
|
+ <!--
|
||||||
|
+ This actually doesn't work in practice because vexpress only has
|
||||||
|
+ 4 virtio slots available, rng makes 5 -->
|
||||||
|
+ <rng model='virtio'>
|
||||||
|
+ <backend model='random'>/dev/random</backend>
|
||||||
|
+ </rng>
|
||||||
|
+ </devices>
|
||||||
|
+</domain>
|
||||||
|
diff --git a/tests/qemuxml2argvtest.c b/tests/qemuxml2argvtest.c
|
||||||
|
index e9b8d64..d1b9e98 100644
|
||||||
|
--- a/tests/qemuxml2argvtest.c
|
||||||
|
+++ b/tests/qemuxml2argvtest.c
|
||||||
|
@@ -1661,6 +1661,12 @@ mymain(void)
|
||||||
|
QEMU_CAPS_DEVICE_VIRTIO_RNG, QEMU_CAPS_OBJECT_RNG_RANDOM,
|
||||||
|
QEMU_CAPS_OBJECT_GPEX, QEMU_CAPS_DEVICE_PCI_BRIDGE,
|
||||||
|
QEMU_CAPS_DEVICE_DMI_TO_PCI_BRIDGE);
|
||||||
|
+ DO_TEST("aarch64-virt-2.6-virtio-pci-default",
|
||||||
|
+ QEMU_CAPS_NODEFCONFIG, QEMU_CAPS_DTB,
|
||||||
|
+ QEMU_CAPS_DEVICE_VIRTIO_MMIO,
|
||||||
|
+ QEMU_CAPS_DEVICE_VIRTIO_RNG, QEMU_CAPS_OBJECT_RNG_RANDOM,
|
||||||
|
+ QEMU_CAPS_OBJECT_GPEX, QEMU_CAPS_DEVICE_PCI_BRIDGE,
|
||||||
|
+ QEMU_CAPS_DEVICE_DMI_TO_PCI_BRIDGE);
|
||||||
|
/* Example of using virtio-pci with no explicit PCI controller
|
||||||
|
but with manual PCI addresses */
|
||||||
|
DO_TEST("aarch64-virtio-pci-manual-addresses",
|
114
0002-build-cleanup-GCC-4.6-Wlogical-op-workaround.patch
Normal file
114
0002-build-cleanup-GCC-4.6-Wlogical-op-workaround.patch
Normal file
@ -0,0 +1,114 @@
|
|||||||
|
From: Pavel Hrdina <phrdina@redhat.com>
|
||||||
|
Date: Sun, 10 Apr 2016 18:21:13 +0200
|
||||||
|
Subject: [PATCH] build: cleanup GCC < 4.6 -Wlogical-op workaround
|
||||||
|
|
||||||
|
Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
|
||||||
|
(cherry picked from commit 7fb81831fc497aa4a34fdfc036be9c9ae4401084)
|
||||||
|
---
|
||||||
|
m4/virt-compile-warnings.m4 | 2 +-
|
||||||
|
src/internal.h | 10 ++++++++++
|
||||||
|
src/util/virbuffer.c | 11 +++--------
|
||||||
|
src/util/virstring.c | 9 +--------
|
||||||
|
src/util/virsysinfo.c | 13 ++-----------
|
||||||
|
5 files changed, 17 insertions(+), 28 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/m4/virt-compile-warnings.m4 b/m4/virt-compile-warnings.m4
|
||||||
|
index 3dd0665..1b0a2cf 100644
|
||||||
|
--- a/m4/virt-compile-warnings.m4
|
||||||
|
+++ b/m4/virt-compile-warnings.m4
|
||||||
|
@@ -236,7 +236,7 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
|
||||||
|
|
||||||
|
if test "$gl_cv_warn_c__Wlogical_op" = yes &&
|
||||||
|
test "$lv_cv_gcc_wlogical_op_broken" = yes; then
|
||||||
|
- AC_DEFINE_UNQUOTED([BROKEN_GCC_WLOGICALOP], 1,
|
||||||
|
+ AC_DEFINE_UNQUOTED([BROKEN_GCC_WLOGICALOP_STRCHR], 1,
|
||||||
|
[Define to 1 if gcc -Wlogical-op reports false positives on strchr])
|
||||||
|
fi
|
||||||
|
])
|
||||||
|
diff --git a/src/internal.h b/src/internal.h
|
||||||
|
index db26fb0..35cc6d4 100644
|
||||||
|
--- a/src/internal.h
|
||||||
|
+++ b/src/internal.h
|
||||||
|
@@ -253,6 +253,16 @@
|
||||||
|
# define VIR_WARNINGS_RESET
|
||||||
|
# endif
|
||||||
|
|
||||||
|
+/* Workaround bogus GCC < 4.6 that produces false -Wlogical-op warnings for
|
||||||
|
+ * strchr(). Those old GCCs don't support push/pop. */
|
||||||
|
+# if BROKEN_GCC_WLOGICALOP_STRCHR
|
||||||
|
+# define VIR_WARNINGS_NO_WLOGICALOP_STRCHR \
|
||||||
|
+ _Pragma ("GCC diagnostic ignored \"-Wlogical-op\"")
|
||||||
|
+# else
|
||||||
|
+# define VIR_WARNINGS_NO_WLOGICALOP_STRCHR
|
||||||
|
+# endif
|
||||||
|
+
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Use this when passing possibly-NULL strings to printf-a-likes.
|
||||||
|
*/
|
||||||
|
diff --git a/src/util/virbuffer.c b/src/util/virbuffer.c
|
||||||
|
index 43cd1a7..d582e7d 100644
|
||||||
|
--- a/src/util/virbuffer.c
|
||||||
|
+++ b/src/util/virbuffer.c
|
||||||
|
@@ -417,14 +417,9 @@ virBufferVasprintf(virBufferPtr buf, const char *format, va_list argptr)
|
||||||
|
buf->use += count;
|
||||||
|
}
|
||||||
|
|
||||||
|
-/* Work around spurious strchr() diagnostics given by -Wlogical-op
|
||||||
|
- * for gcc < 4.6. Doing it via a local pragma keeps the damage
|
||||||
|
- * smaller than disabling it on the package level. Unfortunately, the
|
||||||
|
- * affected GCCs don't allow diagnostic push/pop which would have
|
||||||
|
- * further reduced the impact. */
|
||||||
|
-#if BROKEN_GCC_WLOGICALOP
|
||||||
|
-# pragma GCC diagnostic ignored "-Wlogical-op"
|
||||||
|
-#endif
|
||||||
|
+
|
||||||
|
+VIR_WARNINGS_NO_WLOGICALOP_STRCHR
|
||||||
|
+
|
||||||
|
|
||||||
|
/**
|
||||||
|
* virBufferEscapeString:
|
||||||
|
diff --git a/src/util/virstring.c b/src/util/virstring.c
|
||||||
|
index 7ec42aa..2d7fbf3 100644
|
||||||
|
--- a/src/util/virstring.c
|
||||||
|
+++ b/src/util/virstring.c
|
||||||
|
@@ -989,14 +989,7 @@ virStringHasControlChars(const char *str)
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-/* Work around spurious strchr() diagnostics given by -Wlogical-op
|
||||||
|
- * for gcc < 4.6. Doing it via a local pragma keeps the damage
|
||||||
|
- * smaller than disabling it on the package level. Unfortunately, the
|
||||||
|
- * affected GCCs don't allow diagnostic push/pop which would have
|
||||||
|
- * further reduced the impact. */
|
||||||
|
-#if BROKEN_GCC_WLOGICALOP
|
||||||
|
-# pragma GCC diagnostic ignored "-Wlogical-op"
|
||||||
|
-#endif
|
||||||
|
+VIR_WARNINGS_NO_WLOGICALOP_STRCHR
|
||||||
|
|
||||||
|
|
||||||
|
/**
|
||||||
|
diff --git a/src/util/virsysinfo.c b/src/util/virsysinfo.c
|
||||||
|
index 05d33a8..e8dbd4d 100644
|
||||||
|
--- a/src/util/virsysinfo.c
|
||||||
|
+++ b/src/util/virsysinfo.c
|
||||||
|
@@ -428,17 +428,8 @@ virSysinfoRead(void)
|
||||||
|
|
||||||
|
|
||||||
|
#elif defined(__s390__) || defined(__s390x__)
|
||||||
|
-/*
|
||||||
|
- we need to ignore warnings about strchr caused by -Wlogical-op
|
||||||
|
- for some GCC versions.
|
||||||
|
- Doing it via a local pragma keeps the damage smaller than
|
||||||
|
- disabling it on the package level.
|
||||||
|
- Unfortunately, the affected GCCs don't allow diagnostic push/pop
|
||||||
|
- which would have further reduced the impact.
|
||||||
|
- */
|
||||||
|
-# if BROKEN_GCC_WLOGICALOP
|
||||||
|
-# pragma GCC diagnostic ignored "-Wlogical-op"
|
||||||
|
-# endif
|
||||||
|
+
|
||||||
|
+VIR_WARNINGS_NO_WLOGICALOP_STRCHR
|
||||||
|
|
||||||
|
static char *
|
||||||
|
virSysinfoParseDelimited(const char *base, const char *name, char **value,
|
172
0003-build-add-GCC-6.0-Wlogical-op-workaround.patch
Normal file
172
0003-build-add-GCC-6.0-Wlogical-op-workaround.patch
Normal file
@ -0,0 +1,172 @@
|
|||||||
|
From: Pavel Hrdina <phrdina@redhat.com>
|
||||||
|
Date: Sun, 10 Apr 2016 18:22:20 +0200
|
||||||
|
Subject: [PATCH] build: add GCC 6.0 -Wlogical-op workaround
|
||||||
|
|
||||||
|
fdstream.c: In function 'virFDStreamWrite':
|
||||||
|
fdstream.c:390:29: error: logical 'or' of equal expressions [-Werror=logical-op]
|
||||||
|
if (errno == EAGAIN || errno == EWOULDBLOCK) {
|
||||||
|
^~
|
||||||
|
|
||||||
|
Fedora rawhide now uses gcc 6.0 and there is a bug with -Wlogical-op
|
||||||
|
producing false warnings.
|
||||||
|
|
||||||
|
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69602
|
||||||
|
|
||||||
|
Use GCC pragma push/pop and ignore -Wlogical-op for GCC that supports
|
||||||
|
push/pop pragma and also has this bug.
|
||||||
|
|
||||||
|
Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
|
||||||
|
(cherry picked from commit d713a6b120904c488170e7920c482b2fade70ae1)
|
||||||
|
---
|
||||||
|
m4/virt-compile-warnings.m4 | 20 ++++++++++++++++++++
|
||||||
|
src/fdstream.c | 4 ++++
|
||||||
|
src/internal.h | 12 ++++++++++++
|
||||||
|
src/rpc/virnetsshsession.c | 6 ++++++
|
||||||
|
src/security/security_selinux.c | 2 ++
|
||||||
|
5 files changed, 44 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/m4/virt-compile-warnings.m4 b/m4/virt-compile-warnings.m4
|
||||||
|
index 1b0a2cf..eb689e2 100644
|
||||||
|
--- a/m4/virt-compile-warnings.m4
|
||||||
|
+++ b/m4/virt-compile-warnings.m4
|
||||||
|
@@ -117,6 +117,20 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
|
||||||
|
[lv_cv_gcc_wlogical_op_broken=yes])
|
||||||
|
CFLAGS="$save_CFLAGS"])
|
||||||
|
|
||||||
|
+ AC_CACHE_CHECK([whether gcc gives bogus warnings for -Wlogical-op],
|
||||||
|
+ [lv_cv_gcc_wlogical_op_equal_expr_broken], [
|
||||||
|
+ save_CFLAGS="$CFLAGS"
|
||||||
|
+ CFLAGS="-O2 -Wlogical-op -Werror"
|
||||||
|
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
|
||||||
|
+ #define TEST1 1
|
||||||
|
+ #define TEST2 TEST1
|
||||||
|
+ ]], [[
|
||||||
|
+ int test = 0;
|
||||||
|
+ return test == TEST1 || test == TEST2;]])],
|
||||||
|
+ [lv_cv_gcc_wlogical_op_equal_expr_broken=no],
|
||||||
|
+ [lv_cv_gcc_wlogical_op_equal_expr_broken=yes])
|
||||||
|
+ CFLAGS="$save_CFLAGS"])
|
||||||
|
+
|
||||||
|
# We might fundamentally need some of these disabled forever, but
|
||||||
|
# ideally we'd turn many of them on
|
||||||
|
dontwarn="$dontwarn -Wfloat-equal"
|
||||||
|
@@ -239,4 +253,10 @@ AC_DEFUN([LIBVIRT_COMPILE_WARNINGS],[
|
||||||
|
AC_DEFINE_UNQUOTED([BROKEN_GCC_WLOGICALOP_STRCHR], 1,
|
||||||
|
[Define to 1 if gcc -Wlogical-op reports false positives on strchr])
|
||||||
|
fi
|
||||||
|
+
|
||||||
|
+ if test "$gl_cv_warn_c__Wlogical_op" = yes &&
|
||||||
|
+ test "$lv_cv_gcc_wlogical_op_equal_expr_broken" = yes; then
|
||||||
|
+ AC_DEFINE_UNQUOTED([BROKEN_GCC_WLOGICALOP_EQUAL_EXPR], 1,
|
||||||
|
+ [Define to 1 if gcc -Wlogical-op reports false positive 'or' equal expr])
|
||||||
|
+ fi
|
||||||
|
])
|
||||||
|
diff --git a/src/fdstream.c b/src/fdstream.c
|
||||||
|
index a85cf9d..ef118b5 100644
|
||||||
|
--- a/src/fdstream.c
|
||||||
|
+++ b/src/fdstream.c
|
||||||
|
@@ -387,7 +387,9 @@ static int virFDStreamWrite(virStreamPtr st, const char *bytes, size_t nbytes)
|
||||||
|
retry:
|
||||||
|
ret = write(fdst->fd, bytes, nbytes);
|
||||||
|
if (ret < 0) {
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (errno == EAGAIN || errno == EWOULDBLOCK) {
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
ret = -2;
|
||||||
|
} else if (errno == EINTR) {
|
||||||
|
goto retry;
|
||||||
|
@@ -437,7 +439,9 @@ static int virFDStreamRead(virStreamPtr st, char *bytes, size_t nbytes)
|
||||||
|
retry:
|
||||||
|
ret = read(fdst->fd, bytes, nbytes);
|
||||||
|
if (ret < 0) {
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (errno == EAGAIN || errno == EWOULDBLOCK) {
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
ret = -2;
|
||||||
|
} else if (errno == EINTR) {
|
||||||
|
goto retry;
|
||||||
|
diff --git a/src/internal.h b/src/internal.h
|
||||||
|
index 35cc6d4..926e990 100644
|
||||||
|
--- a/src/internal.h
|
||||||
|
+++ b/src/internal.h
|
||||||
|
@@ -245,11 +245,23 @@
|
||||||
|
_Pragma ("GCC diagnostic push")
|
||||||
|
# endif
|
||||||
|
|
||||||
|
+/* Workaround bogus GCC 6.0 for logical 'or' equal expression warnings.
|
||||||
|
+ * (GCC bz 69602) */
|
||||||
|
+# if BROKEN_GCC_WLOGICALOP_EQUAL_EXPR
|
||||||
|
+# define VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR \
|
||||||
|
+ _Pragma ("GCC diagnostic push") \
|
||||||
|
+ _Pragma ("GCC diagnostic ignored \"-Wlogical-op\"")
|
||||||
|
+# else
|
||||||
|
+# define VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR \
|
||||||
|
+ _Pragma ("GCC diagnostic push")
|
||||||
|
+# endif
|
||||||
|
+
|
||||||
|
# define VIR_WARNINGS_RESET \
|
||||||
|
_Pragma ("GCC diagnostic pop")
|
||||||
|
# else
|
||||||
|
# define VIR_WARNINGS_NO_CAST_ALIGN
|
||||||
|
# define VIR_WARNINGS_NO_PRINTF
|
||||||
|
+# define VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
# define VIR_WARNINGS_RESET
|
||||||
|
# endif
|
||||||
|
|
||||||
|
diff --git a/src/rpc/virnetsshsession.c b/src/rpc/virnetsshsession.c
|
||||||
|
index 406a831..e742175 100644
|
||||||
|
--- a/src/rpc/virnetsshsession.c
|
||||||
|
+++ b/src/rpc/virnetsshsession.c
|
||||||
|
@@ -545,9 +545,11 @@ virNetSSHAuthenticateAgent(virNetSSHSessionPtr sess,
|
||||||
|
agent_identity)))
|
||||||
|
return 0; /* key accepted */
|
||||||
|
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (ret != LIBSSH2_ERROR_AUTHENTICATION_FAILED &&
|
||||||
|
ret != LIBSSH2_ERROR_PUBLICKEY_UNRECOGNIZED &&
|
||||||
|
ret != LIBSSH2_ERROR_PUBLICKEY_UNVERIFIED) {
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
libssh2_session_last_error(sess->session, &errmsg, NULL, 0);
|
||||||
|
virReportError(VIR_ERR_AUTH_FAILED,
|
||||||
|
_("failed to authenticate using SSH agent: %s"),
|
||||||
|
@@ -605,9 +607,11 @@ virNetSSHAuthenticatePrivkey(virNetSSHSessionPtr sess,
|
||||||
|
priv->password)) == 0)
|
||||||
|
return 0; /* success */
|
||||||
|
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (priv->password ||
|
||||||
|
ret == LIBSSH2_ERROR_PUBLICKEY_UNRECOGNIZED ||
|
||||||
|
ret == LIBSSH2_ERROR_AUTHENTICATION_FAILED) {
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
libssh2_session_last_error(sess->session, &errmsg, NULL, 0);
|
||||||
|
virReportError(VIR_ERR_AUTH_FAILED,
|
||||||
|
_("authentication with private key '%s' "
|
||||||
|
@@ -673,11 +677,13 @@ virNetSSHAuthenticatePrivkey(virNetSSHSessionPtr sess,
|
||||||
|
"has failed: %s"),
|
||||||
|
priv->filename, errmsg);
|
||||||
|
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (ret == LIBSSH2_ERROR_PUBLICKEY_UNRECOGNIZED ||
|
||||||
|
ret == LIBSSH2_ERROR_AUTHENTICATION_FAILED)
|
||||||
|
return 1;
|
||||||
|
else
|
||||||
|
return -1;
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
}
|
||||||
|
|
||||||
|
return 0;
|
||||||
|
diff --git a/src/security/security_selinux.c b/src/security/security_selinux.c
|
||||||
|
index 26d95d1..04760a1 100644
|
||||||
|
--- a/src/security/security_selinux.c
|
||||||
|
+++ b/src/security/security_selinux.c
|
||||||
|
@@ -911,8 +911,10 @@ virSecuritySELinuxSetFileconHelper(const char *path, char *tcon,
|
||||||
|
* hopefully sets one of the necessary SELinux virt_use_{nfs,usb,pci}
|
||||||
|
* boolean tunables to allow it ...
|
||||||
|
*/
|
||||||
|
+ VIR_WARNINGS_NO_WLOGICALOP_EQUAL_EXPR
|
||||||
|
if (setfilecon_errno != EOPNOTSUPP && setfilecon_errno != ENOTSUP &&
|
||||||
|
setfilecon_errno != EROFS) {
|
||||||
|
+ VIR_WARNINGS_RESET
|
||||||
|
virReportSystemError(setfilecon_errno,
|
||||||
|
_("unable to set security context '%s' on '%s'"),
|
||||||
|
tcon, path);
|
12
libvirt.spec
12
libvirt.spec
@ -379,7 +379,7 @@
|
|||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 1.3.3
|
Version: 1.3.3
|
||||||
Release: 1%{?dist}%{?extra_release}
|
Release: 2%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -390,6 +390,12 @@ URL: http://libvirt.org/
|
|||||||
%endif
|
%endif
|
||||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
||||||
|
|
||||||
|
# libvirt assigns same address to two PCI devices (bz #1325085)
|
||||||
|
Patch0001: 0001-qemu-support-virt-2.6-machine-type-on-arm.patch
|
||||||
|
# Fix build with -Werror
|
||||||
|
Patch0002: 0002-build-cleanup-GCC-4.6-Wlogical-op-workaround.patch
|
||||||
|
Patch0003: 0003-build-add-GCC-6.0-Wlogical-op-workaround.patch
|
||||||
|
|
||||||
%if %{with_libvirtd}
|
%if %{with_libvirtd}
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
%if %{with_network}
|
%if %{with_network}
|
||||||
@ -2398,6 +2404,10 @@ exit 0
|
|||||||
%doc examples/systemtap
|
%doc examples/systemtap
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 14 2016 Cole Robinson <crobinso@redhat.com> - 1.3.3-2
|
||||||
|
- libvirt assigns same address to two PCI devices (bz #1325085)
|
||||||
|
- Fix build with -Werror
|
||||||
|
|
||||||
* Thu Apr 07 2016 Cole Robinson <crobinso@redhat.com> - 1.3.3-1
|
* Thu Apr 07 2016 Cole Robinson <crobinso@redhat.com> - 1.3.3-1
|
||||||
- Rebased to version 1.3.3
|
- Rebased to version 1.3.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user