Update to 1.0.0 release
This commit is contained in:
parent
2c2e71c0ce
commit
8cc50838dc
@ -1,27 +0,0 @@
|
|||||||
From 37865f1dead1fac2ee34af48f96d19d686296e04 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Thu, 13 Sep 2012 14:37:22 +0100
|
|
||||||
Subject: [PATCH] Use 'qemu-system-i386' as binary instead of 'qemu'.
|
|
||||||
|
|
||||||
---
|
|
||||||
src/qemu/qemu_capabilities.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
|
|
||||||
index af3b0b2..179b3d2 100644
|
|
||||||
--- a/src/qemu/qemu_capabilities.c
|
|
||||||
+++ b/src/qemu/qemu_capabilities.c
|
|
||||||
@@ -244,8 +244,8 @@ static const struct qemu_feature_flags const arch_info_x86_64_flags [] = {
|
|
||||||
|
|
||||||
/* The archicture tables for supported QEMU archs */
|
|
||||||
static const struct qemu_arch_info const arch_info_hvm[] = {
|
|
||||||
- { "i686", 32, NULL, "qemu",
|
|
||||||
- "qemu-system-x86_64", arch_info_i686_flags, 4 },
|
|
||||||
+ { "i686", 32, NULL, "qemu-system-i386",
|
|
||||||
+ NULL, arch_info_i686_flags, 4 },
|
|
||||||
{ "x86_64", 64, NULL, "qemu-system-x86_64",
|
|
||||||
NULL, arch_info_x86_64_flags, 2 },
|
|
||||||
{ "arm", 32, NULL, "qemu-system-arm", NULL, NULL, 0 },
|
|
||||||
--
|
|
||||||
1.7.11.4
|
|
||||||
|
|
50
libvirt.spec
50
libvirt.spec
@ -108,6 +108,7 @@
|
|||||||
%define with_systemd 0%{!?_without_systemd:0}
|
%define with_systemd 0%{!?_without_systemd:0}
|
||||||
%define with_numad 0%{!?_without_numad:0}
|
%define with_numad 0%{!?_without_numad:0}
|
||||||
%define with_firewalld 0%{!?_without_firewalld:0}
|
%define with_firewalld 0%{!?_without_firewalld:0}
|
||||||
|
%define with_libssh2_transport 0%{!?_without_libssh2_transport:0}
|
||||||
|
|
||||||
# Non-server/HV driver defaults which are always enabled
|
# Non-server/HV driver defaults which are always enabled
|
||||||
%define with_python 0%{!?_without_python:1}
|
%define with_python 0%{!?_without_python:1}
|
||||||
@ -229,6 +230,11 @@
|
|||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Enable libssh2 transport for new enough distros
|
||||||
|
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
|
||||||
|
%define with_libssh2_transport 0%{!?_without_libssh2_transport:1}
|
||||||
|
%endif
|
||||||
|
|
||||||
# Disable some drivers when building without libvirt daemon.
|
# Disable some drivers when building without libvirt daemon.
|
||||||
# The logic is the same as in configure.ac
|
# The logic is the same as in configure.ac
|
||||||
%if ! %{with_libvirtd}
|
%if ! %{with_libvirtd}
|
||||||
@ -319,8 +325,8 @@
|
|||||||
|
|
||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.10.2.1
|
Version: 1.0.0
|
||||||
Release: 2%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -330,11 +336,6 @@ URL: http://libvirt.org/
|
|||||||
%define mainturl stable_updates/
|
%define mainturl stable_updates/
|
||||||
%endif
|
%endif
|
||||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
||||||
# Fix qemu -> qemu-system-i386 (RHBZ#857026).
|
|
||||||
# keep: This patch is Fedora-specific and not upstream.
|
|
||||||
Patch1: 0001-Use-qemu-system-i386-as-binary-instead-of-qemu.patch
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
%if %{with_libvirtd}
|
%if %{with_libvirtd}
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
@ -413,8 +414,14 @@ BuildRequires: libpciaccess-devel >= 0.10.9
|
|||||||
BuildRequires: yajl-devel
|
BuildRequires: yajl-devel
|
||||||
%endif
|
%endif
|
||||||
%if %{with_sanlock}
|
%if %{with_sanlock}
|
||||||
|
# make sure libvirt is built with new enough sanlock on
|
||||||
|
# distros that have it; required for on_lockfailure
|
||||||
|
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
|
||||||
|
BuildRequires: sanlock-devel >= 2.4
|
||||||
|
%else
|
||||||
BuildRequires: sanlock-devel >= 1.8
|
BuildRequires: sanlock-devel >= 1.8
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
%if %{with_libpcap}
|
%if %{with_libpcap}
|
||||||
BuildRequires: libpcap-devel
|
BuildRequires: libpcap-devel
|
||||||
%endif
|
%endif
|
||||||
@ -500,9 +507,13 @@ BuildRequires: numactl-devel
|
|||||||
%if %{with_capng}
|
%if %{with_capng}
|
||||||
BuildRequires: libcap-ng-devel >= 0.5.0
|
BuildRequires: libcap-ng-devel >= 0.5.0
|
||||||
%endif
|
%endif
|
||||||
%if %{with_phyp}
|
%if %{with_phyp} || %{with_libssh2_transport}
|
||||||
|
%if %{with_libssh2_transport}
|
||||||
|
BuildRequires: libssh2-devel >= 1.3.0
|
||||||
|
%else
|
||||||
BuildRequires: libssh2-devel
|
BuildRequires: libssh2-devel
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%if %{with_netcf}
|
%if %{with_netcf}
|
||||||
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
|
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
|
||||||
@ -623,7 +634,7 @@ Requires: PolicyKit >= 0.6
|
|||||||
%if %{with_storage_fs}
|
%if %{with_storage_fs}
|
||||||
Requires: nfs-utils
|
Requires: nfs-utils
|
||||||
# For mkfs
|
# For mkfs
|
||||||
Requires: util-linux-ng
|
Requires: util-linux
|
||||||
# For pool-build probing for existing pools
|
# For pool-build probing for existing pools
|
||||||
BuildRequires: libblkid-devel >= 2.17
|
BuildRequires: libblkid-devel >= 2.17
|
||||||
# For glusterfs
|
# For glusterfs
|
||||||
@ -1006,6 +1017,9 @@ Requires: cyrus-sasl
|
|||||||
# work correctly & doesn't have onerous dependencies
|
# work correctly & doesn't have onerous dependencies
|
||||||
Requires: cyrus-sasl-md5
|
Requires: cyrus-sasl-md5
|
||||||
%endif
|
%endif
|
||||||
|
%if %{with_libssh2_transport}
|
||||||
|
Requires: libssh2 >= 1.3.0
|
||||||
|
%endif
|
||||||
|
|
||||||
%description client
|
%description client
|
||||||
Shared libraries and client binaries needed to access to the
|
Shared libraries and client binaries needed to access to the
|
||||||
@ -1025,10 +1039,15 @@ Include header files & development libraries for the libvirt C library.
|
|||||||
%package lock-sanlock
|
%package lock-sanlock
|
||||||
Summary: Sanlock lock manager plugin for QEMU driver
|
Summary: Sanlock lock manager plugin for QEMU driver
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
|
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 6
|
||||||
|
Requires: sanlock >= 2.4
|
||||||
|
%else
|
||||||
Requires: sanlock >= 1.8
|
Requires: sanlock >= 1.8
|
||||||
|
%endif
|
||||||
#for virt-sanlock-cleanup require augeas
|
#for virt-sanlock-cleanup require augeas
|
||||||
Requires: augeas
|
Requires: augeas
|
||||||
Requires: %{name}-daemon = %{version}-%{release}
|
Requires: %{name}-daemon = %{version}-%{release}
|
||||||
|
Requires: %{name}-client = %{version}-%{release}
|
||||||
|
|
||||||
%description lock-sanlock
|
%description lock-sanlock
|
||||||
Includes the Sanlock lock manager plugin for the QEMU
|
Includes the Sanlock lock manager plugin for the QEMU
|
||||||
@ -1050,7 +1069,6 @@ of recent versions of Linux (and other OSes).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -1559,6 +1577,14 @@ fi
|
|||||||
/bin/systemctl try-restart libvirt-guests.service >/dev/null 2>&1 || :
|
/bin/systemctl try-restart libvirt-guests.service >/dev/null 2>&1 || :
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if %{with_sanlock}
|
||||||
|
%post lock-sanlock
|
||||||
|
if getent group sanlock > /dev/null ; then
|
||||||
|
chmod 0770 %{_localstatedir}/lib/libvirt/sanlock
|
||||||
|
chown root:sanlock %{_localstatedir}/lib/libvirt/sanlock
|
||||||
|
fi
|
||||||
|
%endif
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
|
|
||||||
@ -1812,6 +1838,7 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/sysctl.d/libvirtd
|
|||||||
%dir %attr(0700, root, root) %{_localstatedir}/lib/libvirt/sanlock
|
%dir %attr(0700, root, root) %{_localstatedir}/lib/libvirt/sanlock
|
||||||
%{_sbindir}/virt-sanlock-cleanup
|
%{_sbindir}/virt-sanlock-cleanup
|
||||||
%{_mandir}/man8/virt-sanlock-cleanup.8*
|
%{_mandir}/man8/virt-sanlock-cleanup.8*
|
||||||
|
%attr(0755, root, root) %{_libexecdir}/libvirt_sanlock_helper
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files client -f %{name}.lang
|
%files client -f %{name}.lang
|
||||||
@ -1903,6 +1930,9 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/sysctl.d/libvirtd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 8 2012 Daniel P. Berrange <berrange@redhat.com> - 1.0.0-1
|
||||||
|
- Update to 1.0.0 release
|
||||||
|
|
||||||
* Tue Oct 30 2012 Cole Robinson <crobinso@redhat.com> - 0.10.2.1-2
|
* Tue Oct 30 2012 Cole Robinson <crobinso@redhat.com> - 0.10.2.1-2
|
||||||
- Disable libxl on F18 too
|
- Disable libxl on F18 too
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user