* Mon Sep 14 2009 Mark McLoughlin <markmc@redhat.com> - 0.7.1-0.2.gitfac3f4c
- Update to newer snapshot of 0.7.1 - Stop libvirt using untrusted 'info vcpus' PID data (#520864) - Support relabelling of USB and PCI devices - Enable multipath storage support - Restart libvirtd upon RPM upgrade
This commit is contained in:
parent
e4bf8ffa42
commit
897506e66a
@ -1,4 +1,4 @@
|
|||||||
From 5f8d720b5f1393ee333a5fa8375ffe9ac954d48b Mon Sep 17 00:00:00 2001
|
From e2106f6db9beb9f48e9f87f8a1eaba821d1a2296 Mon Sep 17 00:00:00 2001
|
||||||
From: Daniel P. Berrange <berrange@redhat.com>
|
From: Daniel P. Berrange <berrange@redhat.com>
|
||||||
Date: Mon, 17 Aug 2009 08:32:08 +0100
|
Date: Mon, 17 Aug 2009 08:32:08 +0100
|
||||||
Subject: [PATCH] Disable sound cards when running sVirt
|
Subject: [PATCH] Disable sound cards when running sVirt
|
||||||
@ -12,10 +12,10 @@ Fedora-patch: libvirt-0.6.4-svirt-sound.patch
|
|||||||
1 files changed, 16 insertions(+), 1 deletions(-)
|
1 files changed, 16 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
|
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
|
||||||
index 6b0b404..53186e0 100644
|
index f92bcef..f3b4ef0 100644
|
||||||
--- a/src/qemu_conf.c
|
--- a/src/qemu_conf.c
|
||||||
+++ b/src/qemu_conf.c
|
+++ b/src/qemu_conf.c
|
||||||
@@ -1384,6 +1384,20 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
@@ -1510,6 +1510,20 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
||||||
char uuid[VIR_UUID_STRING_BUFLEN];
|
char uuid[VIR_UUID_STRING_BUFLEN];
|
||||||
char domid[50];
|
char domid[50];
|
||||||
const char *cpu = NULL;
|
const char *cpu = NULL;
|
||||||
@ -36,7 +36,7 @@ index 6b0b404..53186e0 100644
|
|||||||
|
|
||||||
uname_normalize(&ut);
|
uname_normalize(&ut);
|
||||||
|
|
||||||
@@ -2015,7 +2029,8 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
@@ -2181,7 +2195,8 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
||||||
}
|
}
|
||||||
|
|
||||||
/* Add sound hardware */
|
/* Add sound hardware */
|
||||||
|
33
libvirt.spec
33
libvirt.spec
@ -18,6 +18,7 @@
|
|||||||
%define with_storage_lvm 0%{!?_without_storage_lvm:1}
|
%define with_storage_lvm 0%{!?_without_storage_lvm:1}
|
||||||
%define with_storage_iscsi 0%{!?_without_storage_iscsi:1}
|
%define with_storage_iscsi 0%{!?_without_storage_iscsi:1}
|
||||||
%define with_storage_disk 0%{!?_without_storage_disk:1}
|
%define with_storage_disk 0%{!?_without_storage_disk:1}
|
||||||
|
%define with_storage_mpath 0%{!?_without_storage_mpath:1}
|
||||||
%define with_numactl 0%{!?_without_numactl:1}
|
%define with_numactl 0%{!?_without_numactl:1}
|
||||||
|
|
||||||
# default to off - selectively enabled below
|
# default to off - selectively enabled below
|
||||||
@ -72,12 +73,12 @@
|
|||||||
%define with_one 0
|
%define with_one 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define git_snapshot git3ef2e05
|
%define git_snapshot gitfac3f4c
|
||||||
|
|
||||||
Summary: Library providing a simple API virtualization
|
Summary: Library providing a simple API virtualization
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.7.1
|
Version: 0.7.1
|
||||||
Release: 0.1.%{git_snapshot}%{?dist}%{?extra_release}
|
Release: 0.2.%{git_snapshot}%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: http://libvirt.org/sources/libvirt-%{version}-%{git_snapshot}.tar.gz
|
Source: http://libvirt.org/sources/libvirt-%{version}-%{git_snapshot}.tar.gz
|
||||||
@ -119,6 +120,11 @@ Requires: glusterfs-client >= 2.0.1
|
|||||||
%if %{with_qemu}
|
%if %{with_qemu}
|
||||||
# From QEMU RPMs
|
# From QEMU RPMs
|
||||||
Requires: /usr/bin/qemu-img
|
Requires: /usr/bin/qemu-img
|
||||||
|
# For image compression
|
||||||
|
Requires: gzip
|
||||||
|
Requires: bzip2
|
||||||
|
Requires: lzop
|
||||||
|
Requires: xz
|
||||||
%else
|
%else
|
||||||
%if %{with_xen}
|
%if %{with_xen}
|
||||||
# From Xen RPMs
|
# From Xen RPMs
|
||||||
@ -137,6 +143,10 @@ Requires: iscsi-initiator-utils
|
|||||||
# For disk driver
|
# For disk driver
|
||||||
Requires: parted
|
Requires: parted
|
||||||
%endif
|
%endif
|
||||||
|
%if %{with_storage_mpath}
|
||||||
|
# For multipath support
|
||||||
|
Requires: device-mapper
|
||||||
|
%endif
|
||||||
%if %{with_xen}
|
%if %{with_xen}
|
||||||
BuildRequires: xen-devel
|
BuildRequires: xen-devel
|
||||||
%endif
|
%endif
|
||||||
@ -192,6 +202,10 @@ BuildRequires: iscsi-initiator-utils
|
|||||||
# For disk driver
|
# For disk driver
|
||||||
BuildRequires: parted-devel
|
BuildRequires: parted-devel
|
||||||
%endif
|
%endif
|
||||||
|
%if %{with_storage_mpath}
|
||||||
|
# For Multipath support
|
||||||
|
BuildRequires: device-mapper-devel
|
||||||
|
%endif
|
||||||
%if %{with_numactl}
|
%if %{with_numactl}
|
||||||
# For QEMU/LXC numa info
|
# For QEMU/LXC numa info
|
||||||
BuildRequires: numactl-devel
|
BuildRequires: numactl-devel
|
||||||
@ -341,6 +355,10 @@ of recent versions of Linux (and other OSes).
|
|||||||
%define _without_storage_disk --without-storage-disk
|
%define _without_storage_disk --without-storage-disk
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if ! %{with_storage_mpath}
|
||||||
|
%define _without_storage_mpath --without-storage-mpath
|
||||||
|
%endif
|
||||||
|
|
||||||
%if ! %{with_numactl}
|
%if ! %{with_numactl}
|
||||||
%define _without_numactl --without-numactl
|
%define _without_numactl --without-numactl
|
||||||
%endif
|
%endif
|
||||||
@ -372,6 +390,7 @@ of recent versions of Linux (and other OSes).
|
|||||||
%{?_without_storage_lvm} \
|
%{?_without_storage_lvm} \
|
||||||
%{?_without_storage_iscsi} \
|
%{?_without_storage_iscsi} \
|
||||||
%{?_without_storage_disk} \
|
%{?_without_storage_disk} \
|
||||||
|
%{?_without_storage_mpath} \
|
||||||
%{?_without_numactl} \
|
%{?_without_numactl} \
|
||||||
%{?_without_capng} \
|
%{?_without_capng} \
|
||||||
%{?_without_netcf} \
|
%{?_without_netcf} \
|
||||||
@ -460,6 +479,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
/sbin/chkconfig --add libvirtd
|
/sbin/chkconfig --add libvirtd
|
||||||
|
if [ "$1" -ge "1" ]; then
|
||||||
|
/sbin/service libvirtd condrestart > /dev/null 2>&1
|
||||||
|
fi
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
@ -628,6 +650,13 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 14 2009 Mark McLoughlin <markmc@redhat.com> - 0.7.1-0.2.gitfac3f4c
|
||||||
|
- Update to newer snapshot of 0.7.1
|
||||||
|
- Stop libvirt using untrusted 'info vcpus' PID data (#520864)
|
||||||
|
- Support relabelling of USB and PCI devices
|
||||||
|
- Enable multipath storage support
|
||||||
|
- Restart libvirtd upon RPM upgrade
|
||||||
|
|
||||||
* Sun Sep 6 2009 Mark McLoughlin <markmc@redhat.com> - 0.7.1-0.1.gitg3ef2e05
|
* Sun Sep 6 2009 Mark McLoughlin <markmc@redhat.com> - 0.7.1-0.1.gitg3ef2e05
|
||||||
- Update to pre-release git snapshot of 0.7.1
|
- Update to pre-release git snapshot of 0.7.1
|
||||||
- Drop upstreamed patches
|
- Drop upstreamed patches
|
||||||
|
Loading…
Reference in New Issue
Block a user