libvirt-5.8.0-1.fc32
Update to version 5.8.0
This commit is contained in:
parent
511e2c5124
commit
8461a521f2
@ -1,26 +0,0 @@
|
||||
From: Michael Chapman <mike@very.puzzling.org>
|
||||
Date: Tue, 17 Sep 2019 17:03:57 +1000
|
||||
Subject: [PATCH] remote: fix registration of TLS socket
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
|
||||
Signed-off-by: Michael Chapman <mike@very.puzzling.org>
|
||||
---
|
||||
src/remote/remote_daemon.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/remote/remote_daemon.c b/src/remote/remote_daemon.c
|
||||
index 546328b24d..8f85d09dd3 100644
|
||||
--- a/src/remote/remote_daemon.c
|
||||
+++ b/src/remote/remote_daemon.c
|
||||
@@ -505,7 +505,7 @@ daemonSetupNetworking(virNetServerPtr srv,
|
||||
config->max_client_requests) < 0)
|
||||
goto cleanup;
|
||||
|
||||
- if (((ipsock && config->listen_tls) || (act && virSystemdActivationHasName(act, "ip-tls")))) {
|
||||
+ if (((ipsock && config->listen_tls) || (act && virSystemdActivationHasName(act, DAEMON_NAME "-tls.socket")))) {
|
||||
virNetTLSContextPtr ctxt = NULL;
|
||||
|
||||
if (config->ca_file ||
|
@ -1,55 +0,0 @@
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Thu, 26 Sep 2019 15:00:55 -0400
|
||||
Subject: [PATCH] vircgroupv2: Fix VM startup when legacy cgroups are defined
|
||||
|
||||
On Fedora 31, starting a 'mock' build alters /proc/$pid/cgroup,
|
||||
probably due to usage of systemd-nspawn.
|
||||
|
||||
Before:
|
||||
$ cat /proc/self/cgroup
|
||||
0::/user.slice/user-1000.slice/...
|
||||
|
||||
After:
|
||||
$ cat /proc/self/cgroup
|
||||
1:name=systemd:/
|
||||
0::/user.slice/user-1000.slice/...
|
||||
|
||||
The cgroupv2 code mishandles that first line in the second case, which
|
||||
causes VM startup to fail with: Unable to read from
|
||||
'/sys/fs/cgroup/machine/cgroup.controllers': No such file or directory
|
||||
|
||||
The kernel docs[1] say that the cgroupv2 path will always start with
|
||||
'0::', which in the code here controllers="". Only set the v2 placement
|
||||
path when we see that cgroup file entry.
|
||||
|
||||
[1] https://www.kernel.org/doc/html/v5.3/admin-guide/cgroup-v2.html#processes
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1751120
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
src/util/vircgroupv2.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/util/vircgroupv2.c b/src/util/vircgroupv2.c
|
||||
index 2aca4e5d62..ecf7d42076 100644
|
||||
--- a/src/util/vircgroupv2.c
|
||||
+++ b/src/util/vircgroupv2.c
|
||||
@@ -194,12 +194,16 @@ virCgroupV2DetectMounts(virCgroupPtr group,
|
||||
static int
|
||||
virCgroupV2DetectPlacement(virCgroupPtr group,
|
||||
const char *path,
|
||||
- const char *controllers ATTRIBUTE_UNUSED,
|
||||
+ const char *controllers,
|
||||
const char *selfpath)
|
||||
{
|
||||
if (group->unified.placement)
|
||||
return 0;
|
||||
|
||||
+ /* controllers="" indicates the cgroupv2 controller path */
|
||||
+ if (STRNEQ_NULLABLE(controllers, ""))
|
||||
+ return 0;
|
||||
+
|
||||
/*
|
||||
* selfpath == "/" + path="" -> "/"
|
||||
* selfpath == "/libvirt.service" + path == "" -> "/libvirt.service"
|
@ -1,72 +0,0 @@
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Thu, 26 Sep 2019 15:25:52 -0400
|
||||
Subject: [PATCH] vircgroup: Add some VIR_DEBUG statements
|
||||
|
||||
These helped with debugging
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1612383
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
src/util/vircgroup.c | 3 ++-
|
||||
src/util/vircgroupv2.c | 9 +++++++++
|
||||
2 files changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/util/vircgroup.c b/src/util/vircgroup.c
|
||||
index 825f62a97b..4f9d80666d 100644
|
||||
--- a/src/util/vircgroup.c
|
||||
+++ b/src/util/vircgroup.c
|
||||
@@ -1157,7 +1157,8 @@ virCgroupNewMachineSystemd(const char *name,
|
||||
virCgroupFree(&init);
|
||||
|
||||
if (!path || STREQ(path, "/") || path[0] != '/') {
|
||||
- VIR_DEBUG("Systemd didn't setup its controller");
|
||||
+ VIR_DEBUG("Systemd didn't setup its controller, path=%s",
|
||||
+ NULLSTR(path));
|
||||
return -2;
|
||||
}
|
||||
|
||||
diff --git a/src/util/vircgroupv2.c b/src/util/vircgroupv2.c
|
||||
index ecf7d42076..ff079be718 100644
|
||||
--- a/src/util/vircgroupv2.c
|
||||
+++ b/src/util/vircgroupv2.c
|
||||
@@ -155,10 +155,14 @@ virCgroupV2CopyPlacement(virCgroupPtr group,
|
||||
const char *path,
|
||||
virCgroupPtr parent)
|
||||
{
|
||||
+ VIR_DEBUG("group=%p path=%s parent=%p", group, path, parent);
|
||||
+
|
||||
if (path[0] == '/') {
|
||||
if (VIR_STRDUP(group->unified.placement, path) < 0)
|
||||
return -1;
|
||||
} else {
|
||||
+ VIR_DEBUG("parent->unified.placement=%s", parent->unified.placement);
|
||||
+
|
||||
/*
|
||||
* parent == "/" + path="" => "/"
|
||||
* parent == "/libvirt.service" + path == "" => "/libvirt.service"
|
||||
@@ -172,6 +176,7 @@ virCgroupV2CopyPlacement(virCgroupPtr group,
|
||||
return -1;
|
||||
}
|
||||
|
||||
+ VIR_DEBUG("set group->unified.placement=%s", group->unified.placement);
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -200,6 +205,9 @@ virCgroupV2DetectPlacement(virCgroupPtr group,
|
||||
if (group->unified.placement)
|
||||
return 0;
|
||||
|
||||
+ VIR_DEBUG("group=%p path=%s controllers=%s selfpath=%s",
|
||||
+ group, path, controllers, selfpath);
|
||||
+
|
||||
/* controllers="" indicates the cgroupv2 controller path */
|
||||
if (STRNEQ_NULLABLE(controllers, ""))
|
||||
return 0;
|
||||
@@ -216,6 +224,7 @@ virCgroupV2DetectPlacement(virCgroupPtr group,
|
||||
path) < 0)
|
||||
return -1;
|
||||
|
||||
+ VIR_DEBUG("set group->unified.placement=%s", group->unified.placement);
|
||||
return 0;
|
||||
}
|
||||
|
46
libvirt.spec
46
libvirt.spec
@ -118,14 +118,13 @@
|
||||
%endif
|
||||
|
||||
# RHEL doesn't ship OpenVZ, VBox, PowerHypervisor,
|
||||
# VMware, libxenserver (xenapi), libxenlight (Xen 4.1 and newer),
|
||||
# VMware, libxenlight (Xen 4.1 and newer),
|
||||
# or HyperV.
|
||||
%if 0%{?rhel}
|
||||
%define with_openvz 0
|
||||
%define with_vbox 0
|
||||
%define with_phyp 0
|
||||
%define with_vmware 0
|
||||
%define with_xenapi 0
|
||||
%define with_libxl 0
|
||||
%define with_hyperv 0
|
||||
%define with_vz 0
|
||||
@ -215,8 +214,8 @@
|
||||
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 5.7.0
|
||||
Release: 3%{?dist}
|
||||
Version: 5.8.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://libvirt.org/
|
||||
|
||||
@ -225,12 +224,6 @@ URL: https://libvirt.org/
|
||||
%endif
|
||||
Source: https://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||
|
||||
# Fix systemd socket activation with TLS socket
|
||||
Patch0001: 0001-remote-fix-registration-of-TLS-socket.patch
|
||||
# Fix VM startup when legacy cgroups are defined (bz #1612383)
|
||||
Patch0002: 0002-vircgroupv2-Fix-VM-startup-when-legacy-cgroups-are-d.patch
|
||||
Patch0003: 0003-vircgroup-Add-some-VIR_DEBUG-statements.patch
|
||||
|
||||
Requires: libvirt-daemon = %{version}-%{release}
|
||||
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
||||
Requires: libvirt-daemon-config-nwfilter = %{version}-%{release}
|
||||
@ -1142,10 +1135,17 @@ exit 1
|
||||
# Nightly edk2.git-arm
|
||||
LOADERS="$LOADERS:/usr/share/edk2.git/arm/QEMU_EFI-pflash.raw:/usr/share/edk2.git/arm/vars-template-pflash.raw"
|
||||
|
||||
# Fedora edk2-ovmf
|
||||
# Fedora edk2-ovmf, x86_64
|
||||
LOADERS="$LOADERS:/usr/share/edk2/ovmf/OVMF_CODE.fd:/usr/share/edk2/ovmf/OVMF_VARS.fd"
|
||||
# Fedora edk2-ovmf, x86_64, with Secure Boot
|
||||
LOADERS="$LOADERS:/usr/share/edk2/ovmf/OVMF_CODE.secboot.fd:/usr/share/edk2/ovmf/OVMF_VARS.secboot.fd"
|
||||
# Fedora edk2-ovmf-ia32
|
||||
LOADERS="$LOADERS:/usr/share/edk2/ovmf-ia32/OVMF_CODE.fd:/usr/share/edk2/ovmf-ia32/OVMF_VARS.fd"
|
||||
# Fedora edk2-ovmf-ia32, with Secure Boot. (NB: Unlike x86_64, for
|
||||
# 'ia32', there is no secboot-variant "VARS" file (NVRAM template).
|
||||
# So the NVRAM template for 'ovmf-ia32/OVMF_CODE.secboot.fd' is the
|
||||
# same as the one for the non-secboot variant.)
|
||||
LOADERS="$LOADERS:/usr/share/edk2/ovmf-ia32/OVMF_CODE.secboot.fd:/usr/share/edk2/ovmf-ia32/OVMF_VARS.fd"
|
||||
# Fedora edk2-aarch64
|
||||
LOADERS="$LOADERS:/usr/share/edk2/aarch64/QEMU_EFI-pflash.raw:/usr/share/edk2/aarch64/vars-template-pflash.raw"
|
||||
# Fedora edk2-arm
|
||||
@ -1175,7 +1175,6 @@ rm -f po/stamp-po
|
||||
%{?arg_esx} \
|
||||
%{?arg_hyperv} \
|
||||
%{?arg_vmware} \
|
||||
--without-xenapi \
|
||||
--without-vz \
|
||||
--without-bhyve \
|
||||
--with-remote-default-mode=legacy \
|
||||
@ -1226,7 +1225,6 @@ rm -f po/stamp-po
|
||||
--with-init-script=systemd \
|
||||
%{?arg_login_shell}
|
||||
make %{?_smp_mflags} V=1
|
||||
gzip -9 ChangeLog
|
||||
|
||||
%install
|
||||
rm -fr %{buildroot}
|
||||
@ -1314,15 +1312,6 @@ mv $RPM_BUILD_ROOT%{_datadir}/systemtap/tapset/libvirt_qemu_probes.stp \
|
||||
%endif
|
||||
|
||||
%check
|
||||
cd tests
|
||||
# These tests don't current work in a mock build root
|
||||
for i in nodeinfotest seclabeltest
|
||||
do
|
||||
rm -f $i
|
||||
printf 'int main(void) { return 0; }' > $i.c
|
||||
printf '#!/bin/sh\nexit 0\n' > $i
|
||||
chmod +x $i
|
||||
done
|
||||
if ! make %{?_smp_mflags} check VIR_TEST_DEBUG=1
|
||||
then
|
||||
cat test-suite.log || true
|
||||
@ -1533,17 +1522,9 @@ exit 0
|
||||
%files
|
||||
|
||||
%files docs
|
||||
%doc AUTHORS ChangeLog.gz NEWS README README.md
|
||||
%doc AUTHORS ChangeLog NEWS README README.md
|
||||
%doc libvirt-docs/*
|
||||
|
||||
# API docs
|
||||
%dir %{_datadir}/gtk-doc/html/libvirt/
|
||||
%doc %{_datadir}/gtk-doc/html/libvirt/*.devhelp
|
||||
%doc %{_datadir}/gtk-doc/html/libvirt/*.html
|
||||
%doc %{_datadir}/gtk-doc/html/libvirt/*.png
|
||||
%doc %{_datadir}/gtk-doc/html/libvirt/*.css
|
||||
|
||||
|
||||
%files daemon
|
||||
|
||||
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/
|
||||
@ -2006,6 +1987,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 07 2019 Cole Robinson <crobinso@redhat.com> - 5.8.0-1
|
||||
- Update to version 5.8.0
|
||||
|
||||
* Thu Sep 26 2019 Cole Robinson <crobinso@redhat.com> - 5.7.0-3
|
||||
- Fix VM startup when legacy cgroups are defined (bz #1612383)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-5.7.0.tar.xz) = b1c8f4a46cb8cbbca2670df7f0a236fc93a6ff341c2f24c0402aa0b194c3e521b43f78ef965a51b4d0f416a7aa1af2e9b64c69eca82ba7053ed79f8deeb031f4
|
||||
SHA512 (libvirt-5.8.0.tar.xz) = 73d18fdf307b8029921a9f1a0c84ca31c50c662a3c0339e3850d6d2f31574168807a6f34943b286ed86a44031decbbc1339f27366da7269e29d38c7094503113
|
||||
|
Loading…
Reference in New Issue
Block a user