release candidate 1 of 0.10.0
This commit is contained in:
parent
438006407c
commit
7b5483236c
@ -1,115 +0,0 @@
|
||||
From 2f2ca021951905439fbb47ae02d0796837eb4f53 Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Denemark <jdenemar@redhat.com>
|
||||
Date: Thu, 2 Aug 2012 14:10:31 +0200
|
||||
Subject: [PATCH] build: Link security manager into libvirt.so
|
||||
|
||||
Security manager is not a dynamically loadable driver, it's a common
|
||||
infrastructure similar to util, conf, cpu, etc. used by individual
|
||||
drivers. Such code is allowed to be linked into libvirt.so.
|
||||
|
||||
This reverts commit ec5b7bd2ecbf40ceff5b2d4fc00d5cfdfba966a4 and most of
|
||||
aae5cfb69948fddef556f8f5b9f80a444f9c6125.
|
||||
|
||||
This patch is supposed to fix virdrivermoduletest failures for qemu and
|
||||
lxc drivers as well as libvirtd's ability to load qemu and lxc drivers.
|
||||
---
|
||||
daemon/Makefile.am | 1 -
|
||||
src/Makefile.am | 3 +--
|
||||
src/libvirt_private.syms | 31 +++++++++++++++++++++++++++++++
|
||||
tests/Makefile.am | 5 ++---
|
||||
4 files changed, 34 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
|
||||
index b8ecbef..928aeaf 100644
|
||||
--- a/daemon/Makefile.am
|
||||
+++ b/daemon/Makefile.am
|
||||
@@ -164,7 +164,6 @@ endif
|
||||
if WITH_NWFILTER
|
||||
libvirtd_LDADD += ../src/libvirt_driver_nwfilter.la
|
||||
endif
|
||||
-libvirtd_LDADD += ../src/libvirt_driver_security.la
|
||||
endif
|
||||
|
||||
libvirtd_LDADD += ../src/libvirt.la
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 844e648..7663ad7 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -1161,8 +1161,7 @@ endif
|
||||
|
||||
libvirt_driver_security_la_SOURCES = $(SECURITY_DRIVER_SOURCES)
|
||||
noinst_LTLIBRARIES += libvirt_driver_security.la
|
||||
-# Stateful, so linked to daemon instead
|
||||
-#libvirt_la_BUILT_LIBADD += libvirt_driver_security.la
|
||||
+libvirt_la_BUILT_LIBADD += libvirt_driver_security.la
|
||||
libvirt_driver_security_la_CFLAGS = \
|
||||
-I$(top_srcdir)/src/conf $(AM_CFLAGS)
|
||||
libvirt_driver_security_la_LDFLAGS = $(AM_LDFLAGS)
|
||||
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
|
||||
index 0b026b8..aace748 100644
|
||||
--- a/src/libvirt_private.syms
|
||||
+++ b/src/libvirt_private.syms
|
||||
@@ -961,6 +961,37 @@ virSecretUsageTypeTypeFromString;
|
||||
virSecretUsageTypeTypeToString;
|
||||
|
||||
|
||||
+# security_driver.h
|
||||
+virSecurityDriverLookup;
|
||||
+
|
||||
+
|
||||
+# security_manager.h
|
||||
+virSecurityManagerClearSocketLabel;
|
||||
+virSecurityManagerFree;
|
||||
+virSecurityManagerGenLabel;
|
||||
+virSecurityManagerGetDOI;
|
||||
+virSecurityManagerGetModel;
|
||||
+virSecurityManagerGetProcessLabel;
|
||||
+virSecurityManagerNew;
|
||||
+virSecurityManagerNewStack;
|
||||
+virSecurityManagerNewDAC;
|
||||
+virSecurityManagerReleaseLabel;
|
||||
+virSecurityManagerReserveLabel;
|
||||
+virSecurityManagerRestoreImageLabel;
|
||||
+virSecurityManagerRestoreAllLabel;
|
||||
+virSecurityManagerRestoreHostdevLabel;
|
||||
+virSecurityManagerRestoreSavedStateLabel;
|
||||
+virSecurityManagerSetAllLabel;
|
||||
+virSecurityManagerSetDaemonSocketLabel;
|
||||
+virSecurityManagerSetImageFDLabel;
|
||||
+virSecurityManagerSetImageLabel;
|
||||
+virSecurityManagerSetHostdevLabel;
|
||||
+virSecurityManagerSetProcessLabel;
|
||||
+virSecurityManagerSetSavedStateLabel;
|
||||
+virSecurityManagerSetSocketLabel;
|
||||
+virSecurityManagerVerify;
|
||||
+virSecurityManagerGetMountOptions;
|
||||
+
|
||||
# sexpr.h
|
||||
sexpr_append;
|
||||
sexpr_cons;
|
||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||
index 6a1b18b..ac26bc5 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -295,8 +295,7 @@ endif
|
||||
|
||||
if WITH_QEMU
|
||||
|
||||
-qemu_LDADDS = ../src/libvirt_driver_qemu_impl.la \
|
||||
- ../src/libvirt_driver_security.la
|
||||
+qemu_LDADDS = ../src/libvirt_driver_qemu_impl.la
|
||||
if WITH_NETWORK
|
||||
qemu_LDADDS += ../src/libvirt_driver_network_impl.la
|
||||
endif
|
||||
@@ -521,7 +520,7 @@ virauthconfigtest_LDADD = $(LDADDS)
|
||||
|
||||
seclabeltest_SOURCES = \
|
||||
seclabeltest.c
|
||||
-seclabeltest_LDADD = $(LDADDS) ../src/libvirt_driver_security.la
|
||||
+seclabeltest_LDADD = $(LDADDS)
|
||||
|
||||
virbuftest_SOURCES = \
|
||||
virbuftest.c testutils.h testutils.c
|
||||
--
|
||||
1.7.11.2
|
||||
|
@ -1,67 +0,0 @@
|
||||
commit 1d170d3f9afce53b748acdbc0612758bba39aa35
|
||||
Author: Eric Blake <eblake@redhat.com>
|
||||
Date: Wed Aug 1 11:00:35 2012 -0600
|
||||
|
||||
build: commit to 0.10.0 release naming
|
||||
|
||||
With 0.10.0-rc0 out the door, we are committed to the next version
|
||||
number.
|
||||
|
||||
* src/libvirt_public.syms (LIBVIRT_0.9.14): Rename...
|
||||
(LIBVIRT_0.10.0): ...to this.
|
||||
* docs/formatdomain.html.in: Fix fallout.
|
||||
* src/openvz/openvz_driver.c (openvzDriver): Likewise.
|
||||
* src/remote/remote_driver.c (remote_driver): Likewise.
|
||||
|
||||
diff --git a/docs/formatdomain.html.in b/docs/formatdomain.html.in
|
||||
index c834577..f97c630 100644
|
||||
--- a/docs/formatdomain.html.in
|
||||
+++ b/docs/formatdomain.html.in
|
||||
@@ -780,7 +780,7 @@
|
||||
CPU model will fail. Supported values for <code>fallback</code>
|
||||
attribute are: <code>allow</code> (this is the default), and
|
||||
<code>forbid</code>. The optional <code>vendor_id</code> attribute
|
||||
- (<span class="since">Since 0.9.14</span>) can be used to set the
|
||||
+ (<span class="since">Since 0.10.0</span>) can be used to set the
|
||||
vendor id seen by the guest. It must be exactly 12 characters long.
|
||||
If not set the vendor id of the host is used. Typical possible
|
||||
values are "AuthenticAMD" and "GenuineIntel".</dd>
|
||||
diff --git a/src/libvirt_public.syms b/src/libvirt_public.syms
|
||||
index 5004182..e3ba119 100644
|
||||
--- a/src/libvirt_public.syms
|
||||
+++ b/src/libvirt_public.syms
|
||||
@@ -544,7 +544,7 @@ LIBVIRT_0.9.13 {
|
||||
virDomainSnapshotRef;
|
||||
} LIBVIRT_0.9.11;
|
||||
|
||||
-LIBVIRT_0.9.14 {
|
||||
+LIBVIRT_0.10.0 {
|
||||
global:
|
||||
virDomainGetHostname;
|
||||
virConnectRegisterCloseCallback;
|
||||
diff --git a/src/openvz/openvz_driver.c b/src/openvz/openvz_driver.c
|
||||
index 4cc7f46..48b5219 100644
|
||||
--- a/src/openvz/openvz_driver.c
|
||||
+++ b/src/openvz/openvz_driver.c
|
||||
@@ -2170,7 +2170,7 @@ static virDriver openvzDriver = {
|
||||
.domainIsUpdated = openvzDomainIsUpdated, /* 0.8.6 */
|
||||
.isAlive = openvzIsAlive, /* 0.9.8 */
|
||||
.domainUpdateDeviceFlags = openvzDomainUpdateDeviceFlags, /* 0.9.13 */
|
||||
- .domainGetHostname = openvzDomainGetHostname, /* 0.9.14 */
|
||||
+ .domainGetHostname = openvzDomainGetHostname, /* 0.10.0 */
|
||||
};
|
||||
|
||||
int openvzRegister(void) {
|
||||
diff --git a/src/remote/remote_driver.c b/src/remote/remote_driver.c
|
||||
index 9354cb4..b9e2127 100644
|
||||
--- a/src/remote/remote_driver.c
|
||||
+++ b/src/remote/remote_driver.c
|
||||
@@ -5366,7 +5366,7 @@ static virDriver remote_driver = {
|
||||
.domainGetDiskErrors = remoteDomainGetDiskErrors, /* 0.9.10 */
|
||||
.domainSetMetadata = remoteDomainSetMetadata, /* 0.9.10 */
|
||||
.domainGetMetadata = remoteDomainGetMetadata, /* 0.9.10 */
|
||||
- .domainGetHostname = remoteDomainGetHostname, /* 0.9.14 */
|
||||
+ .domainGetHostname = remoteDomainGetHostname, /* 0.10.0 */
|
||||
};
|
||||
|
||||
static virNetworkDriver network_driver = {
|
@ -1,30 +0,0 @@
|
||||
From 840b80b48c0189423993db6268f85dd5eac345ac Mon Sep 17 00:00:00 2001
|
||||
From: Jiri Denemark <jdenemar@redhat.com>
|
||||
Date: Wed, 1 Aug 2012 09:59:43 +0200
|
||||
Subject: [PATCH] build: Link security driver into daemon
|
||||
To: libvir-list@redhat.com
|
||||
|
||||
Commit aae5cfb69948fddef556f8f5b9f80a444f9c6125 removed security driver
|
||||
from libvirt_la but forgot to link it into libvirtd in case libvirt is
|
||||
built without modules.
|
||||
|
||||
Signed-off-by: Daniel Veillard <veillard@redhat.com>
|
||||
---
|
||||
daemon/Makefile.am | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
|
||||
index 928aeaf..b8ecbef 100644
|
||||
--- a/daemon/Makefile.am
|
||||
+++ b/daemon/Makefile.am
|
||||
@@ -164,6 +164,7 @@ endif
|
||||
if WITH_NWFILTER
|
||||
libvirtd_LDADD += ../src/libvirt_driver_nwfilter.la
|
||||
endif
|
||||
+libvirtd_LDADD += ../src/libvirt_driver_security.la
|
||||
endif
|
||||
|
||||
libvirtd_LDADD += ../src/libvirt.la
|
||||
--
|
||||
1.7.7.6
|
||||
|
26
libvirt.spec
26
libvirt.spec
@ -106,6 +106,7 @@
|
||||
%define with_sanlock 0%{!?_without_sanlock:0}
|
||||
%define with_systemd 0%{!?_without_systemd:0}
|
||||
%define with_numad 0%{!?_without_numad:0}
|
||||
%define with_firewalld 0%{!?_without_firewalld:0}
|
||||
|
||||
# Non-server/HV driver defaults which are always enabled
|
||||
%define with_python 0%{!?_without_python:1}
|
||||
@ -146,6 +147,11 @@
|
||||
%define with_systemd 1
|
||||
%endif
|
||||
|
||||
# Fedora 18 / RHEL-7 are first where firewalld support is enabled
|
||||
%if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
|
||||
%define with_firewalld 1
|
||||
%endif
|
||||
|
||||
# RHEL-5 has restricted QEMU to x86_64 only and is too old for LXC
|
||||
%if 0%{?rhel} == 5
|
||||
%define with_qemu_tcg 0
|
||||
@ -309,7 +315,7 @@
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 0.10.0
|
||||
Release: 0rc0.2%{?dist}%{?extra_release}
|
||||
Release: 0rc1%{?dist}%{?extra_release}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
@ -318,10 +324,7 @@ URL: http://libvirt.org/
|
||||
%if %(echo %{version} | grep -o \\. | wc -l) == 3
|
||||
%define mainturl stable_updates/
|
||||
%endif
|
||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}-rc0.tar.gz
|
||||
Patch0: libvirt-0.10.0-rc0-release-naming.patch
|
||||
Patch1: libvirt-build-Link-security-driver-into-daemon.patch
|
||||
Patch2: build-Link-security-manager-into-libvirt.so.patch
|
||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}-rc1.tar.gz
|
||||
|
||||
%if %{with_libvirtd}
|
||||
Requires: libvirt-daemon = %{version}-%{release}
|
||||
@ -1023,9 +1026,6 @@ of recent versions of Linux (and other OSes).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
%if ! %{with_xen}
|
||||
@ -1192,6 +1192,10 @@ of recent versions of Linux (and other OSes).
|
||||
%define _without_driver_modules --without-driver-modules
|
||||
%endif
|
||||
|
||||
%if %{with_firewalld}
|
||||
%define _with_firewalld --with-firewalld
|
||||
%endif
|
||||
|
||||
%define when %(date +"%%F-%%T")
|
||||
%define where %(hostname)
|
||||
%define who %{?packager}%{!?packager:Unknown}
|
||||
@ -1250,6 +1254,7 @@ autoreconf -if
|
||||
%{?_without_audit} \
|
||||
%{?_without_dtrace} \
|
||||
%{?_without_driver_modules} \
|
||||
%{?_with_firewalld} \
|
||||
%{with_packager} \
|
||||
%{with_packager_version} \
|
||||
--with-qemu-user=%{qemu_user} \
|
||||
@ -1338,7 +1343,7 @@ make
|
||||
for i in nodeinfotest seclabeltest virdrivermoduletest
|
||||
do
|
||||
rm -f $i
|
||||
printf 'int main(void) { return(0); }' > $i.c
|
||||
printf 'int main(void) { return 0; }' > $i.c
|
||||
printf '#!/bin/sh\nexit 0\n' > $i
|
||||
chmod +x $i
|
||||
done
|
||||
@ -1848,6 +1853,9 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/sysctl.d/libvirtd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Aug 23 2012 Daniel Veillard <veillard@redhat.com> - 0.10.0-0rc1
|
||||
- release candidate 1 of 0.10.0
|
||||
|
||||
* Tue Aug 14 2012 Daniel P. Berrange <berrange@redhat.com> - 0.10.0-0rc0.2
|
||||
- Enable autotools to make previous patch work
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user