Upstream release libvirt-0.8.4
This commit is contained in:
parent
03369d2383
commit
742b24eb23
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
i686
|
i686
|
||||||
x86_64
|
x86_64
|
||||||
libvirt-*.tar.gz
|
libvirt-*.tar.gz
|
||||||
|
/libvirt-0.8.4.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -rup libvirt-0.8.3.orig/src/qemu/qemu_conf.c libvirt-0.8.3.new/src/qemu/qemu_conf.c
|
|
||||||
--- libvirt-0.8.3.orig/src/qemu/qemu_conf.c 2010-08-04 13:21:27.000000000 +0100
|
|
||||||
+++ libvirt-0.8.3.new/src/qemu/qemu_conf.c 2010-08-23 21:08:13.239794362 +0100
|
|
||||||
@@ -3651,7 +3651,7 @@ int qemudBuildCommandLine(virConnectPtr
|
|
||||||
{
|
|
||||||
int i;
|
|
||||||
char memory[50];
|
|
||||||
- char boot[VIR_DOMAIN_BOOT_LAST];
|
|
||||||
+ char boot[VIR_DOMAIN_BOOT_LAST+1];
|
|
||||||
struct utsname ut;
|
|
||||||
int disableKQEMU = 0;
|
|
||||||
int disableKVM = 0;
|
|
16
libvirt.spec
16
libvirt.spec
@ -64,6 +64,7 @@
|
|||||||
%define with_nwfilter 0%{!?_without_nwfilter:0}
|
%define with_nwfilter 0%{!?_without_nwfilter:0}
|
||||||
%define with_libpcap 0%{!?_without_libpcap:0}
|
%define with_libpcap 0%{!?_without_libpcap:0}
|
||||||
%define with_macvtap 0%{!?_without_macvtap:0}
|
%define with_macvtap 0%{!?_without_macvtap:0}
|
||||||
|
%define with_libnl 0%{!?_without_libnl:0}
|
||||||
|
|
||||||
# Non-server/HV driver defaults which are always enabled
|
# Non-server/HV driver defaults which are always enabled
|
||||||
%define with_python 0%{!?_without_python:1}
|
%define with_python 0%{!?_without_python:1}
|
||||||
@ -159,8 +160,6 @@
|
|||||||
|
|
||||||
%if %{with_macvtap}
|
%if %{with_macvtap}
|
||||||
%define with_libnl 1
|
%define with_libnl 1
|
||||||
%else
|
|
||||||
%define with_libnl 0
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Force QEMU to run as non-root
|
# Force QEMU to run as non-root
|
||||||
@ -184,12 +183,11 @@
|
|||||||
|
|
||||||
Summary: Library providing a simple API virtualization
|
Summary: Library providing a simple API virtualization
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.8.3
|
Version: 0.8.4
|
||||||
Release: 2%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: http://libvirt.org/sources/libvirt-%{version}.tar.gz
|
Source: http://libvirt.org/sources/libvirt-%{version}.tar.gz
|
||||||
Patch1: %{name}-%{version}-boot-menu.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://libvirt.org/
|
URL: http://libvirt.org/
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
@ -425,7 +423,6 @@ of recent versions of Linux (and other OSes).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -649,10 +646,6 @@ rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/libvirtd.lxc
|
|||||||
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/libvirtd.uml
|
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/libvirtd.uml
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if %{with_libvirtd}
|
|
||||||
chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/libvirtd
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -fr %{buildroot}
|
rm -fr %{buildroot}
|
||||||
|
|
||||||
@ -916,6 +909,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 13 2010 Daniel Veillard <veillard@redhat.com> - 0.8.4-1
|
||||||
|
- Upstream release 0.8.4
|
||||||
|
|
||||||
* Mon Aug 23 2010 Daniel P. Berrange <berrange@redhat.com> - 0.8.3-2
|
* Mon Aug 23 2010 Daniel P. Berrange <berrange@redhat.com> - 0.8.3-2
|
||||||
- Fix potential overflow in boot menu code
|
- Fix potential overflow in boot menu code
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user