Upstream release, 0.6.3, Daniel
This commit is contained in:
parent
1e2f9fce0a
commit
6a73119e65
@ -6,3 +6,4 @@ libvirt-*.tar.gz
|
|||||||
libvirt-0.6.0.tar.gz
|
libvirt-0.6.0.tar.gz
|
||||||
libvirt-0.6.1.tar.gz
|
libvirt-0.6.1.tar.gz
|
||||||
libvirt-0.6.2.tar.gz
|
libvirt-0.6.2.tar.gz
|
||||||
|
libvirt-0.6.3.tar.gz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
From 0ae4c67ff5f1d24698c5cfc8a9719d333c892644 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mark McLoughlin <markmc@redhat.com>
|
|
||||||
Date: Thu, 16 Apr 2009 11:23:55 +0100
|
|
||||||
Subject: [PATCH 1/3] qemu -drive takes format= not fmt=
|
|
||||||
|
|
||||||
Seems like a simple typo - it has been "format=" since the flag
|
|
||||||
was introduced, but we added it as "fmt=".
|
|
||||||
|
|
||||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
|
||||||
---
|
|
||||||
src/qemu_conf.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
|
|
||||||
index f36c927..6f9e610 100644
|
|
||||||
--- a/src/qemu_conf.c
|
|
||||||
+++ b/src/qemu_conf.c
|
|
||||||
@@ -1135,7 +1135,7 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
|
||||||
disk->device == VIR_DOMAIN_DISK_DEVICE_DISK)
|
|
||||||
virBufferAddLit(&opt, ",boot=on");
|
|
||||||
if (disk->driverType)
|
|
||||||
- virBufferVSprintf(&opt, ",fmt=%s", disk->driverType);
|
|
||||||
+ virBufferVSprintf(&opt, ",format=%s", disk->driverType);
|
|
||||||
|
|
||||||
if (disk->cachemode) {
|
|
||||||
const char *mode =
|
|
@ -12,7 +12,7 @@
|
|||||||
+ getuid() == 0) {
|
+ getuid() == 0) {
|
||||||
+ static int soundWarned = 0;
|
+ static int soundWarned = 0;
|
||||||
+ skipSound = 1;
|
+ skipSound = 1;
|
||||||
+ if (vm->def->nsounds &&
|
+ if (def->nsounds &&
|
||||||
+ !soundWarned) {
|
+ !soundWarned) {
|
||||||
+ soundWarned = 1;
|
+ soundWarned = 1;
|
||||||
+ VIR_WARN0("Sound cards for VMs are disabled while SELinux security model is active");
|
+ VIR_WARN0("Sound cards for VMs are disabled while SELinux security model is active");
|
||||||
@ -25,8 +25,8 @@
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Add sound hardware */
|
/* Add sound hardware */
|
||||||
- if (vm->def->nsounds) {
|
- if (def->nsounds) {
|
||||||
+ if (vm->def->nsounds &&
|
+ if (def->nsounds &&
|
||||||
+ !skipSound) {
|
+ !skipSound) {
|
||||||
int size = 100;
|
int size = 100;
|
||||||
char *modstr;
|
char *modstr;
|
44
libvirt.spec
44
libvirt.spec
@ -1,26 +1,14 @@
|
|||||||
# -*- rpm-spec -*-
|
# -*- rpm-spec -*-
|
||||||
|
|
||||||
%define with_xen 0%{!?_without_xen:1}
|
|
||||||
%define with_xen_proxy 0%{!?_without_xen_proxy:1}
|
|
||||||
%define with_qemu 0%{!?_without_qemu:1}
|
|
||||||
%define with_openvz 0%{!?_without_openvz:1}
|
|
||||||
%define with_lxc 0%{!?_without_lxc:1}
|
|
||||||
%define with_sasl 0%{!?_without_sasl:1}
|
|
||||||
%define with_avahi 0%{!?_without_avahi:1}
|
|
||||||
%define with_polkit 0%{!?_without_polkit:0}
|
|
||||||
%define with_python 0%{!?_without_python:1}
|
|
||||||
%define with_libvirtd 0%{!?_without_libvirtd:1}
|
|
||||||
%define with_uml 0%{!?_without_uml:1}
|
|
||||||
%define with_network 0%{!?_without_network:1}
|
|
||||||
|
|
||||||
%define with_xen 0%{!?_without_xen:1}
|
%define with_xen 0%{!?_without_xen:1}
|
||||||
%define with_xen_proxy 0%{!?_without_xen_proxy:1}
|
%define with_xen_proxy 0%{!?_without_xen_proxy:1}
|
||||||
%define with_qemu 0%{!?_without_qemu:1}
|
%define with_qemu 0%{!?_without_qemu:1}
|
||||||
%define with_openvz 0%{!?_without_openvz:1}
|
%define with_openvz 0%{!?_without_openvz:1}
|
||||||
%define with_lxc 0%{!?_without_lxc:1}
|
%define with_lxc 0%{!?_without_lxc:1}
|
||||||
|
%define with_vbox 0%{!?_without_vbox:1}
|
||||||
%define with_sasl 0%{!?_without_sasl:1}
|
%define with_sasl 0%{!?_without_sasl:1}
|
||||||
%define with_avahi 0%{!?_without_avahi:1}
|
%define with_avahi 0%{!?_without_avahi:1}
|
||||||
%define with_polkit 0%{!?_without_polkit:0}
|
%define with_polkit 0%{!?_without_polkit:1}
|
||||||
%define with_python 0%{!?_without_python:1}
|
%define with_python 0%{!?_without_python:1}
|
||||||
%define with_libvirtd 0%{!?_without_libvirtd:1}
|
%define with_libvirtd 0%{!?_without_libvirtd:1}
|
||||||
%define with_uml 0%{!?_without_uml:1}
|
%define with_uml 0%{!?_without_uml:1}
|
||||||
@ -60,23 +48,24 @@
|
|||||||
%define with_rhel5 0
|
%define with_rhel5 0
|
||||||
%else
|
%else
|
||||||
%define with_rhel5 1
|
%define with_rhel5 1
|
||||||
|
%define with_polkit 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
Summary: Library providing a simple API virtualization
|
Summary: Library providing a simple API virtualization
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.6.2
|
Version: 0.6.3
|
||||||
Release: 2%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: libvirt-%{version}.tar.gz
|
Source: libvirt-%{version}.tar.gz
|
||||||
|
|
||||||
# Patches cherry-picked from upstream
|
# Patches cherry-picked from upstream
|
||||||
Patch0: libvirt-0.6.2-qemu-drive-format.patch
|
# N/A
|
||||||
|
|
||||||
# Not for upstream. Temporary hack till PulseAudio autostart
|
# Not for upstream. Temporary hack till PulseAudio autostart
|
||||||
# problems are sorted out when SELinux enforcing
|
# problems are sorted out when SELinux enforcing
|
||||||
Patch200: libvirt-0.6.2-svirt-sound.patch
|
Patch200: libvirt-0.6.3-svirt-sound.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://libvirt.org/
|
URL: http://libvirt.org/
|
||||||
@ -227,8 +216,6 @@ of recent versions of Linux (and other OSes).
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%patch200 -p0
|
%patch200 -p0
|
||||||
|
|
||||||
mv NEWS NEWS.old
|
mv NEWS NEWS.old
|
||||||
@ -251,6 +238,10 @@ iconv -f ISO-8859-1 -t UTF-8 < NEWS.old > NEWS
|
|||||||
%define _without_lxc --without-lxc
|
%define _without_lxc --without-lxc
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%if ! %{with_vbox}
|
||||||
|
%define _without_vbox --without-vbox
|
||||||
|
%endif
|
||||||
|
|
||||||
%if ! %{with_sasl}
|
%if ! %{with_sasl}
|
||||||
%define _without_sasl --without-sasl
|
%define _without_sasl --without-sasl
|
||||||
%endif
|
%endif
|
||||||
@ -307,6 +298,7 @@ iconv -f ISO-8859-1 -t UTF-8 < NEWS.old > NEWS
|
|||||||
%{?_without_qemu} \
|
%{?_without_qemu} \
|
||||||
%{?_without_openvz} \
|
%{?_without_openvz} \
|
||||||
%{?_without_lxc} \
|
%{?_without_lxc} \
|
||||||
|
%{?_without_vbox} \
|
||||||
%{?_without_sasl} \
|
%{?_without_sasl} \
|
||||||
%{?_without_avahi} \
|
%{?_without_avahi} \
|
||||||
%{?_without_polkit} \
|
%{?_without_polkit} \
|
||||||
@ -341,7 +333,7 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.a
|
|||||||
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/run/libvirt/
|
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/run/libvirt/
|
||||||
# Default dir for disk images defined in SELinux policy
|
# Default dir for disk images defined in SELinux policy
|
||||||
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/lib/libvirt/images/
|
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/lib/libvirt/images/
|
||||||
# Default dir for kernel+initrd images defnied in SELinux policy
|
# Default dir for kernel+initrd images defined in SELinux policy
|
||||||
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/lib/libvirt/boot/
|
install -d -m 0755 $RPM_BUILD_ROOT%{_localstatedir}/lib/libvirt/boot/
|
||||||
|
|
||||||
%if %{with_qemu}
|
%if %{with_qemu}
|
||||||
@ -414,8 +406,10 @@ fi
|
|||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
|
|
||||||
%doc AUTHORS ChangeLog NEWS README COPYING.LIB TODO
|
%doc AUTHORS ChangeLog NEWS README COPYING.LIB TODO
|
||||||
%doc %{_mandir}/man1/virsh.1*
|
%{_mandir}/man1/virsh.1*
|
||||||
|
%{_mandir}/man1/virt-xml-validate.1*
|
||||||
%{_bindir}/virsh
|
%{_bindir}/virsh
|
||||||
|
%{_bindir}/virt-xml-validate
|
||||||
%{_libdir}/lib*.so.*
|
%{_libdir}/lib*.so.*
|
||||||
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/
|
%dir %attr(0700, root, root) %{_sysconfdir}/libvirt/
|
||||||
|
|
||||||
@ -547,6 +541,12 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 24 2009 Daniel Veillard <veillard@redhat.com> - 0.6.3-1.fc12
|
||||||
|
- release of 0.6.3
|
||||||
|
- VirtualBox driver
|
||||||
|
- new virt-xml-validate command
|
||||||
|
- assorted bug fixes
|
||||||
|
|
||||||
* Thu Apr 16 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-2.fc12
|
* Thu Apr 16 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-2.fc12
|
||||||
- Fix qemu drive format specification (#496092)
|
- Fix qemu drive format specification (#496092)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user