Fix preun script (bz #1142367)
This commit is contained in:
parent
a540751e83
commit
622cf0d642
32
0009-spec-Fix-preun-script-for-daemon.patch
Normal file
32
0009-spec-Fix-preun-script-for-daemon.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 09f0ff32b8925131c058de768751d3368f47a722 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jiri Denemark <jdenemar@redhat.com>
|
||||||
|
Date: Wed, 3 Sep 2014 10:51:14 +0200
|
||||||
|
Subject: [PATCH] spec: Fix preun script for daemon
|
||||||
|
|
||||||
|
%systemd_preun macro cannot be split into several lines.
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1136736
|
||||||
|
|
||||||
|
Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
|
||||||
|
(cherry picked from commit 6209454d5b10c2d89faab8a56b250f1569d823fe)
|
||||||
|
---
|
||||||
|
libvirt.spec.in | 6 +-----
|
||||||
|
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/libvirt.spec.in b/libvirt.spec.in
|
||||||
|
index 7d8748d..6129f00 100644
|
||||||
|
--- a/libvirt.spec.in
|
||||||
|
+++ b/libvirt.spec.in
|
||||||
|
@@ -1680,11 +1680,7 @@ fi
|
||||||
|
%preun daemon
|
||||||
|
%if %{with_systemd}
|
||||||
|
%if %{with_systemd_macros}
|
||||||
|
- %systemd_preun \
|
||||||
|
- libvirtd.socket \
|
||||||
|
- libvirtd.service \
|
||||||
|
- virtlockd.socket \
|
||||||
|
- virtlockd.service
|
||||||
|
+ %systemd_preun libvirtd.socket libvirtd.service virtlockd.socket virtlockd.service
|
||||||
|
%else
|
||||||
|
if [ $1 -eq 0 ] ; then
|
||||||
|
# Package removal, not upgrade
|
15
libvirt.spec
15
libvirt.spec
@ -366,7 +366,7 @@
|
|||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 1.2.8
|
Version: 1.2.8
|
||||||
Release: 2%{?dist}%{?extra_release}
|
Release: 3%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -391,6 +391,8 @@ Patch0007: 0007-rpc-make-daemon-spawning-a-bit-more-intelligent.patch
|
|||||||
# Disable wireshark building, currently broken on f21/rawhide
|
# Disable wireshark building, currently broken on f21/rawhide
|
||||||
# Nonupstream patch
|
# Nonupstream patch
|
||||||
Patch0008: 0008-spec-Don-t-build-wireshark-on-f21-non-upstream.patch
|
Patch0008: 0008-spec-Don-t-build-wireshark-on-f21-non-upstream.patch
|
||||||
|
# Fix preun script (bz #1142367)
|
||||||
|
Patch0009: 0009-spec-Fix-preun-script-for-daemon.patch
|
||||||
|
|
||||||
%if %{with_libvirtd}
|
%if %{with_libvirtd}
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
@ -1230,6 +1232,8 @@ driver
|
|||||||
# Disable wireshark building, currently broken on f21/rawhide
|
# Disable wireshark building, currently broken on f21/rawhide
|
||||||
# Nonupstream patch
|
# Nonupstream patch
|
||||||
%patch0008 -p1
|
%patch0008 -p1
|
||||||
|
# Fix preun script (bz #1142367)
|
||||||
|
%patch0009 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -1710,11 +1714,7 @@ fi
|
|||||||
%preun daemon
|
%preun daemon
|
||||||
%if %{with_systemd}
|
%if %{with_systemd}
|
||||||
%if %{with_systemd_macros}
|
%if %{with_systemd_macros}
|
||||||
%systemd_preun \
|
%systemd_preun libvirtd.socket libvirtd.service virtlockd.socket virtlockd.service
|
||||||
libvirtd.socket \
|
|
||||||
libvirtd.service \
|
|
||||||
virtlockd.socket \
|
|
||||||
virtlockd.service
|
|
||||||
%else
|
%else
|
||||||
if [ $1 -eq 0 ] ; then
|
if [ $1 -eq 0 ] ; then
|
||||||
# Package removal, not upgrade
|
# Package removal, not upgrade
|
||||||
@ -2309,6 +2309,9 @@ exit 0
|
|||||||
%doc examples/systemtap
|
%doc examples/systemtap
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 17 2014 Cole Robinson <crobinso@redhat.com> - 1.2.8-3
|
||||||
|
- Fix preun script (bz #1142367)
|
||||||
|
|
||||||
* Mon Sep 15 2014 Cole Robinson <crobinso@redhat.com> - 1.2.8-2
|
* Mon Sep 15 2014 Cole Robinson <crobinso@redhat.com> - 1.2.8-2
|
||||||
- Generate non-colliding network IP range at RPM install time (bz #811967)
|
- Generate non-colliding network IP range at RPM install time (bz #811967)
|
||||||
- Fix directory creation at session daemon startup (bz #1139672)
|
- Fix directory creation at session daemon startup (bz #1139672)
|
||||||
|
Loading…
Reference in New Issue
Block a user