libvirt-7.5.0-1.el9

- Rebased to libvirt-7.5.0 (rhbz#1950948)
- The rebase also fixes the following bugs:
    rhbz#1949388, rhbz#1969354, rhbz#1970277, rhbz#1972145, rhbz#1973094
    rhbz#1975071, rhbz#1972468, rhbz#1975677

Resolves: rhbz#1949388, rhbz#1950948, rhbz#1969354, rhbz#1970277, rhbz#1972145
Resolves: rhbz#1972468, rhbz#1973094, rhbz#1975071, rhbz#1975677
This commit is contained in:
Jiri Denemark 2021-07-14 19:44:02 +02:00
parent ecfafb711e
commit 5e7679dbfe
11 changed files with 95 additions and 77 deletions

View File

@ -1,5 +1,5 @@
From 44a70fb199212fcfa762979d1dfa0a7b6f6eaa34 Mon Sep 17 00:00:00 2001
Message-Id: <44a70fb199212fcfa762979d1dfa0a7b6f6eaa34@dist-git>
From e764e6b0a72f5dae5457178661d88982017ff07d Mon Sep 17 00:00:00 2001
Message-Id: <e764e6b0a72f5dae5457178661d88982017ff07d@dist-git>
From: Peter Krempa <pkrempa@redhat.com>
Date: Mon, 16 Mar 2020 22:12:34 +0100
Subject: [PATCH] RHEL: Enable usage of x-blockdev-reopen
@ -53,18 +53,18 @@ index 6627d044cd..a531bdd704 100644
if (qemuDomainObjExitMonitor(driver, vm) < 0 || rc < 0)
return -1;
diff --git a/src/qemu/qemu_capabilities.c b/src/qemu/qemu_capabilities.c
index 75dd01f06e..9f33e57d8e 100644
index d1cd8f11ac..c663bf456e 100644
--- a/src/qemu/qemu_capabilities.c
+++ b/src/qemu/qemu_capabilities.c
@@ -630,6 +630,7 @@ VIR_ENUM_IMPL(virQEMUCaps,
"compat-deprecated",
"acpi-index",
"input-linux",
@@ -636,6 +636,7 @@ VIR_ENUM_IMPL(virQEMUCaps,
/* 405 */
"confidential-guest-support",
"query-display-options",
+ "blockdev-reopen.__com.redhat_rhel-av-8_2_0-api",
);
@@ -1544,6 +1545,7 @@ static struct virQEMUCapsDevicePropsFlags virQEMUCapsDevicePropsVhostUserFS[] =
@@ -1549,6 +1550,7 @@ static struct virQEMUCapsDevicePropsFlags virQEMUCapsDevicePropsVhostUserFS[] =
/* see documentation for virQEMUQAPISchemaPathGet for the query format */
static struct virQEMUCapsStringFlags virQEMUCapsQMPSchemaQueries[] = {
@ -72,7 +72,7 @@ index 75dd01f06e..9f33e57d8e 100644
{ "blockdev-add/arg-type/options/+gluster/debug-level", QEMU_CAPS_GLUSTER_DEBUG_LEVEL},
{ "blockdev-add/arg-type/+gluster/debug", QEMU_CAPS_GLUSTER_DEBUG_LEVEL},
{ "blockdev-add/arg-type/+vxhs", QEMU_CAPS_VXHS},
@@ -5192,6 +5194,15 @@ virQEMUCapsInitProcessCaps(virQEMUCaps *qemuCaps)
@@ -5191,6 +5193,15 @@ virQEMUCapsInitProcessCaps(virQEMUCaps *qemuCaps)
qemuCaps->arch == VIR_ARCH_MIPS)
virQEMUCapsSet(qemuCaps, QEMU_CAPS_SCSI_NCR53C90);
@ -89,13 +89,13 @@ index 75dd01f06e..9f33e57d8e 100644
}
diff --git a/src/qemu/qemu_capabilities.h b/src/qemu/qemu_capabilities.h
index 94f2fad05a..97448e54e3 100644
index 7944b9170a..a4792ebd27 100644
--- a/src/qemu/qemu_capabilities.h
+++ b/src/qemu/qemu_capabilities.h
@@ -610,6 +610,7 @@ typedef enum { /* virQEMUCapsFlags grouping marker for syntax-check */
QEMU_CAPS_COMPAT_DEPRECATED, /* -compat deprecated-(input|output) is supported */
QEMU_CAPS_ACPI_INDEX, /* PCI device 'acpi-index' property */
QEMU_CAPS_INPUT_LINUX, /* -object input-linux */
@@ -616,6 +616,7 @@ typedef enum { /* virQEMUCapsFlags grouping marker for syntax-check */
/* 405 */
QEMU_CAPS_MACHINE_CONFIDENTAL_GUEST_SUPPORT, /* -machine confidential-guest-support */
QEMU_CAPS_QUERY_DISPLAY_OPTIONS, /* 'query-display-options' qmp command present */
+ QEMU_CAPS_BLOCKDEV_REOPEN_COM_REDHAT_AV_8_2_0_API, /* downstream support for blockdev reopen in rhel-av-8.2.0 */
QEMU_CAPS_LAST /* this must always be the last item */
@ -137,10 +137,10 @@ index 6a25def78b..14bfbb600e 100644
int qemuMonitorBlockdevDel(qemuMonitor *mon,
const char *nodename);
diff --git a/src/qemu/qemu_monitor_json.c b/src/qemu/qemu_monitor_json.c
index 46aa3330a8..1a5c3a6f4d 100644
index 223777739d..6e7b28c6c7 100644
--- a/src/qemu/qemu_monitor_json.c
+++ b/src/qemu/qemu_monitor_json.c
@@ -8746,13 +8746,19 @@ qemuMonitorJSONBlockdevAdd(qemuMonitor *mon,
@@ -8704,13 +8704,19 @@ qemuMonitorJSONBlockdevAdd(qemuMonitor *mon,
int
qemuMonitorJSONBlockdevReopen(qemuMonitor *mon,
@ -178,5 +178,5 @@ index 01a3ba25f1..90792c9939 100644
int qemuMonitorJSONBlockdevDel(qemuMonitor *mon,
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From 74a928fc91e016d5b6628dcd6f7e005798d6836a Mon Sep 17 00:00:00 2001
Message-Id: <74a928fc91e016d5b6628dcd6f7e005798d6836a@dist-git>
From 482de1261b2cdb52eea365e8e6419be7d6e713ab Mon Sep 17 00:00:00 2001
Message-Id: <482de1261b2cdb52eea365e8e6419be7d6e713ab@dist-git>
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
Date: Mon, 27 Aug 2018 13:09:38 +0200
Subject: [PATCH] RHEL: Fix virConnectGetMaxVcpus output
@ -42,5 +42,5 @@ index bf7fda23af..0dfa56b8d7 100644
/* at first try KVM_CAP_MAX_VCPUS to determine the maximum count */
if ((ret = ioctl(fd, KVM_CHECK_EXTENSION, KVM_CAP_MAX_VCPUS)) > 0)
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From c4182edf706fda88e3f144de3c93983b7a6c21b5 Mon Sep 17 00:00:00 2001
Message-Id: <c4182edf706fda88e3f144de3c93983b7a6c21b5@dist-git>
From 34ded5c6dfa0d565901b80d60b3feeab7c13e4c0 Mon Sep 17 00:00:00 2001
Message-Id: <34ded5c6dfa0d565901b80d60b3feeab7c13e4c0@dist-git>
From: John Ferlan <jferlan@redhat.com>
Date: Mon, 17 Dec 2018 20:42:30 -0500
Subject: [PATCH] RHEL: qemu: Add ability to set sgio values for hostdev
@ -77,5 +77,5 @@ index 916a3d36ee..a749fc1bbc 100644
/* Do not do anything if unpriv_sgio is not supported by the kernel and the
* whitelist is enabled. But if requesting unfiltered access, always call
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From b7cd8139a3f7b09ccb99b36201f8df768fe4677e Mon Sep 17 00:00:00 2001
Message-Id: <b7cd8139a3f7b09ccb99b36201f8df768fe4677e@dist-git>
From e85d335bc6660dd3e8b86d7305e837c97da1b0b2 Mon Sep 17 00:00:00 2001
Message-Id: <e85d335bc6660dd3e8b86d7305e837c97da1b0b2@dist-git>
From: John Ferlan <jferlan@redhat.com>
Date: Mon, 17 Dec 2018 20:42:31 -0500
Subject: [PATCH] RHEL: qemu: Add check for unpriv sgio for SCSI generic host
@ -62,5 +62,5 @@ index a749fc1bbc..2beef89cd1 100644
qemuDriverLock(driver);
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From f959b3e81ab6fe0b5e311ea10293d1fd05365f40 Mon Sep 17 00:00:00 2001
Message-Id: <f959b3e81ab6fe0b5e311ea10293d1fd05365f40@dist-git>
From 277db698d2e33100be4007ff00ed59d122067827 Mon Sep 17 00:00:00 2001
Message-Id: <277db698d2e33100be4007ff00ed59d122067827@dist-git>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Fri, 6 Mar 2020 15:52:21 +0100
Subject: [PATCH] RHEL: virscsi: Check device type before getting it's /dev
@ -211,5 +211,5 @@ index 0000000000..573541ac97
@@ -0,0 +1 @@
+0
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From 4c0403b06ae7fa23fcf2f4dacab9fb5a57eb4985 Mon Sep 17 00:00:00 2001
Message-Id: <4c0403b06ae7fa23fcf2f4dacab9fb5a57eb4985@dist-git>
From ab13cb0cce89c6f77bf1530af787015bae71c5fa Mon Sep 17 00:00:00 2001
Message-Id: <ab13cb0cce89c6f77bf1530af787015bae71c5fa@dist-git>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Fri, 6 Mar 2020 15:52:23 +0100
Subject: [PATCH] RHEL: virscsi: Introduce and use
@ -30,10 +30,10 @@ Reviewed-by: Jiri Denemark <jdenemar@redhat.com>
6 files changed, 49 insertions(+), 31 deletions(-)
diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
index 0ced2a7990..de0d9b101d 100644
index 68e4b6aab8..5af3eec2e9 100644
--- a/src/libvirt_private.syms
+++ b/src/libvirt_private.syms
@@ -3156,6 +3156,7 @@ virSCSIDeviceGetSgName;
@@ -3159,6 +3159,7 @@ virSCSIDeviceGetSgName;
virSCSIDeviceGetShareable;
virSCSIDeviceGetTarget;
virSCSIDeviceGetUnit;
@ -166,10 +166,10 @@ index 65ad15ed76..5721985939 100644
virSCSIDevice *virSCSIDeviceNew(const char *sysfs_prefix,
const char *adapter,
diff --git a/src/util/virutil.c b/src/util/virutil.c
index 311cbbf93a..198ee8d591 100644
index 199d405286..50ed1cabab 100644
--- a/src/util/virutil.c
+++ b/src/util/virutil.c
@@ -1384,18 +1384,13 @@ virGetUnprivSGIOSysfsPath(const char *path,
@@ -1382,18 +1382,13 @@ virGetUnprivSGIOSysfsPath(const char *path,
int
virSetDeviceUnprivSGIO(const char *path,
@ -189,7 +189,7 @@ index 311cbbf93a..198ee8d591 100644
virReportError(VIR_ERR_OPERATION_INVALID, "%s",
_("unpriv_sgio is not supported by this kernel"));
goto cleanup;
@@ -1403,38 +1398,32 @@ virSetDeviceUnprivSGIO(const char *path,
@@ -1401,38 +1396,32 @@ virSetDeviceUnprivSGIO(const char *path,
val = g_strdup_printf("%d", unpriv_sgio);
@ -232,7 +232,7 @@ index 311cbbf93a..198ee8d591 100644
goto cleanup;
if ((tmp = strchr(buf, '\n')))
@@ -1442,13 +1431,12 @@ virGetDeviceUnprivSGIO(const char *path,
@@ -1440,13 +1429,12 @@ virGetDeviceUnprivSGIO(const char *path,
if (virStrToLong_i(buf, NULL, 10, unpriv_sgio) < 0) {
virReportError(VIR_ERR_INTERNAL_ERROR,
@ -263,5 +263,5 @@ index 854b494890..da267c6446 100644
char *virGetUnprivSGIOSysfsPath(const char *path,
const char *sysfs_dir);
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From 7284ac8d7fc2351bcf0c663dd8179c90eb2158bc Mon Sep 17 00:00:00 2001
Message-Id: <7284ac8d7fc2351bcf0c663dd8179c90eb2158bc@dist-git>
From 7ed1929b385b577f2b3c2a0faae3aa582555bf7b Mon Sep 17 00:00:00 2001
Message-Id: <7ed1929b385b577f2b3c2a0faae3aa582555bf7b@dist-git>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Fri, 6 Mar 2020 15:52:22 +0100
Subject: [PATCH] RHEL: virscsi: Support TAPEs in virSCSIDeviceGetDevName()
@ -197,5 +197,5 @@ index 0d7c35a261..0647bb4841 100644
ret = -1;
--
2.31.1
2.32.0

View File

@ -1,5 +1,5 @@
From 79a94d508777bfa7118ac7fe60eb1eb5143f3f70 Mon Sep 17 00:00:00 2001
Message-Id: <79a94d508777bfa7118ac7fe60eb1eb5143f3f70@dist-git>
From b6045e61d3402cccba88e1b3be55871603c61d4f Mon Sep 17 00:00:00 2001
Message-Id: <b6045e61d3402cccba88e1b3be55871603c61d4f@dist-git>
From: Michal Privoznik <mprivozn@redhat.com>
Date: Fri, 6 Mar 2020 15:52:24 +0100
Subject: [PATCH] RHEL: virutil: Accept non-block devices in virGetDeviceID()
@ -19,10 +19,10 @@ Reviewed-by: Jiri Denemark <jdenemar@redhat.com>
1 file changed, 3 deletions(-)
diff --git a/src/util/virutil.c b/src/util/virutil.c
index 198ee8d591..1e51cdf0cb 100644
index 50ed1cabab..2e5a6abff2 100644
--- a/src/util/virutil.c
+++ b/src/util/virutil.c
@@ -1340,9 +1340,6 @@ virGetDeviceID(const char *path, int *maj, int *min)
@@ -1338,9 +1338,6 @@ virGetDeviceID(const char *path, int *maj, int *min)
if (stat(path, &sb) < 0)
return -errno;
@ -33,5 +33,5 @@ index 198ee8d591..1e51cdf0cb 100644
*maj = major(sb.st_rdev);
if (min)
--
2.31.1
2.32.0

View File

@ -85,6 +85,10 @@
%endif
%define with_storage_iscsi_direct 0%{!?_without_storage_iscsi_direct:1}
# libiscsi has been dropped in RHEL-9
%if 0%{?rhel} > 8
%define with_storage_iscsi_direct 0
%endif
# Other optional features
%define with_numactl 0%{!?_without_numactl:1}
@ -196,7 +200,7 @@
Summary: Library providing a simple virtualization API
Name: libvirt
Version: 7.4.0
Version: 7.5.0
Release: 1%{?dist}%{?extra_release}
License: LGPLv2+
URL: https://libvirt.org/
@ -253,7 +257,6 @@ BuildRequires: ninja-build
BuildRequires: git
BuildRequires: perl-interpreter
BuildRequires: python3
BuildRequires: systemd-units
%if %{with_libxl}
BuildRequires: xen-devel
%endif
@ -418,10 +421,7 @@ Requires: polkit >= 0.112
Requires: dmidecode
%endif
# For service management
Requires(post): systemd-units
Requires(post): systemd-sysv
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): /usr/bin/systemctl
%if %{with_numad}
Requires: numad
%endif
@ -1125,11 +1125,14 @@ export SOURCE_DATE_EPOCH=$(stat --printf='%Y' %{_specdir}/%{name}.spec)
-Dsasl=enabled \
-Dpolkit=enabled \
-Ddriver_libvirtd=enabled \
-Ddriver_remote=enabled \
-Ddriver_test=enabled \
%{?arg_esx} \
%{?arg_hyperv} \
%{?arg_vmware} \
-Ddriver_vz=disabled \
-Ddriver_bhyve=disabled \
-Ddriver_ch=disabled \
-Dremote_default_mode=legacy \
-Ddriver_interface=enabled \
-Ddriver_network=enabled \
@ -1153,6 +1156,7 @@ export SOURCE_DATE_EPOCH=$(stat --printf='%Y' %{_specdir}/%{name}.spec)
-Dselinux=enabled \
%{?arg_selinux_mount} \
-Dapparmor=disabled \
-Dapparmor_profiles=disabled \
-Dsecdriver_apparmor=disabled \
-Dudev=enabled \
-Dyajl=enabled \
@ -1205,7 +1209,7 @@ rm -f $RPM_BUILD_ROOT%{wireshark_plugindir}/libvirt.la
%endif
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/lib/libvirt/dnsmasq/
# We don't want to install /etc/libvirt/qemu/networks in the main %files list
# We don't want to install /etc/libvirt/qemu/networks in the main %%files list
# because if the admin wants to delete the default network completely, we don't
# want to end up re-incarnating it on every RPM upgrade.
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/libvirt/networks/
@ -1214,7 +1218,7 @@ cp $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml \
# libvirt saves this file with mode 0600
chmod 0600 $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml
# nwfilter files are installed in /usr/share/libvirt and copied to /etc in %post
# nwfilter files are installed in /usr/share/libvirt and copied to /etc in %%post
# to avoid verification errors on changed files in /etc
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/libvirt/nwfilter/
cp -a $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/nwfilter/*.xml \
@ -1280,31 +1284,35 @@ getent group libvirt >/dev/null || groupadd -r libvirt
exit 0
%post daemon
%global post_units \\\
virtlockd.socket virtlockd-admin.socket \\\
virtlogd.socket virtlogd-admin.socket \\\
libvirtd.socket libvirtd-ro.socket libvirtd-admin.socket \\\
libvirtd-tcp.socket libvirtd-tls.socket \\\
libvirtd.service \\\
libvirt-guests.service
%systemd_post virtlockd.socket virtlockd-admin.socket
%systemd_post virtlogd.socket virtlogd-admin.socket
%systemd_post libvirtd.socket libvirtd-ro.socket libvirtd-admin.socket
%systemd_post libvirtd-tcp.socket libvirtd-tls.socket
%systemd_post libvirtd.service
%systemd_post libvirt-guests.service
%systemd_post %post_units
# request daemon restart in posttrans
mkdir -p %{_localstatedir}/lib/rpm-state/libvirt || :
touch %{_localstatedir}/lib/rpm-state/libvirt/restart || :
%preun daemon
%systemd_preun libvirtd.service
%systemd_preun libvirtd-tcp.socket libvirtd-tls.socket
%systemd_preun libvirtd.socket libvirtd-ro.socket libvirtd-admin.socket
%systemd_preun virtlogd.socket virtlogd-admin.socket virtlogd.service
%systemd_preun virtlockd.socket virtlockd-admin.socket virtlockd.service
%systemd_preun libvirt-guests.service
%global preun_units \\\
libvirtd.service \\\
libvirtd-tcp.socket libvirtd-tls.socket \\\
libvirtd.socket libvirtd-ro.socket libvirtd-admin.socket \\\
virtlogd.socket virtlogd-admin.socket virtlogd.service \\\
virtlockd.socket virtlockd-admin.socket virtlockd.service \\\
libvirt-guests.service
%systemd_preun %preun_units
%postun daemon
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
if [ $1 -ge 1 ] ; then
/bin/systemctl reload-or-try-restart virtlockd.service >/dev/null 2>&1 || :
/bin/systemctl reload-or-try-restart virtlogd.service >/dev/null 2>&1 || :
/bin/systemctl reload-or-try-restart virtlockd.service virtlogd.service >/dev/null 2>&1 || :
fi
%systemd_postun libvirt-guests.service
@ -1331,11 +1339,12 @@ if [ -f %{_localstatedir}/lib/rpm-state/libvirt/restart ]; then
# systemd socket activation, because switching things
# might confuse mgmt tool like puppet/ansible that
# expect the old style libvirtd
/bin/systemctl mask libvirtd.socket >/dev/null 2>&1 || :
/bin/systemctl mask libvirtd-ro.socket >/dev/null 2>&1 || :
/bin/systemctl mask libvirtd-admin.socket >/dev/null 2>&1 || :
/bin/systemctl mask libvirtd-tls.socket >/dev/null 2>&1 || :
/bin/systemctl mask libvirtd-tcp.socket >/dev/null 2>&1 || :
/bin/systemctl mask \
libvirtd.socket \
libvirtd-ro.socket \
libvirtd-admin.socket \
libvirtd-tls.socket \
libvirtd-tcp.socket >/dev/null 2>&1 || :
else
# Old libvirtd owns the sockets and will delete them on
# shutdown. Can't use a try-restart as libvirtd will simply
@ -1347,9 +1356,10 @@ if [ -f %{_localstatedir}/lib/rpm-state/libvirt/restart ]; then
then
/bin/systemctl stop libvirtd.service >/dev/null 2>&1 || :
/bin/systemctl try-restart libvirtd.socket >/dev/null 2>&1 || :
/bin/systemctl try-restart libvirtd-ro.socket >/dev/null 2>&1 || :
/bin/systemctl try-restart libvirtd-admin.socket >/dev/null 2>&1 || :
/bin/systemctl try-restart \
libvirtd.socket \
libvirtd-ro.socket \
libvirtd-admin.socket >/dev/null 2>&1 || :
/bin/systemctl start libvirtd.service >/dev/null 2>&1 || :
fi
@ -1919,6 +1929,12 @@ exit 0
%changelog
* Wed Jul 14 2021 Jiri Denemark <jdenemar@redhat.com> - 7.5.0-1
- Rebased to libvirt-7.5.0 (rhbz#1950948)
- The rebase also fixes the following bugs:
rhbz#1949388, rhbz#1969354, rhbz#1970277, rhbz#1972145, rhbz#1973094
rhbz#1975071, rhbz#1972468, rhbz#1975677
* Mon Jun 7 2021 Jiri Denemark <jdenemar@redhat.com> - 7.4.0-1
- Rebased to libvirt-7.4.0 (rhbz#1950948)
- The rebase also fixes the following bugs:

View File

@ -1 +1 @@
SHA512 (libvirt-7.4.0.tar.xz) = efe3fb2813613c3c5e94ed49d0cae4ad92cca6a727a8b55808d8c3bdfacb355642796dfab49362ee59654f9471f9134b96374ced50cc9b3227f4f1c6201bf7f1
SHA512 (libvirt-7.5.0.tar.xz) = cf89800c8970b8b1373ee32cc49ea88b87e76b50fd134df5da354be83e0ef490e514f16425c1c16eb3989fbadd3ba7d9976972fbbae6cb40db3d2ae94863219d

View File

@ -211,6 +211,7 @@ tests/qemuxml2xmloutdata/vhost-vsock-ccw-iommu.s390x-latest.xml ../qemuxml2argvd
tests/qemuxml2xmloutdata/vhost-vsock-ccw.xml ../qemuxml2argvdata/vhost-vsock-ccw.xml
tests/qemuxml2xmloutdata/vhost-vsock.xml ../qemuxml2argvdata/vhost-vsock.xml
tests/qemuxml2xmloutdata/video-qxl-resolution.xml ../qemuxml2argvdata/video-qxl-resolution.xml
tests/qemuxml2xmloutdata/video-virtio-vga-gpu-gl.x86_64-latest.xml ../qemuxml2argvdata/video-virtio-vga-gpu-gl.xml
tests/qemuxml2xmloutdata/virtio-options.x86_64-latest.xml ../qemuxml2argvdata/virtio-options.xml
tests/vircaps2xmldata/linux-basic-dies/system/cpu ../../../virhostcpudata/linux-with-die/cpu
tests/vircaps2xmldata/linux-basic-dies/system/node ../../../virhostcpudata/linux-with-die/node
@ -238,6 +239,7 @@ tests/vircaps2xmldata/linux-caches/system/node/node0/cpu4 ../../cpu/cpu4
tests/vircaps2xmldata/linux-caches/system/node/node0/cpu5 ../../cpu/cpu5
tests/vircaps2xmldata/linux-caches/system/node/node0/cpu6 ../../cpu/cpu6
tests/vircaps2xmldata/linux-caches/system/node/node0/cpu7 ../../cpu/cpu7
tests/vircaps2xmldata/linux-hmat/system/node/node0/access1/targets/node1 ../../../node1
tests/vircaps2xmldata/linux-resctrl-cdp/system ../linux-resctrl/system/
tests/vircaps2xmldata/linux-resctrl-cmt/system ../linux-resctrl/system
tests/vircaps2xmldata/linux-resctrl-fake-feature/system ../linux-resctrl/system