Release of 0.3.2, remove the old patch, Daniel
This commit is contained in:
parent
b2a1a0e9ba
commit
55fabd69c0
@ -20,3 +20,4 @@ libvirt-0.2.2.tar.gz
|
||||
libvirt-0.2.3.tar.gz
|
||||
libvirt-0.3.0.tar.gz
|
||||
libvirt-0.3.1.tar.gz
|
||||
libvirt-0.3.2.tar.gz
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -rup libvirt-0.3.1.orig/src/qemu_conf.c libvirt-0.3.1.new/src/qemu_conf.c
|
||||
--- libvirt-0.3.1.orig/src/qemu_conf.c 2007-07-24 11:06:38.000000000 -0400
|
||||
+++ libvirt-0.3.1.new/src/qemu_conf.c 2007-07-26 10:22:09.000000000 -0400
|
||||
@@ -1088,6 +1088,10 @@ static struct qemud_vm_def *qemudParseXM
|
||||
if ((obj == NULL) || (obj->type != XPATH_STRING) ||
|
||||
(obj->stringval == NULL) || (obj->stringval[0] == 0)) {
|
||||
const char *defaultMachine = qemudDefaultMachineForArch(def->os.arch);
|
||||
+ if (!defaultMachine) {
|
||||
+ qemudReportError(conn, NULL, NULL, VIR_ERR_INTERNAL_ERROR, "unsupported arch %s", def->os.arch);
|
||||
+ goto error;
|
||||
+ }
|
||||
if (strlen(defaultMachine) >= (QEMUD_OS_MACHINE_MAX_LEN-1)) {
|
||||
qemudReportError(conn, NULL, NULL, VIR_ERR_INTERNAL_ERROR, "%s", "machine type too long");
|
||||
goto error;
|
17
libvirt.spec
17
libvirt.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: Library providing a simple API virtualization
|
||||
Name: libvirt
|
||||
Version: 0.3.1
|
||||
Release: 4%{?dist}%{?extra_release}
|
||||
Version: 0.3.2
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: LGPL
|
||||
Group: Development/Libraries
|
||||
Source: libvirt-%{version}.tar.gz
|
||||
@ -24,7 +24,6 @@ BuildRequires: gettext
|
||||
BuildRequires: gnutls-devel
|
||||
Obsoletes: libvir
|
||||
ExclusiveArch: i386 x86_64 ia64
|
||||
Patch0: libvirt-qemu.patch
|
||||
|
||||
%description
|
||||
Libvirt is a C toolkit to interract with the virtualization capabilities
|
||||
@ -57,7 +56,6 @@ of recent versions of Linux (and other OSes).
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure --with-init-script=redhat --with-qemud-pid-file=%{_localstatedir}/run/libvirt_qemud.pid --with-remote-file=%{_localstatedir}/run/libvirtd.pid
|
||||
@ -138,8 +136,8 @@ fi
|
||||
%dir %attr(0700, root, root) %{_localstatedir}/log/libvirt/qemu/
|
||||
%attr(4755, root, root) %{_libexecdir}/libvirt_proxy
|
||||
%attr(0755, root, root) %{_sbindir}/libvirtd
|
||||
%doc docs/libvirt.rng
|
||||
%doc docs/network.rng
|
||||
%doc docs/*.rng
|
||||
%doc docs/*.xml
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root)
|
||||
@ -169,6 +167,13 @@ fi
|
||||
%doc docs/examples/python
|
||||
|
||||
%changelog
|
||||
* Tue Aug 21 2007 Daniel Veillard <veillard@redhat.com> - 0.3.2-1.fc8
|
||||
- Release of 0.3.2
|
||||
- API for domains migration
|
||||
- APIs for collecting statistics on disks and interfaces
|
||||
- lots of assorted bugfixes and cleanups
|
||||
- documentation and localization improvements
|
||||
|
||||
* Thu Aug 16 2007 Daniel Veillard <veillard@redhat.com> - 0.3.1-4.fc8
|
||||
- Fixes missing Requires for libvirt-devel
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user