Update to 1.3.1 release
This commit is contained in:
parent
cb71801a2b
commit
50e253df29
@ -1,52 +0,0 @@
|
||||
From ace1ee225f5cd87fb095054a6a19bdcd0fa57518 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Krempa <pkrempa@redhat.com>
|
||||
Date: Thu, 10 Dec 2015 14:36:51 +0100
|
||||
Subject: [PATCH] test: qemuxml2argv: Mock virMemoryMaxValue to remove 32/64
|
||||
bit difference
|
||||
|
||||
Always return LLONG_MAX even on 32 bit systems. The limitation
|
||||
originates from our use of "unsigned long" in several APIs. The internal
|
||||
data type is unsigned long long. Make the test suite deterministic by
|
||||
removing the architecture difference.
|
||||
|
||||
Flaw was introduced in 645881139b3d2c86acf9d644c3a1471520bc9e57 where
|
||||
I've added a test that uses too large numbers.
|
||||
---
|
||||
src/util/virutil.c | 2 ++
|
||||
tests/qemuxml2argvmock.c | 10 ++++++++++
|
||||
2 files changed, 12 insertions(+)
|
||||
|
||||
diff --git a/src/util/virutil.c b/src/util/virutil.c
|
||||
index 177f9d7..bb9604a 100644
|
||||
--- a/src/util/virutil.c
|
||||
+++ b/src/util/virutil.c
|
||||
@@ -2658,6 +2658,8 @@ virMemoryLimitIsSet(unsigned long long value)
|
||||
* @capped: whether the value must fit into unsigned long
|
||||
* (long long is assumed otherwise)
|
||||
*
|
||||
+ * Note: This function is mocked in tests/qemuxml2argvmock.c for test stability
|
||||
+ *
|
||||
* Returns the maximum possible memory value in bytes.
|
||||
*/
|
||||
unsigned long long
|
||||
diff --git a/tests/qemuxml2argvmock.c b/tests/qemuxml2argvmock.c
|
||||
index e58b8ce..8426108 100644
|
||||
--- a/tests/qemuxml2argvmock.c
|
||||
+++ b/tests/qemuxml2argvmock.c
|
||||
@@ -74,3 +74,13 @@ virTPMCreateCancelPath(const char *devpath)
|
||||
|
||||
return path;
|
||||
}
|
||||
+
|
||||
+/**
|
||||
+ * Large values for memory would fail on 32 bit systems, despite having
|
||||
+ * variables that support it.
|
||||
+ */
|
||||
+unsigned long long
|
||||
+virMemoryMaxValue(bool capped ATTRIBUTE_UNUSED)
|
||||
+{
|
||||
+ return LLONG_MAX;
|
||||
+}
|
||||
--
|
||||
2.5.0
|
||||
|
20
libvirt.spec
20
libvirt.spec
@ -377,7 +377,7 @@
|
||||
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 1.3.0
|
||||
Version: 1.3.1
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
@ -388,7 +388,6 @@ URL: http://libvirt.org/
|
||||
%define mainturl stable_updates/
|
||||
%endif
|
||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.gz
|
||||
Patch1: 0001-test-qemuxml2argv-Mock-virMemoryMaxValue-to-remove-3.patch
|
||||
|
||||
%if %{with_libvirtd}
|
||||
Requires: libvirt-daemon = %{version}-%{release}
|
||||
@ -648,8 +647,8 @@ BuildRequires: util-linux
|
||||
BuildRequires: nfs-utils
|
||||
%endif
|
||||
|
||||
%if %{with_firewalld}
|
||||
# Communication with the firewall daemon uses DBus
|
||||
%if %{with_firewalld} || %{with_polkit}
|
||||
# Communication with the firewall and polkit daemons use DBus
|
||||
BuildRequires: dbus-devel
|
||||
%endif
|
||||
|
||||
@ -1548,10 +1547,8 @@ rm -fr %{buildroot}
|
||||
# on RHEL 5, thus we need to expand it here.
|
||||
make install DESTDIR=%{?buildroot} SYSTEMD_UNIT_DIR=%{_unitdir}
|
||||
|
||||
for i in object-events dominfo domsuspend hellolibvirt openauth xml/nwfilter systemtap dommigrate domtop rename
|
||||
do
|
||||
(cd examples/$i ; make clean ; rm -rf .deps .libs Makefile Makefile.in)
|
||||
done
|
||||
make -C examples distclean
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.la
|
||||
@ -1793,9 +1790,9 @@ if [ $1 -ge 1 ] ; then
|
||||
/bin/systemctl start virtlogd.socket || :
|
||||
%else
|
||||
/sbin/chkconfig libvirtd 1>/dev/null 2>&1 &&
|
||||
/bin/chkconfig virtlogd on || :
|
||||
/sbin/chkconfig virtlogd on || :
|
||||
/sbin/service libvirtd status 1>/dev/null 2>&1 &&
|
||||
/bin/service virtlogd start || :
|
||||
/sbin/service virtlogd start || :
|
||||
%endif
|
||||
fi
|
||||
|
||||
@ -2380,6 +2377,9 @@ exit 0
|
||||
%doc examples/systemtap
|
||||
|
||||
%changelog
|
||||
* Tue Jan 19 2016 Daniel Berrange <berrange@redhat.com> - 1.3.1-1
|
||||
- Update to 1.3.1 release
|
||||
|
||||
* Wed Dec 9 2015 Daniel Berrange <berrange@redhat.com> - 1.3.0-1
|
||||
- Update to 1.3.0 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user