Upstream release of 0.9.9
This commit is contained in:
parent
f9de2f6bc6
commit
4e460d5f09
@ -1,81 +0,0 @@
|
|||||||
commit 455c85302f4ed14c7cd953d10cdfbb0efeccd7ed
|
|
||||||
Author: Daniel P. Berrange <berrange@redhat.com>
|
|
||||||
Date: Thu Dec 8 13:30:24 2011 +0000
|
|
||||||
|
|
||||||
Fix installation of libvirt-guests.service
|
|
||||||
|
|
||||||
The installation rules for the libvirt-guests.service were
|
|
||||||
totally broken
|
|
||||||
|
|
||||||
- Installing in the wrong location
|
|
||||||
- The location was not overridable
|
|
||||||
- The install-systemd rule was not invoked anywhere
|
|
||||||
- The install-systemd rule was not invoking install-initscript
|
|
||||||
which it depends on
|
|
||||||
- The installed service file lacked a .service extension
|
|
||||||
|
|
||||||
* tools/Makefile.am: Fix install of libvirt-guests.service
|
|
||||||
|
|
||||||
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
|
||||||
index c735398..25f0ffe 100644
|
|
||||||
--- a/tools/Makefile.am
|
|
||||||
+++ b/tools/Makefile.am
|
|
||||||
@@ -148,9 +148,9 @@ endif
|
|
||||||
virsh.1: virsh.pod
|
|
||||||
$(AM_V_GEN)$(POD2MAN) $< $(srcdir)/$@
|
|
||||||
|
|
||||||
-install-data-local: install-init
|
|
||||||
+install-data-local: install-init install-systemd
|
|
||||||
|
|
||||||
-uninstall-local: uninstall-init
|
|
||||||
+uninstall-local: uninstall-init uninstall-systemd
|
|
||||||
|
|
||||||
install-sysconfig:
|
|
||||||
mkdir -p $(DESTDIR)$(sysconfdir)/sysconfig
|
|
||||||
@@ -162,17 +162,20 @@ uninstall-sysconfig:
|
|
||||||
|
|
||||||
EXTRA_DIST += libvirt-guests.init.sh
|
|
||||||
|
|
||||||
-if LIBVIRT_INIT_SCRIPT_RED_HAT
|
|
||||||
-install-init: libvirt-guests.init install-sysconfig
|
|
||||||
+install-initscript: libvirt-guests.init
|
|
||||||
mkdir -p $(DESTDIR)$(sysconfdir)/rc.d/init.d
|
|
||||||
$(INSTALL_SCRIPT) libvirt-guests.init \
|
|
||||||
$(DESTDIR)$(sysconfdir)/rc.d/init.d/libvirt-guests
|
|
||||||
|
|
||||||
-uninstall-init: install-sysconfig
|
|
||||||
+uninstall-initscript:
|
|
||||||
rm -f $(DESTDIR)$(sysconfdir)/rc.d/init.d/libvirt-guests
|
|
||||||
|
|
||||||
-BUILT_SOURCES += libvirt-guests.init
|
|
||||||
|
|
||||||
+
|
|
||||||
+if LIBVIRT_INIT_SCRIPT_RED_HAT
|
|
||||||
+BUILT_SOURCES += libvirt-guests.init
|
|
||||||
+install-init: install-sysconfig install-initscript
|
|
||||||
+uninstall-init: uninstall-sysconfig uninstall-initscript
|
|
||||||
else
|
|
||||||
install-init:
|
|
||||||
uninstall-init:
|
|
||||||
@@ -194,14 +197,16 @@ libvirt-guests.init: libvirt-guests.init.sh $(top_builddir)/config.status
|
|
||||||
|
|
||||||
EXTRA_DIST += libvirt-guests.service.in
|
|
||||||
|
|
||||||
+SYSTEMD_UNIT_DIR = /lib/systemd/system
|
|
||||||
+
|
|
||||||
if LIBVIRT_INIT_SCRIPT_SYSTEMD
|
|
||||||
-install-systemd: libvirt-guests.service install-sysconfig
|
|
||||||
- mkdir -p $(DESTDIR)$(sysconfdir)/rc.d/systemd.d
|
|
||||||
+install-systemd: libvirt-guests.service install-initscript install-sysconfig
|
|
||||||
+ mkdir -p $(DESTDIR)$(SYSTEMD_UNIT_DIR)
|
|
||||||
$(INSTALL_SCRIPT) libvirt-guests.service \
|
|
||||||
- $(DESTDIR)$(sysconfdir)/rc.d/systemd.d/libvirt-guests
|
|
||||||
+ $(DESTDIR)$(SYSTEMD_UNIT_DIR)/libvirt-guests.service
|
|
||||||
|
|
||||||
-uninstall-systemd: install-sysconfig
|
|
||||||
- rm -f $(DESTDIR)$(sysconfdir)/rc.d/systemd.d/libvirt-guests
|
|
||||||
+uninstall-systemd: uninstall-initscript uninstall-sysconfig
|
|
||||||
+ rm -f $(DESTDIR)$(SYSTEMD_UNIT_DIR)/libvirt-guests.service
|
|
||||||
|
|
||||||
BUILT_SOURCES += libvirt-guests.service
|
|
||||||
|
|
28
libvirt.spec
28
libvirt.spec
@ -11,7 +11,7 @@
|
|||||||
# Default to skipping autoreconf. Distros can change just this one line
|
# Default to skipping autoreconf. Distros can change just this one line
|
||||||
# (or provide a command-line override) if they backport any patches that
|
# (or provide a command-line override) if they backport any patches that
|
||||||
# touch configure.ac or Makefile.am.
|
# touch configure.ac or Makefile.am.
|
||||||
%define enable_autotools %{?enable_autotools:1}
|
%{!?enable_autotools:%define enable_autotools 0}
|
||||||
|
|
||||||
# A client only build will create a libvirt.so only containing
|
# A client only build will create a libvirt.so only containing
|
||||||
# the generic RPC driver, and test driver and no libvirtd
|
# the generic RPC driver, and test driver and no libvirtd
|
||||||
@ -147,7 +147,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Fedora doesn't have new enough Xen for libxl until F16
|
# Fedora doesn't have new enough Xen for libxl until F16
|
||||||
%if 0%{?fedora} < 16
|
%if 0%{?fedora} && 0%{?fedora} < 16
|
||||||
%define with_libxl 0
|
%define with_libxl 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -184,7 +184,7 @@
|
|||||||
%define with_sanlock 0%{!?_without_sanlock:%{server_drivers}}
|
%define with_sanlock 0%{!?_without_sanlock:%{server_drivers}}
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?rhel} >= 6
|
%if 0%{?rhel} >= 6
|
||||||
%ifnarch i386 i586 i686 x86_64
|
%ifarch i386 i586 i686 x86_64
|
||||||
%define with_sanlock 0%{!?_without_sanlock:%{server_drivers}}
|
%define with_sanlock 0%{!?_without_sanlock:%{server_drivers}}
|
||||||
%endif
|
%endif
|
||||||
%endif
|
%endif
|
||||||
@ -251,12 +251,11 @@
|
|||||||
|
|
||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.9.8
|
Version: 0.9.9
|
||||||
Release: 2%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: http://libvirt.org/sources/libvirt-%{version}.tar.gz
|
Source: http://libvirt.org/sources/libvirt-%{version}.tar.gz
|
||||||
Patch1: %{name}-%{version}-systemd-libvirt-guests.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
URL: http://libvirt.org/
|
URL: http://libvirt.org/
|
||||||
|
|
||||||
@ -273,6 +272,9 @@ Requires: %{name}-client = %{version}-%{release}
|
|||||||
Requires: module-init-tools
|
Requires: module-init-tools
|
||||||
# for /sbin/ip & /sbin/tc
|
# for /sbin/ip & /sbin/tc
|
||||||
Requires: iproute
|
Requires: iproute
|
||||||
|
%if %{with_avahi}
|
||||||
|
Requires: avahi
|
||||||
|
%endif
|
||||||
%endif
|
%endif
|
||||||
%if %{with_network}
|
%if %{with_network}
|
||||||
Requires: dnsmasq >= 2.41
|
Requires: dnsmasq >= 2.41
|
||||||
@ -302,7 +304,7 @@ Requires: PolicyKit >= 0.6
|
|||||||
%if %{with_storage_fs}
|
%if %{with_storage_fs}
|
||||||
Requires: nfs-utils
|
Requires: nfs-utils
|
||||||
# For mkfs
|
# For mkfs
|
||||||
Requires: util-linux
|
Requires: util-linux-ng
|
||||||
# For pool-build probing for existing pools
|
# For pool-build probing for existing pools
|
||||||
BuildRequires: libblkid-devel >= 2.17
|
BuildRequires: libblkid-devel >= 2.17
|
||||||
# For glusterfs
|
# For glusterfs
|
||||||
@ -356,9 +358,9 @@ Requires(postun): systemd-units
|
|||||||
|
|
||||||
# All build-time requirements
|
# All build-time requirements
|
||||||
%if 0%{?enable_autotools}
|
%if 0%{?enable_autotools}
|
||||||
BuildRequires: gettext-devel
|
|
||||||
BuildRequires: autoconf
|
BuildRequires: autoconf
|
||||||
BuildRequires: automake
|
BuildRequires: automake
|
||||||
|
BuildRequires: gettext-devel
|
||||||
BuildRequires: libtool
|
BuildRequires: libtool
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
@ -585,7 +587,6 @@ of recent versions of Linux (and other OSes).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if ! %{with_xen}
|
%if ! %{with_xen}
|
||||||
@ -954,7 +955,7 @@ fi
|
|||||||
%if %{with_cgconfig}
|
%if %{with_cgconfig}
|
||||||
# Starting with Fedora 16, systemd automounts all cgroups, and cgconfig is
|
# Starting with Fedora 16, systemd automounts all cgroups, and cgconfig is
|
||||||
# no longer a necessary service.
|
# no longer a necessary service.
|
||||||
%if 0%{?fedora} <= 15 || 0%{?rhel} <= 6
|
%if 0%{?rhel} || (0%{?fedora} && 0%{?fedora} < 16)
|
||||||
if [ "$1" -eq "1" ]; then
|
if [ "$1" -eq "1" ]; then
|
||||||
/sbin/chkconfig cgconfig on
|
/sbin/chkconfig cgconfig on
|
||||||
fi
|
fi
|
||||||
@ -1273,6 +1274,13 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/sysctl.d/libvirtd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 7 2012 Daniel Veillard <veillard@redhat.com> - 0.9.9-1
|
||||||
|
- Add API virDomain{S,G}etInterfaceParameters
|
||||||
|
- Add API virDomain{G, S}etNumaParameters
|
||||||
|
- Add support for ppc64 qemu
|
||||||
|
- Support Xen domctl v8
|
||||||
|
- many improvements and bug fixes
|
||||||
|
|
||||||
* Thu Dec 8 2011 Daniel P. Berrange <berrange@redhat.com> - 0.9.8-2
|
* Thu Dec 8 2011 Daniel P. Berrange <berrange@redhat.com> - 0.9.8-2
|
||||||
- Fix install of libvirt-guests.service & libvirtd.service
|
- Fix install of libvirt-guests.service & libvirtd.service
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user