Update to 1.0.2 release
This commit is contained in:
parent
1b71b68bb9
commit
350081d1a9
40
0001-complete-virterror-virerror-name-change.patch
Normal file
40
0001-complete-virterror-virerror-name-change.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From a6b8bae5a6a4752926eba409202ec061d81c6c8a Mon Sep 17 00:00:00 2001
|
||||
From: Serge Hallyn <serge.hallyn@canonical.com>
|
||||
Date: Wed, 30 Jan 2013 21:05:45 -0600
|
||||
Subject: [PATCH] complete virterror->virerror name change
|
||||
|
||||
Without these two string changes in generator.py, the
|
||||
virGetLastError wrapper does not get created in
|
||||
/usr/share/pyshared/libvirt.py. Noticed when running
|
||||
tests with virt-install.
|
||||
|
||||
Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
|
||||
---
|
||||
python/generator.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/python/generator.py b/python/generator.py
|
||||
index 5d27f66..71ca883 100755
|
||||
--- a/python/generator.py
|
||||
+++ b/python/generator.py
|
||||
@@ -123,7 +123,7 @@ class docParser(xml.sax.handler.ContentHandler):
|
||||
self.function_return_field = attrs['field']
|
||||
elif tag == 'enum':
|
||||
if (attrs['file'] == "libvirt" or
|
||||
- attrs['file'] == "virterror"):
|
||||
+ attrs['file'] == "virerror"):
|
||||
enum(attrs['type'],attrs['name'],attrs['value'])
|
||||
elif attrs['file'] == "libvirt-lxc":
|
||||
lxc_enum(attrs['type'],attrs['name'],attrs['value'])
|
||||
@@ -137,7 +137,7 @@ class docParser(xml.sax.handler.ContentHandler):
|
||||
if self.function != None:
|
||||
if (self.function_module == "libvirt" or
|
||||
self.function_module == "virevent" or
|
||||
- self.function_module == "virterror"):
|
||||
+ self.function_module == "virerror"):
|
||||
function(self.function, self.function_descr,
|
||||
self.function_return, self.function_args,
|
||||
self.function_file, self.function_module,
|
||||
--
|
||||
1.8.1
|
||||
|
@ -1,31 +0,0 @@
|
||||
From bb19491cf5e3b78f2d72bbcbcc06e985d29b7f4b Mon Sep 17 00:00:00 2001
|
||||
From: Peter Krempa <pkrempa@redhat.com>
|
||||
Date: Fri, 11 Jan 2013 11:10:34 +0100
|
||||
Subject: [PATCH] network: bridge: Fix regression when defining persistent
|
||||
networks
|
||||
|
||||
Commit 0211fd6e04cdc402da20818df54299c6ded3d3cb introduced regression
|
||||
where newly defined networks were not made persistent.
|
||||
|
||||
This patch makes the network persistent on each successful definition.
|
||||
---
|
||||
src/network/bridge_driver.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/network/bridge_driver.c b/src/network/bridge_driver.c
|
||||
index 660c38d..975b7f6 100644
|
||||
--- a/src/network/bridge_driver.c
|
||||
+++ b/src/network/bridge_driver.c
|
||||
@@ -3124,6 +3124,9 @@ static virNetworkPtr networkDefine(virConnectPtr conn, const char *xml) {
|
||||
goto cleanup;
|
||||
}
|
||||
|
||||
+ /* define makes the network persistent - always */
|
||||
+ network->persistent = 1;
|
||||
+
|
||||
/* def was asigned */
|
||||
freeDef = false;
|
||||
|
||||
--
|
||||
1.8.1
|
||||
|
@ -1,55 +0,0 @@
|
||||
From 46532e3e8ed5f5a736a02f67d6c805492f9ca720 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Krempa <pkrempa@redhat.com>
|
||||
Date: Fri, 4 Jan 2013 16:15:04 +0100
|
||||
Subject: [PATCH] rpc: Fix crash on error paths of message dispatching
|
||||
|
||||
This patch resolves CVE-2013-0170:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=893450
|
||||
|
||||
When reading and dispatching of a message failed the message was freed
|
||||
but wasn't removed from the message queue.
|
||||
|
||||
After that when the connection was about to be closed the pointer for
|
||||
the message was still present in the queue and it was passed to
|
||||
virNetMessageFree which tried to call the callback function from an
|
||||
uninitialized pointer.
|
||||
|
||||
This patch removes the message from the queue before it's freed.
|
||||
|
||||
* rpc/virnetserverclient.c: virNetServerClientDispatchRead:
|
||||
- avoid use after free of RPC messages
|
||||
---
|
||||
src/rpc/virnetserverclient.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/rpc/virnetserverclient.c b/src/rpc/virnetserverclient.c
|
||||
index af0560e..446e1e9 100644
|
||||
--- a/src/rpc/virnetserverclient.c
|
||||
+++ b/src/rpc/virnetserverclient.c
|
||||
@@ -987,6 +987,7 @@ readmore:
|
||||
|
||||
/* Decode the header so we can use it for routing decisions */
|
||||
if (virNetMessageDecodeHeader(msg) < 0) {
|
||||
+ virNetMessageQueueServe(&client->rx);
|
||||
virNetMessageFree(msg);
|
||||
client->wantClose = true;
|
||||
return;
|
||||
@@ -996,6 +997,7 @@ readmore:
|
||||
* file descriptors */
|
||||
if (msg->header.type == VIR_NET_CALL_WITH_FDS &&
|
||||
virNetMessageDecodeNumFDs(msg) < 0) {
|
||||
+ virNetMessageQueueServe(&client->rx);
|
||||
virNetMessageFree(msg);
|
||||
client->wantClose = true;
|
||||
return; /* Error */
|
||||
@@ -1005,6 +1007,7 @@ readmore:
|
||||
for (i = msg->donefds ; i < msg->nfds ; i++) {
|
||||
int rv;
|
||||
if ((rv = virNetSocketRecvFD(client->sock, &(msg->fds[i]))) < 0) {
|
||||
+ virNetMessageQueueServe(&client->rx);
|
||||
virNetMessageFree(msg);
|
||||
client->wantClose = true;
|
||||
return;
|
||||
--
|
||||
1.8.1
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 1bf661caf4e926efcad6e85151a587cea5fd29f4 Mon Sep 17 00:00:00 2001
|
||||
From: Eric Blake <eblake@redhat.com>
|
||||
Date: Mon, 14 Jan 2013 10:47:41 -0700
|
||||
Subject: [PATCH] build: further fixes for broken if_bridge.h
|
||||
|
||||
Commit c308a9ae was incomplete; it resolved the configure failure,
|
||||
but not a later build failure.
|
||||
|
||||
* src/util/virnetdevbridge.c: Include pre-req header.
|
||||
* configure.ac (AC_CHECK_HEADERS): Prefer standard in.h over
|
||||
non-standard ip6.h.
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
src/util/virnetdevbridge.c | 3 ++-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 3ab3c4e..712918f 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -979,7 +979,7 @@ if test "$with_linux" = "yes"; then
|
||||
if test "$with_qemu" = "yes" || test "$with_lxc" = "yes" ; then
|
||||
AC_CHECK_HEADERS([linux/param.h linux/sockios.h linux/if_bridge.h linux/if_tun.h],,
|
||||
[AC_MSG_ERROR([You must install kernel-headers in order to compile libvirt with QEMU or LXC support])],
|
||||
- [[#include <netinet/ip6.h>
|
||||
+ [[#include <netinet/in.h>
|
||||
]])
|
||||
fi
|
||||
fi
|
||||
diff --git a/src/util/virnetdevbridge.c b/src/util/virnetdevbridge.c
|
||||
index b87c601..3c00be9 100644
|
||||
--- a/src/util/virnetdevbridge.c
|
||||
+++ b/src/util/virnetdevbridge.c
|
||||
@@ -1,5 +1,5 @@
|
||||
/*
|
||||
- * Copyright (C) 2007-2012 Red Hat, Inc.
|
||||
+ * Copyright (C) 2007-2013 Red Hat, Inc.
|
||||
*
|
||||
* This library is free software; you can redistribute it and/or
|
||||
* modify it under the terms of the GNU Lesser General Public
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
#include <net/if.h>
|
||||
+#include <netinet/in.h>
|
||||
|
||||
#ifdef __linux__
|
||||
# include <linux/sockios.h>
|
||||
--
|
||||
1.8.0.2
|
||||
|
@ -1,43 +0,0 @@
|
||||
From c308a9ae153db619fc0366bad9fd8f6c49cfac58 Mon Sep 17 00:00:00 2001
|
||||
From: Eric Blake <eblake@redhat.com>
|
||||
Date: Mon, 14 Jan 2013 09:54:25 -0700
|
||||
Subject: [PATCH] build: work around broken kernel header
|
||||
|
||||
I got this scary warning during ./configure on rawhide:
|
||||
|
||||
checking linux/if_bridge.h usability... no
|
||||
checking linux/if_bridge.h presence... yes
|
||||
configure: WARNING: linux/if_bridge.h: present but cannot be compiled
|
||||
configure: WARNING: linux/if_bridge.h: check for missing prerequisite headers?
|
||||
configure: WARNING: linux/if_bridge.h: see the Autoconf documentation
|
||||
configure: WARNING: linux/if_bridge.h: section "Present But Cannot Be Compiled"
|
||||
configure: WARNING: linux/if_bridge.h: proceeding with the compiler's result
|
||||
configure: WARNING: ## ------------------------------------- ##
|
||||
configure: WARNING: ## Report this to libvir-list@redhat.com ##
|
||||
configure: WARNING: ## ------------------------------------- ##
|
||||
checking for linux/if_bridge.h... no
|
||||
|
||||
* configure.ac (AC_CHECK_HEADERS): Provide struct in6_addr, since
|
||||
linux/if_bridge.h uses it without declaring it.
|
||||
---
|
||||
configure.ac | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 8a424e7..1d0add5 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -978,7 +978,9 @@ dnl
|
||||
if test "$with_linux" = "yes"; then
|
||||
if test "$with_qemu" = "yes" || test "$with_lxc" = "yes" ; then
|
||||
AC_CHECK_HEADERS([linux/param.h linux/sockios.h linux/if_bridge.h linux/if_tun.h],,
|
||||
- AC_MSG_ERROR([You must install kernel-headers in order to compile libvirt with QEMU or LXC support]))
|
||||
+ [AC_MSG_ERROR([You must install kernel-headers in order to compile libvirt with QEMU or LXC support])],
|
||||
+ [[#include <netinet/ip6.h>
|
||||
+ ]])
|
||||
fi
|
||||
fi
|
||||
|
||||
--
|
||||
1.8.0.2
|
||||
|
912
libvirt.spec
912
libvirt.spec
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user