Update to 3.0.0 release
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
This commit is contained in:
parent
6e7bca6631
commit
2c49d1fd11
34
0001-Disable-use-of-namespaces-by-default.patch
Normal file
34
0001-Disable-use-of-namespaces-by-default.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From ec9c065d405a129d3d33abd3d10d8a7ff1a49420 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Daniel P. Berrange" <berrange@redhat.com>
|
||||||
|
Date: Wed, 18 Jan 2017 10:48:12 +0000
|
||||||
|
Subject: [PATCH] Disable use of namespaces by default
|
||||||
|
|
||||||
|
When namespaces are enabled there is currently breakage when
|
||||||
|
using disk hotplug and when using AppArmor
|
||||||
|
|
||||||
|
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
||||||
|
---
|
||||||
|
src/qemu/qemu_conf.c | 7 -------
|
||||||
|
1 file changed, 7 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/qemu/qemu_conf.c b/src/qemu/qemu_conf.c
|
||||||
|
index 6613d59..aa05b46 100644
|
||||||
|
--- a/src/qemu/qemu_conf.c
|
||||||
|
+++ b/src/qemu/qemu_conf.c
|
||||||
|
@@ -317,13 +317,6 @@ virQEMUDriverConfigPtr virQEMUDriverConfigNew(bool privileged)
|
||||||
|
if (!(cfg->namespaces = virBitmapNew(QEMU_DOMAIN_NS_LAST)))
|
||||||
|
goto error;
|
||||||
|
|
||||||
|
-#if defined(__linux__)
|
||||||
|
- if (privileged &&
|
||||||
|
- virProcessNamespaceAvailable(VIR_PROCESS_NAMESPACE_MNT) == 0 &&
|
||||||
|
- virBitmapSetBit(cfg->namespaces, QEMU_DOMAIN_NS_MOUNT) < 0)
|
||||||
|
- goto error;
|
||||||
|
-#endif /* defined(__linux__) */
|
||||||
|
-
|
||||||
|
#ifdef DEFAULT_LOADER_NVRAM
|
||||||
|
if (virFirmwareParseList(DEFAULT_LOADER_NVRAM,
|
||||||
|
&cfg->firmwares,
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
@ -1,47 +0,0 @@
|
|||||||
From 93c2b9d2f01e878ed86566620130089aba61580f Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Daniel P. Berrange" <berrange@redhat.com>
|
|
||||||
Date: Mon, 5 Dec 2016 11:47:04 +0000
|
|
||||||
Subject: [PATCH] tests: blacklist gnutls 3.5.6 for wildcard tests
|
|
||||||
|
|
||||||
GNUTLS 3.5.6 broke wildcard support by reversing the
|
|
||||||
fields in the reported dname. This regression will
|
|
||||||
be fixed in 3.5.7, so rather than workaround it in
|
|
||||||
libvirt we just blacklist that version
|
|
||||||
|
|
||||||
https://lists.gnupg.org/pipermail/gnutls-devel/2016-November/008224.html
|
|
||||||
|
|
||||||
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
|
||||||
---
|
|
||||||
tests/virnettlssessiontest.c | 9 +++++++++
|
|
||||||
1 file changed, 9 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/virnettlssessiontest.c b/tests/virnettlssessiontest.c
|
|
||||||
index 0d2e106..b146072 100644
|
|
||||||
--- a/tests/virnettlssessiontest.c
|
|
||||||
+++ b/tests/virnettlssessiontest.c
|
|
||||||
@@ -374,6 +374,14 @@ mymain(void)
|
|
||||||
DO_SESS_TEST(cacertreq.filename, servercertalt2req.filename, clientcertreq.filename,
|
|
||||||
false, false, "wiki.libvirt.org", NULL);
|
|
||||||
|
|
||||||
+#if GNUTLS_VERSION_NUMBER != 0x030506
|
|
||||||
+ /*
|
|
||||||
+ * GNUTLS 3.5.6 broke wildcard support by reversing the
|
|
||||||
+ * fields in the reported dname. This regression will
|
|
||||||
+ * be fixed in 3.5.7, so rather than workaround it in
|
|
||||||
+ * libvirt we just blacklist that version
|
|
||||||
+ * https://lists.gnupg.org/pipermail/gnutls-devel/2016-November/008224.html
|
|
||||||
+ */
|
|
||||||
const char *const wildcards1[] = {
|
|
||||||
"C=UK,CN=dogfood",
|
|
||||||
NULL,
|
|
||||||
@@ -412,6 +420,7 @@ mymain(void)
|
|
||||||
false, false, "libvirt.org", wildcards5);
|
|
||||||
DO_SESS_TEST(cacertreq.filename, servercertreq.filename, clientcertreq.filename,
|
|
||||||
false, false, "libvirt.org", wildcards6);
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
TLS_ROOT_REQ(cacertrootreq,
|
|
||||||
"UK", "libvirt root", NULL, NULL, NULL, NULL,
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
17
libvirt.spec
17
libvirt.spec
@ -226,8 +226,8 @@
|
|||||||
|
|
||||||
Summary: Library providing a simple virtualization API
|
Summary: Library providing a simple virtualization API
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 2.5.0
|
Version: 3.0.0
|
||||||
Release: 3%{?dist}%{?extra_release}
|
Release: 1%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||||
@ -237,10 +237,9 @@ URL: http://libvirt.org/
|
|||||||
%define mainturl stable_updates/
|
%define mainturl stable_updates/
|
||||||
%endif
|
%endif
|
||||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||||
# Temporarily disable wildcard tests due to gnutls 3.5.6
|
# Temporarily disable namespaces due to various regressions
|
||||||
# regression. Remove when gnutls 3.5.7 arrives
|
# they cause
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1394318
|
Patch1: 0001-Disable-use-of-namespaces-by-default.patch
|
||||||
Patch1: 0001-tests-blacklist-gnutls-3.5.6-for-wildcard-tests.patch
|
|
||||||
|
|
||||||
Requires: libvirt-daemon = %{version}-%{release}
|
Requires: libvirt-daemon = %{version}-%{release}
|
||||||
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
||||||
@ -1849,6 +1848,8 @@ exit 0
|
|||||||
|
|
||||||
%{_datadir}/libvirt/cpu_map.xml
|
%{_datadir}/libvirt/cpu_map.xml
|
||||||
|
|
||||||
|
%{_datadir}/libvirt/test-screenshot.png
|
||||||
|
|
||||||
%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
|
%config(noreplace) %{_sysconfdir}/sasl2/libvirt.conf
|
||||||
|
|
||||||
%files admin
|
%files admin
|
||||||
@ -1863,6 +1864,7 @@ exit 0
|
|||||||
|
|
||||||
%files nss
|
%files nss
|
||||||
%{_libdir}/libnss_libvirt.so.2
|
%{_libdir}/libnss_libvirt.so.2
|
||||||
|
%{_libdir}/libnss_libvirt_guest.so.2
|
||||||
|
|
||||||
%if %{with_lxc}
|
%if %{with_lxc}
|
||||||
%files login-shell
|
%files login-shell
|
||||||
@ -1909,6 +1911,9 @@ exit 0
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 19 2017 Daniel P. Berrange <berrange@redhat.com> - 3.0.0-1
|
||||||
|
- Rebase to version 3.0.0
|
||||||
|
|
||||||
* Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.5.0-3
|
* Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 2.5.0-3
|
||||||
- Rebuild for readline 7.x
|
- Rebuild for readline 7.x
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user