* Thu Apr 16 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-2.fc12
- Fix qemu drive format specification (#496092)
This commit is contained in:
parent
f5edf79c95
commit
1e2f9fce0a
26
libvirt-0.6.2-qemu-drive-format.patch
Normal file
26
libvirt-0.6.2-qemu-drive-format.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 0ae4c67ff5f1d24698c5cfc8a9719d333c892644 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mark McLoughlin <markmc@redhat.com>
|
||||||
|
Date: Thu, 16 Apr 2009 11:23:55 +0100
|
||||||
|
Subject: [PATCH 1/3] qemu -drive takes format= not fmt=
|
||||||
|
|
||||||
|
Seems like a simple typo - it has been "format=" since the flag
|
||||||
|
was introduced, but we added it as "fmt=".
|
||||||
|
|
||||||
|
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||||
|
---
|
||||||
|
src/qemu_conf.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
|
||||||
|
index f36c927..6f9e610 100644
|
||||||
|
--- a/src/qemu_conf.c
|
||||||
|
+++ b/src/qemu_conf.c
|
||||||
|
@@ -1135,7 +1135,7 @@ int qemudBuildCommandLine(virConnectPtr conn,
|
||||||
|
disk->device == VIR_DOMAIN_DISK_DEVICE_DISK)
|
||||||
|
virBufferAddLit(&opt, ",boot=on");
|
||||||
|
if (disk->driverType)
|
||||||
|
- virBufferVSprintf(&opt, ",fmt=%s", disk->driverType);
|
||||||
|
+ virBufferVSprintf(&opt, ",format=%s", disk->driverType);
|
||||||
|
|
||||||
|
if (disk->cachemode) {
|
||||||
|
const char *mode =
|
10
libvirt.spec
10
libvirt.spec
@ -66,11 +66,14 @@
|
|||||||
Summary: Library providing a simple API virtualization
|
Summary: Library providing a simple API virtualization
|
||||||
Name: libvirt
|
Name: libvirt
|
||||||
Version: 0.6.2
|
Version: 0.6.2
|
||||||
Release: 1%{?dist}%{?extra_release}
|
Release: 2%{?dist}%{?extra_release}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Source: libvirt-%{version}.tar.gz
|
Source: libvirt-%{version}.tar.gz
|
||||||
|
|
||||||
|
# Patches cherry-picked from upstream
|
||||||
|
Patch0: libvirt-0.6.2-qemu-drive-format.patch
|
||||||
|
|
||||||
# Not for upstream. Temporary hack till PulseAudio autostart
|
# Not for upstream. Temporary hack till PulseAudio autostart
|
||||||
# problems are sorted out when SELinux enforcing
|
# problems are sorted out when SELinux enforcing
|
||||||
Patch200: libvirt-0.6.2-svirt-sound.patch
|
Patch200: libvirt-0.6.2-svirt-sound.patch
|
||||||
@ -224,6 +227,8 @@ of recent versions of Linux (and other OSes).
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%patch200 -p0
|
%patch200 -p0
|
||||||
|
|
||||||
mv NEWS NEWS.old
|
mv NEWS NEWS.old
|
||||||
@ -542,6 +547,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 16 2009 Mark McLoughlin <markmc@redhat.com> - 0.6.2-2.fc12
|
||||||
|
- Fix qemu drive format specification (#496092)
|
||||||
|
|
||||||
* Fri Apr 3 2009 Daniel Veillard <veillard@redhat.com> - 0.6.2-1.fc11
|
* Fri Apr 3 2009 Daniel Veillard <veillard@redhat.com> - 0.6.2-1.fc11
|
||||||
- release of 0.6.2
|
- release of 0.6.2
|
||||||
- memory ballooning in QEMU
|
- memory ballooning in QEMU
|
||||||
|
Loading…
Reference in New Issue
Block a user