import libvirt-7.10.0-1.el9

This commit is contained in:
CentOS Sources 2022-01-11 12:57:42 -05:00 committed by Stepan Oksanichenko
parent 3bd4fe799f
commit 093dda6091
5 changed files with 23 additions and 9 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/libvirt-7.9.0.tar.xz
SOURCES/libvirt-7.10.0.tar.xz

View File

@ -1 +1 @@
dcf9c3c8404e2a91c93538db9a57c9356abb927d SOURCES/libvirt-7.9.0.tar.xz
fcaf7b763bf6e930d8b0a131b32752ebc2b8af9f SOURCES/libvirt-7.10.0.tar.xz

View File

@ -1,5 +1,5 @@
From 48c3540f12f4c14fc8f84de08603f3bf6ccfbd70 Mon Sep 17 00:00:00 2001
Message-Id: <48c3540f12f4c14fc8f84de08603f3bf6ccfbd70@dist-git>
From 4e5854dd33f113e9aa81f7e1a23c50ac21dbefde Mon Sep 17 00:00:00 2001
Message-Id: <4e5854dd33f113e9aa81f7e1a23c50ac21dbefde@dist-git>
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
Date: Mon, 27 Aug 2018 13:09:38 +0200
Subject: [PATCH] RHEL: Fix virConnectGetMaxVcpus output
@ -26,10 +26,10 @@ Reviewed-by: Andrea Bolognani <abologna@redhat.com>
1 file changed, 5 insertions(+)
diff --git a/src/util/virhostcpu.c b/src/util/virhostcpu.c
index 5dd2baf2df..6811c498f9 100644
index 67b6910626..d5d7d5eae0 100644
--- a/src/util/virhostcpu.c
+++ b/src/util/virhostcpu.c
@@ -1192,6 +1192,11 @@ virHostCPUGetKVMMaxVCPUs(void)
@@ -1189,6 +1189,11 @@ virHostCPUGetKVMMaxVCPUs(void)
return -1;
}
@ -42,5 +42,5 @@ index 5dd2baf2df..6811c498f9 100644
/* at first try KVM_CAP_MAX_VCPUS to determine the maximum count */
if ((ret = ioctl(fd, KVM_CHECK_EXTENSION, KVM_CAP_MAX_VCPUS)) > 0)
--
2.33.1
2.34.1

View File

@ -164,6 +164,7 @@ tests/qemuxml2xmloutdata/fd-memory-no-numa-topology.xml ../qemuxml2argvdata/fd-m
tests/qemuxml2xmloutdata/fd-memory-numa-topology.xml ../qemuxml2argvdata/fd-memory-numa-topology.xml
tests/qemuxml2xmloutdata/fd-memory-numa-topology2.xml ../qemuxml2argvdata/fd-memory-numa-topology2.xml
tests/qemuxml2xmloutdata/fd-memory-numa-topology3.xml ../qemuxml2argvdata/fd-memory-numa-topology3.xml
tests/qemuxml2xmloutdata/fd-memory-numa-topology4.x86_64-latest.xml ../qemuxml2argvdata/fd-memory-numa-topology4.xml
tests/qemuxml2xmloutdata/hugepages-default-2M.xml ../qemuxml2argvdata/hugepages-default-2M.xml
tests/qemuxml2xmloutdata/hugepages-default-system-size.xml ../qemuxml2argvdata/hugepages-default-system-size.xml
tests/qemuxml2xmloutdata/hugepages-memaccess.xml ../qemuxml2argvdata/hugepages-memaccess.xml

View File

@ -190,6 +190,10 @@
%define qemu_user qemu
%define qemu_group qemu
# Locations for QEMU data
%define qemu_moddir %{_libdir}/qemu
%define qemu_datadir %{_datadir}/qemu
# RHEL releases provide stable tool chains and so it is safe to turn
# compiler warning into errors without being worried about frequent
@ -205,7 +209,7 @@
Summary: Library providing a simple virtualization API
Name: libvirt
Version: 7.9.0
Version: 7.10.0
Release: 1%{?dist}%{?extra_release}
License: LGPLv2+
URL: https://libvirt.org/
@ -1180,6 +1184,8 @@ export SOURCE_DATE_EPOCH=$(stat --printf='%Y' %{_specdir}/%{name}.spec)
%{arg_packager_version} \
-Dqemu_user=%{qemu_user} \
-Dqemu_group=%{qemu_group} \
-Dqemu_moddir=%{qemu_moddir} \
-Dqemu_datadir=%{qemu_datadir} \
-Dtls_priority=%{tls_priority} \
%{?enable_werror} \
-Dexpensive_tests=enabled \
@ -1212,7 +1218,6 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt/storage-file/*.a
rm -f $RPM_BUILD_ROOT%{wireshark_plugindir}/libvirt.la
%endif
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/lib/libvirt/dnsmasq/
# We don't want to install /etc/libvirt/qemu/networks in the main %%files list
# because if the admin wants to delete the default network completely, we don't
# want to end up re-incarnating it on every RPM upgrade.
@ -2003,6 +2008,7 @@ exit 0
%{_mandir}/man1/virt-pki-validate.1*
%{_bindir}/virsh
%{_bindir}/virt-xml-validate
%{_bindir}/virt-pki-query-dn
%{_bindir}/virt-pki-validate
%{_datadir}/bash-completion/completions/virsh
@ -2085,6 +2091,13 @@ exit 0
%changelog
* Wed Dec 1 2021 Jiri Denemark <jdenemar@redhat.com> - 7.10.0-1
- Rebased to libvirt-7.10.0 (rhbz#2001507)
- The rebase also fixes the following bugs:
rhbz#2024098, rhbz#1964223, rhbz#2018488, rhbz#2021437, rhbz#2022589
rhbz#2023605, rhbz#1431589, rhbz#2024435, rhbz#2016599, rhbz#1945501
rhbz#2023674
* Fri Nov 5 2021 Jiri Denemark <jdenemar@redhat.com> - 7.9.0-1
- Rebased to libvirt-7.9.0 (rhbz#2001507)
- The rebase also fixes the following bugs: