libvirt-7.2.0-1
Update to version 7.2.0
This commit is contained in:
parent
5845f1efec
commit
03a98aaf59
@ -1,32 +0,0 @@
|
||||
From 0d49ef856846eac919725ad0278451e94c78d9ff Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Mon, 1 Mar 2021 13:15:37 -0500
|
||||
Subject: [PATCH] hyperv: Fix 32bit compilation
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
src/hyperv/hyperv_driver.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/hyperv/hyperv_driver.c b/src/hyperv/hyperv_driver.c
|
||||
index 701456cdb3..e4f537bd12 100644
|
||||
--- a/src/hyperv/hyperv_driver.c
|
||||
+++ b/src/hyperv/hyperv_driver.c
|
||||
@@ -3004,7 +3004,7 @@ hypervDomainDefineXML(virConnectPtr conn, const char *xml)
|
||||
/* Attach serials */
|
||||
for (i = 0; i < def->nserials; i++) {
|
||||
if (hypervDomainAttachSerial(domain, def->serials[i]) < 0) {
|
||||
- virReportError(VIR_ERR_INTERNAL_ERROR, _("Could not attach serial port %lu"), i);
|
||||
+ virReportError(VIR_ERR_INTERNAL_ERROR, _("Could not attach serial port %zu"), i);
|
||||
goto error;
|
||||
}
|
||||
}
|
||||
@@ -3012,7 +3012,7 @@ hypervDomainDefineXML(virConnectPtr conn, const char *xml)
|
||||
/* Attach networks */
|
||||
for (i = 0; i < def->nnets; i++) {
|
||||
if (hypervDomainAttachSyntheticEthernetAdapter(domain, def->nets[i], hostname) < 0) {
|
||||
- virReportError(VIR_ERR_INTERNAL_ERROR, _("Could not attach network %lu"), i);
|
||||
+ virReportError(VIR_ERR_INTERNAL_ERROR, _("Could not attach network %zu"), i);
|
||||
goto error;
|
||||
}
|
||||
}
|
11
libvirt.spec
11
libvirt.spec
@ -218,8 +218,8 @@
|
||||
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 7.1.0
|
||||
Release: 2%{?dist}
|
||||
Version: 7.2.0
|
||||
Release: 1%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: https://libvirt.org/
|
||||
|
||||
@ -227,7 +227,6 @@ URL: https://libvirt.org/
|
||||
%define mainturl stable_updates/
|
||||
%endif
|
||||
Source: https://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||
Patch1: 32bit-fix.patch
|
||||
|
||||
Requires: libvirt-daemon = %{version}-%{release}
|
||||
Requires: libvirt-daemon-config-network = %{version}-%{release}
|
||||
@ -267,7 +266,6 @@ BuildRequires: python3-docutils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson >= 0.54.0
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: make
|
||||
BuildRequires: git
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
BuildRequires: perl-interpreter
|
||||
@ -279,7 +277,7 @@ BuildRequires: systemd-units
|
||||
%if %{with_libxl}
|
||||
BuildRequires: xen-devel
|
||||
%endif
|
||||
BuildRequires: glib2-devel >= 2.48
|
||||
BuildRequires: glib2-devel >= 2.56
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: readline-devel
|
||||
@ -1975,6 +1973,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 05 2021 Cole Robinson <crobinso@redhat.com> - 7.2.0-1
|
||||
- Update to version 7.2.0
|
||||
|
||||
* Tue Mar 9 2021 Richard W.M. Jones <rjones@redhat.com> - 7.1.0-2
|
||||
- Bump and rebuild for libwsman_client.so.4 -> .5
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-7.1.0.tar.xz) = 475b212e920bf8587db4a551126d9eb417d4e18a72550f94feb1aec94821fbac8c84d67ffd59cfe4f8289b6b10ae5f6b579ee170c0d72cb0493ec7ec52183cd6
|
||||
SHA512 (libvirt-7.2.0.tar.xz) = f6bb26ca7cb5a8d342f1f39afd051ed76b71414e1b934557cf50784da17e4f2fb3301c2ace3b593fcdeb6a18ad559a007ad594111c2c348b9157d3a59d475928
|
||||
|
Loading…
Reference in New Issue
Block a user