Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/libvirt-glib.git#ccb702b7b4be3c8ed982c577e9a95b0ae40cd6cf
This commit is contained in:
parent
d015ff985d
commit
e30c0dfdb0
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
.build*.log
|
||||
*.rpm
|
||||
/libvirt-glib-*.tar.gz
|
||||
/libvirt-glib-*.tar.xz
|
||||
|
12
libvirt-glib-4.0.0-cast-align.patch
Normal file
12
libvirt-glib-4.0.0-cast-align.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -rup libvirt-glib-4.0.0.orig/meson.build libvirt-glib-4.0.0.new/meson.build
|
||||
--- libvirt-glib-4.0.0.orig/meson.build 2021-02-15 12:23:04.609036200 +0000
|
||||
+++ libvirt-glib-4.0.0.new/meson.build 2021-02-15 14:50:24.838971022 +0000
|
||||
@@ -175,8 +175,6 @@ cc_flags += [
|
||||
'-Wbuiltin-declaration-mismatch',
|
||||
'-Wbuiltin-macro-redefined',
|
||||
'-Wcannot-profile',
|
||||
- '-Wcast-align',
|
||||
- '-Wcast-align=strict',
|
||||
'-Wcast-function-type',
|
||||
'-Wchar-subscripts',
|
||||
'-Wclobbered',
|
@ -1,42 +1,22 @@
|
||||
# -*- rpm-spec -*-
|
||||
|
||||
%define with_introspection 0
|
||||
%define with_vala 0
|
||||
|
||||
%if 0%{?fedora} >= 15
|
||||
%define with_introspection 1
|
||||
%endif
|
||||
%if 0%{?rhel} > 6
|
||||
%define with_introspection 1
|
||||
%endif
|
||||
%define with_vala %{with_introspection}
|
||||
|
||||
%define libvirt_version 1.2.5
|
||||
|
||||
Name: libvirt-glib
|
||||
Version: 3.0.0
|
||||
Release: 4%{?dist}
|
||||
Version: 4.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: libvirt glib integration for events
|
||||
License: LGPLv2+
|
||||
URL: http://libvirt.org/
|
||||
Source0: ftp://libvirt.org/libvirt/glib/%{name}-%{version}.tar.gz
|
||||
URL: https://libvirt.org/
|
||||
Source0: https://libvirt.org/sources/glib/%{name}-%{version}.tar.xz
|
||||
Patch1: %{name}-%{version}-cast-align.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: glib2-devel >= 2.38.0
|
||||
BuildRequires: libvirt-devel >= %{libvirt_version}
|
||||
%if %{with_introspection}
|
||||
BuildRequires: meson
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libvirt-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
%if 0%{?fedora} == 12
|
||||
BuildRequires: gir-repository-devel
|
||||
%endif
|
||||
%endif
|
||||
BuildRequires: libxml2-devel
|
||||
# Hack due to https://bugzilla.redhat.com/show_bug.cgi?id=613466
|
||||
BuildRequires: libtool
|
||||
%if %{with_vala}
|
||||
BuildRequires: vala
|
||||
%endif
|
||||
BuildRequires: intltool
|
||||
BuildRequires: vala-tools
|
||||
BuildRequires: gettext
|
||||
BuildRequires: gtk-doc
|
||||
|
||||
%package devel
|
||||
Summary: libvirt glib integration for events development files
|
||||
@ -57,7 +37,7 @@ Summary: libvirt object APIs for managing virtualization hosts development files
|
||||
Requires: %{name}-devel = %{version}-%{release}
|
||||
Requires: libvirt-gconfig-devel = %{version}-%{release}
|
||||
Requires: libvirt-gobject = %{version}-%{release}
|
||||
Requires: libvirt-devel >= %{libvirt_version}
|
||||
Requires: libvirt-devel
|
||||
|
||||
%description
|
||||
This package provides integration between libvirt and the glib
|
||||
@ -85,36 +65,19 @@ managing virtualization host objects
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
|
||||
%if %{with_introspection}
|
||||
%define introspection_arg --enable-introspection
|
||||
%else
|
||||
%define introspection_arg --disable-introspection
|
||||
%endif
|
||||
|
||||
%configure %{introspection_arg}
|
||||
%__make %{?_smp_mflags}
|
||||
|
||||
%meson -Drpath=disabled
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%__make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-glib-1.0.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-glib-1.0.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-gconfig-1.0.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-gconfig-1.0.la
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-gobject-1.0.a
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libvirt-gobject-1.0.la
|
||||
%meson_install
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%check
|
||||
if ! make %{?_smp_mflags} check; then
|
||||
cat tests/test-suite.log || true
|
||||
exit 1
|
||||
fi
|
||||
%meson_test
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
@ -123,23 +86,17 @@ fi
|
||||
%ldconfig_scriptlets -n libvirt-gobject
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc README COPYING AUTHORS ChangeLog NEWS
|
||||
%doc README COPYING AUTHORS NEWS
|
||||
%{_libdir}/libvirt-glib-1.0.so.*
|
||||
%if %{with_introspection}
|
||||
%{_libdir}/girepository-1.0/LibvirtGLib-1.0.typelib
|
||||
%endif
|
||||
|
||||
%files -n libvirt-gconfig
|
||||
%{_libdir}/libvirt-gconfig-1.0.so.*
|
||||
%if %{with_introspection}
|
||||
%{_libdir}/girepository-1.0/LibvirtGConfig-1.0.typelib
|
||||
%endif
|
||||
|
||||
%files -n libvirt-gobject
|
||||
%{_libdir}/libvirt-gobject-1.0.so.*
|
||||
%if %{with_introspection}
|
||||
%{_libdir}/girepository-1.0/LibvirtGObject-1.0.typelib
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%doc examples/event-test.c
|
||||
@ -149,13 +106,10 @@ fi
|
||||
%dir %{_includedir}/libvirt-glib-1.0/libvirt-glib
|
||||
%{_includedir}/libvirt-glib-1.0/libvirt-glib/libvirt-glib.h
|
||||
%{_includedir}/libvirt-glib-1.0/libvirt-glib/libvirt-glib-*.h
|
||||
%if %{with_introspection}
|
||||
%{_datadir}/gir-1.0/LibvirtGLib-1.0.gir
|
||||
%endif
|
||||
%{_datadir}/gtk-doc/html/Libvirt-glib
|
||||
%if %{with_vala}
|
||||
%{_datadir}/vala/vapi/libvirt-glib-1.0.deps
|
||||
%{_datadir}/vala/vapi/libvirt-glib-1.0.vapi
|
||||
%endif
|
||||
|
||||
%files -n libvirt-gconfig-devel
|
||||
%doc examples/event-test.c
|
||||
@ -165,13 +119,10 @@ fi
|
||||
%dir %{_includedir}/libvirt-gconfig-1.0/libvirt-gconfig
|
||||
%{_includedir}/libvirt-gconfig-1.0/libvirt-gconfig/libvirt-gconfig.h
|
||||
%{_includedir}/libvirt-gconfig-1.0/libvirt-gconfig/libvirt-gconfig-*.h
|
||||
%if %{with_introspection}
|
||||
%{_datadir}/gir-1.0/LibvirtGConfig-1.0.gir
|
||||
%endif
|
||||
%{_datadir}/gtk-doc/html/Libvirt-gconfig
|
||||
%if %{with_vala}
|
||||
%{_datadir}/vala/vapi/libvirt-gconfig-1.0.deps
|
||||
%{_datadir}/vala/vapi/libvirt-gconfig-1.0.vapi
|
||||
%endif
|
||||
|
||||
%files -n libvirt-gobject-devel
|
||||
%doc examples/event-test.c
|
||||
@ -181,16 +132,15 @@ fi
|
||||
%dir %{_includedir}/libvirt-gobject-1.0/libvirt-gobject
|
||||
%{_includedir}/libvirt-gobject-1.0/libvirt-gobject/libvirt-gobject.h
|
||||
%{_includedir}/libvirt-gobject-1.0/libvirt-gobject/libvirt-gobject-*.h
|
||||
%if %{with_introspection}
|
||||
%{_datadir}/gir-1.0/LibvirtGObject-1.0.gir
|
||||
%endif
|
||||
%{_datadir}/gtk-doc/html/Libvirt-gobject
|
||||
%if %{with_vala}
|
||||
%{_datadir}/vala/vapi/libvirt-gobject-1.0.deps
|
||||
%{_datadir}/vala/vapi/libvirt-gobject-1.0.vapi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 15 2021 Daniel P. Berrangé <berrange@redhat.com> - 4.0.0-1
|
||||
- Rebased to 4.0.0 release
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
@ -199,43 +149,3 @@ fi
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Nov 26 2019 Daniel P. Berrangé <berrange@redhat.com> - 3.0.0-1
|
||||
- Update to 3.0.0 release
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Feb 04 2019 Kalev Lember <klember@redhat.com> - 2.0.0-3
|
||||
- Update BRs for vala packaging changes
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Oct 12 2018 Daniel P. Berrangé <berrange@redhat.com> - 2.0.0-1
|
||||
- Update to 2.0.0 release
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Oct 30 2017 Marek Kasik <mkasik@redhat.com> - 1.0.0-5
|
||||
- Enable unit tests
|
||||
- Resolves: #1502639
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Nov 4 2016 Daniel P. Berrange <berrange@redhat.com> - 1.0.0-1
|
||||
- Update to 1.0.0 release
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-glib-3.0.0.tar.gz) = b9e7d782c25b5c3a9b2829f1be8162352438ab3505510a1ca7dd64d741eaab158dc9206fdd4b0e3e27b0c049e4bcfc47db0c9a7fa1a84888864e23d3c35c079e
|
||||
SHA512 (libvirt-glib-4.0.0.tar.xz) = e1b99e80aa671fa5a4d7f7f7a4ea70ce7c5fdaf97574407f79aa11a75dd177e1e3f92027728a83ded62e305852bbda76eb90326aaa1f5f19b77272b008351810
|
||||
|
Loading…
Reference in New Issue
Block a user