Rebase to 5.0.0 release
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
This commit is contained in:
parent
3a288ed6f4
commit
397ebdb834
@ -1,12 +0,0 @@
|
||||
diff -rup libvirt-glib-4.0.0.orig/meson.build libvirt-glib-4.0.0.new/meson.build
|
||||
--- libvirt-glib-4.0.0.orig/meson.build 2021-02-15 12:23:04.609036200 +0000
|
||||
+++ libvirt-glib-4.0.0.new/meson.build 2021-02-15 14:50:24.838971022 +0000
|
||||
@@ -175,8 +175,6 @@ cc_flags += [
|
||||
'-Wbuiltin-declaration-mismatch',
|
||||
'-Wbuiltin-macro-redefined',
|
||||
'-Wcannot-profile',
|
||||
- '-Wcast-align',
|
||||
- '-Wcast-align=strict',
|
||||
'-Wcast-function-type',
|
||||
'-Wchar-subscripts',
|
||||
'-Wclobbered',
|
@ -1,27 +0,0 @@
|
||||
From e0bfc34682744a74b850fa217e9c206a9eb80612 Mon Sep 17 00:00:00 2001
|
||||
From: Markus Volk <f_l_k@t-online.de>
|
||||
Date: Wed, 23 Nov 2022 16:47:52 +0100
|
||||
Subject: [PATCH] libvirt-gconfig-domain-capabilities-os.c: fix pointer-sign
|
||||
issue
|
||||
|
||||
Signed-off-by: Markus Volk <f_l_k@t-online.de>
|
||||
---
|
||||
libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c b/libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c
|
||||
index 98a1bff..e70d22d 100644
|
||||
--- a/libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c
|
||||
+++ b/libvirt-gconfig/libvirt-gconfig-domain-capabilities-os.c
|
||||
@@ -67,7 +67,7 @@ static gboolean search_firmwares(xmlNodePtr node, gpointer opaque)
|
||||
{
|
||||
const gchar *content;
|
||||
|
||||
- if (!g_str_equal(node->name, "enum"))
|
||||
+ if (!g_str_equal((const gchar *)node->name, "enum"))
|
||||
return TRUE;
|
||||
|
||||
content = gvir_config_xml_get_attribute_content(node, "name");
|
||||
--
|
||||
2.39.0
|
||||
|
@ -6,14 +6,12 @@
|
||||
%endif
|
||||
|
||||
Name: libvirt-glib
|
||||
Version: 4.0.0
|
||||
Release: 9%{?dist}
|
||||
Version: 5.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: libvirt glib integration for events
|
||||
License: LGPL-2.1-or-later
|
||||
URL: https://libvirt.org/
|
||||
Source0: https://libvirt.org/sources/glib/%{name}-%{version}.tar.xz
|
||||
Patch: %{name}-%{version}-cast-align.patch
|
||||
Patch: %{name}-%{version}-pointer-cast.patch
|
||||
|
||||
BuildRequires: meson
|
||||
BuildRequires: glib2-devel
|
||||
@ -296,10 +294,13 @@ MinGW Windows libvirt-gobject virtualization library.
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Nov 30 2023 Daniel P. Berrangé <berrange@redhat.com> - 5.0.0-1
|
||||
- Rebased to 5.0.0 release
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon Aug 8 2022 Daniel P. Berrangé <berrange@redhat.com> - 4.0.0-8
|
||||
* Tue Jan 24 2023 Daniel P. Berrangé <berrange@redhat.com> - 4.0.0-8
|
||||
- Fix pointer cast warning
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-7
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-glib-4.0.0.tar.xz) = e1b99e80aa671fa5a4d7f7f7a4ea70ce7c5fdaf97574407f79aa11a75dd177e1e3f92027728a83ded62e305852bbda76eb90326aaa1f5f19b77272b008351810
|
||||
SHA512 (libvirt-glib-5.0.0.tar.xz) = bb09474c0d6d4bc00844e7a1ede882f0834d0810804b70b8f8607f2e764f72cc9da14883794e58dd53640433ffaecc13dd3c1c147b82e86fa2fdca6e5903933c
|
||||
|
Loading…
Reference in New Issue
Block a user