0.3.1, spec cleanups

This commit is contained in:
Peter Robinson 2021-01-17 12:04:39 +00:00
parent a2c0de63f6
commit 6339073bc0
4 changed files with 17 additions and 77 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/libverto-0.2.6.tar.gz
/libverto-0.3.0.tar.gz
/libverto-0.3.1.tar.gz

View File

@ -1,26 +0,0 @@
From b6f0579cfd44a7e5b84b8239663a56f346acfc47 Mon Sep 17 00:00:00 2001
From: Robbie Harwood <rharwood@redhat.com>
Date: Fri, 1 Sep 2017 15:59:49 -0400
Subject: [PATCH] Work around libev not being c89-compliant
(cherry picked from commit c57599d7039d2435c306830b2edae999c462befb)
[rharwood@redhat.com: Remove travis files]
---
configure.ac | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 09ee123..b7b5908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,8 +7,8 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
[AC_USE_SYSTEM_EXTENSIONS],
[AC_GNU_SOURCE])
-AC_PROG_CC_C89
-for flag in -std=c89 -Wall -Wextra; do
+AC_PROG_CC_C99
+for flag in -Wall -Wextra; do
AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
done

View File

@ -1,30 +1,22 @@
%global homepage https://github.com/latchset/libverto
Name: libverto
Version: 0.3.0
Release: 11%{?dist}
Version: 0.3.1
Release: 1%{?dist}
Summary: Main loop abstraction library
License: MIT
URL: %{homepage}
Source0: %{homepage}/releases/download/%{version}/%{name}-%{version}.tar.gz
Patch0: Work-around-libev-not-being-c89-compliant.patch
URL: https://github.com/latchset/libverto
Source0: %{url}/releases/download/%{version}/%{name}-%{version}.tar.gz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: make
BuildRequires: glib2-devel
BuildRequires: libevent-devel
# BuildRequires: libtevent-devel
BuildRequires: libtool
BuildRequires: make
%if !0%{?rhel}
BuildRequires: libev-devel
%endif
BuildRequires: git
Obsoletes: libverto-tevent < 0.3.0-2
Obsoletes: libverto-tevent-devel < 0.3.0-2
@ -85,26 +77,6 @@ Requires: %{name}-devel%{?_isa} = %{version}-%{release}
The %{name}-libevent-devel package contains libraries and header files for
developing applications that use %{name}-libevent.
# %package tevent
# Summary: tevent module for %{name}
# Requires: %{name}%{?_isa} = %{version}-%{release}
# Provides: %{name}-module-base = %{version}-%{release}
# %description tevent
# Module for %{name} which provides integration with tevent.
# This package provides %{name}-module-base since it supports io, timeout
# and signal.
# %package tevent-devel
# Summary: Development files for %{name}-tevent
# Requires: %{name}-tevent%{?_isa} = %{version}-%{release}
# Requires: %{name}-devel%{?_isa} = %{version}-%{release}
# %description tevent-devel
# The %{name}-tevent-devel package contains libraries and header files for
# developing applications that use %{name}-tevent.
%if !0%{?rhel}
%package libev
Summary: libev module for %{name}
@ -131,30 +103,27 @@ and signal.
%endif
%prep
%autosetup -S git
%autosetup -p1
%build
autoreconf -fiv
%configure --disable-static
make %{?_smp_mflags}
%{make_build}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%{make_install}
find $RPM_BUILD_ROOT -name '*.la' -delete
%ldconfig_scriptlets
%ldconfig_scriptlets glib
%ldconfig_scriptlets libevent
#ldconfig_scriptlets tevent
%if !0%{?rhel}
%ldconfig_scriptlets libev
%endif
%files
%{!?_licensedir:%global license %%doc}
%license COPYING
%doc AUTHORS ChangeLog NEWS README
%doc AUTHORS NEWS README
%{_libdir}/%{name}.so.*
%files devel
@ -179,14 +148,6 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%{_libdir}/%{name}-libevent.so
%{_libdir}/pkgconfig/%{name}-libevent.pc
# %files tevent
# %{_libdir}/%{name}-tevent.so.*
# %files tevent-devel
# %{_includedir}/verto-tevent.h
# %{_libdir}/%{name}-tevent.so
# %{_libdir}/pkgconfig/%{name}-tevent.pc
%if !0%{?rhel}
%files libev
%{_libdir}/%{name}-libev.so.*
@ -198,6 +159,10 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%endif
%changelog
* Sun Jan 17 2021 Peter Robinson <pbrobinson@fedoraproject.org> - 0.3.1-1
- Update to 0.3.1
- Spec file cleanups
* Tue Sep 15 2020 Robbie Harwood <rharwood@redhat.com> - 0.3.0-11
- Rebuild for libevent soname bump

View File

@ -1 +1 @@
SHA512 (libverto-0.3.0.tar.gz) = af4fec9cd20058c1db404443004c2b6c98bcacd0742369bb91f46dde6a35358e44f659bdfef30ab113e112ac1afb3156b098f5b5e2f4a58d1f4cd949abf0f57f
SHA512 (libverto-0.3.1.tar.gz) = baef4fd280e0cb30167743608fd5a950fb4340eeb89e3630a0f63f8eab4d56f0f894a2e3283583b7ed8774d5e896c44e2c68c25882d95a07350f980af36b8740