import libverto-0.3.2-2.el8
This commit is contained in:
parent
8c7e8f7ae2
commit
22744f74a9
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/libverto-0.3.0.tar.gz
|
||||
SOURCES/libverto-0.3.2.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
5c76a1cb04aa5643391fafd2d1093e26df6c89d8 SOURCES/libverto-0.3.0.tar.gz
|
||||
75faff55d9d1b06413612e6f2826fdd9adb73e33 SOURCES/libverto-0.3.2.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
From b6f0579cfd44a7e5b84b8239663a56f346acfc47 Mon Sep 17 00:00:00 2001
|
||||
From: Robbie Harwood <rharwood@redhat.com>
|
||||
Date: Fri, 1 Sep 2017 15:59:49 -0400
|
||||
Subject: [PATCH] Work around libev not being c89-compliant
|
||||
|
||||
(cherry picked from commit c57599d7039d2435c306830b2edae999c462befb)
|
||||
[rharwood@redhat.com: Remove travis files]
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 09ee123..b7b5908 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -7,8 +7,8 @@ m4_ifdef([AC_USE_SYSTEM_EXTENSIONS],
|
||||
[AC_USE_SYSTEM_EXTENSIONS],
|
||||
[AC_GNU_SOURCE])
|
||||
|
||||
-AC_PROG_CC_C89
|
||||
-for flag in -std=c89 -Wall -Wextra; do
|
||||
+AC_PROG_CC_C99
|
||||
+for flag in -Wall -Wextra; do
|
||||
AC_TRY_COMPILE([], [return 0;], [CFLAGS="$CFLAGS $flag"],)
|
||||
done
|
||||
|
@ -1,26 +1,22 @@
|
||||
%global homepage https://github.com/latchset/libverto
|
||||
|
||||
Name: libverto
|
||||
Version: 0.3.0
|
||||
Release: 5%{?dist}
|
||||
Version: 0.3.2
|
||||
Release: 2%{?dist}
|
||||
Summary: Main loop abstraction library
|
||||
|
||||
License: MIT
|
||||
URL: %{homepage}
|
||||
Source0: %{homepage}/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: Work-around-libev-not-being-c89-compliant.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
BuildRequires: libtool
|
||||
BuildRequires: make
|
||||
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libevent-devel
|
||||
# BuildRequires: libtevent-devel
|
||||
%if !0%{?rhel}
|
||||
BuildRequires: libev-devel
|
||||
%endif
|
||||
|
||||
BuildRequires: git
|
||||
|
||||
@ -84,27 +80,6 @@ Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
The %{name}-libevent-devel package contains libraries and header files for
|
||||
developing applications that use %{name}-libevent.
|
||||
|
||||
# %package tevent
|
||||
# Summary: tevent module for %{name}
|
||||
# Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
# Provides: %{name}-module-base = %{version}-%{release}
|
||||
|
||||
# %description tevent
|
||||
# Module for %{name} which provides integration with tevent.
|
||||
|
||||
# This package provides %{name}-module-base since it supports io, timeout
|
||||
# and signal.
|
||||
|
||||
# %package tevent-devel
|
||||
# Summary: Development files for %{name}-tevent
|
||||
# Requires: %{name}-tevent%{?_isa} = %{version}-%{release}
|
||||
# Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||
|
||||
# %description tevent-devel
|
||||
# The %{name}-tevent-devel package contains libraries and header files for
|
||||
# developing applications that use %{name}-tevent.
|
||||
|
||||
%if !0%{?rhel}
|
||||
%package libev
|
||||
Summary: libev module for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
@ -127,7 +102,6 @@ developing applications that use %{name}-libev.
|
||||
|
||||
This package provides %{name}-module-base since it supports io, timeout
|
||||
and signal.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -S git
|
||||
@ -145,10 +119,7 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
%ldconfig_scriptlets
|
||||
%ldconfig_scriptlets glib
|
||||
%ldconfig_scriptlets libevent
|
||||
#ldconfig_scriptlets tevent
|
||||
%if !0%{?rhel}
|
||||
%ldconfig_scriptlets libev
|
||||
%endif
|
||||
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
@ -178,15 +149,6 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
%{_libdir}/%{name}-libevent.so
|
||||
%{_libdir}/pkgconfig/%{name}-libevent.pc
|
||||
|
||||
# %files tevent
|
||||
# %{_libdir}/%{name}-tevent.so.*
|
||||
|
||||
# %files tevent-devel
|
||||
# %{_includedir}/verto-tevent.h
|
||||
# %{_libdir}/%{name}-tevent.so
|
||||
# %{_libdir}/pkgconfig/%{name}-tevent.pc
|
||||
|
||||
%if !0%{?rhel}
|
||||
%files libev
|
||||
%{_libdir}/%{name}-libev.so.*
|
||||
|
||||
@ -194,9 +156,16 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
%{_includedir}/verto-libev.h
|
||||
%{_libdir}/%{name}-libev.so
|
||||
%{_libdir}/pkgconfig/%{name}-libev.pc
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jun 29 2022 Julien Rische <jrische@redhat.com> - 0.3.2-1
|
||||
- New upstream release (0.3.2)
|
||||
- Resolves: rhbz#2100916
|
||||
|
||||
* Wed Mar 20 2019 Robbie Harwood <rharwood@redhat.com> - 0.3.0-6
|
||||
- Add gating
|
||||
- Resolves: #1682288
|
||||
|
||||
* Mon Feb 19 2018 Robbie Harwood <rharwood@redhat.com> - 0.3.0-5
|
||||
- Rebuild due to libevent soname bump
|
||||
|
||||
@ -288,4 +257,3 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
|
||||
* Mon Aug 15 2011 Nathaniel McCallum <npmccallum@redhat.com> - 0.1-1
|
||||
- Initial release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user