libvarlink/0001-Drop-tags-and-ctags-targets.patch
DistroBaker c449c1c49a Merged update from upstream sources
This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/libvarlink.git#646c2a8fd6df8507aad6bc3961ec3de59b7a40c6
2020-12-10 16:44:04 +00:00

50 lines
1.5 KiB
Diff

From 5fad96254cf20fc6d473037b48c50031cd7e8b45 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
Date: Fri, 3 Apr 2020 18:35:21 +0200
Subject: [PATCH] Drop tags and ctags targets
meson 0.43 started providing a built-in ctags target which
conflicts with the hand-rolled one here. There shouldn't be
much difference, so let's drop ours.
Fixes #22.
---
meson.build | 22 ----------------------
1 file changed, 22 deletions(-)
diff --git a/meson.build b/meson.build
index 5fc51d282d78dd7127c3ac3c7c80f65aa492b871..72ac7867c694fc96bd387530bcd92d4ae0839963 100644
--- a/meson.build
+++ b/meson.build
@@ -77,27 +77,5 @@ varlink_wrapper_py = find_program('./varlink-wrapper.py')
subdir('lib')
subdir('tool')
subdir('vim')
subdir('bash-completion')
-
-############################################################
-
-git = find_program('git', required : false)
-
-if git.found()
- all_files = run_command(
- git,
- ['--git-dir=@0@/.git'.format(meson.current_source_dir()),
- 'ls-files',
- ':/*.[ch]'])
- all_files = files(all_files.stdout().split())
-
- custom_target(
- 'tags',
- output : 'tags',
- command : ['env', 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
- custom_target(
- 'ctags',
- output : 'ctags',
- command : ['env', 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
-endif
--
2.29.2