Update to 1.43.0
Disable tests that cannot run in Koji and re-enable tests by default Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
f9c9eb311d
commit
f0e009738d
1
.gitignore
vendored
1
.gitignore
vendored
@ -77,3 +77,4 @@ libuv-v*/
|
||||
/libuv-v1.41.0.tar.gz
|
||||
/libuv-v1.41.1.tar.gz
|
||||
/libuv-v1.42.0.tar.gz
|
||||
/libuv-v1.43.0.tar.gz
|
||||
|
57
0001-Fedora-Skip-tests-that-can-t-run-in-Koji.patch
Normal file
57
0001-Fedora-Skip-tests-that-can-t-run-in-Koji.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From 4b1c94bd264245b0c1eaaaa5c2cd8e7725a0cfd8 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Wed, 5 Jan 2022 17:02:49 -0500
|
||||
Subject: [PATCH] Fedora: Skip tests that can't run in Koji
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
test/test-list.h | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/test/test-list.h b/test/test-list.h
|
||||
index 1f566861a0e2e9e29c925972155f49667bb7ce85..20d6f29cbc319c88de5e4016adb2ea1ab26b9a2f 100644
|
||||
--- a/test/test-list.h
|
||||
+++ b/test/test-list.h
|
||||
@@ -163,15 +163,13 @@ TEST_DECLARE (udp_connect)
|
||||
TEST_DECLARE (udp_connect6)
|
||||
TEST_DECLARE (udp_create_early)
|
||||
TEST_DECLARE (udp_create_early_bad_bind)
|
||||
TEST_DECLARE (udp_create_early_bad_domain)
|
||||
TEST_DECLARE (udp_send_and_recv)
|
||||
-TEST_DECLARE (udp_send_hang_loop)
|
||||
TEST_DECLARE (udp_send_immediate)
|
||||
TEST_DECLARE (udp_send_unreachable)
|
||||
TEST_DECLARE (udp_mmsg)
|
||||
-TEST_DECLARE (udp_multicast_join)
|
||||
TEST_DECLARE (udp_multicast_join6)
|
||||
TEST_DECLARE (udp_multicast_ttl)
|
||||
TEST_DECLARE (udp_multicast_interface)
|
||||
TEST_DECLARE (udp_multicast_interface6)
|
||||
TEST_DECLARE (udp_dgram_too_big)
|
||||
@@ -741,11 +739,10 @@ TASK_LIST_START
|
||||
TEST_ENTRY (udp_connect6)
|
||||
TEST_ENTRY (udp_create_early)
|
||||
TEST_ENTRY (udp_create_early_bad_bind)
|
||||
TEST_ENTRY (udp_create_early_bad_domain)
|
||||
TEST_ENTRY (udp_send_and_recv)
|
||||
- TEST_ENTRY (udp_send_hang_loop)
|
||||
TEST_ENTRY (udp_send_immediate)
|
||||
TEST_ENTRY (udp_send_unreachable)
|
||||
TEST_ENTRY (udp_dgram_too_big)
|
||||
TEST_ENTRY (udp_dual_stack)
|
||||
TEST_ENTRY (udp_ipv6_only)
|
||||
@@ -753,11 +750,10 @@ TASK_LIST_START
|
||||
TEST_ENTRY (udp_options6)
|
||||
TEST_ENTRY (udp_no_autobind)
|
||||
TEST_ENTRY (udp_mmsg)
|
||||
TEST_ENTRY (udp_multicast_interface)
|
||||
TEST_ENTRY (udp_multicast_interface6)
|
||||
- TEST_ENTRY (udp_multicast_join)
|
||||
TEST_ENTRY (udp_multicast_join6)
|
||||
TEST_ENTRY (udp_multicast_ttl)
|
||||
TEST_ENTRY (udp_sendmmsg_error)
|
||||
TEST_ENTRY (udp_try_send)
|
||||
|
||||
--
|
||||
2.33.1
|
||||
|
17
libuv.spec
17
libuv.spec
@ -1,12 +1,10 @@
|
||||
# Some of the tests do not work with the network-free environment in Koji
|
||||
# The packager should run `fedpkg local --with tests` on their machine
|
||||
# before pushing to Koji
|
||||
%bcond_with tests
|
||||
# Run the tests by default
|
||||
%bcond_without tests
|
||||
|
||||
Name: libuv
|
||||
Epoch: 1
|
||||
Version: 1.42.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.43.0
|
||||
Release: %autorelease
|
||||
Summary: Platform layer for node.js
|
||||
|
||||
# the licensing breakdown is described in detail in the LICENSE file
|
||||
@ -22,6 +20,9 @@ BuildRequires: make
|
||||
|
||||
# -- Patches -- #
|
||||
|
||||
# Disable some tests that fail in the network-free Koji builders
|
||||
Patch0001: 0001-Fedora-Skip-tests-that-can-t-run-in-Koji.patch
|
||||
|
||||
%description
|
||||
libuv is a new platform layer for Node. Its purpose is to abstract IOCP on
|
||||
Windows and libev on Unix systems. We intend to eventually contain all platform
|
||||
@ -81,8 +82,4 @@ install -Dm0644 -t %{buildroot}%{_libdir}/libuv/ %{SOURCE3}
|
||||
%{_libdir}/%{name}.a
|
||||
|
||||
%changelog
|
||||
* Thu Sep 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1.42.0-2
|
||||
- Drop use of rpmautospec for the release field due to
|
||||
https://pagure.io/fedora-ci/general/issue/273
|
||||
|
||||
%autochangelog
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libuv-v1.42.0.tar.gz) = cc8ca797ec6e02fff7d4998fd5a509373ae6c674ff0d57960fef3418f59d3b93a655f52913ee5f712e32e3980b29df6315685c8b506790295d97c7c1f94f3425
|
||||
SHA512 (libuv-v1.43.0.tar.gz) = ba48140ac5733e09462a731fe9194c902b011a1a93a63175949c616367bde56bd1c114e8487c5580bee2d4656b45ab8cdc4fc335f67dd35e793c1a943f69fb34
|
||||
|
Loading…
Reference in New Issue
Block a user