bump to version included with node 0.9.4
- drop upstreamed patch - respect optflags
This commit is contained in:
parent
3d50eed573
commit
e53c004290
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/libuv-0.9.3git09b0222.tar.gz
|
/libuv-0.9.3git09b0222.tar.gz
|
||||||
|
/libuv-0.9.4gitdc559a5.tar.gz
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
From fcd8668e5f89ac8afe7e3e2cafe4bc2da0fd000e Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Thu, 15 Nov 2012 12:04:11 -0500
|
|
||||||
Subject: [PATCH] Export uv_inet_* functions
|
|
||||||
|
|
||||||
---
|
|
||||||
include/uv.h | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/include/uv.h b/include/uv.h
|
|
||||||
index 9d80d9a186810532f862642dbc8f09c13fbb69ef..7f3bc589a55ff41eef6b25083b9a9d25ef4c436a 100644
|
|
||||||
--- a/include/uv.h
|
|
||||||
+++ b/include/uv.h
|
|
||||||
@@ -1701,8 +1701,8 @@ UV_EXTERN int uv_ip6_name(struct sockaddr_in6* src, char* dst, size_t size);
|
|
||||||
/* Cross-platform IPv6-capable implementation of the 'standard' inet_ntop */
|
|
||||||
/* and inet_pton functions. On success they return UV_OK. If an error */
|
|
||||||
/* the target of the `dst` pointer is unmodified. */
|
|
||||||
-uv_err_t uv_inet_ntop(int af, const void* src, char* dst, size_t size);
|
|
||||||
-uv_err_t uv_inet_pton(int af, const char* src, void* dst);
|
|
||||||
+UV_EXTERN uv_err_t uv_inet_ntop(int af, const void* src, char* dst, size_t size);
|
|
||||||
+UV_EXTERN uv_err_t uv_inet_pton(int af, const char* src, void* dst);
|
|
||||||
|
|
||||||
/* Gets the executable path */
|
|
||||||
UV_EXTERN int uv_exepath(char* buffer, size_t* size);
|
|
||||||
--
|
|
||||||
1.8.0
|
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
git clone https://github.com/joyent/libuv.git
|
git clone https://github.com/joyent/libuv.git
|
||||||
pushd libuv
|
pushd libuv
|
||||||
git archive --format=tar --prefix=libuv-0.9.3/ 09b022232aaddce1ee9def7092538734415f386c |gzip -nc > ../libuv-0.9.3git09b0222.tar.gz
|
git archive --format=tar --prefix=libuv-0.9.4/ dc559a5ce69cef28e1c73a3782c17b5801989e67 |gzip -nc > ../libuv-0.9.4gitdc559a5.tar.gz
|
||||||
popd
|
popd
|
||||||
|
|
||||||
rm -Rf libuv
|
rm -Rf libuv
|
||||||
|
21
libuv.spec
21
libuv.spec
@ -1,8 +1,8 @@
|
|||||||
%global git_snapshot 09b0222
|
%global git_snapshot dc559a5
|
||||||
|
|
||||||
Name: libuv
|
Name: libuv
|
||||||
Version: 0.9.3
|
Version: 0.9.4
|
||||||
Release: 0.3.git%{git_snapshot}%{?dist}
|
Release: 0.1.git%{git_snapshot}%{?dist}
|
||||||
Summary: Platform layer for node.js
|
Summary: Platform layer for node.js
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -23,9 +23,6 @@ Requires(postun): /sbin/ldconfig
|
|||||||
# https://fedorahosted.org/fpc/ticket/231
|
# https://fedorahosted.org/fpc/ticket/231
|
||||||
Provides: bundled(libev) = 4.04
|
Provides: bundled(libev) = 4.04
|
||||||
|
|
||||||
# Properly export missing function
|
|
||||||
Patch0001: 0001-Export-uv_inet_-functions.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
libuv is a new platform layer for Node. Its purpose is to abstract IOCP on
|
libuv is a new platform layer for Node. Its purpose is to abstract IOCP on
|
||||||
Windows and libev on Unix systems. We intend to eventually contain all platform
|
Windows and libev on Unix systems. We intend to eventually contain all platform
|
||||||
@ -45,9 +42,9 @@ Development libraries for libuv
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch0001 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
export CFLAGS='%{optflags}'
|
||||||
|
export CXXFLAGS='%{optflags}'
|
||||||
./gyp_uv -Dcomponent=shared_library -Dlibrary=shared_library
|
./gyp_uv -Dcomponent=shared_library -Dlibrary=shared_library
|
||||||
|
|
||||||
# Modify the build so it produces a versioned shared library
|
# Modify the build so it produces a versioned shared library
|
||||||
@ -77,8 +74,7 @@ mkdir -p %{buildroot}/%{_includedir}/uv-private
|
|||||||
cp %{_builddir}/%{name}-%{version}/include/uv.h \
|
cp %{_builddir}/%{name}-%{version}/include/uv.h \
|
||||||
%{buildroot}/%{_includedir}
|
%{buildroot}/%{_includedir}
|
||||||
|
|
||||||
cp %{_builddir}/%{name}-%{version}/include/uv-private/ev.h \
|
cp \
|
||||||
%{_builddir}/%{name}-%{version}/include/uv-private/ev-proto.h \
|
|
||||||
%{_builddir}/%{name}-%{version}/include/uv-private/ngx-queue.h \
|
%{_builddir}/%{name}-%{version}/include/uv-private/ngx-queue.h \
|
||||||
%{_builddir}/%{name}-%{version}/include/uv-private/tree.h \
|
%{_builddir}/%{name}-%{version}/include/uv-private/tree.h \
|
||||||
%{_builddir}/%{name}-%{version}/include/uv-private/uv-linux.h \
|
%{_builddir}/%{name}-%{version}/include/uv-private/uv-linux.h \
|
||||||
@ -116,6 +112,11 @@ sed -e "s#@prefix@#%{_prefix}#g" \
|
|||||||
%{_includedir}/uv-private
|
%{_includedir}/uv-private
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 26 2012 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.4-0.1.gitdc559a5
|
||||||
|
- bump to version included with node 0.9.4
|
||||||
|
- drop upstreamed patch
|
||||||
|
- respect optflags
|
||||||
|
|
||||||
* Thu Nov 15 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-0.3.git09b0222
|
* Thu Nov 15 2012 Stephen Gallagher <sgallagh@redhat.com> - 0.9.3-0.3.git09b0222
|
||||||
- Add patch to export uv_inet_*
|
- Add patch to export uv_inet_*
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user