Use cmake, check signature and add docs
This commit is contained in:
parent
bebae6e41b
commit
98fbdcf94d
@ -1,47 +0,0 @@
|
||||
From 90cd9ddf16515faa3a2542761e4fb0e0fe594ce6 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Wed, 5 Jan 2022 17:02:49 -0500
|
||||
Subject: [PATCH] Fedora: Skip tests that can't run in Koji
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
test/test-list.h | 6 ------
|
||||
1 file changed, 6 deletions(-)
|
||||
|
||||
diff --git a/test/test-list.h b/test/test-list.h
|
||||
index 68c9c1171a7fe85cb8f02686e0521e73560d2956..abe992118db311ee3e2d6b2ad9a5199d8366bdff 100644
|
||||
--- a/test/test-list.h
|
||||
+++ b/test/test-list.h
|
||||
@@ -166,12 +166,9 @@ TEST_DECLARE (udp_create_early)
|
||||
TEST_DECLARE (udp_create_early_bad_bind)
|
||||
TEST_DECLARE (udp_create_early_bad_domain)
|
||||
TEST_DECLARE (udp_send_and_recv)
|
||||
-TEST_DECLARE (udp_send_hang_loop)
|
||||
TEST_DECLARE (udp_send_immediate)
|
||||
TEST_DECLARE (udp_send_unreachable)
|
||||
TEST_DECLARE (udp_mmsg)
|
||||
-TEST_DECLARE (udp_multicast_join)
|
||||
-TEST_DECLARE (udp_multicast_join6)
|
||||
TEST_DECLARE (udp_multicast_ttl)
|
||||
TEST_DECLARE (udp_multicast_interface)
|
||||
TEST_DECLARE (udp_multicast_interface6)
|
||||
@@ -764,7 +761,6 @@ TASK_LIST_START
|
||||
TEST_ENTRY (udp_create_early_bad_bind)
|
||||
TEST_ENTRY (udp_create_early_bad_domain)
|
||||
TEST_ENTRY (udp_send_and_recv)
|
||||
- TEST_ENTRY (udp_send_hang_loop)
|
||||
TEST_ENTRY (udp_send_immediate)
|
||||
TEST_ENTRY (udp_send_unreachable)
|
||||
TEST_ENTRY (udp_dgram_too_big)
|
||||
@@ -776,8 +772,6 @@ TASK_LIST_START
|
||||
TEST_ENTRY (udp_mmsg)
|
||||
TEST_ENTRY (udp_multicast_interface)
|
||||
TEST_ENTRY (udp_multicast_interface6)
|
||||
- TEST_ENTRY (udp_multicast_join)
|
||||
- TEST_ENTRY (udp_multicast_join6)
|
||||
TEST_ENTRY (udp_multicast_ttl)
|
||||
TEST_ENTRY (udp_sendmmsg_error)
|
||||
TEST_ENTRY (udp_try_send)
|
||||
--
|
||||
2.40.1
|
||||
|
BIN
keysuv.gpg
Normal file
BIN
keysuv.gpg
Normal file
Binary file not shown.
16
libuv-v1.46.0.tar.gz.sign
Normal file
16
libuv-v1.46.0.tar.gz.sign
Normal file
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCgAdFiEEYS8OrZQBYiN530QC8ow8jaM8A74FAmSfH78ACgkQ8ow8jaM8
|
||||
A75O6Q//eh0rFOJSaFQcLAVAuvjJR6VZkNYHEjgiuG603Bls/f9UTl3VhuktQeik
|
||||
kJTjIv3+bP0BNCXM4Dmtc4eeItVmCLKSfGsspt095HxjQlYA5O+gPqJN4htEoBPf
|
||||
6YgCLGcN0I0+6DecuouXov0SjnsBj0soicFvbd1DlZdTOwJdb+TGsszVWDPn4aY2
|
||||
dRo4sI1jTMbRKkMJI6tS6hZbnDzDGC8tUyqCFCXCe9dCTXo/jZIAhBVvxxZwgqaN
|
||||
zPN57/JBuWDb7bTo1+vpd5cVEO5koImYZ0ZCWXv0SE7T9DzIxK2Hd62wQsE2sLBh
|
||||
rmMgi1WBtFZf+n/mZPF0lgWYI998vAIstv+fdPmrxoZJLez4GTkYeU+cqoIKRzfs
|
||||
NUBbeDCVSGXAFANWtLVeVgm7Lf42rpQUXceZb2Lol+ZUkNOueNgW7jAAPUNDQn+r
|
||||
Mn/+9jgWfZhHwAJMSC+HZBhcytf3eMIxh/+97YvEx2WO4qNN51InaXbNrL7XvLN7
|
||||
XXRaRljJ4bEY/p7TKdbjKELcq2dcycBRKVzQUyswN9NraUU/nOJh4G/EVFCpCGAD
|
||||
c7zUB6OUoQiq8fyvra3sDOCzWllyiqhzl4mX6guYh+W4Xeo3PRiwRVVNh53+QWvE
|
||||
++3YIPNTcvfu2okzWCrXWp13f9cLYsLGtuVtR0HGyGpQ0va4yDk=
|
||||
=MIjS
|
||||
-----END PGP SIGNATURE-----
|
11
libuv.pc.in
11
libuv.pc.in
@ -1,11 +0,0 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
libdir=@libdir@
|
||||
includedir=@includedir@
|
||||
|
||||
Name: libuv
|
||||
Description: Development libraries for libuv
|
||||
Version: @version@
|
||||
Libs: -L${libdir} -luv -lrt -lpthread -lnsl -ldl
|
||||
Cflags: -I{includedir}
|
||||
URL: http://libuv.org/
|
80
libuv.spec
80
libuv.spec
@ -2,26 +2,38 @@
|
||||
%bcond_without tests
|
||||
|
||||
Name: libuv
|
||||
Epoch: 1
|
||||
Epoch: 2
|
||||
Version: 1.46.0
|
||||
Release: %autorelease
|
||||
Summary: Platform layer for node.js
|
||||
|
||||
# the licensing breakdown is described in detail in the LICENSE file
|
||||
License: MIT and BSD and ISC
|
||||
# Code is MIT
|
||||
# Documentation is CC-BY-4.0
|
||||
# src/inet.c is ISC
|
||||
# include/uv/tree.h is BSD-2-Clause
|
||||
License: MIT and CC-BY-4.0 and ISC AND BSD-2-Clause
|
||||
URL: http://libuv.org/
|
||||
Source0: http://dist.libuv.org/dist/v%{version}/libuv-v%{version}.tar.gz
|
||||
Source2: %{name}.pc.in
|
||||
Source1: https://dist.libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz.sign
|
||||
# mkdir temp
|
||||
# gpg --no-default-keyring --keyring temp/keyring.gpg --keyserver keyserver.ubuntu.com \
|
||||
# --recv-keys D77B1E34243FBAF05F8E9CC34F55C8C846AB89B9 \
|
||||
# FDF519364458319FA8233DC9410E5553AE9BC059 94AE36675C464D64BAFA68DD7434390BDBE9B9C5 \
|
||||
# 57353E0DBDAAA7E839B66A1AFF47D5E4AD8B4FDC AEAD0A4B686767751A0E4AEF34A25FB128246514 \
|
||||
# CFBB9CA9A5BEAFD70E2B3C5A79A67C55A3679C8B C82FA3AE1CBEDC6BE46B9360C43CEC45C17AB93C \
|
||||
# 612F0EAD9401622379DF4402F28C3C8DA33C03BE \
|
||||
# && gpg --no-default-keyring --keyring temp/keyring.gpg --output temp/keysuv.gpg --export
|
||||
# cp temp/keysuv.gpg .
|
||||
Source2: keysuv.gpg
|
||||
Source3: libuv.abignore
|
||||
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
BuildRequires: make
|
||||
BuildRequires: gnupg2
|
||||
# Documentation
|
||||
BuildRequires: make
|
||||
BuildRequires: python3-sphinx
|
||||
|
||||
# -- Patches -- #
|
||||
|
||||
# Disable some tests that fail in the network-free Koji builders
|
||||
Patch0001: 0001-Fedora-Skip-tests-that-can-t-run-in-Koji.patch
|
||||
|
||||
%description
|
||||
libuv is a new platform layer for Node. Its purpose is to abstract IOCP on
|
||||
@ -44,42 +56,62 @@ Static library (.a) version of libuv.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-v%{version} -p1
|
||||
gpgv2 --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
||||
%autosetup -n %{name}-v%{version}
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure --disable-silent-rules
|
||||
%make_build
|
||||
%if %{with tests}
|
||||
%cmake -DBUILD_TESTING=ON
|
||||
%else
|
||||
%cmake -DBUILD_TESTING=OFF
|
||||
%endif
|
||||
%cmake_build
|
||||
# Build Documentation
|
||||
cd docs
|
||||
make man
|
||||
cd ..
|
||||
|
||||
%install
|
||||
%make_install
|
||||
rm -f %{buildroot}%{_libdir}/libuv.la
|
||||
|
||||
%cmake_install
|
||||
# install documentation
|
||||
mkdir -p %{buildroot}/%{_mandir}/man1/
|
||||
install -p -m 644 docs/build/man/libuv.1 %{buildroot}/%{_mandir}/man1/
|
||||
mkdir -p %{buildroot}%{_libdir}/libuv/
|
||||
install -Dm0644 -t %{buildroot}%{_libdir}/libuv/ %{SOURCE3}
|
||||
# Remove packaged license files
|
||||
rm %{buildroot}/%{_docdir}/libuv/LICENSE
|
||||
rm %{buildroot}/%{_docdir}/libuv/LICENSE-extra
|
||||
|
||||
|
||||
%check
|
||||
%if %{with tests}
|
||||
%make_build check
|
||||
./%{__cmake_builddir}/uv_run_tests
|
||||
./%{__cmake_builddir}/uv_run_tests_a
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc README.md AUTHORS CONTRIBUTING.md MAINTAINERS.md SUPPORTED_PLATFORMS.md
|
||||
%doc ChangeLog
|
||||
%license LICENSE
|
||||
%{_libdir}/%{name}.so.*
|
||||
%{_libdir}/libuv/libuv.abignore
|
||||
%license LICENSE LICENSE-docs LICENSE-extra
|
||||
%{_libdir}/%{name}.so.1
|
||||
%{_libdir}/%{name}.so.1.*
|
||||
%dir %{_libdir}/%{name}
|
||||
%{_libdir}/%{name}/libuv.abignore
|
||||
%{_mandir}/man1/%{name}.1*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/uv.h
|
||||
%dir %{_includedir}/uv
|
||||
%{_includedir}/uv/*.h
|
||||
%{_libdir}/%{name}.so
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
%{_includedir}/uv.h
|
||||
%{_includedir}/uv/
|
||||
%dir %{_libdir}/cmake/%{name}
|
||||
%{_libdir}/cmake/%{name}/*.cmake
|
||||
|
||||
%files static
|
||||
%{_libdir}/%{name}.a
|
||||
%{_libdir}/pkgconfig/%{name}-static.pc
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
||||
|
Loading…
Reference in New Issue
Block a user