Merge branch 'master' into f19
This commit is contained in:
commit
7fd0876917
42
0001-unix-include-uv.h-in-src-version.c.patch
Normal file
42
0001-unix-include-uv.h-in-src-version.c.patch
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
From fb660262d4f8b6d0f300a3923063ec5a718411ad Mon Sep 17 00:00:00 2001
|
||||||
|
From: Ben Noordhuis <info@bnoordhuis.nl>
|
||||||
|
Date: Thu, 4 Apr 2013 03:02:06 +0200
|
||||||
|
Subject: [PATCH] unix: include uv.h in src/version.c
|
||||||
|
|
||||||
|
Include uv.h so the compiler sees the right visibility attribute for
|
||||||
|
uv_version() and uv_version_string().
|
||||||
|
|
||||||
|
GYP builds compile with -fvisibility=hidden. Before this commit, the
|
||||||
|
symbols were not visible in libuv.so.
|
||||||
|
|
||||||
|
Fixes joyent/node#5213.
|
||||||
|
(cherry picked from commit f1215b791811e5c860152ecde038f35537dab57f)
|
||||||
|
---
|
||||||
|
src/version.c | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/version.c b/src/version.c
|
||||||
|
index 0ee0753..7326180 100644
|
||||||
|
--- a/src/version.c
|
||||||
|
+++ b/src/version.c
|
||||||
|
@@ -19,6 +19,7 @@
|
||||||
|
* IN THE SOFTWARE.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#include "uv.h"
|
||||||
|
|
||||||
|
/*
|
||||||
|
* Versions with an even minor version (e.g. 0.6.1 or 1.0.4) are API and ABI
|
||||||
|
@@ -26,6 +27,9 @@
|
||||||
|
* releases.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#undef UV_VERSION_MAJOR /* TODO(bnoordhuis) Remove in v0.11. */
|
||||||
|
+#undef UV_VERSION_MINOR /* TODO(bnoordhuis) Remove in v0.11. */
|
||||||
|
+
|
||||||
|
#define UV_VERSION_MAJOR 0
|
||||||
|
#define UV_VERSION_MINOR 10
|
||||||
|
#define UV_VERSION_PATCH 3
|
||||||
|
--
|
||||||
|
1.8.1.4
|
||||||
|
|
10
libuv.spec
10
libuv.spec
@ -7,7 +7,7 @@
|
|||||||
Name: libuv
|
Name: libuv
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 0.10.3
|
Version: 0.10.3
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Platform layer for node.js
|
Summary: Platform layer for node.js
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -16,6 +16,10 @@ URL: http://nodejs.org/
|
|||||||
Source0: http://libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
|
Source0: http://libuv.org/dist/v%{version}/%{name}-v%{version}.tar.gz
|
||||||
Source2: libuv.pc.in
|
Source2: libuv.pc.in
|
||||||
|
|
||||||
|
# backport fix to FTBFS in nodejs-0.10.3
|
||||||
|
# https://github.com/joyent/node/issues/5213
|
||||||
|
Patch0001: 0001-unix-include-uv.h-in-src-version.c.patch
|
||||||
|
|
||||||
BuildRequires: gyp
|
BuildRequires: gyp
|
||||||
Requires(post): /sbin/ldconfig
|
Requires(post): /sbin/ldconfig
|
||||||
Requires(postun): /sbin/ldconfig
|
Requires(postun): /sbin/ldconfig
|
||||||
@ -42,6 +46,7 @@ Development libraries for libuv
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-v%{version}
|
%setup -q -n %{name}-v%{version}
|
||||||
|
%patch0001 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS='%{optflags}'
|
export CFLAGS='%{optflags}'
|
||||||
@ -113,6 +118,9 @@ sed -e "s#@prefix@#%{_prefix}#g" \
|
|||||||
%{_includedir}/uv-private
|
%{_includedir}/uv-private
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 04 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 1:0.10.3-2
|
||||||
|
- backport patch that fixes FTBFS in nodejs-0.10.3
|
||||||
|
|
||||||
* Sun Mar 31 2013 tchollingsworth@gmail.com - 1:0.10.3-1
|
* Sun Mar 31 2013 tchollingsworth@gmail.com - 1:0.10.3-1
|
||||||
- rebase to 0.10.3
|
- rebase to 0.10.3
|
||||||
- upstream now does proper releases
|
- upstream now does proper releases
|
||||||
|
Loading…
Reference in New Issue
Block a user